Subject: Re: [Enum] Neustar and GSM create alternate ROOT

From: Christian de Larrinaga <[email-masked]>
Date: Sat, 1 Oct 2005 11:10:19 +0100

Are GSM members intending to keep access to all domains open for  
users (ENUM) or to  filter out all other domains so only this hybrid  
carrier ENUM is available to provide (routing) services to mobile  
users under operator control?

Christian de Larrinaga
[email-masked]

On 30 Sep 2005, at 20:42, Stastny Richard wrote:

> Yes and no,
>
> Routing in IMS is done via SIP URIs (see ETSI TS 123.228)
> It is a complete new root also for SIP routing of "public" User  
> Identities (finding
> the other servers)
>
> Of course it will also contain a ENUM tree for mapping E.164 to  
> these SIP URIs,
> which will then also resolved within this alternate root
>
> Richard
>
> ________________________________
>
> Von: Tom-PT Taylor [mailto:[email-masked]]
> Gesendet: Fr 30.09.2005 21:37
> An: Stastny Richard
> Cc: [email-masked]
> Betreff: Re: [Enum] Neustar and GSM create alternate ROOT
>
>
>
> Do I understand correctly that this is a form of carrier ENUM?
>
> Stastny Richard wrote:
>
>> Dear co-chairs, especially Patrik,
>>
>> what is your opiniion on this press release?
>>
>> http://www.neustar.com/pressroom/files/announcements/ 
>> ns_pr_09282005.pdf
>>
>> GSM Association and NeuStar Sign Agreement to Offer Root DNS  
>> Services to More than 680 Global GSM Mobile Operators
>>
>> providing .grps and 3gppnetwork.org as TLD in the GRX network  
>> using public IP addresses.
>>
>> I thought the IAB recommended to 3GPP NOT to do this because of  
>> leakage
>>
>> Richard
>>
>> _______________________________________________
>> enum mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/enum
>>
>>
>>
>
>
>
>
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
>

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Sat, 1 Oct 2005 12:27:20 +0200

The GRX network uses public IP addresses, but has NO connection to the
public Internet (at least not now). It is only connected to the networks
of the mobile operators (via NAT) and they use private 10.x.x.x ranges

So there is no way to access other domains in the public DNS.
It is a completely separate namespace.

The main use of the GRX now is to tunnel roaming subscribers
using data access via the visited network and the GRX to
the hone network.

If you use a data connection say roaming in vodafone.uk
and access the Internet, you will be tunneled through and
will get your public IP address from the home network.

Richard

Von: Christian de Larrinaga [mailto:[email-masked]]
Gesendet: Sa 01.10.2005 12:10
An: Stastny Richard
Cc: Tom-PT Taylor; [email-masked]
Betreff: Re: [Enum] Neustar and GSM create alternate ROOT

Christian de Larrinaga
[email-masked]

---

From: "Fullbrook Kim \(UK\)" <[email-masked]>
Date: Mon, 3 Oct 2005 09:42:35 +0100

Use of domain names on the GRX network is described in recent version of
3GPP TS 23.003, for example V6.7.1 at:
http://www.3gpp.org/ftp/Specs/archive/23_series/23.003/23003-671.zip

As a result of the policy, those existing services that use the .gprs
domain will continue to use it and any new services will use the
3gppnetwork.org domain. There might be new services in the future that
would like to use a different domain name, in which case that domain
name must be registered on the public Internet to avoid any potential
leakage problem.

The Neustar press release describes the implementation of a root DNS to
carry the .gprs domain (for some existing services) and 3gppnetwork.org
domain for new services.

Kim Fullbrook
O2 UK (Member of GSMA)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stastny Richard
Sent: 30 September 2005 20:23
To: [email-masked]
Subject: [Enum] Neustar and GSM create alternate ROOT

 
http://www.neustar.com/pressroom/files/announcements/ns_pr_09282005.pdf
 
GSM Association and NeuStar Sign Agreement to Offer Root DNS Services to
More than 680 Global GSM Mobile Operators

providing .grps and 3gppnetwork.org as TLD in the GRX network using
public IP addresses.
 
I thought the IAB recommended to 3GPP NOT to do this because of leakage
 
Richard

=====================================================
This electronic message contains information from O2 which may be privileged or confidential. The information is intended to be for the use of the individual(s) or entity named above. If you are not the intended recipient be aware that any disclosure, copying distribution or use of the contents of this information is prohibited. If you have received this electronic message in error, please notify us by telephone or email (to the numbers or address above) immediately.
=====================================================

---

From: "Stastny Richard" <[email-masked]>
Date: Mon, 3 Oct 2005 12:01:17 +0200

Hi Kim,

just one question: If I use a Public User Identity as defined
in TS 23.228 in the format of a SIP URI to be used on
a business card (as also stated there) - e.g.
sip:[email-masked]

is the domain part of this SIP URI resolved in the GRX DNS
or in the public DNS?

Richard

> Fullbrook Kim (UK)
> Sent: Monday, October 03, 2005 10:43 AM
> To: [email-masked]
> Subject: RE: [Enum] Neustar and GSM create alternate ROOT
> 
leakage
> This electronic message contains information from O2 which may be
> privileged or confidential. The information is intended to be for the
use
> of the individual(s) or entity named above. If you are not the
intended
> recipient be aware that any disclosure, copying distribution or use of
the
> contents of this information is prohibited. If you have received this
> electronic message in error, please notify us by telephone or email
(to
> the numbers or address above) immediately.

---

From: "Stastny Richard" <[email-masked]>
Date: Mon, 3 Oct 2005 17:14:16 +0200

Hi Kim,

> What I can say is that whatever solution we adopt needs to be 
> compatible with the need to interwork with non-GSMA carriers 
> in the future.

thank you for this statement, I consider it important

It would also be interesting what GSMA considers a non-GSMA "Carrier"
;-)

Best regards
Richard

> Sent: Monday, October 03, 2005 3:13 PM
> To: [email-masked]
> This is an interesting question but it's not appropriate for me to
> comment on an area which has not been fully agreed within the GSMA.
What
> I can say is that whatever solution we adopt needs to be compatible
with
> the need to interwork with non-GSMA carriers in the future.
> 
> Kim Fullbrook
> O2 UK
> 
> From: Stastny Richard [mailto:[email-masked]]
> Sent: 03 October 2005 11:01
> To: Fullbrook Kim (UK); [email-masked]
use
intended
the
(to

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 5 Oct 2005 11:08:20 +0200

> what is your opiniion on this press release?

Please read RFC 2826 again.

2826 IAB Technical Comment on the Unique DNS Root. Internet
      Architecture Board. May 2000. (Format: TXT=13400 bytes) (Status:
      INFORMATIONAL)

If someone add one TLD to the root zone, they have created a 2nd root.

I don't think any further comments are needed.

     Patrik