Subject: [Enum] What is a Carrier and who has the right to enter numbers in Carrier ENUM?

From: "Stastny Richard" <[email-masked]>
Date: Thu, 6 Oct 2005 20:20:58 +0200

To get the discussion going:
 
I think the answers to these question are  the central point of the definitions
in both groups:
 
The answeres are somehow linked, but not necessary the same.
 
Lets start with Carrier ENUM:
IMHO an entity should have the right to enter numbers in Carrier ENUM
if he has been assigned the number or number range directly from
the number assignment authority (NRA for short) for this CC
(better wording here needed to cover also global CCs) 
OR
the number is ported by an end-user from such an entity to him
 
Now we have three cases:

Case A
The above entity is a "carrier" in the sense of a "Carrier-of-Record"
(whatever that is) . So the ENUM entry he is providing is pointing
to an entry point in his "network" (a SBC) or to a SIP proxy, if he
is a "virtual network" provider. This Carrier needs to be able to peer
and therefore is a "Carrier" within the scope of voipeer.
 
Case B:
The above entity is a company (enterprise) or even an "End-User" deriving
a number from the NRA direct, e.g an 800 number or a coprorate
number, but he decides to host the servivce with an above described
"Carrier". In this case he decides what is entered in Carrier ENUM,
but the entry is pointing to the above described "Carrier". Same
result for Voipeer.
 
Case C:
The enterprise or end-user is deciding to run their own server and
since they are in charge of the Carrier ENUM entry, they enter
a pointer to their server in Carrier ENUM. To be able to peer, they
also need to be able to participate in the Voipeer club.
This case is the most controverry, of course.
What are the minimum requirements especially for such "Carriers)
 
It is also interesting in the case C that the company may also decide
to enter the same pointer in User ENUM.
 
have phun
Richard

________________________________

Von: David Meyer [mailto:[email-masked]]
Gesendet: Do 06.10.2005 19:45
An: Richard Shockey
Cc: Stastny Richard; Lind, Steven D, ALABS; [email-masked]
Betreff: Re: [Enum] Its that time again .... Agenda Items for IETF Vancouver

On Thu, Oct 06, 2005 at 01:41:02PM -0400, Richard Shockey wrote:
>
>    David Meyer wrote:
>
> On Thu, Oct 06, 2005 at 04:05:02PM +0200, Stastny Richard wrote:
>  
>
> I'm assuming that VOIPEER will hold a 2nd BOF in Vancouver as well.
>      
>
> Now as you mention it, this is also a good question
> The voipeer list has gone dead also
>
> I needs to be revived
>    
>
>         Definitely, and my fault :-) The list is still there, and
>         I too have been waiting for our ADs to answer up on the
>         chartering question. BTW, I have asked for a 2.5 hr slot
>         for Vancouver.
>
>         Finally, I have a terminology draft that I'm trying to
>         finish if I can get a few minutes, so that will be input
>         (fodder) for Vancouver.
>
>  
>
>    Hummm ..
>    What is a carrier ?
>    What constitutes peering?
>    What is truth?
>    Is there a God?
>    Dave you have your work cut out for you  :-)

        That's what I keep hearing :-)

        Dave

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Pfautz, Penn L, NEO" <[email-masked]>
Date: Thu, 6 Oct 2005 14:29:07 -0400

Richard:
In case B below by "host" I assume you mean that the carrier provides
the PSTN point-of-interface for the number. Is this correct? If so, some
might suggest that the carrier is still the carrier-of-record and gets
to decide about the entry.
This moves toward a definition of carrier as the entity that provides
the PSTN PoI for a number.

What you think?

In case C below do you assume the number was directly assigned to the
enterprise? 

Penn

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Stastny Richard
Sent: Thursday, October 06, 2005 2:21 PM
To: David Meyer; Richard Shockey; [email-masked]
Cc: Lind, Steven D, ALABS; [email-masked]
Subject: [voipeer] What is a Carrier and who has the right to enter
numbers in Carrier ENUM?

I think the answers to these question are  the central point of the
definitions
in both groups:

 
Now we have three cases:

Case A
 
Case B:
The above entity is a company (enterprise) or even an "End-User"
deriving
 
Case C:

have phun
Richard

Von: David Meyer [mailto:[email-masked]]
Gesendet: Do 06.10.2005 19:45
An: Richard Shockey
Cc: Stastny Richard; Lind, Steven D, ALABS; [email-masked]
Betreff: Re: [Enum] Its that time again .... Agenda Items for IETF
Vancouver

        Dave

________________________________________________________________________
_____
List Archive: http://darkwing.uoregon.edu/~llynch/voipeer/
User Tools: http://darkwing.uoregon.edu/~llynch/voipeer.html

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 6 Oct 2005 20:48:37 +0200

In both cases the numbers are assigned directly
 
The numbers I am talking about here are IN numbers:
so the question on the PSTN point of interface is a bit problematic
 
A company eg gets an 800 number (or an 05 number in Austria) and now decides
which carrier should do the (second) IN dip to translate the number to the real
geographic number with his IN-service.

The carrier now is the one entered in the IN database for the first IN dip to
route the number. The geonumber now may be with another carrier.
 
Since ENUM is now "bypassing" all this IN dips and no geographic number
is required to reach the SIP server of the company (the "Carrier" may still
provide some IN-type time-of-day routing magic, the question of PSTN PoI
is not valid.
 
I think that in proctice the carrier still may have the lead and do all this stuff
for the company (as it may also happen in User ENUM) but we are discussing
here the principles. I also beleive that in case B the company and the carrier
have to talk to each oother, at least the carrier has to tel the company what
SIP URU to enter.
 
Richard

Von: Pfautz, Penn L, NEO [mailto:[email-masked]]
Gesendet: Do 06.10.2005 20:29
An: Stastny Richard; David Meyer; Richard Shockey; [email-masked]
Cc: Lind, Steven D, ALABS; [email-masked]
Betreff: RE: [voipeer] What is a Carrier and who has the right to enter numbers in Carrier ENUM?

Richard:

What you think?

Penn

-----Original Message-----

Now we have three cases:

Case A

Case B:

Case C:

have phun
Richard

        Dave

---

From: "Pfautz, Penn L, NEO" <[email-masked]>
Date: Thu, 6 Oct 2005 14:49:58 -0400

The IN number question raises interesting questions.   The end user
direct number assignee certainly has rights to end user ENUM but do they
have the carrier ENUM rights? I'm not so sure those don't belong to the
hosting carrier.

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Thursday, October 06, 2005 2:49 PM
To: Pfautz, Penn L, NEO; David Meyer; Richard Shockey;
[email-masked]
Cc: Lind, Steven D, ALABS; [email-masked]
Subject: Re: [voipeer] What is a Carrier and who has the right to enter
numbers in Carrier ENUM?

 
A company eg gets an 800 number (or an 05 number in Austria) and now
decides
which carrier should do the (second) IN dip to translate the number to
the real
geographic number with his IN-service.

The carrier now is the one entered in the IN database for the first IN
dip to
route the number. The geonumber now may be with another carrier.
 
Since ENUM is now "bypassing" all this IN dips and no geographic number
is required to reach the SIP server of the company (the "Carrier" may
still
provide some IN-type time-of-day routing magic, the question of PSTN PoI
is not valid.
 
I think that in proctice the carrier still may have the lead and do all
this stuff
for the company (as it may also happen in User ENUM) but we are
discussing
here the principles. I also beleive that in case B the company and the
carrier
have to talk to each oother, at least the carrier has to tel the company
what
SIP URU to enter.
 
Richard

Von: Pfautz, Penn L, NEO [mailto:[email-masked]]
Gesendet: Do 06.10.2005 20:29
An: Stastny Richard; David Meyer; Richard Shockey;
[email-masked]
Cc: Lind, Steven D, ALABS; [email-masked]
Betreff: RE: [voipeer] What is a Carrier and who has the right to enter
numbers in Carrier ENUM?

Richard:

What you think?

Penn

-----Original Message-----

Now we have three cases:

Case A

Case B:

Case C:

have phun
Richard

[deleted]

---

From: [email-masked]
Date: Thu, 6 Oct 2005 15:24:01 -0400

Richard,

I'm not sure if cases B and C are actually "Carrier" ENUM.  Maybe I'm 
being too U.S. centric in my thinking, but I think this applies elsewhere 
as well. 

In the U.S., neither subscribers of toll-free ("800") numbers nor other 
end-users (e.g., enterprises) receive number assignments directly from the 
"NRA."  The North American Numbering Plan Administrator (NANPA) assigns 
blocks of numbers to carriers who then assign individual numbers or blocks 
to these users.  Thus, there is still a "carrier of record," and we are 
still dealing with case A.  The carrier controls carrier ENUM entries. Any 
other ENUM entries the subscriber wants to publish would go into end-user 
ENUM.  I believe that the same applies to case C. 

Where numbers are ported, I take porting to mean the subscriber moving the 
number from one carrier-of-record to another.  The new carrier would be 
one that also has its own supply of numbers assigned from the NRA.  In all 
of the situations I have described above, the carrier does maintain THE 
point of interconnection to the PSTN.  There can be only one POI for 
incoming calls from the PSTN to a given number. 

I there are areas of the world where this carrier-of-record model doesn't 
apply, please let me know.  Maybe an end user can get a number assignment 
"directly" from an NRA, but doesn't the number come with a default 
carrier-of-record that maintains the PSTN POI?

I'm not suggesting that things could never or should never change, but I 
think that the concept of a required PSTN POI will be important for quite 
a few years. 

Jim Baskin

"Stastny Richard" <[email-masked]>
Sent by: [email-masked]
10/06/2005 02:20 PM

        To:     "David Meyer" <[email-masked]>, "Richard Shockey" <[email-masked]>, 
[email-masked]
        cc:     "Lind, Steven D, ALABS" <[email-masked]>, [email-masked]
        Subject:        [Enum] What is a Carrier and who has the right to enter numbers in Carrier 
ENUM?

 

Now we have three cases:

Case A
 
Case B:
 
Case C:

have phun
Richard

        Dave

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 6 Oct 2005 22:08:55 +0200

I think that is one of the central issues we need to discuss here
Richard

Gesendet: Do 06.10.2005 20:49

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Thursday, October 06, 2005 2:49 PM
To: Pfautz, Penn L, NEO; David Meyer; Richard Shockey;

Richard

Richard:

What you think?

Penn

-----Original Message-----

Now we have three cases:

Case A

Case B:

Case C:

have phun
Richard

[deleted]