Subject: [Enum] Comments on draft-meyer-voipeer-terminology-00.txt

From: "Stastny Richard" <[email-masked]>
Date: Wed, 19 Oct 2005 22:04:47 +0200

Hi all,
 
I am posting this on both the enum and the voipeer list, because there
are some interdependencies in this draft.
 
ad Figure 1
 
I consider this figure very important and I suggest to draw a line above:
 
SIP URI <--- Call Routing Data (CRD)
 
This line indicates the scope boundary between ENUM WG and voipeer.
 
The main task of ENUM is to deliver a SIP URI that
can be used as Call Routing Data as defined in 3.1
 
How to deal with this call routing data is the task of voipeer.
 
Therefore I suggest to change the text below the figure from:
 
Note that voipeer is primarily concerned with the acquisition and use
   of the Call Routing Data (CRD) shown in in Figure 1.  Importantly,
   the CRD can be derived from an E.164 entry, as shown in Figure 1, or
   via any other mechanism available to the user.
 
to
 
Note that ENUM is primarily concerned with the acquisition and 
   voipeer primarily with the use
   of the Call Routing Data (CRD) shown in in Figure 1.  Importantly,
   the CRD can be derived from an E.164 entry in ENUM, as shown in Figure 1, or
   via any other mechanism available to the user.

ad 3.1.  Call Routing Data (CRD)
   Call Routing Data, or CRD, is a SIP URI used to route a (real-time,
   voice or other type) call to its termination point.
   [ed: do we need a definition of "termination point"?]
 
yes and no:
 
I propose to change the text to:
Call Routing Data, or CRD, is a SIP URI used to route a (real-time,
   voice or other type) call to the destination network, where network
   is defined in 3.4
 
ad 3.4.  Network
   For purposes of this document and the voipeer work, a network is
   defined to be the set of SIP servers and customers that are
   controlled by a single administration. 
 
change to:
   For purposes of this document and the voipeer and ENUM work, a 
   network is
   defined to be the set of SIP servers and end-users (customers)
   that are controlled by a single administrative domain.
   The network may also contain end-users on the PSTN.
 
ad 3.6 Carrier (of Record)
 
The definition of a carrier is irrelevant for voipeer, voipeer
is only dealing with L5 peering between VoIP Service providers
as defined in 3.5 so either

the definition is deleted or the definition of ENUM in
draft-lind-infrastructure-enum-reqs-01 is used:
 
For purposes of this document, "Carrier of Record" refers to the
   entity that provides PSTN service for an E.164 number with the
   understanding that this definition is ultimately a matter for
   national authorities to determine.
 
Proposal:
 
4.1 User ENUM
 
In User ENUM the end-user having the right to use the
E.164 number in question is responsible for the data
entered in the corresponding domain within e164.arpa
The end user hosted within a VoIP service providers network
may enter CRD (a SIP URI) given to him by this VoIP 
service provider.
 
Another VoIP service provider or end-user may query User ENUM 
and use the retrieved CDR to route calls to the VoIP service
providers network of the first user.
 
4.2 Carrier ENUM
 
In carrier ENUM only Carrier of Records as defined in 3.6 
(or ENUM) may enter data in the corresponding domain within tbd. 
The Carrier of Record may enter may enter CRD (a SIP URI) 
to allow other VoIP Service Providers to route calls to his network
as defined within voipeer.
 
Note: ENUM may also contain other data beyond the CRD as defined
in voipeer. This is out of scope for voipeer. This is especially true
for data containing tel URIs. Tel URis are used to interconnect
with the PSTN directly and are out of scope of voipeer. Endpoints
on the PSTN served by a Carrier of Record and reachable via CDR
and networks as defined in 3.4 are NOT out of scope.

best regards
Richard

________________________________

Von: [email-masked] im Auftrag von David Meyer
Gesendet: Fr 14.10.2005 23:30
An: [email-masked]
Cc: [email-masked]; [email-masked]
Betreff: [Enum] "straw-person" terminology draft posted

        Folks,

        I just posted draft-meyer-voipeer-terminology-00.txt.
        Please consider this a straw{man,woman,person} draft; I
        wanted to get something onto the I-D repository before
        the -00 cutoff, and so we'd have some canon fodder :-)

        Have a good weekend all,

        Dave

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: David Meyer <[email-masked]>
Date: Wed, 19 Oct 2005 15:14:13 -0700

> This line indicates the scope boundary between ENUM WG and voipeer.

	Good point. I'll try to make that clear.

>    via any other mechanism available to the user.

	Sure. I think we had different meanings of "acquisition",
	but this is clear.

>    voice or other type) call to the destination network, where network

	Sure.

>    The network may also contain end-users on the PSTN.

	Yep.

>    national authorities to determine.

	Ok, no problem with that either.

> and networks as defined in 3.4 are NOT out of scope.

	I'll fit this in too. 

	Thanks for the detailed comments,

	Dave