Subject: Re: [Enum] What is a Carrier and who has the right to enternumbers in Carrier ENUM?

From: "Stastny Richard" <[email-masked]>
Date: Thu, 6 Oct 2005 22:16:55 +0200

James,
 
>I there are areas of the world where this carrier-of-record model doesn't
>apply, please let me know.  Maybe an end user can get a number assignment
>"directly" from an NRA, but doesn't the number come with a default
>carrier-of-record that maintains the PSTN POI?

I think this is the central question here and it would be nice if
some regulators would respond here.

There are countries where you get numbers directly, the
question is only what is first, the carrier or the user

Richard

________________________________

Von: [email-masked] im Auftrag von [email-masked]
Gesendet: Do 06.10.2005 21:24
An: [email-masked]; [email-masked]
Betreff: Re: [Enum] What is a Carrier and who has the right to enternumbers in Carrier ENUM?

Richard,

I'm not sure if cases B and C are actually "Carrier" ENUM.  Maybe I'm
being too U.S. centric in my thinking, but I think this applies elsewhere
as well.

In the U.S., neither subscribers of toll-free ("800") numbers nor other
end-users (e.g., enterprises) receive number assignments directly from the
"NRA."  The North American Numbering Plan Administrator (NANPA) assigns
blocks of numbers to carriers who then assign individual numbers or blocks
to these users.  Thus, there is still a "carrier of record," and we are
still dealing with case A.  The carrier controls carrier ENUM entries. Any
other ENUM entries the subscriber wants to publish would go into end-user
ENUM.  I believe that the same applies to case C.

Where numbers are ported, I take porting to mean the subscriber moving the
number from one carrier-of-record to another.  The new carrier would be
one that also has its own supply of numbers assigned from the NRA.  In all
of the situations I have described above, the carrier does maintain THE
point of interconnection to the PSTN.  There can be only one POI for
incoming calls from the PSTN to a given number.

I there are areas of the world where this carrier-of-record model doesn't
apply, please let me know.  Maybe an end user can get a number assignment
"directly" from an NRA, but doesn't the number come with a default
carrier-of-record that maintains the PSTN POI?

I'm not suggesting that things could never or should never change, but I
think that the concept of a required PSTN POI will be important for quite
a few years.

Jim Baskin

"Stastny Richard" <[email-masked]>
Sent by: [email-masked]
10/06/2005 02:20 PM

        To:     "David Meyer" <[email-masked]>, "Richard Shockey" <[email-masked]>,
[email-masked]
        cc:     "Lind, Steven D, ALABS" <[email-masked]>, [email-masked]
        Subject:        [Enum] What is a Carrier and who has the right to enter numbers in Carrier
ENUM?

To get the discussion going:

I think the answers to these question are  the central point of the
definitions
in both groups:

The answeres are somehow linked, but not necessary the same.

Lets start with Carrier ENUM:
IMHO an entity should have the right to enter numbers in Carrier ENUM
if he has been assigned the number or number range directly from
the number assignment authority (NRA for short) for this CC
(better wording here needed to cover also global CCs)
OR
the number is ported by an end-user from such an entity to him

Now we have three cases:

Case A
The above entity is a "carrier" in the sense of a "Carrier-of-Record"
(whatever that is) . So the ENUM entry he is providing is pointing
to an entry point in his "network" (a SBC) or to a SIP proxy, if he
is a "virtual network" provider. This Carrier needs to be able to peer
and therefore is a "Carrier" within the scope of voipeer.

Case B:
The above entity is a company (enterprise) or even an "End-User" deriving
a number from the NRA direct, e.g an 800 number or a coprorate
number, but he decides to host the servivce with an above described
"Carrier". In this case he decides what is entered in Carrier ENUM,
but the entry is pointing to the above described "Carrier". Same
result for Voipeer.

Case C:
The enterprise or end-user is deciding to run their own server and
since they are in charge of the Carrier ENUM entry, they enter
a pointer to their server in Carrier ENUM. To be able to peer, they
also need to be able to participate in the Voipeer club.
This case is the most controverry, of course.
What are the minimum requirements especially for such "Carriers)

It is also interesting in the case C that the company may also decide
to enter the same pointer in User ENUM.

have phun
Richard

________________________________

Von: David Meyer [mailto:[email-masked]]
Gesendet: Do 06.10.2005 19:45
An: Richard Shockey
Cc: Stastny Richard; Lind, Steven D, ALABS; [email-masked]
Betreff: Re: [Enum] Its that time again .... Agenda Items for IETF
Vancouver

On Thu, Oct 06, 2005 at 01:41:02PM -0400, Richard Shockey wrote:
>
>    David Meyer wrote:
>
> On Thu, Oct 06, 2005 at 04:05:02PM +0200, Stastny Richard wrote:
>
>
> I'm assuming that VOIPEER will hold a 2nd BOF in Vancouver as well.
>
>
> Now as you mention it, this is also a good question
> The voipeer list has gone dead also
>
> I needs to be revived
>
>
>         Definitely, and my fault :-) The list is still there, and
>         I too have been waiting for our ADs to answer up on the
>         chartering question. BTW, I have asked for a 2.5 hr slot
>         for Vancouver.
>
>         Finally, I have a terminology draft that I'm trying to
>         finish if I can get a few minutes, so that will be input
>         (fodder) for Vancouver.
>
>
>
>    Hummm ..
>    What is a carrier ?
>    What constitutes peering?
>    What is truth?
>    Is there a God?
>    Dave you have your work cut out for you  :-)

        That's what I keep hearing :-)

        Dave

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Vince Humphries <[email-masked]>
Date: Fri, 7 Oct 2005 09:18:54 +1000

Richard, James

We don't have assignments of numbers directly to end-users in my country
(Australia), but I'm aware from my previous job that several European
countries -- notably Austria, Germany, the Netherlands and Switzerland -- do
make assignments direct to end-users. The types of numbers assigned in this
way usually comprise freephone (800), shared cost, premium rate (900) and
personal numbers.
As far as I'm aware, the assignment is in all these cases made without any
carrier-of-record; subsequent to the assignment, it's up to the end-user to
arrange for the supply of a service with a chosen carrier in connection with
the assigned number.

Vince Humphries

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Friday, 7 October 2005 06:17
To: [email-masked]; [email-masked]; [email-masked]
Subject: [voipeer] Re: [Enum] What is a Carrier and who has the right to
enternumbers in Carrier ENUM?

James,
 
>I there are areas of the world where this carrier-of-record model
>doesn't apply, please let me know.  Maybe an end user can get a number 
>assignment "directly" from an NRA, but doesn't the number come with a 
>default carrier-of-record that maintains the PSTN POI?

I think this is the central question here and it would be nice if some
regulators would respond here.

There are countries where you get numbers directly, the question is only
what is first, the carrier or the user

Richard

Von: [email-masked] im Auftrag von [email-masked]
Gesendet: Do 06.10.2005 21:24
An: [email-masked]; [email-masked]
Betreff: Re: [Enum] What is a Carrier and who has the right to enternumbers
in Carrier ENUM?

Richard,

I'm not sure if cases B and C are actually "Carrier" ENUM.  Maybe I'm being
too U.S. centric in my thinking, but I think this applies elsewhere as well.

Where numbers are ported, I take porting to mean the subscriber moving the
number from one carrier-of-record to another.  The new carrier would be one
that also has its own supply of numbers assigned from the NRA.  In all of
the situations I have described above, the carrier does maintain THE point
of interconnection to the PSTN.  There can be only one POI for incoming
calls from the PSTN to a given number.

I'm not suggesting that things could never or should never change, but I
think that the concept of a required PSTN POI will be important for quite a
few years.

Jim Baskin

        To:     "David Meyer" <[email-masked]>, "Richard Shockey"
<[email-masked]>,
[email-masked]
        cc:     "Lind, Steven D, ALABS" <[email-masked]>, [email-masked]
        Subject:        [Enum] What is a Carrier and who has the right to
enter numbers in Carrier
ENUM?

I think the answers to these question are  the central point of the
definitions in both groups:

Lets start with Carrier ENUM:
IMHO an entity should have the right to enter numbers in Carrier ENUM if he
has been assigned the number or number range directly from the number
assignment authority (NRA for short) for this CC (better wording here needed
to cover also global CCs) OR the number is ported by an end-user from such
an entity to him

Now we have three cases:

Case A
The above entity is a "carrier" in the sense of a "Carrier-of-Record"
(whatever that is) . So the ENUM entry he is providing is pointing to an
entry point in his "network" (a SBC) or to a SIP proxy, if he is a "virtual
network" provider. This Carrier needs to be able to peer and therefore is a
"Carrier" within the scope of voipeer.

Case B:
The above entity is a company (enterprise) or even an "End-User" deriving a
number from the NRA direct, e.g an 800 number or a coprorate number, but he
decides to host the servivce with an above described "Carrier". In this case
he decides what is entered in Carrier ENUM, but the entry is pointing to the
above described "Carrier". Same result for Voipeer.

Case C:
The enterprise or end-user is deciding to run their own server and since
they are in charge of the Carrier ENUM entry, they enter a pointer to their
server in Carrier ENUM. To be able to peer, they also need to be able to
participate in the Voipeer club. This case is the most controverry, of
course. What are the minimum requirements especially for such "Carriers)

It is also interesting in the case C that the company may also decide to
enter the same pointer in User ENUM.

have phun
Richard

Von: David Meyer [mailto:[email-masked]]
Gesendet: Do 06.10.2005 19:45
An: Richard Shockey
Cc: Stastny Richard; Lind, Steven D, ALABS; [email-masked]
Betreff: Re: [Enum] Its that time again .... Agenda Items for IETF Vancouver

        Dave

____________________________________________________________________________
_
List Archive: http://darkwing.uoregon.edu/~llynch/voipeer/
User Tools: http://darkwing.uoregon.edu/~llynch/voipeer.html

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 7 Oct 2005 07:54:54 +0200

This could be one solution for B
and case C?
 
Richard
 
And I have an additional question:
 
>From the responses I got up to now, we should define what a carrier is
in carrier ENUM (basically a tool die be used on the Internet)
depending on the carriers role and existence on the PSTN (PoI)
 
I do not think that this is a good idea, we should come up
with something better
 
Richard

Von: Yu, James [mailto:[email-masked]]
Gesendet: Fr 07.10.2005 01:33
An: Stastny Richard
Betreff: Re: [voipeer] Re: [Enum] What is a Carrier and who has the right to enternumbers in Carrier ENUM?

How the phone numbers are assigned is not an issue.  So long as there is a carrier who serves the number, that carrier is the one to register/provision the data for that phone number in Carrier ENUM.  The end user is not involved.  It will be an issue if more than one carriers can serve the same phone number.

James
--------------------------
Sent from my BlackBerry Wireless Handheld

-----Original Message-----
From: [email-masked]
To: 'Stastny Richard'; [email-masked]
CC: [email-masked]; [email-masked]
Sent: Thu Oct 06 19:18:54 2005
Subject: RE: [voipeer] Re: [Enum] What is a Carrier and who has the right to enternumbers in Carrier ENUM?

Richard, James

Vince Humphries

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Friday, 7 October 2005 06:17
To: [email-masked]; [email-masked]; [email-masked]
Subject: [voipeer] Re: [Enum] What is a Carrier and who has the right to

James,

Richard

Richard,

Jim Baskin

Now we have three cases:

Case A

Case B:

Case C:

have phun
Richard

        Dave

---

From: Vince Humphries <[email-masked]>
Date: Fri, 7 Oct 2005 16:02:04 +1000

Richard

I agree, and we need a definition that works in any country.

...Vince Humphries

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Friday, 7 October 2005 15:55
To: [email-masked]
Cc: [email-masked]
Subject: Re: [voipeer] Re: [Enum] What is a Carrier and who has the right to

Richard
 
And I have an additional question:
 
>From the responses I got up to now, we should define what a carrier is in
carrier ENUM (basically a tool die be used on the Internet) depending on the
carriers role and existence on the PSTN (PoI)

Richard

Von: Yu, James [mailto:[email-masked]]
Gesendet: Fr 07.10.2005 01:33
An: Stastny Richard
Betreff: Re: [voipeer] Re: [Enum] What is a Carrier and who has the right to
enternumbers in Carrier ENUM?

How the phone numbers are assigned is not an issue.  So long as there is a
carrier who serves the number, that carrier is the one to register/provision
the data for that phone number in Carrier ENUM.  The end user is not
involved.  It will be an issue if more than one carriers can serve the same
phone number.

James

-----Original Message-----
From: [email-masked]
To: 'Stastny Richard'; [email-masked]
CC: [email-masked]; [email-masked]
Sent: Thu Oct 06 19:18:54 2005
Subject: RE: [voipeer] Re: [Enum] What is a Carrier and who has the right to

Richard, James

We don't have assignments of numbers directly to end-users in my country
(Australia), but I'm aware from my previous job that several European
countries -- notably Austria, Germany, the Netherlands and Switzerland -- do
make assignments direct to end-users. The types of numbers assigned in this
way usually comprise freephone (800), shared cost, premium rate (900) and
personal numbers. As far as I'm aware, the assignment is in all these cases
made without any carrier-of-record; subsequent to the assignment, it's up to
the end-user to arrange for the supply of a service with a chosen carrier in
connection with the assigned number.

Vince Humphries

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Friday, 7 October 2005 06:17
To: [email-masked]; [email-masked]; [email-masked]
Subject: [voipeer] Re: [Enum] What is a Carrier and who has the right to

James,

Richard

Richard,

Jim Baskin

Now we have three cases:

Case A

Case B:

Case C:

have phun
Richard

        Dave