Subject: [Enum] Carrier ENUM an applet of Voipeer (IP Interconnect)

From: "Stastny Richard" <[email-masked]>
Date: Tue, 13 Sep 2005 14:51:33 +0200

Hi all,
 
since we still do not have a new ENUM charter and time is running out,
(ADs missing in non-action)
I want to throw in some stones in the pond to stir up the
Carrier ENUM requirements discussion:
 
ENUM (Carrier and User ENUM) is an applet to IP -Interconnect. To be able to use an applet you need to be able to use the applications the applet is running on.

You cannot use e.g. an applet integrating your Skype buddies in MS Outlook without having Skype and MS Outlook installed and running on your laptop.

Same with ENUM:

ENUM is useless without the possibility to enter an E.164 number in DNS and the capability to use the resulting URI, e.g. in case of real-time communications a SIP URI. 
 
For further background and rationale see:
http://voipandenum.blogspot.com/2005/09/carrier-enum-is-applet-of-ip.html
 
Executive summary:
 
The basic requirement for Carrier ENUM to work is a global IP Interconnect (VoIP peering) solution for "Carriers".

To summarize:

1. The minimum requirements and rules for IP Interconnect based on routing via SIP URIs have to be established globally. Note: if the minimum requirements are fullfilled (e.g. TLS), the calling server must be able to resolve the SIP AoR to the IP-address of the called server and also to be able to contact the called server. The called user MAY have additional agreements in his profile, e.g. to reject all anonymous calls.

2. Only if this is in place, Carrier ENUM makes sense on a global scale. This does not imply that Carrier ENUM may not be trialed and used commercially earlier, but only in a limited way.

3. Carrier ENUM must be available on a global scale. This implies that Carrier MUST be available for any carrier who wants to use it. This implies that although it is a national matter how to implement Carrier ENUM in detail and to define e.g. the entity operating the Tier 1, there should be no opt-out possible (this is IMHO the most problematic point).

4. It is a national matter to define who is entitled to enter which numbers and the corresponding NAPTRs in "Carrier" ENUM,

e.g. an entity is only allowed to enter numbers in Carrier ENUM if it is hosting the final destination of the E.164 number on behalf of the end-user (that means no signalling transit is allowed)

or if it is providing a direct gateway/SBC to the own destination network hosting the E.164 number on a private IP-based network (NGN) or on the PSTN. National number portability issues have also be taken into account here.

If an entity is assigned an E.164 number directly (e.g. an 800 number or a corporate number), and if the entity is running the SIP server on its own, it may also be allowed to enter this number and the NAPTRs in Carrier ENUM.

4. There is no user opt-in or opt-out possible in Carrier ENUM. The entities allowed to enter NAPTRs in Carrier ENUM MUST be aware that the data in Carrier ENUM is public, therefor end-user privacy MUST be assured. This implies that either the E.164 number or a random number (userid) is used in the user-part of the SIP URI. The mapping from this number to the end-user identity used further (even if it is a public identity) MUST be done within the end-systems.

5. All SIP URIs entered in Carrier ENUM must be reachable via the minimum requirements of IP Interconnect as defined in 1. 
 
Richard

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Kewin Stoeckigt <[email-masked]>
Date: Wed, 14 Sep 2005 18:55:51 +1000

Hi Richard,

...
> 4. There is no user opt-in or opt-out possible in Carrier ENUM. The entities allowed to enter NAPTRs in Carrier ENUM MUST be aware that the data in Carrier ENUM is public, therefor end-user privacy…

Confess...you were reading on the Terena TF-VVC list
(http://www.terena.nl/mail-archives/tf-vvc/). We were discussing such an
option - using the informational RFC3944 for the 'backend'. We should
formalize the thoughts thou...

Kewin

> 5. All SIP URIs entered in Carrier ENUM must be reachable via the minimum requirements of IP Interconnect as defined in 1. 

- --
- ----------------------------------------------
Australian Academic and
Research Network (AARNet)

Kewin Stoeckigt

Building 9, Banks Street
Canberra ACT 2600
Australia

Phone: +61 2 6222 3546
Fax:   +61 2 6222 3535
Mobile:+61 4 2158 2563
Email: [email-masked]
SIP: [email-masked]
WWW: http://www.aarnet.edu.au/~kos/
- -----------------------------------------------