Subject: RE: [Enum] Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs incommonpolicy

From: "Stastny Richard" <[email-masked]>
Date: Thu, 18 Aug 2005 16:19:48 +0200

I strongly support this, because this would
finally end the confusion with dialled digits and 
phone numbers

BTW, Brian, please update 
draft-rosen-iptel-dialstring-02.txt

becauseit is obsolete already.
In addition, I would propose then a WGLC
So I copy this to the iptel list also

Richard Stastny
OeFEG
tel:+43 664 420 4100
enum:+43 780 203 211
callto://fordprefect
http://voipandenum.blogspot.com

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Brian Rosen
> Sent: Thursday, August 18, 2005 3:36 PM
> To: 'Otmar Lendl'; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [Enum] Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs
> incommonpolicy
> 
> In step 1, if the phone does not do dialplan interpretation, then what
the
> user entered is a dialstring, and not a telephone number.  This could
be
> encoded, as you show, as a SIP uri, but might be better encoded as a
> dialstring, per draft-rosen-iptel-dialstring-02.txt.  A tel uri is
> explicitly NOT used to carry a dialstring.
> 
> I think it would be better labeled as a dialstring, and not something
that
> could be confused as a telephone number.  It remains true that the
user-
> part
> of sip:[email-masked] can only be interpreted by the
> my-voip-provider.at domain, so your flow definitely can work.
> 
> Brian
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Otmar Lendl
> Sent: Thursday, August 18, 2005 6:33 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: [Enum] Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in
> commonpolicy
> 
> On 2005/08/18 05:08, Jonathan Rosenberg <[email-masked]> wrote:
> >
> > My point is that I think it makes sense to consider the tel URI a
URN,
> > and that it is merely an accident of history that it wasn't a URN
more
> > properly. Now, as you and I both know phone numbers in the PSTN are
> > abused to represent lots of things, but there is no reason to carry
> > forward this confusion into voip. This is why I am proposing that
when a
> > phone number is in a tel URI, it represents a name. We don't know
where
> > it is on the network (indeed even if its on an IP network). To know
> > that, we translate to an address. That address is a SIP URI. That
SIP
> > URI can contain a phone number, i.e.
> > sip:[email-masked];user=phone, however in this format the
> > phone number has been resolved to an address. The act of porting a
> > number is a change in the translation of the phone number as a name
(the
> > tel URI) to the phone number as an address (the SIP URI).
> >
> 
> This is a very sensible notion.
> 
> Based on this thinking the dialing of a number on a VoIP-phone
> goes through the following conceptual stages:
> 
> 1) User enters a (potentially partial) number on his phone.
>    The phone appends its default domain and sends the invite to its
proxy:
>    e.g. 	sip:[email-masked]
> 
> 2) The SIP proxy applies the local dialplan to translate the
>    SIP address to an E.164 number:
> 
>    e.g. customer is in vienna, thus 5056416 maps to +43 1 5056416
>    -> We now have a URN: tel:+4315056416
> 
> 3) The SIP proxy now tries to route the call. In this example,
>    user ENUM finds:
>    "E2U+sip" "!^.*$!sip:[email-masked]!"
> 
>    or it could map to the local PSTN gateway with an URI like
>    sip:[email-masked]
> 
> /ol
> --
> < Otmar Lendl ([email-masked]) | nic.at Systems Engineer >
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Mon, 22 Aug 2005 19:14:39 +0200

Following the discussion between you two, I first
have agree with Henry's last statement:
 
>What goes over the net should be only E.164 addresses or SIP URIs.

but restricted to 
What goes over the net between SIP-server should be only E.164 addresses or SIP URIs.
(a bsic requiremnt for voipeer.
 
Now between UAC and proxy:
here we will need dialstrings

It is up the the UAC to have digit analysis and also send
only E.164 numbers, SIP-URIs (and emergency URIs such as sip:[email-masked])
Any UAC capable of queying user ENUM must be able to do so
That is fine with me, but I agree with Brian
 
>We need standards if we want dial plan interpretation in phones, and we need
>a fairly substantial change in existing phone code to get it.  That applies
>to both residential and enterprise.  I'm sanguine about that happening
 
and in addition
BUT there will be also many clients no capable of doing this and
also for this the above mentioned standards are needed:
It is not useful if every phone has iis own method to translate
dialed digits to numbers. One reason is BTW that setting
up a feasable dialing plan is not so easy and should NOT be
left to average user - he may easily shot himself into the foot.
 
-richard

________________________________

Von: [email-masked] im Auftrag von Brian Rosen
Gesendet: Mo 22.08.2005 17:27
An: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Betreff: RE: [Enum] RE: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs incommonpolicy

Henry

This is waay to much hand waving.

"Designers of enterprise communications systems" aren't any different from
designers of residential communications systems.  While there are firms who
plan to provide both phones and servers, and hope their customers choose
them for both tasks, there are many others who want the phone choice and the
server choice to be independent.  To do that, the phones and the servers
have to follow standards, and that includes dial plans.

The residential case is exactly the same.  The phone vendors and the server
vendors are more typically different, but you have some significant
exceptions.

I like presence and click to call, but don't think it's going to supplant
dialing completely for some long time.  If you dial, even occasionally,
these issues arise.

We need standards if we want dial plan interpretation in phones, and we need
a fairly substantial change in existing phone code to get it.  That applies
to both residential and enterprise.  I'm sanguine about that happening.

Brian

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]]
Sent: Monday, August 22, 2005 11:01 AM
To: 'Brian Rosen'; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [Enum] RE: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in
commonpolicy

>However, there are very, very few phones that do dialplan interpretation,
>especially one suitable for an enterprise.  We either have to change that
>behavior, or support dialstrings.

This is true and best left to implementers of enterprise communication
systems where there is a different design space altogether. Enlightened
enterprises may prefer presence anyhow to PBX-style dialing or just use
mobile phone style click to call based on presence and SIP events.

What goes over the net should be only E.164 addresses or SIP URIs.

Henry

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]]
Sent: Monday, August 22, 2005 9:51 AM
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [Enum] RE: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in
commonpolicy

FWIW, I agree with you; phones should do dialplan interpretation.  That begs
the issue of how you download a dialplan into a phone.

However, there are very, very few phones that do dialplan interpretation,
especially one suitable for an enterprise.  We either have to change that
behavior, or support dialstrings.

Brian

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]]
Sent: Monday, August 22, 2005 10:42 AM
To: 'Brian Rosen'; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [Enum] RE: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in
commonpolicy

Brian,

I agree with both you and Richard Stastny how you formulate the problem with
dial plans.

The fact however that so many IETF contributors have taken a stab at solving
the dial plan problem and are still trying after all these years, makes me
think the dial plan complexities should best left to the endpoints who
should know what to do. Dial plans should be left to the implementers of
endpoints and not with the IETF. I have only given in previous mail the
example of endpoints that know what to do, to prove that endpoints can do
it.

So unless it is an E.164 PSTN phone number or a SIP URI, SIP services should
not ever be burdened with anything else. Nor should users be burdened to
know anything else.

I bet however that in spite of this, there will be more engineering attempts
to solve the dial plans in the IETF and will look forward with interest...

My two cents.

Thanks, Henry

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]]
Sent: Monday, August 22, 2005 9:19 AM
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [Enum] RE: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in
commonpolicy

Henry

You've been around enough to know that what you said is not the issue.
Dialplans, and dialstrings, arise because you don't generally know how long
a dialstring is, and phones don't know how to render a dialstring into a
telephone number or service indication.  Either you allow dialstrings in
which case some entity, the phone or a proxy, interprets digits according to
a dial plan to know when the terminal digit has been entered, adding
appropriate prefixes, or you use the wireless mechanism of not having "dial
tone", entering digits, and having a key press that indicates end of dialed
number and forcing the user to put in all the prefixes, or some combination.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Henry Sinnreich
Sent: Sunday, August 21, 2005 12:57 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [Enum] RE: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in
commonpolicy

Folks,

I have followed the discussions on dial plans for a while, and it has been
going on actually for several years. Since the dial plan topic is so complex
even for the experts in the IETF, how can anyone hope that developers or
even more, users will get it right?

KISS and use only one of the three:

1. E.164 numbers for the Internet challenged,
2. SIP URIs for everyone else, or the best of all
3. Hide any type of CA in the AO and use Presence. Just click to call.

Thanks, Henry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Otmar Lendl
Sent: Thursday, August 18, 2005 5:33 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in common policy