Subject: [Enum] Re: [Geopriv] Re: [Simple] tel URIs in common policy

From: "Stastny Richard" <[email-masked]>
Date: Wed, 17 Aug 2005 20:06:06 +0200

James wrote:
>So, and perhaps this is a naive point/question - 
yes ;-)
 
>what happens when a
>carrier no longer operates a phone number that is in operation by another
>carrier?

You mean, what happens if you port a phone number from one cariier-of-record
to another? This is exactly what Carreir ENUM is for.

>For example, my wife has had the same cell phone number for 15+ years, yet
>she has recently changed to her third carrier.  The company that originally
>owned her phone number is being acquired by a 4th company now (here in the
>US, giving you a hint as to two of the players involved).

>What does this do to your statement:

>         "The format sip:[email-masked];user=phone
>gets very important especially for Carrier ENUM indicating
>the destination providers"

 sip:[email-masked];user=phone
has to be changed to

 sip:[email-masked];user=phone

to indicate the new carrier-of-record

-richard

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 17 Aug 2005 11:46:21 -0500

At 06:14 PM 8/17/2005 +0200, Stastny Richard wrote:
>I fully agree that there seems to be an issue here,
>because the problem is currently discussed at voipeer
>also.The format sip:[email-masked];user=phone
>the destination providers (see below)

So, and perhaps this is a naive point/question - what happens when a 
carrier no longer operates a phone number that is in operation by another 
carrier?

>
>It also concerns the CLI and CLIR aspect not yet fully discussed
>in voipeer. This is one issue definitely in scope of voipeer.
>
>comments inline
>

cheers,
James

                                 *******************
                 Truth is not to be argued... it is to be presented.

---

From: "Pfautz, Penn L, NEO" <[email-masked]>
Date: Thu, 18 Aug 2005 10:50:10 -0400

Tom-PT Taylor wrote...

  "ENUM has chosen to add 
the concept of "ownership" to narrow down the range of possibilities ...

and has thereby embroiled itself in politics."

There is isn't really a choice involved if you ever want to evolve PSTN
interconnection.

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 18 Aug 2005 12:39:36 -0400

Not sure why Outlook is omitting carriage returns:

So:

Donor 1 = ENUM leaf  (original carrier moves customer to ENUM) 

Donor 1 -> Serving 2 = ENUM leaf  (first port) 

Donor 1 -> Serving 3 = ENUM leaf  (second port) 

Donor 1 -> Serving 4 = ENUM leaf  (third port) 

Donor 5 -> Serving 4 = ENUM leaf  (carrier 5 buys carrier 1) Donor 5 =
ENUM leaf  (customer cancels)

Does that make sense?

Mike

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Michael Hammer (mhammer)
> Sent: Thursday, August 18, 2005 12:33 PM
> To: James Polk (jmpolk); Stastny Richard; Jonathan Rosenberg 
> (jdrosen); Paul Kyzivat (pkyzivat); [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Enum] Re: [Geopriv] Re: [Simple] tel URIs in 
> common policy
> 
> James,
> 
> This seems to be a number portability question.  E.164 
> numbers get assigned by the national authority either 
> directly to the individual or to a carrier.
> 
> In the individual case, when the number ports from one SIP 
> address to another, it remains "owned" by the individual.
> 
> In the carrier case (at least in the US as I understand it), 
> the number is assigned to what is known as the donor 
> switch/network/carrier.  This is typically the network that 
> "owned" the number before number portability was invented.  
> When a user ports to a new serving switch/network/carrier, 
> the NP database maps the number to a location routing number 
> (LRN).  Carrier ENUM does essentially the same thing, it 
> records the current E.164 to SIP URI of Serving Carrier point 
> of interconnect.
> 
> If the user ports again, the donor network remains the same, 
> while the serving network in ENUM will change.
> 
> If the user relinquishes the number (cancels service), the 
> number reverts back to the donor network to be assigned to 
> their next new customer.  (Not sure if this is same worldwide.)
> 
> If one carrier buys another carrier, then the numbers owned 
> by the acquired carrier will now belong to the buying carrier.
> 
> So:
> 
> Donor 1 = ENUM leaf  (original carrier moves customer to 
> ENUM) Donor 1 -> Serving 2 = ENUM leaf  (first port) Donor 1 
> -> Serving 3 = ENUM leaf  (second port) Donor 1 -> Serving 4 
> = ENUM leaf  (third port) Donor 5 -> Serving 4 = ENUM leaf  
> (carrier 5 buys carrier 1) Donor 5 = ENUM leaf  (customer cancels)
> 
> Does that make sense?
> 
> Mike
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of James Polk (jmpolk)
> > Sent: Wednesday, August 17, 2005 12:46 PM
> > To: Stastny Richard; Jonathan Rosenberg (jdrosen); Paul Kyzivat 
> > (pkyzivat); [email-masked]
> > Cc: [email-masked]; [email-masked]
> > Subject: [Enum] Re: [Geopriv] Re: [Simple] tel URIs in common policy
> > 
> > >I fully agree that there seems to be an issue here, because
> > the problem
> > >is currently discussed at voipeer also.The format 
> > >gets very important especially for Carrier ENUM indicating the 
> > >destination providers (see below)
> > 
> > carrier no longer operates a phone number that is in operation by 
> > another carrier?
> > 
> > For example, my wife has had the same cell phone number for
> > 15+ years, yet she has recently changed to her third carrier. 
> >  The company that originally owned her phone number is 
> being acquired 
> > by a 4th company now (here in the US, giving you a hint as 
> to two of 
> > the players involved).
> > 
> > gets very important especially for Carrier ENUM indicating the 
> > destination providers"
> > 
> > >
> > >It also concerns the CLI and CLIR aspect not yet fully 
> discussed in 
> > >voipeer. This is one issue definitely in scope of voipeer.
> > >
> > >comments inline
> > >
> > 
> > 
> > cheers,
> > James
> > 
> >                                  *******************

---

From: "Stastny Richard" <[email-masked]>
Date: Sat, 20 Aug 2005 00:35:38 +0200

I think we have detected a problem here:
(I have read the sip-identity draft now ;-)
 
Starting with Jonathans request to use 
sip:[email-masked];user=phone
only if foo.com is the carrier hosting the E.164 number
in the FROM Field for identity assertion
he also proposed to use this in the TO field
only if the carrier is the one hosting the E.164 number
in all other case the following should be used if 
an intermediary is used

>>INVITE tel:+1973952500 SIP/2.0
>>Route: sip:<whatever-you-want>@gateway.provider.com
>
> 
> instead of the currently used
> sip:tel:[email-masked];user=phone
 
This makes sense also in carrier ENUM, but: only
if the NAPTR is pointing to the final destination network
 
But there could be cases that a group of carriers, say e.g. the
mobile operators, still want to use for final routing their own provate
network. The public carrier ENUM enrty could then point to a SBC
sitting of the edge of the private network
 
According to the above proposal in this case
>>INVITE tel:+1973952500 SIP/2.0
>>Route: sip:<whatever-you-want>@gateway.provider.com
 
should be used to access the SBC
but this cannot be entered in ENUM
only
> sip:tel:[email-masked];user=phone

is currently possible
but there is no way to distuingish for the
originating network if the destination is a gateway
or the destination network
 
Maybe an additional parameter could help here to
construct
>>INVITE tel:+1973952500 SIP/2.0
>>Route: sip:<whatever-you-want>@gateway.provider.com
out of the ENUM URI
if this becomes recommended practice.
sip:tel:[email-masked];user=phone;route=gw

-richard

________________________________

Von: Michael Hammer (mhammer) [mailto:[email-masked]]
Gesendet: Sa 20.08.2005 00:05
An: Paul Kyzivat (pkyzivat)
Cc: James Polk (jmpolk); Stastny Richard; Jonathan Rosenberg (jdrosen); [email-masked]; [email-masked]; [email-masked]
Betreff: RE: [Enum] Re: [Geopriv] Re: [Simple] tel URIs in common policy

Paul,

I understand what you are driving at when presented a sip address
containing an E.164 number with no other context.  But, I would suggest
that putting such a number into Carrier ENUM must be limited to the
carrier of record currently serving that phone number.  Otherwise, what
stops all 3000+ carriers in the US from asking to put an entry for my
phone number into that location of the Carrier ENUM tree pointing
traffic to their domain?

Mike

> From: Paul Kyzivat (pkyzivat)
> Sent: Friday, August 19, 2005 5:35 PM
> To: Michael Hammer (mhammer)
> Cc: James Polk (jmpolk); Stastny Richard; Jonathan Rosenberg
> (jdrosen); [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Enum] Re: [Geopriv] Re: [Simple] tel URIs in
> common policy
>
>
>
> Michael Hammer (mhammer) wrote:
> > James,
> >
> > This seems to be a number portability question.  E.164 numbers get
> > assigned by the national authority either directly to the
> individual
> > or to a carrier.
> >
> address to
> > another, it remains "owned" by the individual.
> >
> > In the carrier case (at least in the US as I understand it), the
> > number is assigned to what is known as the donor
> > switch/network/carrier.  This is typically the network that "owned"
> > the number before number portability was invented.  When a
> user ports
> > to a new serving switch/network/carrier, the NP database maps the
> > number to a location routing number (LRN).  Carrier ENUM does
> > essentially the same thing, it records the current E.164 to
> SIP URI of
> > Serving Carrier point of interconnect.
> >
> > If the user ports again, the donor network remains the
> same, while the
> > serving network in ENUM will change.
>
> I thought I saw a note that the ENUM WG accepted a work item
> to do exactly this, which would imply that it isn't yet being
> done this way.
> If its not, then I would assume that the carrier enum would
> simply point to the donor network.
>
> > If the user relinquishes the number (cancels service), the number
> > reverts back to the donor network to be assigned to their next new
> > customer.  (Not sure if this is same worldwide.)
> >
> > If one carrier buys another carrier, then the numbers owned by the
> > acquired carrier will now belong to the buying carrier.
> >
> > So:
> >
> ENUM) Donor 1
> > -> Serving 2 = ENUM leaf  (first port) Donor 1 -> Serving 3 = ENUM
> > leaf  (second port) Donor 1 -> Serving 4 = ENUM leaf  (third port)
> Modulo the above comments. But I don't think this really has
> a whole lot to do with the original question. This comes down
> to whether you believe that
>
> is only valid if foo.com is the serving network/carrier for
> +1-232-555-1234. There are a whole lot of people who don't think that.
>
> In my mind all that you can conclude from such a URI is that
> foo.com is to participate in routing calls to that URI.
> Whether they terminate in foo.com's network, or are
> eventually terminated someplace else is for foo.com to decide.
>
>       Paul
>
>

---

From: "Stastny Richard" <[email-masked]>
Date: Mon, 22 Aug 2005 15:33:58 +0200

> A properly designed adapter (like the FXS station in the Intertex
IX67)
> will
> support converting a phone number, like +1-972-123-5555 into a URL by
> dialing a prefix, for example, dialing 90:
> 
> 90-1-972-123-5555 will call out to sip:[email-masked]

So you are proposing a new international standard using "90" as 
access code for international calls?

FYI, there is already one recommended by ITU-T: "00".
Not all countries are compliant, but most.

In addition: you cannot expect end-user to configure their 
IX67 and Sipura. It just has to work and it should work consistently
like the old phone system.

Richard

Richard Stastny
OeFEG
tel:+43 664 420 4100
enum:+43 780 203 211
callto://fordprefect
http://voipandenum.blogspot.com

> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: Monday, August 22, 2005 12:09 AM
> To: Stastny Richard; [email-masked]; [email-masked];
> [email-masked]
> Cc: 'Karl Stahl'; [email-masked]
> Subject: RE: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in common
> policy
> 
> Richard,
> 
> >Nevertheless, there are still may POTS phones out using terminal
> >adapters capable only of entering digits and * and #.
> 
> A properly designed adapter (like the FXS station in the Intertex
IX67)
> will
> support converting a phone number, like +1-972-123-5555 into a URL by
> dialing a prefix, for example, dialing 90:
> 
> 90-1-972-123-5555 will call out to sip:[email-masked]
> 
> The phone adapter will then have sort of a customized phone book.
> Since VoIP is still in its initial growth curve, the IETF could give
such
> indications for SIP-PSTN adapters to support PSTN number translation
to
> SIP
> URIs.
> 
> In this way we can keep our dear old phones and the beloved phone
numbers
> :-) but will relieve SIP based calling of supporting dial plans that
are
> an
> eternal discussion tema at the IETF.
> 
> Will this work?
> 
> Thanks, Henry
> 
> 
> 
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Stastny Richard
> Sent: Sunday, August 21, 2005 4:02 PM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in common
> policy
> 
> Henry,
> 
> I know your position ;-) and I basically agree.
> 
> >Since the dial plan topic is so complex, even for the experts in the
IETF
> ...
> You mean "especially" for the (dial plan) experts in the IETF ;-)
> 
> >...how can anyone hope that developers or even more, users will get
it
> right?
> User normally had no problems with dial plans since more than 50
years.
> 
> >KISS and use only one of the three:
> 
> >1. E.164 numbers for the Internet challenged,
> >2. SIP URIs for everyone else, or the best of all
> >3. Hide any type of CA in the AO and use Presence. Just click to
call.
> 
> I basically agree.
> 
> Anybody using a softclient, be it on a laptop, PDA or softphone
> should use the same practice like on mobile phone, entering E.164
numbers
> ONLY (or preferably) in the international format with the leading "+"
> 
> Nevertheless, there are still may POTS phones out using terminal
adapters
> capable only of entering digits aad * and #.
> 
> So you MUST use a dialing plan and this can only be a national, local
or
> private dialing plan, because NO international dialing plan exists.
> 
> >I have followed the discussions on dial plans for a while, and it has
> been
> >going on actually for several years.
> 
> Yes, and I tried some two years ago to get a discussion going (ask
Carl)
> to
> find
> a solution for global VoIP providers and eventually also a common
> practice to dial international numbers e.g. with * or ** as
replacement
> for +, with no reaction. I am currently thinking to revive and rewrite
the
> draft
> http://enum.nic.at/documents/IETF/Internet_Drafts/draft-stastny-enum-
> numberi
> ng-voip-00.txt
> 
> cheers
> 
> -richard
> 
> 
> 
> 
>
________________________________________________________________________
__
> __
> _
> List Archive: http://darkwing.uoregon.edu/~llynch/voipeer/
> User Tools: http://darkwing.uoregon.edu/~llynch/voipeer.html
> 
>

---

From: "Stastny Richard" <[email-masked]>
Date: Tue, 23 Aug 2005 16:19:15 +0200

>In the E164 plan, there was never any intention that the caller would actually dial a "+". 

E.164 is a numbering plan, not a dialing plan
 
>The "+" can be thought of as representing the extra digits for the international prefix that you must dial according >to the local dialing plan before you dial the number which follows the "+". Since it's different in various countries, it >shouldn't be written as a part of the number.

Correct
 
>There is no need to be able to enter a "+" on a keypad.

So you never used a mobile phone out of the US. You enter a '+' and is translated
by the system to the local international access code as you say above.

Richard

Von: [email-masked] [mailto:[email-masked]]
Gesendet: Di 23.08.2005 15:30
An: Stastny Richard; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Betreff: Re: [Enum] Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in common policy

In a message dated 8/21/2005 5:01:54 PM Eastern Daylight Time, [email-masked] writes:

	Anybody using a softclient, be it on a laptop, PDA or softphone
	should use the same practice like on mobile phone, entering E.164 numbers 
	ONLY (or preferably) in the international format with the leading "+"
	
	Nevertheless, there are still may POTS phones out using terminal adapters
	capable only of entering digits aad * and #.
	
	So you MUST use a dialing plan and this can only be a national, local or
	private dialing plan, because NO international dialing plan exists.

In the E164 plan, there was never any intention that the caller would actually dial a "+". It is only a way to represent numbers when written (like on letterhead). The "+" can be thought of as representing the extra digits for the international prefix that you must dial according to the local dialing plan before you dial the number which follows the "+". Since it's different in various countries, it shouldn't be written as a part of the number.

There is no need to be able to enter a "+" on a keypad.

Mike Pierce