Subject: Re: Carrier ENUM Definition (was RE: [Enum] Agenda items for IETF Paris)

From: "Stastny Richard" <[email-masked]>
Date: Fri, 08 Jul 2005 07:48:02 -0400

Short reply to the privacy? problem
 
Kim wrote
>Before NP was introduced you could figure out the end operator 
>who provided service to a number purely by analysing the digits in the number. 
>When NP is introduced you can no longer do this.
....
>The primary purpose of Carrier ENUM is to solve the number portability problem. Given an E.164 number, which operator provides >connectivity to that number for the desired service 
....
>For privacy reasons this information needs to be restricted to carriers and not made 
>available to end users - except transparently when they make a call.

Can anybody explain to me why before NP one could figure out the end operator
by analysing the number and this was NOT a privacy problem -
and now with NP this IS a privacy problem?

Which privacy? of the user or of the operator?
 
-richard

________________________________

Von: enum-bounces at ietf.org im Auftrag von Fullbrook Kim (UK)
Gesendet: Fr 08.07.2005 10:32
An: enum at ietf.org
Betreff: Carrier ENUM Definition (was RE: [Enum] Agenda items for IETF Paris)

Would agree with previous definitions of User ENUM. On to my definition of carrier enum.

First a bit of background. In most countries of the world where there are multiple mobile operators it is possible to keep your E.164 number when you move your service to a different mobile operator. In a smaller number of countries it is possible to do the same when moving between fixed line operators. This is called Number Portability. Before NP was introduced you could figure out the end operator who provided service to a number purely by analysing the digits in the number. When NP is introduced you can no longer do this.

The primary purpose of Carrier ENUM is to solve the number portability problem. Given an E.164 number, which operator provides connectivity to that number for the desired service (strictly: for the desired enumservice) ? Of course ENUM relates an E.164 number to a URI so there is other information available in the URI such as the protocol needed and there may possibly be other optional information as well.

For privacy reasons this information needs to be restricted to carriers and not made available to end users - except transparently when they make a call.

The call obviously needs to be routed to the destination network and may actually be routed via several intermediate carriers. For example if I make a circuit-switched call from my mobile on the O2 network in the UK to Mr Y in China, there is no direct peering between O2 and any Chinese network. We would route the call to one of our International carriers who may forward it to another International carrier (and maybe forwarded again), before reaching the local Chinese carrier of Mr Y.  Once we know the end destination of the call we figure out which of our carriers is the "next hop" and forward the call. They then forward it as appropriate. This is how the circuit-switched world works today. The same model will inevitably be followed for IMS's SIP-based calls because direct peering is not realistic on a global telco scale.

Peering and routing information between carriers is nothing to do with ENUM at all. There is definitely a need for this information somewhere but it is not ENUM.  Discussion about "Carrier ENUM" tends to include peering and routing information because of the need for privacy at a carrier level but this is a separate (although related) subject. Perhaps we need to introduce a term "Carrier DNS" for non-ENUM related information held in a DNS ?  Alternative terms could be "Carrier Routing" and/or "Carrier Peering".

Kim Fullbrook
O2 UK

-----Original Message-----

=====================================================
This electronic message contains information from O2 which may be privileged or confidential. The information is intended to be for the use of the individual(s) or entity named above. If you are not the intended recipient be aware that any disclosure, copying distribution or use of the contents of this information is prohibited. If you have received this electronic message in error, please notify us by telephone or email (to the numbers or address above) immediately.
=====================================================

From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org] On Behalf Of Stastny Richard
Sent: 07 July 2005 22:44
To: Patrik Fältström; Livingood, Jason
Cc: enum at ietf.org; Richard Shockey
Subject: Re: [Enum] Agenda items for IETF Paris

Hi all,

>For example, I know Stasny have said several times "this is not ENUM"
>and personally, I do agree with him. But, to be able to have that
>discussion, we first need the meta-discussion...

I agree that there seems to be a discussion necessary

to clarify this, as I tried to state in the definitions I posted:

The purpose of User ENUM is for mapping end-user URIs to E.164 numbers.
basically a service for end-users. The basic requirement for end-users
is to find other end.users. The second requirement is that orig end-user
must be able to reach the destination user, because the Internet is
end-to-end. User ENUM is conformant to the Internet principles

The purpose of Carrier ENUM is to help carriers finding peering partners
using E.164 numbers to map to URIs, basically find the destination networks
from an origination network. The basic requirement for carriers is to find other
carriers. Here it is NOT required that every carrier must be able to reach any
other carrier, this is depandant on peering agreements.

These two implementations are orthogonal and independant.

If there is an efficient way to use the same nfrastructure for these
differnt purposes, fine.

IMHO the VoIP peering requirements necessary to do so are out of scope
of ENUM WG. I leave it to the discussion if they are within the scope of the IETF.
On the other hand, many IETF protocols are used on IP-based networks separated
from the Internet (e.g. SIP within 3GPP).

-richard

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 08 Jul 2005 16:11:54 -0400

Kim,

You are heading down the wrong path.  We do not need to re-invent the PSTN.  Ideally, there is only P2P, but that doesn't scale.  Next best, there is only originating and terminating voice carriers.  All the Inter-exchange carrier stuff can be done at the data transport layer, as there is no value added in terms of voice features.

ENUM should not be viewed as a general purpose database, otherwise it grows lots of barnacles.  If you have extra information that needs to be shared, but privacy-protected, point to more general purpose databases to store that information.  If the requestor has the right authentication credentials and policy authorizes it, then they get access.

As for number portability, the only requirement is that resolution of a single E.164 number query MUST return  either zero (not assigned or user ENUM case) or one carrier RR.  That may also seem to imply that any sub-string within that number should not return a carrier RR unless all other E.164 numbers that share that same sub-string also share the same carrier.

Mike

> From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org] On 
> Behalf Of Fullbrook Kim (UK)
> Sent: Friday, July 08, 2005 4:32 AM
> To: enum at ietf.org
> Subject: Carrier ENUM Definition (was RE: [Enum] Agenda items 
> for IETF Paris)
> 
> First a bit of background. In most countries of the world 
> where there are multiple mobile operators it is possible to 
> keep your E.164 number when you move your service to a 
> different mobile operator. In a smaller number of countries 
> it is possible to do the same when moving between fixed line 
> operators. This is called Number Portability. Before NP was 
> introduced you could figure out the end operator who provided 
> service to a number purely by analysing the digits in the 
> number. When NP is introduced you can no longer do this.
> 
> The primary purpose of Carrier ENUM is to solve the number 
> portability problem. Given an E.164 number, which operator 
> provides connectivity to that number for the desired service 
> (strictly: for the desired enumservice) ? Of course ENUM 
> relates an E.164 number to a URI so there is other 
> information available in the URI such as the protocol needed 
> and there may possibly be other optional information as well.
> 
> For privacy reasons this information needs to be restricted 
> to carriers and not made available to end users - except 
> transparently when they make a call.
> 
> The call obviously needs to be routed to the destination 
> network and may actually be routed via several intermediate 
> carriers. For example if I make a circuit-switched call from 
> my mobile on the O2 network in the UK to Mr Y in China, there 
> is no direct peering between O2 and any Chinese network. We 
> would route the call to one of our International carriers who 
> may forward it to another International carrier (and maybe 
> forwarded again), before reaching the local Chinese carrier 
> of Mr Y.  Once we know the end destination of the call we 
> figure out which of our carriers is the "next hop" and 
> forward the call. They then forward it as appropriate. This 
> is how the circuit-switched world works today. The same model 
> will inevitably be followed for IMS's SIP-based calls because 
> direct peering is not realistic on a global telco scale.
> 
> Peering and routing information between carriers is nothing 
> to do with ENUM at all. There is definitely a need for this 
> information somewhere but it is not ENUM.  Discussion about 
> "Carrier ENUM" tends to include peering and routing 
> information because of the need for privacy at a carrier 
> level but this is a separate (although related) subject. 
> Perhaps we need to introduce a term "Carrier DNS" for 
> non-ENUM related information held in a DNS ?  Alternative 
> terms could be "Carrier Routing" and/or "Carrier Peering".
> 
> Kim Fullbrook
> O2 UK
> 
> This electronic message contains information from O2 which 
> may be privileged or confidential. The information is 
> intended to be for the use of the individual(s) or entity 
> named above. If you are not the intended recipient be aware 
> that any disclosure, copying distribution or use of the 
> contents of this information is prohibited. If you have 
> received this electronic message in error, please notify us 
> by telephone or email (to the numbers or address above) immediately.
> basically a service for end-users. The basic requirement for 
> end-users is to find other end.users. The second requirement 
> is that orig end-user must be able to reach the destination 
> user, because the Internet is end-to-end. User ENUM is 
> conformant to the Internet principles
>  
> The purpose of Carrier ENUM is to help carriers finding 
> peering partners using E.164 numbers to map to URIs, 
> basically find the destination networks from an origination 
> network. The basic requirement for carriers is to find other 
> carriers. Here it is NOT required that every carrier must be 
> able to reach any other carrier, this is depandant on peering 
> agreements.
>  
> If there is an efficient way to use the same nfrastructure 
> for these differnt purposes, fine.
>  
> IMHO the VoIP peering requirements necessary to do so are out 
> of scope of ENUM WG. I leave it to the discussion if they are 
> within the scope of the IETF.
> On the other hand, many IETF protocols are used on IP-based 
> networks separated from the Internet (e.g. SIP within 3GPP).
>  
>  
> -richard
>