Subject: RE: Carrier ENUM Definition (was RE: [Enum] Agenda items forIETF Paris)

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 08 Jul 2005 17:33:34 -0400

Following up on the question about hiding the points of interconnect between two carriers:

1.  Does this mean that if party A has been assigned an ENUM number directly from a national authority and A tries to call party B that got his number from a carrier X in club Y, that the ENUM query for the SBC to access carrier X will be null because A is not in club Y?

2.  Should the RR identifying the SBC to access carrier X contain both sip and sips URI?  One for public access and one for private club access?  If I scan the DNS would I find these URIs?

Mike

> -----Original Message-----
> From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org] On 
> Behalf Of Richard Shockey
> Sent: Friday, July 08, 2005 1:07 PM
> To: Patrik Faltstrom (pfaltstr); Richard Shockey
> Cc: enum at ietf.org
> Subject: Re: Carrier ENUM Definition (was RE: [Enum] Agenda 
> items forIETF Paris)
> 
> At 12:48 PM 7/8/2005, Patrik Fältström wrote:
> 
> 
> >On Jul 8, 2005, at 16:44, Richard Shockey wrote:
> >
> >>...there is a requirement among service providers for some form of 
> >>database technology that, based on a E164 number, can provide 
> >>information on how to route a service to a point of carrier 
> >>interconnection or ALG as expressed as a URI.
> >
> >Ok, this is for me one requirement. Sorry for maybe not being clear.
> >
> >>For privacy reasons this information needs to be restricted 
> to service 
> >>providers and not generally available to end users.
> >
> >Is the requirement that this information (the mapping from E.164 to
> >URI) is only to be visible for the party that need to know, or "any 
> >service provider being part of the same club"?
> 
> oh fine distinction can you elaborate a bit ?...what is the 
> difference been 'party that needs to know' or 'service 
> provider being part of the same club' .. what is the distinction?
> 
> as some here might postulate the exposure of the URI of the 
> ALG may or may not be visible to A. all parties as in the use 
> of .carrier.e164.arpa B. 
> just visible to the club as in 3GPP.NET or e164MSO.ORG and 
> the visibility of the ALG URI does not necessarily imply a 
> formal peering agreement between party A and party B.
> 
> What the egress ALG does once it gets in INVITE is a matter 
> between consenting capitalists.
> 
> Does that help?
> 
> 
> >    paf
> >
> >
> >
> 
> 
>  >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> Richard Shockey, Director - Member of Technical Staff NeuStar Inc.
> 46000 Center Oak Plaza  -   Sterling, VA  20166
> sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
> ENUM +87810-13313-31331
> PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  
> Fax: +1 815.333.1237 <mailto:richard(at)shockey.us> or 
> <mailto:richard.shockey(at)neustar.biz>
> <http://www.neustar.biz> ; <http://www.enum.org> 
> <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
> 
> 
> _______________________________________________
> enum mailing list
> enum at ietf.org
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Haberler <[email-masked]>
Date: Sat, 09 Jul 2005 04:33:09 -0400

At 23:33 08.07.2005, Michael Hammer \(mhammer\) wrote:
Following up on the question about hiding the points of interconnect 
between two carriers:

1.  Does this mean that if party A has been assigned an ENUM number 
directly from a national authority and A tries to call party B that got 
his number from a carrier X in club Y, that the ENUM query for the SBC to 
access carrier X will be null because A is not in club Y?
A will be able to call B if B has opted in to User ENUM.
If A, a "User", looks in the carrier tree for B, he will find X's SBC URI. 
The session setup to this URI will fail though.

2.  Should the RR identifying the SBC to access carrier X contain both sip 
and sips URI?  One for public access and one for private club access?  If 
I scan the DNS would I find these URIs?
sip or sips, they would be for "private club access". This doesnt prevent a 
carrier to leave their SBC/ALG openly accessible, but I dont expect that to 
happen frequently.

You would find them in the DNS, but they will not be particularly 
interesting beyond giving the SBC/ALG URI.

-Michael