Subject: Re: [Enum] ENUM and location information

From: "Stastny Richard" <[email-masked]>
Date: Mon, 04 Jul 2005 04:38:36 -0400

Hi Tuomo,
 
you are correct, there was (is) a proposal to include location
information in ENUM, which may be quite useful for companies
and hotels together with 1-800 numbers.
 
ETSI TS 102 172 proposes such an Enumservice, BTW als
a pointer to public keys:
"9.4.2.1 "ENUMservices" for Location Information

This "ENUMservice" indicates that the associated resource can act as a source 
for location information. It is proposed to provide this information in 
Geography Markup Language (GML).

* loc:http

9.4.2.2 "ENUMservices" for Public Key Information

These "ENUMservices" indicate that the associated resource can act as a source for public key information.

* key:ldap

* key:http"

These Enumservices are an the bottom of the list.
We are currently trying to get some of the Enumserices defined in ETSI TS 102 172
through IETF and IANA, but this is a very slow process, so we are still stuck
in the first third of the list.
 
IETF is working much slower then ITU-T and ETSI and can take only
one or two new Enumservices at a time, so I have now idea
when we will reach the bottom of the list (or throw the towel before).
 
Anyway, it would be useful if somebody tries out
the ETSI defined Enumservices to get some experience
and feedback
 
best regards
Richard

________________________________

Von: enum-bounces at ietf.org im Auftrag von Rostela Tuomo
Gesendet: Mo 04.07.2005 09:50
An: enum at ietf.org
Betreff: [Enum] ENUM and location information

Hi I am partial time lurker of this list and that's the reason I'm not in touch of all discussions.

Perhaps most of us remember "business card" example of ENUM. There was mentioned user can publish his location information like street address or longitude/latitude.
In my mind there is not yet specified suitable NAPTR for this but obviously I'm wrong. I read rfc 3403 (DDDS) and discussions of lists "ietf-ecrit" and "ietf-geopriv" but I didn't got an idea to implement ENUM-query/location-responce pair.
Now I am asking if someone know any experimental implementation of this kind environments. I don't mean WHOIS or any that kind systems, only pure ENUM based system.

Regards, Tuomo

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Jim Reid <[email-masked]>
Date: Mon, 04 Jul 2005 05:26:18 -0400

On Jul 4, 2005, at 09:41, Stastny Richard wrote:
you are correct, there was (is) a proposal to include location
information in ENUM, which may be quite useful for companies
and hotels together with 1-800 numbers.
ETSI TS 102 172 proposes such an Enumservice, BTW als
a pointer to public keys:
"9.4.2.1 "ENUMservices" for Location Information
What does this achieve that can't already be done with a LOC record?
ie If people just put a LOC record into their ENUM zone files and 
applications looked up those RRs we're done.

The LOC record also has the advantage of being a lot more succint and 
far easier to parse than a string of ?ML goop.

---

From: lconroy <[email-masked]>
Date: Mon, 04 Jul 2005 05:58:31 -0400

Hi Jim, Richard, Rostela,
 The LOC resource record is very specific - there's an explicit syntax, 
and of course it is published in DNS.
 The loc:http (or loc:https) Enumservice was intended for those of us 
who are not ecstatic about everyone in
the universe** knowing where we are, or for real-time updated location 
where DNS is probably not appropriate.

** I understand that most governments insist that only evildoers with 
something to hid would object to people knowing where they are, or what 
they're doing, or (if it were possible without the nuisance of wires 
permanently plugged into their head) what they're thinking. However, 
with DNS it isn't just governments - it's everyone.

all the best,
  Lawrence
On 4 Jul 2005, at 10:24, Jim Reid wrote:

The LOC record also has the advantage of being a lot more succint and 
far easier to parse than a string of ?ML goop.
---------------------------------------
lawrence conroy    |tel:+44-1794-833666
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Jim Reid <[email-masked]>
Date: Mon, 04 Jul 2005 09:24:57 -0400

On Jul 4, 2005, at 10:54, lconroy wrote:
 The LOC resource record is very specific - there's an explicit 
syntax, and of course it is published in DNS.
 The loc:http (or loc:https) Enumservice was intended for those of us 
who are not ecstatic about everyone in
the universe** knowing where we are, or for real-time updated location 
where DNS is probably not appropriate.
I don't understand this. How does publishing one's location data via a 
LOC record differ from publishing it though some GML string? After all, 
they'e both in the DNS where anyone can see them. I'm not sure I buy 
the argument that the DNS isn't appropriate for real-time updates 
either.

So I'll ask again, what can a loc:http NAPTR do that a LOC record can't?
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum