Subject: RE: [Enum] Fwd: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt

From: "Stastny Richard" <[email-masked]>
Date: Fri, 22 Jul 2005 11:05:54 -0400

Dear all,
 
although I did not receive (yet) any response to my e-mail below,
I want to comment on the mentioned draft:
 
I have a question to the following paragraph:
 
"The following Enumservice is registered with this document: "npd" to 
   indicate number portability data.  The purpose of this Enumservice is 
   to describe information about telephone numbers which cannot be used 
   on the public Internet or a private/peered Internet Protocol (IP) 
   network.  Thus, these are numbers which are only reachable via the 
   traditional Public Switched Telephone Network (PSTN)."
 
The second sentence seems to imply that ONLY ported numbers
will be used with the Enumservice "npd". The example 4.2 indicates
that also non-ported numbers may be used.
 
The third sentence is simply not true: I myself have ported numbers
that can be reached on the public Internet via SIP URIs.
 
IMHO there is a more in-depth analysis required how this
Enumservice is used, what it implies and with which other
Enumservices it can be used togother
 
There is also a need to consolidate the different Enumservices
using the tel URI and their use in User and Carrier ENUM.
Also the usage of crosspointers (entries in User ENUM pointing
to Carrier ENUM and vice versa) with tel URIs is necessary.
 
One example is the usage of ENUM-only numbers existing only
in User ENUM (e.g. +43780 and +87810). Here a pointer in
Carrier ENUM may be useful to point from Carrier ENUM to
User ENUM. Such a number may have a routing number , but 
this routing numbers are only of national significance and cannot
be used in a global system.
 
There is also missing a note that with this Enumservice the tel URI
MUST always contain the same number then the AUS.
 
regards
 
-richard

________________________________

Von: enum-bounces at ietf.org im Auftrag von Stastny Richard
Gesendet: So 10.07.2005 14:51
An: Richard Shockey; enum at ietf.org
Betreff: Re: [Enum] Fwd: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt

Dear all, especially Allison Mankin,

I consider this I-D very interesting, because I also proposed in the past to use the
parameters defined in draft-ietf-iptel-tel-np-06.txt e.g. ";rn=" within ENUM,
but did not bring this forward because of reason stated below.

Before I comment on this draft and raise some questions, I would like to
get some principle statements from our esteemed AD Allison if this draft
is within the scope of IETF and ENUM WG.

The rationale for this question is the following:

The intended use of the Enumservice "npd:tel" is primarily for
carriers, because only carriers my interpret and use the "rn= parameter.

Routing numbers MUST NEVER be used by end-users.

During the discussion Lawrence Conroy and I had with Ted Hardie
and Allison Mankin in Geneva in May regarding the I-D draft-ietf-enum-msg-04.txt,
especially about Enumservice "mms:mailto", I mentioned the fact that
this Enumservice MAY also be used by carriers.

Allison did not like this statement at all and said ENUM and
Enumservices to-be-defined are ONLY for end-user usage. I only
got over this hurdle by confirming that "mms:mailto" is ALSO
useful for end-users.

Therefore I want to have a clear statement from the responsible AD
if an Enumservice for carrier use ONLY is within the scope of ENUM WG,
before I waste my time in discussing this I-D on the list.

Richard Stastny

________________________________

Von: enum-bounces at ietf.org im Auftrag von Richard Shockey
Gesendet: Fr 08.07.2005 22:52
An: enum at ietf.org
Betreff: [Enum] Fwd: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt

>To: i-d-announce at ietf.org
>From: Internet-Drafts at ietf.org
>Date: Fri, 08 Jul 2005 15:50:01 -0400
>X-Spam-Score: 0.4 (/)
>X-Scan-Signature: 73734d43604d52d23b3eba644a169745
>X-BeenThere: i-d-announce at ietf.org
>X-Mailman-Version: 2.1.5
>Reply-To: internet-drafts at ietf.org
>List-Id: i-d-announce.ietf.org
>List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/i-d-announce>,
>         <mailto:i-d-announce-request at ietf.org?subject=unsubscribe>
>List-Post: <mailto:i-d-announce at ietf.org>
>List-Help: <mailto:i-d-announce-request at ietf.org?subject=help>
>List-Subscribe: <https://www1.ietf.org/mailman/listinfo/i-d-announce>,
>         <mailto:i-d-announce-request at ietf.org?subject=subscribe>
>Sender: i-d-announce-bounces at ietf.org
>X-SongbirdInformation: support at songbird.com for more information
>X-Songbird: Found to be clean
>X-Songbird-From: i-d-announce-bounces at ietf.org
>Subject: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt
>X-Keywords:
>
>
>
>
>X-MIME-Autoconverted: from 8bit to quoted-printable by ietf.org id PAA11687
>
>A New Internet-Draft is available from the on-line Internet-Drafts
>directories.
>
>
>         Title           : IANA Registration for an Enumservice
>                           Containing Number Portability and PSTN
>                           Signaling Information
>         Author(s)       : J. Livingood, R. Shockey
>         Filename        : draft-livingood-shockey-enum-npd-00.txt
>         Pages           : 8
>         Date            : 2005-7-8
>
>    This document registers the Enumservice "npd" and subtype "tel" using
>    the URI scheme 'tel:' as per the IANA registration process defined in
>    the ENUM specification, RFC 3761.  This data is used to facilitate
>    the routing of telephone calls in those countries where Number
>    Portability exists.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-livingood-shockey-enum-npd-00.txt
>
>To remove yourself from the I-D Announcement list, send a message to
>i-d-announce-request at ietf.org with the word unsubscribe in the body of the
>message.
>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
>to change your subscription settings.
>
>
>Internet-Drafts are also available by anonymous FTP. Login with the username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
>         "get draft-livingood-shockey-enum-npd-00.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>         mailserv at ietf.org.
>In the body type:
>         "FILE /internet-drafts/draft-livingood-shockey-enum-npd-00.txt".
>
>NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
>
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>
>Content-Type: text/plain
>Content-ID: <2005-7-8104034.I-D at ietf.org>
>
>ENCODING mime
>FILE /internet-drafts/draft-livingood-shockey-enum-npd-00.txt
>
>
><ftp://ftp.ietf.org/internet-drafts/draft-livingood-shockey-enum-npd-00.txt>
>_______________________________________________
>I-D-Announce mailing list
>I-D-Announce at ietf.org
>https://www1.ietf.org/mailman/listinfo/i-d-announce

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or <mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Fri, 22 Jul 2005 14:46:27 -0400

Stastny Richard wrote:
Dear all,

That is not true. The ENUM serive npd indicated number portability data 
that may be associated with any telephone number.

The examples in the textare quite clear that the information relates to 
both Ported and NonPorted numbers.

4.1 Example of a Ported Telephone Number
$ORIGIN 3.1.8.7.1.8.9.5.1.2.1.e164.arpa.
NAPTR 10 100 "u" "E2U+npd:tel"
"!^.*$!tel:+1-215-981-7813;rn=+1-215-981-7600;npdi!"
In this example, a Routing Number (rn) and a Number Portability Dip
Indicator (npdi) are used as shown in draft-ietf-iptel-tel-np-06.txt
[10] (Internet-Draft New Parameters for the "tel" URI to Support
Number Portability, draft-ietf-iptel-tel-np-06.txt [10]). The &#x2018;npdi&#x2019;
field is included in order to prevent subsequent lookups in legacy-
style PSTN databases.
4.2 Example of a Non-Ported Telephone Number
$ORIGIN 3.1.8.7.1.8.9.5.1.2.1.e164.arpa.
NAPTR 10 100 "u" "E2U+npd:tel"
"!^.*$!tel:+1-215-981-7813;npdi!"
I have had a private request to consider an alternative formation of th 
e URI.

as in
The modification is to define a new enumservice field.
E2U+npd:sip
with the URI defined something like this.
NAPTR 10 10 "u" "E2U+npd:sip" 
"!^.*$!sip:+15714345651 at mg4.mso.net;rn=+15712768933;npdi!"

the rationale for this is that many gateways dont know what tel URI's are.
The third sentence is simply not true: I myself have ported numbers
that can be reached on the public Internet via SIP URIs.

A fair criticism a better wording might have been.
"Thus, this information is only useful in a national specific context within the traditional Public Switched Telephone Network (PSTN)."

For what purpose?

--

PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1
815.333.1237