Subject: [Enum] VoIP Peering BoF - Naming and Addressing Issues

From: "Stastny Richard" <[email-masked]>
Date: Mon, 18 Jul 2005 17:09:15 -0400

This is my input on the BoF session on VoIP peering and Interconnect
dealing only with the first two issues on
(a) Call routing and 
(b) ENUM and raising a third not yet mentioned issue:
 
-Numbering, naming and addressing
 
In my understanding the basic requirement of VoIP peering
is that voice calls (and other IP communications) originating
on IP and terminating on IP should stay on IP. There reason 
for this has been stated in VOIP peering documents many times:
-better QoS
-more capabilities (BB codecs, presence, IM, video, etc.)
 
Any call going via the PSTN will loose this advantages.
One (very) simple minded could ask the question: "And where is
the problem?" I also can send an e-mail to anybody as
long as I know his e-mail address.
 
Currently the following "types" of "VoIP" exist
(for simplicity I assume only VoIP implemented using SIP):

1. freely accessible servers (proxies) on the public Internet
(ala e-mail)

2. servers on the public Internet, but requiring authentication

3. servers in private networks, accessible from the public
Internet via a Session Border Controller

4. servers in private networks, accessible from the public
Internet via a Session Border Controller (SBC), requiring 
authentication

5. servers in private networks, accessible only via SBC
from other private networks, eventually via a commonly
shared network. 
 
and for completeness:

6. servers in private networks only reachable via the 
PSTN

7. users on a PSTN network which is connected to the
Internet via gateway acting as SBC.
 
There may exist other cases and more details, especially
if SIP, H323 and IMS systems are taken into account
 
The first question that needs to be answered in a
BoF session on VoIP peering is:

A. which of these scenarios are in- and out-of-scope
 
After the scenarios are defined, the next question is
how to route calls between two servers.
 
Routing of calls implies to find out in the originating
network the destination network and, if there is no
direct interconnection between origination network and 
destination network, the transit networks required to
interconnect.

So we are back to question A.: "Are there transit networks
within the scenarios in-scope?"
 
Routing of calls is done normally by analyzing the
"public" identifier of the called party the calling 
party enters.
 
It is obvious that on IP IP-based addresses and names
will be used for routing, the basic question is:

What are the "public" identifiers an end-user will
enter?
 
To make it simple: What identifier does one put on his 
business card?
 
There are currently two choices:
-E.164 numbers
-sip AoR in the format sip:user at foo.bar
-both
 
If it is E.164 numbers only, these E.164 numbers
are translated by some magic (e.g ENUM) to
internal identifiers e.g. sip AoR to find
the routing. The assignement of these
E.164 is according to national rules.
 
If it is SIP AoR, an additional question
comes up: is an end-user restricted to
public identifiers given out by providers
such as richard.stastny AT vodafone.de

or is it possible also to "port in" 
identifiers such as richard AT stastny.com?
 
If it is both, the E.164 identifiers need
to be mapped to SIP AoRs by some means
e.g. ENUM. This ENUM cannot be USER ENUM
because the Carriers services relies on this
mapping, so it must be independant.
 
For all these cases depending on the scenarios
the required mappings and access to DNS and IP
addresses need to be investigated and defined.
 
Some preliminary work in this regard analyzing
the possible scenarios has been done by ETSI
in TS 102 055 "Infrastructure ENUM".

Richard Stastny

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 22 Jul 2005 16:37:23 -0400

Richard,

Could you clarify what you mean by "transit networks"? 

Are these data transport only networks, or do you mean to include
networks that require transport and application layer functions to setup
data network paths?

That would be an interesting discussion point.

Mike

> -----Original Message-----
> From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org] On 
> Behalf Of Stastny Richard
> Sent: Monday, July 18, 2005 5:13 PM
> To: voipeer at lists.uoregon.edu
> Cc: enum at ietf.org
> Subject: [Enum] VoIP Peering BoF - Naming and Addressing Issues
> 
> This is my input on the BoF session on VoIP peering and 
> Interconnect dealing only with the first two issues on
> (a) Call routing and
> In my understanding the basic requirement of VoIP peering is 
> that voice calls (and other IP communications) originating on 
> IP and terminating on IP should stay on IP. There reason for 
> this has been stated in VOIP peering documents many times:
> -better QoS
> One (very) simple minded could ask the question: "And where 
> is the problem?" I also can send an e-mail to anybody as long 
> as I know his e-mail address.
>  
> Currently the following "types" of "VoIP" exist (for 
> simplicity I assume only VoIP implemented using SIP):
> 
> 5. servers in private networks, accessible only via SBC from 
> other private networks, eventually via a commonly shared network. 
>  
> and for completeness:
> 
> 6. servers in private networks only reachable via the PSTN
> 
> 7. users on a PSTN network which is connected to the Internet 
> via gateway acting as SBC.
>  
> There may exist other cases and more details, especially if 
> SIP, H323 and IMS systems are taken into account
>  
> The first question that needs to be answered in a BoF session 
> on VoIP peering is:
> 
> After the scenarios are defined, the next question is how to 
> route calls between two servers.
>  
> network the destination network and, if there is no direct 
> interconnection between origination network and destination 
> network, the transit networks required to interconnect.
> 
> Routing of calls is done normally by analyzing the "public" 
> identifier of the called party the calling party enters.
>  
> It is obvious that on IP IP-based addresses and names will be 
> used for routing, the basic question is:
> 
> What are the "public" identifiers an end-user will enter?
>  
> To make it simple: What identifier does one put on his business card?
>  
> If it is E.164 numbers only, these E.164 numbers are 
> translated by some magic (e.g ENUM) to internal identifiers 
> e.g. sip AoR to find the routing. The assignement of these
> If it is SIP AoR, an additional question comes up: is an 
> end-user restricted to public identifiers given out by 
> providers such as richard.stastny AT vodafone.de
> 
> If it is both, the E.164 identifiers need to be mapped to SIP 
> AoRs by some means e.g. ENUM. This ENUM cannot be USER ENUM 
> because the Carriers services relies on this mapping, so it 
> must be independant.
>  
> For all these cases depending on the scenarios the required 
> mappings and access to DNS and IP addresses need to be 
> investigated and defined.
>  
> Some preliminary work in this regard analyzing the possible 
> scenarios has been done by ETSI in TS 102 055 "Infrastructure ENUM".
> 
> Richard Stastny
> 
> 
>