Subject: RE: [Enum] Comments on ID on new ENUM service "mobileweb"

From: "Fullbrook Kim \(UK\)" <[email-masked]>
Date: Mon, 18 Jul 2005 12:41:22 -0400

The point is that unless the web site receives the CLI of the phone it
can't use ENUM to look up the desired details. If the web site can't use
ENUM then I'm can't see the applicability of the "mobileweb" enumservice
being proposed.

Kim.

-----Original Message-----

=====================================================
This electronic message contains information from O2 which may be privileged or confidential. The information is intended to be for the use of the individual(s) or entity named above. If you are not the intended recipient be aware that any disclosure, copying distribution or use of the contents of this information is prohibited. If you have received this electronic message in error, please notify us by telephone or email (to the numbers or address above) immediately.
=====================================================

From: Jim Reid [mailto:jim at rfc1035.com] 
Sent: 18 July 2005 16:19
To: Fullbrook Kim (UK)
Cc: enum at ietf.org
Subject: Re: [Enum] Comments on ID on new ENUM service "mobileweb"

On Jul 18, 2005, at 13:13, Fullbrook Kim ((UK)) wrote:
> Can you imagine the implications of
> surfing the Net from your phone and presenting your CLI to each and
> every web site ?

No I can't. Please enlighten me. As far as I'm aware no internet 
websites look for CLI from their clients. Unless a client's  browser 
disclosed that info, how could a HTTP server know if it was talking to 
a phone as opposed to (say) a laptop?

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Peter Koch <[email-masked]>
Date: Mon, 18 Jul 2005 12:51:40 -0400

Kim,

> ENUM then I'm can't see the applicability of the "mobileweb" enumservice

are you suggesting that the web server uses ENUM as kind of "reverse mapping"
to lookup the properties of the requesting client which happens to be a
phone? Lawrence (thanks by the way) has already clarified that that's not the
case.

-Peter

---

From: Ray Anderson <[email-masked]>
Date: Tue, 19 Jul 2005 04:53:09 -0400

Just re-reading the "mobileweb" submission, and it could be
read differently.
Lets say you promote your phone number 44 1234 567890 to people as
an
access point to your business, you might also want to make the same
number
a short - cut to one or more web pages.   (Just like Bango
Numbers point to URLs)
You could store the page URLs - different URLs for different browser
types -
in the DNS using ENUM.
The idea of having a differnt URL (ENUM record) for each browser type is
probably
as flawed as the .MOBI idea - since HTTP_ACCEPT should be used.
The idea of using ENUM / DNS to map numbers to content URLs is very
reasonable.
At 17:51 18/07/2005, Peter Koch wrote:
Kim,
> ENUM then I'm can't see the applicability of the
"mobileweb" enumservice
are you suggesting that the web server uses ENUM as kind of "reverse
mapping"
to lookup the properties of the requesting client which happens to be
a
phone? Lawrence (thanks by the way) has already clarified that that's not
the
case.
-Peter
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

Ray Anderson   CEO Bango   ray at bango.com    www.bango.com Mobile: +44 7768 454545  Fax: +44 20 7692 5558  
Come and see Bango at Mobile Entertainment Summit 2005,  Hilton Universal City, Los Angeles, USA   27-28 July www.ihollywoodforum.com

---

From: Jim Reid <[email-masked]>
Date: Tue, 19 Jul 2005 09:36:46 -0400

On Jul 18, 2005, at 17:32, Fullbrook Kim ((UK)) wrote:
The point is that unless the web site receives the CLI of the phone it
can't use ENUM to look up the desired details. If the web site can't 
use
ENUM then I'm can't see the applicability of the "mobileweb" 
enumservice
being proposed.
I seem to have things back-to-front. I thought that ENUM was about 
mapping phone numbers to URIs and that web servers talked to clients 
that had IP addresses.