Subject: RE: [Enum] Fwd: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 25 Jul 2005 16:28:52 -0400

Some comments inline. 

> -----Original Message-----
> From: Stastny Richard [mailto:Richard.Stastny at oefeg.at] 
> Sent: Monday, July 25, 2005 4:10 PM
> To: Michael Hammer (mhammer); Richard Shockey
> Cc: enum at ietf.org
> Subject: Re: [Enum] Fwd: I-D 
> ACTION:draft-livingood-shockey-enum-npd-00.txt
> 
> Mike wrote:
>  
> >> In Carrier ENUM the holder of the domain has to change if 
> the number 
> >> is ported.
> 
> >Call it porting if you like, but do you use the ENUM registration 
> >process or the Number Portability process to make the change in the 
> >Carrier ENUM registry?
> 
> It is not decided yet how this works in practice
> 
> This is the discussion about the so-called carrier-of-record, 
> and will be defined nationally
> 
> It is my private opinion that basically no validation is 
> necessary if a carrier says he is hosting the number. Why 
> should he cheat?

Ummm... Add 10 second post-dial delay then onward route?
Then advertize your network's quick setup.  :)  Just being cynical.

> 
> In User ENUM it is commonly agreed that the best validation 
> method is that the carrier hosting the number is approving 
> that the end-user has the right to use this number.
> 
> Now if the carrier wants to do the same in carrier ENUM why 
> not trust him now?
> What would be the incentive to enter number in Carrier ENUM 
> he is not hosting?
> the calls would be routed to him and what then?
> 
> Carrier ENUMs already implemented use this trust principle
> 
> Of course if a process for NP is in place and Carrier ENUM is 
> implemented in or near e164.arpa, the existing mechanism 
> could be used to include Carrier ENUM also.
> 
> >> What is the tel ENUM services? There is none currently defined.
> 
> >I have heard discussion of putting tel URIs in NAPTR records (maybe 
> >that was on IPTEL list).  Perhaps, I am using wrong 
> terminology.  What 
> >do you call such NAPTRs?  Perhaps, also defining such is 
> still work in 
> >progress.  I found all the SIP+E2U versus E2U+SIP IANA registration 
> >mixup confusing.
> 
> As I stated in my previous posting, there are many 
> Enumservices using tel: URI already. in addition there is 
> fax:tel, mms:tel, sms:tel, etc
> 
> Yes, it is confusing and you are not alone ;-)
> 
> 
> > 
> >> No, routing numbers are only meaningfull on the PSTN and also here 
> >> only in a national context.
> 
> >Given the +CCxxxxx digits the national context can be known. 
>  While it 
> >is meanful to determine which switch or gateway the rn= digits are 
> >homed to, that does not mean that one needs to route to the nearest 
> >PSTN GW to get the call to that switch.  If an SP has many 
> PSTN GWs, it 
> >may be cost-effective to route to that rn= value through one PSTN GW 
> >versus another.  Are there any assumptions being made here?
> 
> You may route such a call to any PSTN-GW, but then the rn 
> info is meaningless, so you could as well remove it.

The PSTN GW can interwork this information into the appropriate ISUP
parameter.

> Only if you route it to a PSTN GW in the country, an then you 
> just save the GW another NP dip.

Exactly.

> As Rich pointed out this is basically for the US and here 
> everything is national anyway ;-)
> 
> The real benefit of this Enumservice is IMHO that you may no 
> use Carrier ENUM as the real NP Database by querying the DB 
> also from the PSTN via an IN  SCP-mediation

Yes, the ENUM can *now* replace the current NP database system.

Mike

> -richard

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Mon, 25 Jul 2005 16:48:02 -0400

Michael Hammer (mhammer) wrote:
As Rich pointed out this is basically for the US and here 
everything is national anyway ;-)

Ah ...well.. <cough> no.  You cant replace the NPAC ..but you can 
provide service providers some new options on how to use it.

--

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1
815.333.1237
<mailto:richard(at)shockey.us> or <mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum