Subject: Re: [Enum] Fwd: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt

From: "Stastny Richard" <[email-masked]>
Date: Mon, 25 Jul 2005 06:19:59 -0400

Rich,
 
One comment first
I basically like the idea of a generic tel Enumservice, whatever it
is called. but I do not have thought through all implications
Maybe we can discuss this in Paris (we have a whole week ;-)
 
To your remarks:
 
>That is not true. The ENUM serive npd indicated number portability data
>that may be associated with any telephone number.

>The examples in the textare quite clear that the information relates to
>both Ported and NonPorted numbers.

Thats what I said:

Still, the sentence:

"The purpose of this Enumservice is
to describe information about telephone numbers which cannot be used
on the public Internet or a private/peered Internet Protocol (IP)
network.  "

is unclear (or wrong, because you can use proted numbers on the Public Internet
(I do)

>The modification is to define a new enumservice field.
>E2U+npd:sip
>with the URI defined something like this.

>NAPTR 10 10 "u" "E2U+npd:sip"
>"!^.*$!sip:+15714345651 at mg4.mso.net;rn=+15712768933;npdi!"

>the rationale for this is that many gateways dont know what tel URI's are.
 
Now I am completely lost. I tought the "npd" was a generic Enumservice
giving the "rn" to be used (in the national network), but the gateway to
user is your choice. One may even query this information from the
PSTN via a IN-mediation device. Now you introduce a specific
"transit" gateway.
 
BTW: your example URI should be:
sip:+15714345651;rn=+15712768933;npdi at mg4.mso.net

>For what purpose?
 
For this:

>
>One example is the usage of ENUM-only numbers existing only
>in User ENUM (e.g. +43780 and +87810). Here a pointer in
>Carrier ENUM may be useful to point from Carrier ENUM to
>User ENUM. Such a number may have a routing number , but
>this routing numbers are only of national significance and cannot
>be used in a global system.
>
>There is also missing a note that with this Enumservice the tel URI
>MUST always contain the same number then the AUS.

________________________________

Von: Richard Shockey [mailto:Rich.Shockey at neustar.biz]
Gesendet: Fr 22.07.2005 20:46
An: Stastny Richard
Cc: Richard Shockey; enum at ietf.org
Betreff: Re: [Enum] Fwd: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt

Stastny Richard wrote:

>Dear all,
>
>although I did not receive (yet) any response to my e-mail below,
>I want to comment on the mentioned draft:
>
>I have a question to the following paragraph:
>
>"The following Enumservice is registered with this document: "npd" to
>   indicate number portability data.  The purpose of this Enumservice is
>   to describe information about telephone numbers which cannot be used
>   on the public Internet or a private/peered Internet Protocol (IP)
>   network.  Thus, these are numbers which are only reachable via the
>   traditional Public Switched Telephone Network (PSTN)."
>
>The second sentence seems to imply that ONLY ported numbers
>will be used with the Enumservice "npd". The example 4.2 indicates
>that also non-ported numbers may be used.
> 
>
That is not true. The ENUM serive npd indicated number portability data
that may be associated with any telephone number.

The examples in the textare quite clear that the information relates to
both Ported and NonPorted numbers.

4.1 Example of a Ported Telephone Number

$ORIGIN 3.1.8.7.1.8.9.5.1.2.1.e164.arpa.

NAPTR 10 100 "u" "E2U+npd:tel"

"!^.*$!tel:+1-215-981-7813;rn=+1-215-981-7600;npdi!"

In this example, a Routing Number (rn) and a Number Portability Dip

Indicator (npdi) are used as shown in draft-ietf-iptel-tel-np-06.txt

[10] (Internet-Draft New Parameters for the "tel" URI to Support

Number Portability, draft-ietf-iptel-tel-np-06.txt [10]). The 'npdi'

field is included in order to prevent subsequent lookups in legacy-

style PSTN databases.

4.2 Example of a Non-Ported Telephone Number

$ORIGIN 3.1.8.7.1.8.9.5.1.2.1.e164.arpa.

NAPTR 10 100 "u" "E2U+npd:tel"

"!^.*$!tel:+1-215-981-7813;npdi!"

I have had a private request to consider an alternative formation of th
e URI.

as in

The modification is to define a new enumservice field.

E2U+npd:sip

with the URI defined something like this.

NAPTR 10 10 "u" "E2U+npd:sip"
"!^.*$!sip:+15714345651 at mg4.mso.net;rn=+15712768933;npdi!"

the rationale for this is that many gateways dont know what tel URI's are.

>
>The third sentence is simply not true: I myself have ported numbers
>that can be reached on the public Internet via SIP URIs.
> 
>
A fair criticism a better wording might have been.

"Thus, this information is only useful in a national specific context within the traditional Public Switched Telephone Network (PSTN)."

>
>IMHO there is a more in-depth analysis required how this
>Enumservice is used, what it implies and with which other
>Enumservices it can be used togother
>
>There is also a need to consolidate the different Enumservices
>using the tel URI and their use in User and Carrier ENUM.
>Also the usage of crosspointers (entries in User ENUM pointing
>to Carrier ENUM and vice versa) with tel URIs is necessary.
> 
>
For what purpose?

>
>One example is the usage of ENUM-only numbers existing only
>in User ENUM (e.g. +43780 and +87810). Here a pointer in
>Carrier ENUM may be useful to point from Carrier ENUM to
>User ENUM. Such a number may have a routing number , but
>this routing numbers are only of national significance and cannot
>be used in a global system.
>
>There is also missing a note that with this Enumservice the tel URI
>MUST always contain the same number then the AUS.
>
>regards
>
>-richard
>
>________________________________
>
>Von: enum-bounces at ietf.org im Auftrag von Stastny Richard
>Gesendet: So 10.07.2005 14:51
>An: Richard Shockey; enum at ietf.org
>Betreff: Re: [Enum] Fwd: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt
>
>
>
>Dear all, especially Allison Mankin,
>
>I consider this I-D very interesting, because I also proposed in the past to use the
>parameters defined in draft-ietf-iptel-tel-np-06.txt e.g. ";rn=" within ENUM,
>but did not bring this forward because of reason stated below.
>
>Before I comment on this draft and raise some questions, I would like to
>get some principle statements from our esteemed AD Allison if this draft
>is within the scope of IETF and ENUM WG.
>
>The rationale for this question is the following:
>
>The intended use of the Enumservice "npd:tel" is primarily for
>carriers, because only carriers my interpret and use the "rn= parameter.
>
>Routing numbers MUST NEVER be used by end-users.
>
>During the discussion Lawrence Conroy and I had with Ted Hardie
>and Allison Mankin in Geneva in May regarding the I-D draft-ietf-enum-msg-04.txt,
>especially about Enumservice "mms:mailto", I mentioned the fact that
>this Enumservice MAY also be used by carriers.
>
>Allison did not like this statement at all and said ENUM and
>Enumservices to-be-defined are ONLY for end-user usage. I only
>got over this hurdle by confirming that "mms:mailto" is ALSO
>useful for end-users.
>
>Therefore I want to have a clear statement from the responsible AD
>if an Enumservice for carrier use ONLY is within the scope of ENUM WG,
>before I waste my time in discussing this I-D on the list.
>
>Richard Stastny
>

--

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1
815.333.1237
<mailto:richard(at)shockey.us> or <mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Mon, 25 Jul 2005 11:19:41 -0400

Stastny Richard wrote:
Rich,
One comment first

We've gone back and forward on this .. this draft does not require a 
generic tel. The service field is what it is.

To your remarks:

Thats what I said:
Still, the sentence:
"The purpose of this Enumservice is
to describe information about telephone numbers which cannot be used
on the public Internet or a private/peered Internet Protocol (IP)
network.  "
I still dont get the problem routing numbers have no signinicance on IP 
Networks... this is a clarity issue.

Did you see my reply ..I conceded this point.
"Thus, this information is only useful in a national specific context 
within the traditional Public Switched Telephone Network (PSTN)."

 

 

user is your choice. 

The operators choice. This draft is meant for use only within the 
context of a Carrier ENUM service and more specifically in North America 
this data would never be globally visable.In other national 
jurisdictions it might be but not in NA.

One may even query this information from the
PSTN via a IN-mediation device. Now you introduce a specific
"transit" gateway.
BTW: your example URI should be:
sip:+15714345651;rn=+15712768933;npdi at mg4.mso.net

no the original was correct. This is not a SIP URI.

For what purpose?

F