Subject: RE: [Enum] Fwd: I-D ACTION:draft-livingood-shockey-enum-npd-00.txt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 25 Jul 2005 09:56:55 -0400

Richard and Richard,

All E.164 numbers in ENUM are effectively ported, so I don't understand
why the npd needs to be an ENUM service rather than just an attribute of
the tel ENUM service.  This is not to say that the result returned does
not have the npdi, rn, cic or other tel parameters provided.

Second, IP-based softswitches can do routing based on such information
in the IP domain, so such information is not only of use to PSTN-based
switches (during the migration from PSTN to IP-based).

Third, since number portability is essentially performed by service
providers, is the scope of this limited only to Carrier ENUM?

Number portability is a PSTN routing database mechanism.  If ENUM is
done right, then when the TDM PSTN as we know it disappears, so should
number portability.  Porting a number in the IP domain ought to be
simply an ENUM re-registration.  A single ENUM dip should be needed, not
an ENUM and an NP dip.  Some of the crufty PSTN mechanisms will fade
away, no?

Mike

> -----Original Message-----
> From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org] On 
> Behalf Of Stastny Richard
> Sent: Monday, July 25, 2005 6:23 AM
> To: Richard Shockey
> Cc: enum at ietf.org
> Subject: Re: [Enum] Fwd: I-D 
> ACTION:draft-livingood-shockey-enum-npd-00.txt
> 
> Rich,
>  
> One comment first
> I basically like the idea of a generic tel Enumservice, 
> whatever it is called. but I do not have thought through all 
> implications Maybe we can discuss this in Paris (we have a 
> whole week ;-)
>  
> To your remarks:
>  
> >That is not true. The ENUM serive npd indicated number 
> portability data 
> >that may be associated with any telephone number.
> 
> >The examples in the textare quite clear that the information 
> relates to 
> >both Ported and NonPorted numbers.
> 
> Thats what I said:
> 
> Still, the sentence:
> 
> "The purpose of this Enumservice is
> to describe information about telephone numbers which cannot 
> be used on the public Internet or a private/peered Internet 
> Protocol (IP) network.  "
> 
> is unclear (or wrong, because you can use proted numbers on 
> the Public Internet (I do)
> 
> >The modification is to define a new enumservice field.
> >E2U+npd:sip
> >with the URI defined something like this.
> 
> >NAPTR 10 10 "u" "E2U+npd:sip"
> >"!^.*$!sip:+15714345651 at mg4.mso.net;rn=+15712768933;npdi!"
> 
> >the rationale for this is that many gateways dont know what 
> tel URI's are.
>  
> Now I am completely lost. I tought the "npd" was a generic 
> Enumservice giving the "rn" to be used (in the national 
> network), but the gateway to user is your choice. One may 
> even query this information from the PSTN via a IN-mediation 
> device. Now you introduce a specific "transit" gateway.
>  
> BTW: your example URI should be:
> sip:+15714345651;rn=+15712768933;npdi at mg4.mso.net
>  
> 
> >For what purpose?
>  
> For this:
> 
> >
> >One example is the usage of ENUM-only numbers existing only in User 
> >ENUM (e.g. +43780 and +87810). Here a pointer in Carrier ENUM may be 
> >useful to point from Carrier ENUM to User ENUM. Such a 
> number may have 
> >a routing number , but this routing numbers are only of national 
> >significance and cannot be used in a global system.
> >
> >There is also missing a note that with this Enumservice the tel URI 
> >MUST always contain the same number then the AUS.
> 
> 
> 
> ________________________________
> 
> Von: Richard Shockey [mailto:Rich.Shockey at neustar.biz]
> Gesendet: Fr 22.07.2005 20:46
> An: Stastny Richard
> Cc: Richard Shockey; enum at ietf.org
> Betreff: Re: [Enum] Fwd: I-D 
> ACTION:draft-livingood-shockey-enum-npd-00.txt
> 
> 
> 
> Stastny Richard wrote:
> 
> >Dear all,
> >
> >although I did not receive (yet) any response to my e-mail below, I 
> >want to comment on the mentioned draft:
> >
> >I have a question to the following paragraph:
> >
> >"The following Enumservice is registered with this document: "npd" to
> >   indicate number portability data.  The purpose of this 
> Enumservice is
> >   to describe information about telephone numbers which 
> cannot be used
> >   on the public Internet or a private/peered Internet Protocol (IP)
> >   network.  Thus, these are numbers which are only reachable via the
> >   traditional Public Switched Telephone Network (PSTN)."
> >
> >The second sentence seems to imply that ONLY ported numbers will be 
> >used with the Enumservice "npd". The example 4.2 indicates that also 
> >non-ported numbers may be used.
> > 
> >
> That is not true. The ENUM serive npd indicated number 
> portability data that may be associated with any telephone number.
> 
> The examples in the textare quite clear that the information 
> relates to both Ported and NonPorted numbers.
> 
> 4.1 Example of a Ported Telephone Number
> 
> $ORIGIN 3.1.8.7.1.8.9.5.1.2.1.e164.arpa.
> 
> NAPTR 10 100 "u" "E2U+npd:tel"
> 
> "!^.*$!tel:+1-215-981-7813;rn=+1-215-981-7600;npdi!"
> 
> 
> In this example, a Routing Number (rn) and a Number Portability Dip
> 
> Indicator (npdi) are used as shown in draft-ietf-iptel-tel-np-06.txt
> 
> [10] (Internet-Draft New Parameters for the "tel" URI to Support
> 
> Number Portability, draft-ietf-iptel-tel-np-06.txt [10]). The 'npdi'
> 
> field is included in order to prevent subsequent lookups in legacy-
> 
> style PSTN databases.
> 
> 4.2 Example of a Non-Ported Telephone Number
> 
> $ORIGIN 3.1.8.7.1.8.9.5.1.2.1.e164.arpa.
> 
> NAPTR 10 100 "u" "E2U+npd:tel"
> 
> "!^.*$!tel:+1-215-981-7813;npdi!"
> 
> I have had a private request to consider an alternative 
> formation of th e URI.
> 
> as in
> 
> The modification is to define a new enumservice field.
> 
> E2U+npd:sip
> 
> with the URI defined something like this.
> 
> NAPTR 10 10 "u" "E2U+npd:sip"
> "!^.*$!sip:+15714345651 at mg4.mso.net;rn=+15712768933;npdi!"
> 
> the rationale for this is that many gateways dont know what 
> tel URI's are.
> 
> >
> >The third sentence is simply not true: I myself have ported numbers 
> >that can be reached on the public Internet via SIP URIs.
> > 
> >
> A fair criticism a better wording might have been.
> 
> "Thus, this information is only useful in a national specific 
> context within the traditional Public Switched Telephone 
> Network (PSTN)."
> 
> 
> >
> >IMHO there is a more in-depth analysis required how this 
> Enumservice is 
> >used, what it implies and with which other Enumservices it 
> can be used 
> >togother
> >
> >There is also a need to consolidate the different Enumservices using 
> >the tel URI and their use in User and Carrier ENUM.
> >Also the usage of crosspointers (entries in User ENUM pointing to 
> >Carrier ENUM and vice versa) with tel URIs is necessary.
> > 
> >
> For what purpose?
> 
> >
> >One example is the usage of ENUM-only numbers existing only in User 
> >ENUM (e.g. +43780 and +87810). Here a pointer in Carrier ENUM may be 
> >useful to point from Carrier ENUM to User ENUM. Such a 
> number may have 
> >a routing number , but this routing numbers are only of national 
> >significance and cannot be used in a global system.
> >
> >There is also missing a note that with this Enumservice the tel URI 
> >MUST always contain the same number then the AUS.
> >
> >regards
> >
> >-richard
> >
> >________________________________
> >
> >Von: enum-bounces at ietf.org im Auftrag von Stastny Richard
> >Gesendet: So 10.07.2005 14:51
> >An: Richard Shockey; enum at ietf.org
> >Betreff: Re: [Enum] Fwd: I-D 
> >ACTION:draft-livingood-shockey-enum-npd-00.txt
> >
> >
> >
> >Dear all, especially Allison Mankin,
> >
> >I consider this I-D very interesting, because I also proposed in the 
> >past to use the parameters defined in draft-ietf-iptel-tel-np-06.txt 
> >e.g. ";rn=" within ENUM, but did not bring this forward 
> because of reason stated below.
> >
> >Before I comment on this draft and raise some questions, I 
> would like 
> >to get some principle statements from our esteemed AD 
> Allison if this 
> >draft is within the scope of IETF and ENUM WG.
> >
> >The rationale for this question is the following:
> >
> >The intended use of the Enumservice "npd:tel" is primarily for 
> >carriers, because only carriers my interpret and use the 
> "rn= parameter.
> >
> >Routing numbers MUST NEVER be used by end-users.
> >
> >During the discussion Lawrence Conroy and I had with Ted Hardie and 
> >Allison Mankin in Geneva in May regarding the I-D 
> >draft-ietf-enum-msg-04.txt, especially about Enumservice 
> "mms:mailto", 
> >I mentioned the fact that this Enumservice MAY also be used 
> by carriers.
> >
> >Allison did not like this statement at all and said ENUM and 
> >Enumservices to-be-defined are ONLY for end-user usage. I 
> only got over 
> >this hurdle by confirming that "mms:mailto" is ALSO useful for 
> >end-users.
> >
> >Therefore I want to have a clear statement from the 
> responsible AD if 
> >an Enumservice for carrier use ONLY is within the scope of ENUM WG, 
> >before I waste my time in discussing this I-D on the list.
> >
> >Richard Stastny
> >
> 
> --
> 
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> Richard Shockey, Director - Member of Technical Staff NeuStar Inc.
> 46000 Center Oak Plaza  -   Sterling, VA  20166
> sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
> ENUM +87810-13313-31331
> PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1
> 815.333.1237
> <mailto:richard(at)shockey.us> or 
> <mailto:richard.shockey(at)neustar.biz>
> <http://www.neustar.biz> ; <http://www.enum.org> 
> <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
> 
> 
> 
> 
> _______________________________________________
> enum mailing list
> enum at ietf.org
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Mon, 25 Jul 2005 11:53:39 -0400

Michael Hammer (mhammer) wrote:
Richard and Richard,
All E.164 numbers in ENUM are effectively ported,
you cannot completely draw that conclusion over time. Policy over number 
allocation isues  are under serious discussion which might change that 
statement ..though for the indefinate future it is reasonable to assume 
that most VoIP numbers will be ported or pooled.

so I don't understand

Enhancing  the search pattern the resolver uses to find the appropriate 
NAPTR record. Yes it could use a pure E2U+tel but I think this is better 
and there are logical arguments for seperating values out such as if you 
wanted to add CNAM.

Unlike some in this WG I have never had an objection to granular "hints" 
as to the service or information contained in a NAPTR record.

More information is better than less.
Second, IP-based softswitches can do routing based on such information
in the IP domain, so such information is not only of use to PSTN-based
switches (during the migration from PSTN to IP-based).

Yes .. you can make some interesting trunking decisions based on the 
NPA-NXX of a particular LRN if you can aquire that information at point 
of session origination vs N-1.

Yes ..that should be self evident by now but as Richard points out this 
is a national specific issue. And as I spefically said before North 
American LNP data cannot be openly distributed. The context of the query 
in the US and Canada would certainly be some form of closed network or 
internal network databases that have DNS query response capability.

BTW this would certainly work in a SIP redirect context as well.
Number portability is a PSTN routing database mechanism.  If ENUM is
done right,
and IF you get significant consumer and enterprise OP-IN ... lots of big 
IF's here

then when the TDM PSTN as we know it disappears, so should
number portability. 

Yes  in the long run we are all dead.
Porting a number in the IP domain ought to be
simply an ENUM re-registration. 

Correct ... IF the PSTN disapears.  but I'm not holding my breath for 
that to happen anytime soon or ending world hunger, rediscovering cold 
fusion, fixing the US trade decifit...etc

A single ENUM dip should be needed, not
an ENUM and an NP dip.  Some of the crufty PSTN mechanisms will fade
away, no?

Yes and we'll all join hands and sing Kumbayaa, but until that time of 
perfect Nirvana, spiritual harmony and bliss arrives we'll just have to 
plug along trying to solve the simple practial problems of interworking 
IP and PSTN networks.

Mike

--

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1
815.333.1237
<mailto:richard(at)shockey.us> or <mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum