Subject: RE: [Enum] Clarification on Carrier ENUM discussions

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 18 Jul 2005 15:21:25 -0400

Richard,

I have serious problems with the statement that only carriers can
discover a point of interconnect for a carrier given an E.164 number.
We do not need walled ENUM gardens, and this will certainly require
regulators in each country to get involved.

Mike

> -----Original Message-----
> From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org] On 
> Behalf Of Stastny Richard
> Sent: Tuesday, July 12, 2005 10:28 AM
> To: enum at ietf.org
> Subject: [Enum] Clarification on Carrier ENUM discussions
> 
> Dear all,
>  
> following the current discussions on carrier ENUM, I have a 
> serious problem with some issues raised
>  
> So to clarify some issues:
> We have on one side User ENUM, which is used by end-users to 
> find other end-users. We so not need to define requirements 
> here and we do not need to discuss its purpose.
>  
> On the other hand we have carrier ENUM. Carrier (or 
> Infrastructure) ENUM is for carriers ONLY and ONLY 
> carriers-of-record are allowed to enter information there and 
> ONLY carriers may use the infromation, even if it may 
> publicly available. Carier ENUM is required for carriers to 
> announce their PoI (IP based or on the PSTN) to other 
> carriers, with ENUM based technology, that is NAPTRs using 
> Enumservices such as "sip", "mms:mailto" or eventually "npd:tel"
>  
> To do so, different methods may be used.
>  
> A. use any tree in any domain (e.g foo.bar). Carriers may do 
> so on their own choice and are already doing so.
> The problem here is that many trees exists.
> If the carriers want to use a commonly agreed tree, they have 
> two options: agree on any tree out of .arpa or use 
>  
> B. an additional (side) tree in .arpa
>  
> here 3 technically equivalent options exists
> 
> 1. use carrier.arpa
> 2. use carrier.e164.arpa
> 3. use carrier.c.c.e164.arpa
>  
> For the avoidance of doubt, carrier could also be "c" od "foo"
> as Otmar pointed out and NOT the name of the carrier (the SPID)
>  
> Any discussion of draft-haberler should restrict itself to 
> the question where to put "carrier" or "c" or "foo" and how 
> to find the proper side tree within the carriers ENUM client 
> and NOT e.g. asking questions like:
>  
> "How does my
> (Scottish) handset figure out what the names (or codes) exist 
> for the telco operators in say Austria? Which one of these 
> Austrian telcos is it supposed to prefer? How do I get my 
> handset to pick a new preferred partner for calls to Austria 
> whenever I port my number to another Scottish telco or if the 
> preferred telco in Austria has been renamed (or gone bust)?"
>  
> This question has nothing to do with the problem at hand not 
> even with ENUM at all (not even in Scottland ;-)
> 
> First: a handset (end-user) will never query carrier enum and 
> even a telco querying carrier ENUM does not have to find out 
> which telco to query or to prefer. ENU will give you this 
> information. And a number may only be hosted by one telco at a time.
> 
> -richard
> 
> 
> 
> _______________________________________________
> enum mailing list
> enum at ietf.org
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Haberler <[email-masked]>
Date: Mon, 18 Jul 2005 21:01:36 -0400

At 21:21 18.07.2005, Michael Hammer \(mhammer\) wrote:
Richard,
I have serious problems with the statement that only carriers can
discover a point of interconnect for a carrier given an E.164 number.
What Richard meant was that just because you *know* the network coordinates 
of POI for a number that doesnt imply that you can *force* the telco 
operating that POI to accept calls from, and terminate for you just because 
you like that to be (assuming you not having an agreement with said telco), 
regardless if you discover the POI coordinates through DNS, published 
information or social engineering.

We do not need walled ENUM gardens, and this will certainly require
regulators in each country to get involved.
I'm a bit fuzzy on what are you're suggesting.
Are you saying any URI which is entered by either User or Carrier-of-Record 
must be publically reachable without authentication (the latter would map 
to an underlying intent or agreement)?

I happen own a +43 780ff number, mapped to a URI in User ENUM, and the SIP 
proxy for that URI accepts calls only from the PSTN->IP gateway handling 
that number.

Am I violating some vision here? is SIP authentication a no-no or what is 
actually the issue?

lost,
-Michael