Subject: RE: [Enum] code and maintainence complexity of combined user/carrierENUM proposal

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 11 Jul 2005 18:18:43 -0400

I thought that the DNS allowed us to avoid tables, e.g. hosts.txt.

Mike

> -----Original Message-----
> From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org] On 
> Behalf Of Jim Reid
> Sent: Monday, July 11, 2005 12:26 PM
> To: Michael Haberler
> Cc: enum at ietf.org
> Subject: Re: [Enum] code and maintainence complexity of 
> combined user/carrierENUM proposal
> 
> > WRT to "table management complexity", let me reiterate:  if 
> we decide 
> > to publish the location record in the CC zone itself, there 
> is no such 
> > thing as table management. A CC Administration decides to use this 
> > scheme, decides on location, enters the record in the cc.e164.arpa 
> > zone, DONE.
> 
> Michael, I think you've overlooked something fundamental. 
> IIUC, you're proposing that there's a "table" of operator 
> names (or codes) immediately beneath <countrycode>.e164.arpa, 
> right? How does my
> (Scottish) handset figure out what the names (or codes) exist 
> for the telco operators in say Austria? Which one of these 
> Austrian telcos is it supposed to prefer? How do I get my 
> handset to pick a new preferred partner for calls to Austria 
> whenever I port my number to another Scottish telco or if the 
> preferred telco in Austria has been renamed (or gone bust)?
> 
> BTW,  the idea of putting this "table" into the DNS somehow 
> is worth considering. This could be a very elegant solution 
> to part of the problem. However I think it would need a new 
> RRtype, one RR per operator/telco. Doing this with TXT  
> records would be very bad.
> 
> I can see other nasties when these hypothetical tables got 
> too big: TCP queries to get the whole table; buffer overflows 
> in clients; telcos/CSPs doing a land grab to get "cute" 
> entries in the table; legacy clients failing to check/refresh 
> this table; etc, etc.
> 
> 
> _______________________________________________
> enum mailing list
> enum at ietf.org
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Haberler <[email-masked]>
Date: Mon, 11 Jul 2005 18:53:39 -0400

At 00:18 12.07.2005, Michael Hammer \(mhammer\) wrote:
I thought that the DNS allowed us to avoid tables, e.g. hosts.txt.
such as the succesful avoidance of the root.cache file, hm  ;-)
no seriously, I'm not ecstatic about the table approach either, which is 
why I'm looking at storing that information in the DNS proper.

-Michael