Subject: Re: [Enum] Carrier ENUM, SIP URIs and DNS

From: "Stastny Richard" <[email-masked]>
Date: Sun, 26 Jun 2005 16:28:15 -0400

James wrote:
>Or is it enough to be in the same namespace where you are able
>to resolve the URI to the appropriate SIP Proxy, or SBC, or whatever next
>step that will eventually fully resolve the URI?

Again you are correct:
If the ENUM DNS responses with a SIP URI of
the form sip:+samenumber at vodafone.de
and the SRV records in the DNS with vodafone.de
are pointing to an SBC of vodafone, thats fine.

Basically user ENUM is a routing from end-user to
end-user (proxy - AoR), carrier ENUM should be a 
routing from orig network to dest network, so a SBC 
as entry is ok.

Richard

________________________________

Von: James McEachern [mailto:jmce at nortel.com]
Gesendet: So 26.06.2005 22:17
An: enum at ietf.org
Cc: Stastny Richard
Betreff: RE: [Enum] Carrier ENUM, SIP URIs and DNS

Richard,
So is it accurate to say that the ENUM discussion should proceed on the
assumption that the resulting URI will be routable, either now, or after
some other WG fixes the problem, and that we should not be distracted by
this issue?

>the ENUM tree has to be placed in
>the same namespace where you can resolve the SIP URI.

I'm not sure I fully understand the implications of this statement.  Do you
mean the ENUM tree must be in the same namespace where you can fully resolve
the SIP URI?  Or is it enough to be in the same namespace where you are able
to resolve the URI to the appropriate SIP Proxy, or SBC, or whatever next
step that will eventually fully resolve the URI?

Jim

-----Original Message-----
From: Stastny Richard [mailto:Richard.Stastny at oefeg.at]
Sent: Sunday, June 26, 2005 3:57 PM
To: McEachern, James [CAR:5N00:EXCH]; enum at ietf.org
Subject: Re: [Enum] Carrier ENUM, SIP URIs and DNS

James wrote:
>So isn't it really a SIP issue rather than an
>ENUM issue?
>
>What am I missing?

Nothing, you are exactly at the point.

What I was saying is: ENUM is just an add-on: If you do not
have the possibility to put a reachable SIP URI in whatever ENUM
you have (User, Carreir, Infrastructure.. ) you cannot use ENUM
anyway, so the discussion where the ENUM "forrest" is placed
is somewhat useless.

Or the other way round: the ENUM tree has to be placed in
the same namespace where you can resolve the SIP URI.
Putting an ENUM tree im a namespace where you cannot
resolve the resulting SIP URIs makes no sense. And if
you can resolve the SIP URI and hide the ENUM tree;
this is also not very useful.

Richard

________________________________

Von: James McEachern [mailto:jmce at nortel.com]
Gesendet: So 26.06.2005 21:37
An: enum at ietf.org
Cc: Stastny Richard
Betreff: RE: [Enum] Carrier ENUM, SIP URIs and DNS

Richard Stastny wrote:

>Still, the basic question for any type of ENUM is:

>Can you reach a sip: URI one gets from an mobile operator
>e.g. sip:frank at vodafone.de from any enterprise owned
>SIP server, from sipgate.de or from fwd.pulver.com

The ability, or inability, to reach a URI such as sip:frank at vodafone.de from
any enterprise owned SIP server would appear to have nothing to do with
converting E.164 numbers to URIs. The problem would be the same if you
started with the URI, or even if there was no E.164 number associated with
the URI at all, would it not? So isn't it really a SIP issue rather than an
ENUM issue?

What am I missing?

Jim

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: lconroy <[email-masked]>
Date: Sun, 26 Jun 2005 17:49:36 -0400

Hi Richard, James, folks,
Careful - this is strictly true, but...
You need to get usable results for your ENUM query. You will also need 
to get usable results for your subsequent SRV query (as specified in 
rfc3263), then do AAAA/A6/A lookups on the host name(s) of the 
server(s) indicated.

In addition, you need to deliver messages to the IP address you have 
found with these ENUM, SRV, AAAA/A6/A queries.

That means that for the call to be successful, you need access to the 
SBC/SIP Server, not just the
DNS records that identify it. What happens after it hits the SBC is 
S.O.P.

As an aside, there's nothing that any IETF WG can do to fix broken DNS 
implementations or broken firewall configurations.

atb,  Lawrence
On 26 Jun 2005, at 21:31, Stastny Richard wrote:
James wrote:
to resolve the URI to the appropriate SIP Proxy, or SBC, or whatever 
next

Richard,
So is it accurate to say that the ENUM discussion should proceed on the
assumption that the resulting URI will be routable, either now, or 
after
some other WG fixes the problem, and that we should not be distracted 
by
this issue?

the ENUM tree has to be placed in
the same namespace where you can resolve the SIP URI.
I'm not sure I fully understand the implications of this statement.  
Do you
mean the ENUM tree must be in the same namespace where you can fully 
resolve
the SIP URI?  Or is it enough to be in the same namespace where you 
are able
to resolve the URI to the appropriate SIP Proxy, or SBC, or whatever 
next
step that will eventually fully resolve the URI?

Jim
-----Original Message-----
From: Stastny Richard [mailto:Richard.Stastny at oefeg.at]
Sent: Sunday, June 26, 2005 3:57 PM
To: McEachern, James [CAR:5N00:EXCH]; enum at ietf.org
Subject: Re: [Enum] Carrier ENUM, SIP URIs and DNS
James wrote:

Richard Stastny wrote:

Can you reach a sip: URI one gets from an mobile operator
e.g. sip:frank at vodafone.de from any enterprise owned
SIP server, from sipgate.de or from fwd.pulver.com
The ability, or inability, to reach a URI such as 
sip:frank at vodafone.de from
any enterprise owned SIP server would appear to have nothing to do with
converting E.164 numbers to URIs. The problem would be the same if you
started with the URI, or even if there was no E.164 number associated 
with
the URI at all, would it not? So isn't it really a SIP issue rather 
than an
ENUM issue?

What am I missing?
Jim

---------------------------------------
lawrence conroy    |tel:+44-1794-833666
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum