Subject: Re: [Enum] Carrier ENUM, SIP URIs and DNS

From: "Stastny Richard" <[email-masked]>
Date: Fri, 24 Jun 2005 17:01:04 -0400

Tom Taylor wrote:
 
>I'm not sure you and Richard are really in conflict.  
 
I think we are not so far apart. Still, the basic question for any type of
ENUM is:
 
Can you reach a sip: URI one gets from an mobile operator 
e.g. sip:frank at vodafone.de from any enterprise owned 
SIP server, from sipgate.de or from fwd.pulver.com
 
If yes, any type of ENUM will work, if not, the ENUM is doomed.
 
And of course is ENUM the ultimate in (global) Service Provider 
Number Portability: porting a number is a change of the NAPTR.
 
The question of User or Carrier ENUM finally succeeds will be decided
by the end-user, as always (=marketing;-)
 
Richard

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Sun, 26 Jun 2005 15:54:17 -0400

James wrote:
>So isn't it really a SIP issue rather than an
>ENUM issue?
>
>What am I missing?

Nothing, you are exactly at the point.
 
What I was saying is: ENUM is just an add-on: If you do not
have the possibility to put a reachable SIP URI in whatever ENUM
you have (User, Carreir, Infrastructure.. ) you cannot use ENUM
anyway, so the discussion where the ENUM "forrest" is placed
is somewhat useless.
 
Or the other way round: the ENUM tree has to be placed in
the same namespace where you can resolve the SIP URI.
Putting an ENUM tree im a namespace where you cannot
resolve the resulting SIP URIs makes no sense. And if
you can resolve the SIP URI and hide the ENUM tree;
this is also not very useful.
 
Richard

________________________________

Von: James McEachern [mailto:jmce at nortel.com]
Gesendet: So 26.06.2005 21:37
An: enum at ietf.org
Cc: Stastny Richard
Betreff: RE: [Enum] Carrier ENUM, SIP URIs and DNS

Richard Stastny wrote:

>Still, the basic question for any type of ENUM is:

>SIP server, from sipgate.de or from fwd.pulver.com

The ability, or inability, to reach a URI such as sip:frank at vodafone.de from
any enterprise owned SIP server would appear to have nothing to do with
converting E.164 numbers to URIs. The problem would be the same if you
started with the URI, or even if there was no E.164 number associated with
the URI at all, would it not? So isn't it really a SIP issue rather than an
ENUM issue?

What am I missing?

Jim

---

From: "James McEachern" <[email-masked]>
Date: Sun, 26 Jun 2005 16:18:02 -0400

Richard,
So is it accurate to say that the ENUM discussion should proceed on the
assumption that the resulting URI will be routable, either now, or after
some other WG fixes the problem, and that we should not be distracted by
this issue?

>the ENUM tree has to be placed in

I'm not sure I fully understand the implications of this statement.  Do you
mean the ENUM tree must be in the same namespace where you can fully resolve
the SIP URI?  Or is it enough to be in the same namespace where you are able
to resolve the URI to the appropriate SIP Proxy, or SBC, or whatever next
step that will eventually fully resolve the URI?

Jim 

-----Original Message-----
From: Stastny Richard [mailto:Richard.Stastny at oefeg.at] 
Sent: Sunday, June 26, 2005 3:57 PM
To: McEachern, James [CAR:5N00:EXCH]; enum at ietf.org
Subject: Re: [Enum] Carrier ENUM, SIP URIs and DNS

 

Richard

What am I missing?

Jim