Subject: [Enum] Are these NAPTRs valid?

From: "Klaus Darilion" <[email-masked]>
Date: Fri, 13 May 2005 10:41:54 -0400

Hi all!

Can you please help me out with the follwing scenario: I have an ENUM
domain. Two digit extensions should be forwarded to another proxy as
three digit extensions. Thus I use the following NAPTRs:

*   NAPTR 100 10 "u" "E2U+sip"
"!^\\+431234567(...)$!sip:e001-366\\1 at proxy1.at!" .
*   NAPTR 100 20 "u" "E2U+sip"
"!^\\+431234567(..)$!sip:e002-\\1 at proxy2.at!" .

IMO, the NAPTRs are fine. But I use an ENUM aware SIP proxy, which does
not handle the two-digit extensions. Should the ENUM resolver also try
the second NAPTR (as the regex of the first NAPTR does not match)?

regards,
Klaus

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: lconroy <[email-masked]>
Date: Fri, 13 May 2005 21:08:27 -0400

Hi Klaus,
   Yes, it should (and yes, they are valid).
Most ENUM-aware proxies are broken :(
Remind the nic.at folk who are coming to the ENUM plugtest to bring 
this software and we'll torture it.
With luck (and source), we may even find time to fix it, once we know 
what it does.

all the best,
  Lawrence
On 13 May 2005, at 15:41, Klaus Darilion wrote:
Hi all!
---------------------------------------
lawrence conroy    |tel:+44-1794-833666