Subject: RE: [Enum] I-D ACTION:draft-ietf-enum-void-00.txt

From: "Klaus Darilion" <[email-masked]>
Date: Thu, 14 Oct 2004 07:25:18 -0400

Hi!

Is there a proposed way how an ENUM client should handle ambiguous
situations, e.g:

3.8.0   NAPTR 10 100 "u" "E2U+void:mailto"
"!^.*$!mailto:num-drama-info at nra.foo!"
3.8.0   NAPTR 10 100 "u" "E2U+voice:sip" "!^.*$!sip:12345 at fwd.foo!"

I'm pretty sure this will happen if customers will manage their NAPTRs
themselves.

regards,
klaus

> -----Original Message-----
> From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org] On 
> Behalf Of Internet-Drafts at ietf.org
> Sent: Tuesday, October 12, 2004 10:10 PM
> To: i-d-announce at ietf.org
> Cc: enum at ietf.org
> Subject: [Enum] I-D ACTION:draft-ietf-enum-void-00.txt
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Telephone Number Mapping 
> Working Group of the IETF.
> 
> 	Title		: IANA Registration for Enumservice VOID
> 	Author(s)	: R. Stastny, L. Conroy
> 	Filename	: draft-ietf-enum-void-00.txt
> 	Pages		: 0
> 	Date		: 2004-10-12
> 	
> This document registers the Enumservice 'void' using the URI schemes
>    'mailto:' and 'http:' as per the IANA registration process defined
>    in the ENUM specification, RFC3761. This Enumservice may be used to
>    indicate that the E.164 number (or E.164 number range) tied to the
>    domain in which the enclosing NAPTR is published is not 
> assigned for
>    communications service. When such an indication is 
> provided, an ENUM
>    client can detect calls that will fail "early".
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-enum-void-00.txt
> 
> To remove yourself from the I-D Announcement list, send a 
> message to i-d-announce-request at ietf.org with the word 
> unsubscribe in the body of the message.  
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username "anonymous" and a password of your e-mail 
> address. After logging in, type "cd internet-drafts" and then
> 	"get draft-ietf-enum-void-00.txt".
> 
> A list of Internet-Drafts directories can be found in 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	mailserv at ietf.org.
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-enum-void-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Conroy, Lawrence (SMTP)" <[email-masked]>
Date: Thu, 14 Oct 2004 08:11:26 -0400

Hi Klaus, folks,
  Strictly, this example is invalid, as the priorities and ORDER field 
values are the same.
In this situation, it is a client's choice whether they reject the 
NAPTRs or just choose
a random order/priority for them.

However, whilst having a 'e2u+void:mailto' NAPTR (or e2u+void:http) 
with any non-void
NAPTR is pretty strange as VOID implies that the number is not in 
service, it's not
possible to stop people doing stupid things. Thus how should a client 
react?

As the client SHOULD be processing these in order/priority sort, in 
theory
"the lowest one wins". However...
In practice I would HOPE that a void NAPTR would be handled first (i.e. 
at the
same time that the NAPTRs are being sorted/pre-discarded/...) - that's 
what our
client is going to do.
If the client 'sees' a void NAPTR, it gives up at that point on the 
current ENUM domain.

(Note that, if the domain was entered as a result of a non-final NAPTR 
reference,
then I guess you would just ignore that domain rather than abort the 
whole query).

hth,
  Lawrence
On 14 Oct 2004, at 12:18, Klaus Darilion wrote:
Hi!