Subject: [Enum] Call Routing

From: "Fullbrook Kim (UK)" <[email-masked]>
Date: Mon, 13 Sep 2004 11:29:21 -0400

Can anyone point me towards RFCs, design documentation, white papers etc which cover call routing via third parties ?  I'll explain what I mean in more detail: 

With Internet SIP calls, the design of the DNS in RFC 3263 intends calls to be routed point-to-point. For example if I use ENUM to look up the SIP URI of the person I'm calling, I'll then extract the domain from the SIP URI and use it to look up the IP address of the SIP server to receive my call. The call then routes directly from my SIP server to the receiving SIP server in their network.

The PSTN rarely works in this simple way  (at least in the area that I know - it might be different in your environment).  If I'm a customer of Telco A and make a call to a customer of Telco B, the call may actually route via Telco C because A and B do not have a direct interconnection.  On the other hand, if I was a customer of Telco D that had a direct connection to Telco C I would expect the call to route directly between the two. What I'm looking for is a way of representing these differing arrangements using any kind of DNS records.

(If this group isn't the right forum for discussing the topic of call routing, apologies -  I'd be very grateful if someone could advise which is the right place).

========================================================This electronic message contains information from the mmO2 plc Group which may be privileged or confidential. The information is intended tobe for the use of the individual(s) or entity named above. If you are notthe intended recipient be aware that any disclosure, copyingdistribution or use of the contents of this information is prohibited. If youhave received this electronic message in error, please notify usby telephone or email (to the numbers or address above) immediately.========================================================
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Tue, 14 Sep 2004 12:28:47 -0400

-----UrsprÃngliche Nachricht----- 
Von: Fullbrook Kim (UK) [mailto:Kim.Fullbrook at O2.COM] 
Gesendet: Mo 13.09.2004 17:11 
An: 'enum at ietf.org' 
Cc: 
Betreff: [Enum] Call Routing

>Can anyone point me towards RFCs, design documentation, white papers etc which cover call routing via third >parties ?  I'll explain what I mean in more detail: 
 
As far as I know these issues are dealt with in TRIP and also the Open Settlement Protocol (OSP from ETSI.
 
>With Internet SIP calls, the design of the DNS in RFC 3263 intends calls to be routed point-to-point. For >example if I use ENUM to look up the SIP URI of the person I'm calling, I'll then extract the domain from the >SIP URI and use it to look up the IP address of the SIP server to receive my call. The call then routes directly >from my SIP server to the receiving SIP server in their network.
 
Correct, ENUM is end-to-end, there is currently no possibility for transit routing.
 
>The PSTN rarely works in this simple way  (at least in the area that I know - it might be different in your >environment).  If I'm a customer of Telco A and make a call to a customer of Telco B, the call may actually >route via Telco C because A and B do not have a direct interconnection.  On the other hand, if I was a >customer of Telco D that had a direct connection to Telco C I would expect the call to route directly between >the two. What I'm looking for is a way of representing these differing arrangements using any kind of DNS >records.
 
ENUM in e164.arpa is to be used on the Internet. On the Internet there is no need to route
via transit networks. Of course you could use some sorta "ENUM" (I do not want to say operator, carrier or
infrastructure ENUM because I am not allowed to use certain terminology at the IETF or on this list)
within your network to route calls to certain E.164 numbers via a border element to a transit network.
 
>(If this group isn't the right forum for discussing the topic of call routing, apologies -  I'd be very grateful if >someone could advise which is the right place).
 
good question, I have no idea (after my experience with the mini-BOF on whatchamacallit ENUM in
San Diego ;-)
 
Richard

  _____  

	========================================================
	This electronic message contains information from the mmO2 plc Group 
	which may be privileged or confidential. The information is intended to
	be for the use of the individual(s) or entity named above. If you are not
	the intended recipient be aware that any disclosure, copying
	distribution or use of the contents of this information is prohibited. If you
	have received this electronic message in error, please notify us
	by telephone or email (to the numbers or address above) immediately.
	========================================================