Subject: [Enum] is the service field in NAPTR records case sensitive?

From: "Klaus Darilion" <[email-masked]>
Date: Mon, 20 Sep 2004 14:00:27 -0400

Hi!
 
I have some questions about the service 
field.

RFC 3761 defines that the 
service type can be written in lower or capital letters.   type          = 1*32(ALPHA / DIGIT)
   subtype       = 1*32(ALPHA / DIGIT)Furthermore, RFC 3764 defines a service type "E2U+SIP"(note: sip in capital letters), but the examples uses lower letters:    IN NAPTR 10 100 "u" "E2U+sip"    "!^.*$!sip:edgar at example.com!"     . My questions:Is there a difference between E2U+sip and E2U+SIP?Is E2U+SIP a valid service type?Does my ENUM resolver has to case insensitive? Thanks for answering my questions.regards,Klaus _______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Conroy, Lawrence (SMTP)" <[email-masked]>
Date: Mon, 20 Sep 2004 17:24:42 -0400

Hi Klaus,
 see the experiences draft, at  
<http://www.ietf.org/internet-drafts/draft-ietf-enum-experiences 
-00.txt>

all the best,
  Lawrence
On 20 Sep 2004, at 18:55, Klaus Darilion wrote:
Hi!
I have some questions about the service field.
RFC 3761 defines that the service type can be written in lower or
capital letters.
   type          = 1*32(ALPHA / DIGIT)
   subtype       = 1*32(ALPHA / DIGIT)
Furthermore, RFC 3764 defines a service type "E2U+SIP"
(note: sip in capital letters), but the examples uses lower letters:
   IN NAPTR 10 100 "u" "E2U+sip"    "!^.*$!sip:edgar at example.com!"      
.

My questions:
Is there a difference between E2U+sip and E2U+SIP?
Is E2U+SIP a valid service type?
Does my ENUM resolver has to case insensitive?
Thanks for answering my questions.
regards,
Klaus
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum