Subject: [Enum] Slides from ENUM WG Meeting

From: Richard Shockey <[email-masked]>
Date: Thu, 05 Aug 2004 17:19:57 -0400

For those of you who are interested attached are the ID's and Relevant 
Presentations from Wednesday's WG meeting

http://www.shockey.us/enum/IETF60_SanDiego_ENUM_WG.zip

Richard Shockey, Senior Manager, Strategic Technology Initiatives
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or <mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: [email-masked]
Date: Thu, 05 Aug 2004 22:04:22 -0400

I didn't send my presentation file :  ENUM experiences draft update
I attach my presentation file in this mail. (magic point format)

--
Fujiwara, Kazunori	JPRS

> From: Richard Shockey <richard at shockey.us>
%include "default.mgp"
%%
%%IETF60 San Diego
%%
%%
%page

%center
draft-ietf-enum-experiences-00.txt

%size 4
IETF60 ENUM-WG
2004/8/04

Kazunori Fujiwara, JPRS <fujiwara at jprs.co.jp>
Lawrence Conroy, Roke Manor Research <lwc at roke.co.uk>
%page

draft-ietf-enum-experiences-00 status

	become working group draft

		Updated from draft-conroy-enum-experiences-01.txt

		Added new items which fujiwara pointed at Seoul IETF meeting

	Separated into "Server" side issues and "Client" side issues

		Server: ENUM zone population side
			Number holder MUST write valid data in DNS.
		Client: ENUM data lookup side
			To be safe and avoid bugs, Clients MAY ignore unrecognized DNS data
%size 3
                 Because clients must accept any data from DNS without crashing
                 Assume bad guys may write malicious data in DNS.

%page

Issues from the original draft

	2.2. Case Sensitivity
		SHOULD NOT assume that the field delimiter is the last character (CLIENT)

	3.2. Treatment of NAPTRs with identical ORDER/PRIORITY values
		SHOULD process all NAPTRs (CLIENT)

	4.2. Non-final NAPTRs - loop detection and response
		SHOULD parse 5 non-final NAPTRs (CLIENT)
%page

New issues (1)

	2.1 Character Sets - Non-ASCII considered harmful (NEW)
%% no previous discussion
		SHOULD use ASCII characters (IDN and URI specific ascii encoding)
		Client MAY ignore NAPTR RR which contains Non-ASCII

	2.3 Regexp field delimiter (from seoul)
		Use '!' (SERVER)
		Client MAY ignore NAPTR RR whose delimiter is not '!' .

	2.4 Regexp meta-character issue (from seoul)
		escape meta character   \+    (SERVER)
%page

New issues (2)

	3.1. Order/Priority values - general processing
		use fixed ORDER   100   (from seoul)

	4.1. Non-final NAPTRs - general issues (from seoul)
		(details are explained later)

	5.  Backward Compatibility (NEW)
		5.1. Service field syntax:
			MUST populate RFC3761 style data (SERVER)
			MUST accept RFC3761 style (CLIENT)
			SHOULD accept RFC2916 style (CLIENT)

%page

Open Issues

	4.1 Non-Final processing - general issues

		To support non-final DDDS NAPTRs:
			non-final NAPTR's service field SHOULD be ignored.
			error processing in DDDS non-final NAPTRs must be consistent

		but, Non-final NAPTR processing is expensive and cause large delay in Telephone switches and embeded terminals
		therefore, some may not be able to support non-final NAPTRs
		I-D authors' recommend:
			SHOULD NOT generate non-final NAPTRs (SERVER)
			MAY discard non-final NAPTRs (CLIENT)
%page

Need comments

	Beware - there are some typos in the draft.

		Those we have noticed have been posted to the list.

	Please check and post to the list or mail the authors.

---

From: Richard Shockey <[email-masked]>
Date: Fri, 06 Aug 2004 13:57:32 -0400

At 09:58 PM 8/5/2004, fujiwara at jprs.co.jp wrote:
I didn't send my presentation file :  ENUM experiences draft update
I attach my presentation file in this mail. (magic point format)
Would you please send it to me personally and I'll add it to the archive 
..several people requested the documentation as soon as I could make it 
avaiable.

--
Fujiwara, Kazunori      JPRS
> http://www.shockey.us/enum/IETF60_SanDiego_ENUM_WG.zip
%include "default.mgp"
%%
%%IETF60 San Diego
%%
%%
%pages://www1.ietf.org/mailman/listinfo/enum

---

From: Carsten Schiefner <[email-masked]>
Date: Sun, 08 Aug 2004 12:35:25 -0400

Richard, Kazunori -
Richard Shockey wrote:
At 09:58 PM 8/5/2004, fujiwara at jprs.co.jp wrote:
I didn't send my presentation file :  ENUM experiences draft update
I attach my presentation file in this mail. (magic point format)
Would you please send it to me personally and I'll add it to the archive 
..several people requested the documentation as soon as I could make it 
avaiable.
could you convert the MPF (magic point format) to a format that is 
likely to be shared by more people - such as PDF, for example? That 
would be helpful.

Cheers,
	-C.

---

From: [email-masked]
Date: Mon, 09 Aug 2004 22:18:13 -0400

now I put pdf version on my page.

http://member.wide.ad.jp/~fujiwara/enum/draft-ietf-enum-experiences-00.mgp.pdf

--
Fujiwara, Kazunori	JPRS

> From: Carsten Schiefner <enumvoipsip.cs at schiefner.de>
> Richard, Kazunori -
> 
> Richard Shockey wrote:

---

From: Carsten Schiefner <[email-masked]>
Date: Tue, 10 Aug 2004 07:50:41 -0400

Kazunori,
fujiwara at jprs.co.jp wrote:
thank you! :-)