Subject: RE: ENUM Privacy (was RE: [Enum] User ENUM vs Operator ENUM)

From: "Stastny Richard" <[email-masked]>
Date: Tue, 29 Jun 2004 12:20:55 -0400

James Seng [mailto:jseng at pobox.org.sg] wrote:
> 
> it would be make sense to define goldentree, silvertree etc as i can see
> we going to use these term regularly in carrier ENUM. anyone wants to
> take a shot at this before san diego...if not, i forsee we going to have
> a lively debate just on the terminology. 1hr is not going to be enough.
> 
> incidently, it might be worthwhile to look at the world as it exists
> first before thinking how we like it to be. the world right now is a
> world of silvertrees.
[Richard>] 
No, not really, there can only be one (or two) silvertrees, 
but many bronze trees

I am somewhat reluctant to define the terms, because immediately
somebody will come up (afterwards) and state that these definitions
are wrong, or he disagrees and BW what about privacy.

Nevertheless, I will try ;-)

ENUM: as defined in RFC3761, implemented in e164.arpa,
publicly accessible, NAPTRs must be retrieveable, ditto URIs,
although the services pointed to by may not be accessible by
anybody (see RFC3764).

"User" ENUM = synonym for ENUM (used to distinguish between 
other types of ENUM.

Golden tree: in ENUM = e164.arpa
In other types of ENUM: a shared tree agreed upon by all operators

Silver tree: a tree used as temporarily replacement for
e164.arpa with the intention to move the whole tree over
to e164.arpa if it is available for every E.164 number.
One could also call this parking tree.
Note: if not every E.164 number will be finally in e164.arpa,
there is a possibility that the silver tree will be around 
forever.

Since all operators may create their golden tree wherever
they want, there is no need there for a silver tree.
What may happen is maybe is wood of bronze trees ;-)

The only silver tree I could imagine here is that everybody
agrees on one tree, but there is no possibility to have
this tree immediately in .arpa, so a parking silver tree
may be useful.

Other types of ENUM:

First, there is no distinction between
Operator, Carrier or Infrastructure (OCI) "ENUM",
One may use each of this terms.

But there is a distinction between:

Private OCI ENUM:
Private OCI ENUM is a tree set-up by a single operator
or network provider within his network. He may choose
any TLD for this tree, even not existing ones, but he may also
choose to use the same tree as Shared OCI ENUM or even e164.arpa
This may come in handy if they decide to use split DNS, providing
different date inside and outside

Shared OCI ENUM:
Is a tree set-up by a confederation of operators.
It is the choice of the confederation if this
tree is private again (e.g. in an extranet), public,
in which tree, and if the data in the tree is accessible.

Only if the tree is public and accessible, they need to
obey privacy

For more information on the different options in
Infrastucture (OCI) ENUM (although not complete yet and still a mess)
see the latest ETSI draft on Infrastructure ENUM

http://enum.nic.at/documents/ETSI/Drafts/0009-TD06r2%20Draft%20ts-102055%20200407%20London%20plus%20Paul.doc 

regards
Richard

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: Jeff Williams <[email-masked]>
Date: Wed, 30 Jun 2004 00:39:03 -0400

Richard and all,

  I have no particular problem with your definitions below.  However
for reasons of clarity in discussions and deliberations, your reference
terms/definitions seem to cause confusion.  Hence I would like to
kindly request and/or suggest that the more proper nomenclature
for "ENUM's" be used.

> http://enum.nic.at/documents/ETSI/Drafts/0009-TD06r2%20Draft%20ts-102055%20200407%20London%20plus%20Paul.doc

Regards,

--
Jeffrey A. Williams
Spokesman for INEGroup LLA. - (Over 134k members/stakeholders strong!)
"Be precise in the use of words and expect precision from others" -
    Pierre Abelard

"If the probability be called P; the injury, L; and the burden, B;
liability depends upon whether B is less than L multiplied by
P: i.e., whether B is less than PL."
United States v. Carroll Towing  (159 F.2d 169 [2d Cir. 1947]
===============================================================
Updated 1/26/04
CSO/DIR. Internet Network Eng. SR. Eng. Network data security
IDNS. div. of Information Network Eng.  INEG. INC.
E-Mail jwkckid1 at ix.netcom.com
 Registered Email addr with the USPS
Contact Number: 214-244-4827