Subject: AW: [Enum] Please start thinking about agenda items for IETF San Diegoetc

From: "Stastny Richard" <[email-masked]>
Date: Thu, 10 Jun 2004 04:06:30 -0400

Hi Rich,
 
I am currently writing on a draft for registration of enum-service "void",
I hope I will have it ready before the deadline
 
Another item I could offer is about the Austrian number ordinance
(in force) and the ENUM-driven numbers.
 
A hot issue currently is infrastructure ENUM. I do not know if we should discuss
this in ENUM WG or in a separate BoF as you proposed.
 
Infrastructure ENUM is getting currently more speed in take-up then
ENUM in e164.arpa. The reason is (as you know very well) that
there is an increasing need for VoIP operators to interconnect
their islands on VoIP.
 
There a really two groups: one is trying to hide the end-user information
by not disclosing the URIs to the public (I call them the NGN walled gardens)
and the others which want to disclose the URIs (the zero termination cost club),
and they would like to go into e164.arpa, but do not get delegations in their country.
These guys look for a (temporary, unregulated=quick) solution beside e164.arpa, but
will be at least not lost forever for e164.arpa (at least for some time).
 
Here at VON Europe a group of UK ITSPs (ITSPA) is considering such a thing on
an European scale, linking all European virtual VoIP providers together with iENUM.
 
BTW, Henry said clearly at the the VON Europe that he consideres implementations
not giving out URIs to the end-user not as VoIP.
 
So IMHO there is currently a critical time period for e164.arpa. If e164.arpa
is not implemented very soon in a wide range of countries, it will be dead.
One year trial in +1 is definetely too long, and this is also important for Europe
since it seems that many countries, even if the have delegations already, are still
waiting for the US.
 
Or as James Seng said at the ENUM Workshop in Brunei:
"The biggest problem in ENUM currently is:
-Those who want to do trials do not get delegations.
-Those who get delegations do not know what to do with it."
 
And I can even add to this: time for trials is over, or it is game over (TILT).
 
And this not for technical reasons, but for administrative and regulatory reasons.
Groups of operators will move to infrastructure ENUM, which is in pronciple not bad,
but will delay global interoperability for some time until a new "golden tree" finally
emerges. In infrastructure ENUM there is of courso also the danger of some wild
implementations ala 882 99 and the Boing 747 Area code, adding to customer confusion.
 
I do not know if these problems are IETF issues at all, but since e164.arpa
is defined in RFC3671, I think it is.
 
regards
Richard

	-----UrsprÃngliche Nachricht----- 
	Von: Richard Shockey [mailto:richard at shockey.us] 
	Gesendet: Mo 07.06.2004 22:31 
	An: enum at ietf.org 
	Cc: paf at cisco.com 
	Betreff: [Enum] Please start thinking about agenda items for IETF San Diegoetc

	Patrik and I will start to accept idea now.
	
	If there are drafts we need to be aware of coming down the pipeline please
	let us know.

	Richard Shockey, Senior Manager, Strategic Technology Initiatives
	NeuStar Inc.
	46000 Center Oak Plaza  -   Sterling, VA  20166
	sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
	ENUM +87810-13313-31331
	PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1 815.333.1237
	<mailto:richard(at)shockey.us> or <mailto:richard.shockey(at)neustar.biz>
	<http://www.neustar.biz> ; <http://www.enum.org>
	<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

	_______________________________________________
	enum mailing list
	enum at ietf.org
	https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Christian de Larrinaga" <[email-masked]>
Date: Thu, 10 Jun 2004 06:40:14 -0400

Richard

Do you think that operators are likely to establish an unofficial golden tree before enough countries in e164 get round to it?

Or do you think that in the end the costs and oversight issues of such an undertaking will mean that iENUM players will come round to the preference of encouraging e164 deployment to support their customer offerings with "universal" connectivity? 

Christian

Christian de Larrinaga
Network Brokers Ltd

-----Original Message-----
From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org]On Behalf Of
Stastny Richard
Sent: 10 June 2004 08:56
To: Richard Shockey; enum at ietf.org
Cc: paf at cisco.com
Subject: AW: [Enum] Please start thinking about agenda items for IETF
SanDiegoetc

Hi Rich,

 

 

 

 
 
regards
Richard

---

From: Richard Shockey <[email-masked]>
Date: Fri, 11 Jun 2004 07:44:39 -0400

At 03:56 AM 6/10/200
Hi Rich,
I am currently writing on a draft for registration of enum-service "void",
I hope I will have it ready before the deadline
OK
Another item I could offer is about the Austrian number ordinance
(in force) and the ENUM-driven numbers.
Well we have so far
1. The ENUM operations document that needs very careful review.
2. Andrzej Bartosiewicz "draft-bartosiewicz-enterprise-enum-00.txt"
3. Scott Hollenbeck on EPP-e164 and whether this is fully baked enough to 
advance . I'm  disappointed to see that there has been little or no 
discussion of this important work on the list.

A hot issue currently is infrastructure ENUM. I do not know if we should 
discuss
this in ENUM WG or in a separate BoF as you proposed.
I still don't know.  I vacillate on this issue depending on cicada insects 
I have to deal with in the morning.

I'm curious to hear what the list thinks about this.  I'm reluctant to use 
WG time since the discussion of infrastructure/carrier ENUM ( aka non 
e164.arpa) could spin off in any number of useless directions and there is 
more fundamental question on whether their is even an appropriate role for 
the IETF in this area at all.

That said its manifestly self evident that everyone and their 
brother-in-law is either becoming a VoIP service provider and or 
infrastructure ENUM registry.

If we did a BoF on carrier ENUM , what would the proposed agenda be?
Infrastructure ENUM is getting currently more speed in take-up then
ENUM in e164.arpa. The reason is (as you know very well) that
there is an increasing need for VoIP operators to interconnect
their islands on VoIP.
ENUM and VoIP have been joined at the hip since its inception. We've always 
known this. As VoIP takes off like a rocket the need to interconnect the 
islands increases exponentially.

There a really two groups: one is trying to hide the end-user information
by not disclosing the URIs to the public (I call them the NGN walled gardens)
and the others which want to disclose the URIs (the zero termination cost 
club),
and they would like to go into e164.arpa, but do not get delegations in 
their country.
These guys look for a (temporary, unregulated=quick) solution beside 
e164.arpa, but
will be at least not lost forever for e164.arpa (at least for some time).

Here at VON Europe a group of UK ITSPs (ITSPA) is considering such a thing on
an European scale, linking all European virtual VoIP providers together 
with iENUM.
humm and as you know a group of Asia-Pac CCTLD operators are putting 
together thieir own ENUM Engineering group

http://www.apenum.org
BTW, Henry said clearly at the the VON Europe that he consideres 
implementations
not giving out URIs to the end-user not as VoIP.
Dr. Sinnreich, as usual, is absolutely correct.
So IMHO there is currently a critical time period for e164.arpa. If e164.arpa
is not implemented very soon in a wide range of countries, it will be dead.
One year trial in +1 is definetely too long, and this is also important 
for Europe
since it seems that many countries, even if the have delegations already, 
are still
waiting for the US.
<sigh> well you remember that +1 is a unique problem in herding 19 nation 
states together but the progress in recent months has been substantial. The 
Canadian ENUM forum is moving forward very quickly the NANP regulators are 
in ongoing discussions...etc etc.

 If North Americans would like the process to move faster they can always 
write their MP's, Senators and Congressmen ..the FCC, The CRTC, the DoC etc 
etc. I'm told they enjoy letters from constituents.

And I can even add to this: time for trials is over, or it is game over 
(TILT).
Right ..It works.

---

From: James Seng <[email-masked]>
Date: Fri, 11 Jun 2004 10:16:29 -0400

i would support enterprise and infrastructure enum to be part of the enum 
charter. 

i would prefer EPP-e164 to be @ PROVREG instead. discussion maybe, charter, 
no.

james

On 11 June 2004 am 00:08, Richard Shockey wrote:
> >by not disclosing the URIs to the public (I call them the NGN walled
> > gardens) and the others which want to disclose the URIs (the zero
> > termination cost club),
> >Here at VON Europe a group of UK ITSPs (ITSPA) is considering such a thing
> > on an European scale, linking all European virtual VoIP providers
> > together with iENUM.
>
> >So IMHO there is currently a critical time period for e164.arpa. If
> > e164.arpa is not implemented very soon in a wide range of countries, it
> > will be dead. One year trial in +1 is definetely too long, and this is
> > also important for Europe
> PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1
> 815.333.1237 <mailto:richard(at)shockey.us> or
> <mailto:richard.shockey(at)neustar.biz> <http://www.neustar.biz> ;
> <http://www.enum.org>

---

From: Richard Shockey <[email-masked]>
Date: Fri, 11 Jun 2004 10:53:54 -0400

At 09:16 AM 6/11/2004, James Seng wrote:
i would support enterprise and infrastructure enum to be part of the enum
charter.
humm OK   I'd certainly like to hear views on this subject from a wide a 
group as possible from the list.

James ..at the very least put together a BOF?  What kind of charter for the 
BOF would you favor?

i would prefer EPP-e164 to be @ PROVREG instead. discussion maybe, charter,
no.
PROVRED is already shut down.  Its seems appropriate to review the 
application specifics here but to your point there has unfortunately has 
not been much discussion on Scott's excellent draft.

james
On

---

From: Jim Reid <[email-masked]>
Date: Fri, 11 Jun 2004 11:22:06 -0400

>>>>> "James" == James Seng <jseng at pobox.org.sg> writes:

    James> i would support enterprise and infrastructure enum to be
    James> part of the enum charter.

Me too!

I believe infrastructure ENUM belongs under e164.arpa, although this
will be achieved with split DNS. Choosing another domain name for this
stuff will make life difficult for applications that will live in both
worlds. And there's already a working process in place for delegations
under e164.arpa. Picking another domain name could cause fragmentation
and complicate the relationship with ITU and the various alternate
ENUM tree providers.

---

From: Andrew Newton <[email-masked]>
Date: Fri, 11 Jun 2004 11:56:50 -0400

On Jun 11, 2004, at 10:23 AM, Richard Shockey wrote:
i would prefer EPP-e164 to be @ PROVREG instead. discussion maybe, 
charter,
no.
PROVRED is already shut down.  Its seems appropriate to review the 
application specifics here but to your point there has unfortunately 
has not been much discussion on Scott's excellent draft.

I agree.  PROVREG is no more, and it seems silly to start a new WG just 
for this.  EPP-e164 should be done in the ENUM working group.

-andy

---

From: Allison Mankin <[email-masked]>
Date: Fri, 11 Jun 2004 12:42:18 -0400

On the epp-e164 point, even before provreg was closed, the model
preferred was for applications of EPP to be produced by their
WGs rather than by provreg, if possible.  ENUM adopted the epp-e164
document as a WG item some time ago, and it is quite right for the
group to give it a thorough expert discussion now.

Allison

---

From: Jaap Akkerhuis <[email-masked]>
Date: Fri, 11 Jun 2004 13:03:15 -0400

Agreed. However, the mailing list is still open. So if you want to
comments from the origional crowd, you might post a pointer there
to point at the discussion at the enum list.

	jaap

---

From: James Seng <[email-masked]>
Date: Fri, 11 Jun 2004 13:19:12 -0400

as a matter of curiousity, anyone interested to implement epp-e164? 
please rise your hand if you are.

on a non-related topic, there is something that has been on my mind for 
a while. the original vision where enum is allocated to the end users 
doesn't seem to hold true anymore.

in all our discussion of numbering plans, enum is more likely to be 
allocated like IP address by blocks of numbers (if that makes sense). 
there are also talks about not delegating to the end-user (or even 
service provider) so that we can preserve the numbering plans.

-James Seng
Andrew Newton wrote:

-andy

---

From: Andrzej Bartosiewicz <[email-masked]>
Date: Tue, 15 Jun 2004 08:02:14 -0400

> discussion of this important work on the list.

If you are interested, we have the working Registry system for ENUM domain
names with EPP's adaptation described in the
www.bartosiewicz.pl/draft-bartosiewicz-enum-48tld-00.txt

Best,
Andrzej Bartosiewicz