Subject: AW: [Enum] Please start thinking about agenda items for IETF SanDiegoetc

From: "Stastny Richard" <[email-masked]>
Date: Thu, 10 Jun 2004 11:44:41 -0400

>Do you think that operators are likely to establish an unofficial golden tree before enough countries in e164 get round to >it?

The answer is yes, it is happening already, see e.g.

http://www.lightreading.com/document.asp?site=lightreading&doc_id=53617

The problem is that there is not ONE unofficial tree, there is a whole forest.

regards

Richard

	-----UrsprÃngliche Nachricht----- 
	Von: Christian de Larrinaga [mailto:cdel at firsthand.net] 
	Gesendet: Do 10.06.2004 12:29 
	An: Stastny Richard; Richard Shockey; enum at ietf.org 
	Cc: paf at cisco.com 
	Betreff: RE: [Enum] Please start thinking about agenda items for IETF SanDiegoetc

	Richard
	
	Do you think that operators are likely to establish an unofficial golden tree before enough countries in e164 get round to it?
	
	Or do you think that in the end the costs and oversight issues of such an undertaking will mean that iENUM players will come round to the preference of encouraging e164 deployment to support their customer offerings with "universal" connectivity?

	Christian
	
	Christian de Larrinaga
	Network Brokers Ltd

	-----Original Message-----
	From: enum-bounces at ietf.org [mailto:enum-bounces at ietf.org]On Behalf Of
	Stastny Richard
	Sent: 10 June 2004 08:56
	To: Richard Shockey; enum at ietf.org
	Cc: paf at cisco.com
	Subject: AW: [Enum] Please start thinking about agenda items for IETF
	SanDiegoetc

	Hi Rich,
	
	I am currently writing on a draft for registration of enum-service "void",
	I hope I will have it ready before the deadline
	
	Another item I could offer is about the Austrian number ordinance
	(in force) and the ENUM-driven numbers.
	
	A hot issue currently is infrastructure ENUM. I do not know if we should discuss
	this in ENUM WG or in a separate BoF as you proposed.
	
	Infrastructure ENUM is getting currently more speed in take-up then
	ENUM in e164.arpa. The reason is (as you know very well) that
	there is an increasing need for VoIP operators to interconnect
	their islands on VoIP.
	
	There a really two groups: one is trying to hide the end-user information
	by not disclosing the URIs to the public (I call them the NGN walled gardens)
	and the others which want to disclose the URIs (the zero termination cost club),
	and they would like to go into e164.arpa, but do not get delegations in their country.
	These guys look for a (temporary, unregulated=quick) solution beside e164.arpa, but
	will be at least not lost forever for e164.arpa (at least for some time).
	
	Here at VON Europe a group of UK ITSPs (ITSPA) is considering such a thing on
	an European scale, linking all European virtual VoIP providers together with iENUM.
	
	BTW, Henry said clearly at the the VON Europe that he consideres implementations
	not giving out URIs to the end-user not as VoIP.
	
	So IMHO there is currently a critical time period for e164.arpa. If e164.arpa
	is not implemented very soon in a wide range of countries, it will be dead.
	One year trial in +1 is definetely too long, and this is also important for Europe
	since it seems that many countries, even if the have delegations already, are still
	waiting for the US.
	
	Or as James Seng said at the ENUM Workshop in Brunei:
	"The biggest problem in ENUM currently is:
	-Those who want to do trials do not get delegations.
	-Those who get delegations do not know what to do with it."
	
	And I can even add to this: time for trials is over, or it is game over (TILT).
	
	And this not for technical reasons, but for administrative and regulatory reasons.
	Groups of operators will move to infrastructure ENUM, which is in pronciple not bad,
	but will delay global interoperability for some time until a new "golden tree" finally
	emerges. In infrastructure ENUM there is of courso also the danger of some wild
	implementations ala 882 99 and the Boing 747 Area code, adding to customer confusion.
	
	I do not know if these problems are IETF issues at all, but since e164.arpa
	is defined in RFC3671, I think it is.
	
	regards
	Richard

	        -----UrsprÃngliche Nachricht-----
	        Von: Richard Shockey [mailto:richard at shockey.us]
	        Gesendet: Mo 07.06.2004 22:31
	        An: enum at ietf.org
	        Cc: paf at cisco.com
	        Betreff: [Enum] Please start thinking about agenda items for IETF San Diegoetc

	
	        Patrik and I will start to accept idea now.
	       
	        If there are drafts we need to be aware of coming down the pipeline please
	        let us know.

	        Richard Shockey, Senior Manager, Strategic Technology Initiatives
	        NeuStar Inc.
	        46000 Center Oak Plaza  -   Sterling, VA  20166
	        sip:rshockey(at)iptel.org   sip:57141 at fwd.pulver.com
	        ENUM +87810-13313-31331
	        PSTN Office +1 571.434.5651 PSTN Mobile: +1 703.593.2683,  Fax: +1 815.333.1237
	        <mailto:richard(at)shockey.us> or <mailto:richard.shockey(at)neustar.biz>
	        <http://www.neustar.biz> ; <http://www.enum.org>
	        <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

	        _______________________________________________
	        enum mailing list
	        enum at ietf.org
	        https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
enum at ietf.org
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Christian de Larrinaga" <[email-masked]>
Date: Fri, 11 Jun 2004 10:47:24 -0400

Richard

>The ansI wer is yes, it is happening already, see e.g.

--->cdel > Nice article. 

But the argument that nobody has managed to think of a reason why users might want ENUM does not lead to the conclusion that users won't find a few reasons themselves once a billion or so are using VoIP end to end regularly.

>The problem is that there is not ONE unofficial tree, there is a whole forest.

--->cdel >If the premise is accepted that universal addressing requires a golden tree then where we have a forest of trees (or forest of forests) these ultimately will all be looking to form into the universal golden tree. 

The first question is whether e164 is not the most obvious way for these "trees or forests" to ultimately interconnect? If not then why not? 
 
Secondly if infrastructure ENUM contiunues to be seen as a useful tool for carriers then this could become an important contributor to boost VoIP usage. 

These new users in turn will learn that they can take control by using ENUM amongst other tools themselves to manipulate the routing through URI and or IP address routing and so strengthen independence from operators. (Hence significance of Henry Sinnrich's observation).

So I am not convinced as yet that iENUM is a long range threat to existance of e164, provided e164 is implemented, robustly and universally, although I can see it might cause ripples of concern amongst us sensitive folk involved in various national trials as we contemplate the possibility that the infra-structures being designed to support e164 deployment have not taken (or been able to take) the market impact of iENUM into account.

Christian
Christian de Larrinaga