Subject: [Enum] Prototype of ENUM validation system online

From: Michael Haberler <[email-masked]>
Date: Tue, 04 Nov 2003 17:38:20 +0100

over summer we developed a distributed authentication architecture for ENUM 
validation based on the RADIUS protocol, which was described in 
http://enum.nic.at/documents/AETP/Permanent_Documents/Drafts/0030-ENUM_validation_architecture_v04.doc 
.

Otmar Lendl has just finished a prototype as proof-of-concept of this 
design and this prototype is now online.

The presentation is available at 
http://enum.nic.at/documents/AETP/Presentations/Austria/0026-2003-11_ENUM-Validation-demo.ppt

The demo system is online for your perusal at http://samuel.ops.at43.at/ .

The documentation for this demo software is at http://samuel.ops.at43.at/docs/

we're very interested in comments & feedback.

One aspect which I should underline - the method is intended to work also 
in the face of telcos which just ignore ENUM, in which case another 
validation entities take their role; this will not be necessarily more 
efficient but is important for consumer choice. The point is that there 
might be more than one "TSP" validating a given number.

-Michael Haberler

---

From: "Pfautz, Penn L, ALABS" <[email-masked]>
Date: Tue, 4 Nov 2003 12:03:00 -0500

Michael:
Thanks for this interesting document. Validation is a problem we grappled with some in the US ENUM Forum. The trick of course is to get the TSP to cooperate in the process. In the US it is not even possible to determine from publicly available information who is the TSP. Then there is the issue of how much the TSP will charge for assisting in the verification process. So we'll be watching experience with great interest.

Penn Pfautz
AT&T

-----Original Message-----
From: Michael Haberler [mailto:[email-masked]]
Sent: Tuesday, November 04, 2003 11:38 AM
To: [email-masked]
Subject: [Enum] Prototype of ENUM validation system online

-Michael Haberler

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 5 Nov 2003 16:56:24 +0100

Hi Oliver,

you are running in open doors. That was exactly the proposal we made to our regulator,
considering that all numbers are portable now anyway, so the assigee could the end-user itself,
and he is then selecting his provider, as it is alredy done with service numbers.

This would not imply much changes in practice, because normally the TSP would also
be the 'registrar', but we could use the existing DNS Registry technology to handle
the transactions, as you proposed.

Our regulator did not reject the proposal immediately, but pointed out some legal and 
procedural problems to be solved (currently every number assigned not in bulk yoi need
a single legal paper (Bescheid).

At least we are discussing to try this model with the number range for ENUM.

I will bring forward some more information on the current level of discussion to the ECC meeting
in Biel on NNA.

best regards
Richard

> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Wednesday, November 05, 2003 4:38 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE : [Enum] Prototype of ENUM validation system online
> 
> 
> Dear Colleagues, 
> 
> The best thing would be to have a validation process totally 
> independent from the TSP... This is not possible as long as 
> the TSP will be responsible for the allocation of individual 
> E.164 numbers to customers. 
> 
> What about a direct allocation of E.164 numbers to the 
> customers based on the model used for Internet domain names ?
> 
> This could be done directly by the Authority managing the 
> E.164 ressources in a country... In this scenario, the 
> Authority would also have the control of information related 
> to the numbers like e.g. directory data and could give anyone 
> access to those data at a fair price...! :o)  And as this 
> solution require a centralized database, some information 
> (like who is the TSP for a given number) could also be made 
> available to any service or application provider... 
> 
> I know, I'm dreaming... :o) 
> 
> Best, 
> 
> olivier
> 
> 
> -----Message d'origine-----
> De : Pfautz, Penn L, ALABS [mailto:[email-masked]] 
> Envoyé : mardi, 4. novembre 2003 18:03
> À : Michael Haberler; [email-masked]
> Objet : RE: [Enum] Prototype of ENUM validation system online
> 
> 
> Michael:
> Thanks for this interesting document. Validation is a problem 
> we grappled with some in the US ENUM Forum. The trick of 
> course is to get the TSP to cooperate in the process. In the 
> US it is not even possible to determine from publicly 
> available information who is the TSP. Then there is the issue 
> of how much the TSP will charge for assisting in the 
> verification process. So we'll be watching experience with 
> great interest.
> 
> Penn Pfautz
> AT&T
> 
> http://enum.nic.at/documents/AETP/Permanent_Documents/Drafts/0
030-ENUM_valid
ation_architecture_v04.doc 
.

The presentation is available at 
http://enum.nic.at/documents/AETP/Presentations/Austria/0026-2003-11_ENUM-Va
lidation-demo.ppt

-Michael Haberler

---

From: [email-masked]
Date: Thu, 6 Nov 2003 09:07:42 +0100

Hi Jim, 

No. What I suggest is that the individual E.164 numbers be allocated
directly to the end users. Once done, the customer may contact one (or more)
operator or service provider in order to implement his number for the
service(s) he wants to have.

The regulator does not intend to administer ENUM delegations.

Best regards, 

olivier

-----Message d'origine-----
De : Jim Reid [mailto:[email-masked]] 
Envoyé : mercredi, 5. novembre 2003 19:47
À : [email-masked]
Cc : [email-masked]; [email-masked]; [email-masked]
Objet : Re: RE : [Enum] Prototype of ENUM validation system online 

>>>>> "Olivier" == Olivier Girard <[email-masked]> 
>>>>> writes:

    Olivier> What about a direct allocation of E.164 numbers to the
    Olivier> customers based on the model used for Internet domain
    Olivier> names ?

What model is that? On the internet, anyone can pretty much register any
domain name they want with little or no authentication beyond a credit card
number for payment. Is this what you're suggesting for the registration of
E.164 numbers?

Now it might be nice for the regulator to administer ENUM delegations but
this is likely to be impractical for a number of reasons.

---

From: "Conroy, Lawrence (SMTP)" <[email-masked]>
Date: Thu, 6 Nov 2003 10:58:56 +0000

At 10:51 am +0100 6/11/03, Richard wrote:
>See inline:
>  > From: Clive D.W. Feather [mailto:[email-masked]]

<snip>

>  > I don't have time to write a full explanation of the history
>>  and issues, but a proposal like that would simply result in
>>  Enum being seen, by UK telcos, as "a stupid idea from a bunch
>>  of complete idiots".
>
>Hold on, currently service numbers are already given to the end-users
>directly. What is proposed here
>by Oliver is to do the same for portable geo and mobile numbers also.
>This has nothing to do with ENUM.

Hi Folks,
  two comments -
  to all in this thread - Richard's comment is well put - how does 
this fit into the IETF ENUM WG?

  to Clive - how would the proposal change the the level of activity 
(or views) of the players in the UK?

I'm puzzled here...
I think that there is still the embedded assumption that an 
individual has a right
to use a phone number, so I can't select 'Whitehall 1212' as a number 
I can register.
We still need proof that the number is assigned to a person, and that 
the person
making the registration request IS that person to whom a number is 
assigned. The
difference lies only in the place from where we get the proof of assignment.

I think that there is still the embedded assumption that the 
registration is valid
only if the number is active (i.e. it has Telephony Service from a 
provider), so
we also need proof that there is an active Telephony Service 
associated with the number.

I'd be very interested if folk don't have those assumptions, but I 
would have thought
that such a change would be a topic for the ITU (or ETSI, or the 
EU/FCC/...) and the IAB
rather that the IETF.

all the best,
   Lawrence
-- 
-----------------------------------------------------------------------
Roke Manor Research    : This information is provided "as is" and is not
<mailto:[email-masked]>: intended to create any contractual or legal
<tel:+441794833666>    : relationship.

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 6 Nov 2003 12:22:04 +0100

> difference lies only in the place from where we get the proof 

This is still valid for opt-in numbers
> associated with the number.

Again for opt-in numbers
> that such a change would be a topic for the ITU (or ETSI, or the 

But if you consider numbers for VoIP and ENUM where ENUM IS the service,
the whole thing is turning around. You have the service only if there is
an entry
in ENUM. So getting the ENUM domain AND the E.164 number is one step, so
there
is no need for valtdation and re-validation.

Once again: with the entry in e164.arpa you get the telephony service
and the number
and this is linked 1:1. If you give back the domain, the service ceases
to exist.

The above mentioned prove of identitty is the same if you subscribe to a
telephony service
not more and not less (You fill out a form and fax it or submit it). Has
anybody checked
when you subscribed your phone if you are the person you pretend to be?

Richard