Subject: RE: [Enum] CRISP

From: "McCandless, Kevin" <[email-masked]>
Date: Wed, 23 Jul 2003 06:30:36 -0700

Here are my thoughts.

WHOIS is unacceptable for ENUM implementation within the US.  We need an alternative based on feedback from organization such as EPIC and FTC.  I would like the ENUM working group to accept IRIS as a working group item.  Why because we need other options for ENUM registrars to store only minimum amount of information related to the registrant and to help ensure their privacy.  Even though CRISP may work this in parallel they have a large battle in front of them if they want to use IRIS as a replacement for WHOIS for the domain name registrars.  This will become a religious battle within a five letter organization.  So, we can avoid this by being very specific as the use for IRIS as it related to ENUM and stay away from the broader debates!

K......

> -----Original Message-----
> From: Patrik Fältström [mailto:[email-masked]]
> Sent: Friday, July 18, 2003 3:17 AM
> To: [email-masked]
> Subject: [Enum] CRISP
> 
> 
> There has been some side-discussions about what I as chair saw 
> happening with regards to the CRISP/ENUM draft which was presented at 
> the meeting.
> 
> My conclusion, after asking Andy and Michael, is that:
> 
>   - The CRISP wg is working on the CRISP architecture, and
>     the ENUM wg is happy "someone else is solving this problem"
>   - The document editors want the ENUM wg to evaluate the
>     data model in the CRISP/ENUM document
>   - There was not consensus whether the document should be
>     added to the charter of the ENUM wg
> 
> First of all, if people don't agree with my view, send a 
> message to the 
> list.
> 
> Secondly, I see absolutely no problem with using the ENUM 
> mailing list 
> for discussions about this ENUM/CRISP draft.
> 
> Richard and myself will check with our AD's what they think about 
> adding this and other documents to the charter. I.e. the overall 
> question for us chairs is what this wg is to do next.
> 
> Conclusion: This document must be reviewed. The ENUM experts 
> are on the 
> ENUM mailing list. Whether the document is on the charter or 
> not should 
> not make any difference for the existence of the discussion.
> 
>      paf
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Jim Reid <[email-masked]>
Date: Wed, 23 Jul 2003 07:10:07 -0700

I'm happy for this WG to consider the applicability of the CRISP to
ENUM. Though personally I doubt if it would be applicable. It will be
fun to find out though.

Like you, I think a whois-based solution is unacceptable. 

Just wondering: how often is whois actually used for something that's
operationally useful? Do the DNS Delegation Police ever use the whois
contact data when they come across dead or lame name servers?

---

From: Kim Davies <[email-masked]>
Date: Wed, 23 Jul 2003 16:59:55 +0200

> WHOIS is unacceptable for ENUM implementation within the US.  We need an alternative based on feedback from organization such as EPIC and FTC.  I would like the ENUM working group to accept IRIS as…

It seems a little presumptuous to introduce IRIS as a work item into the 
ENUM group when it might not be the ultimate protocol coming out of the 
CRISP working group. I'd rather see any considerations be protocol 
neutral at this stage, so the possibility of the two groups arriving at 
two different protocols is removed.

kim

---

From: Jim Reid <[email-masked]>
Date: Wed, 23 Jul 2003 08:27:00 -0700

>>>>> "Kim" == Kim Davies <[email-masked]> writes:

    Kim> It seems a little presumptuous to introduce IRIS as a work
    Kim> item into the ENUM group when it might not be the ultimate
    Kim> protocol coming out of the CRISP working group. I'd rather
    Kim> see any considerations be protocol neutral at this stage, so
    Kim> the possibility of the two groups arriving at two different
    Kim> protocols is removed.

Indeed. However it's possible that the deliberations on CRISP issues
as they pertain to ENUM could inform the protocol development that
gets done in the CRISP WG.

And just to avoid any misunderstanding, I presume you're not implying
this WG should develop its own protocol or duplicate what goes on in
the CRISP WG? You might recall when I suggested this WG looked at
DNSSEC, some people mistakenly thought I wanted the group to get into
the politics of who held what key or RR formats and packet headers.

---

From: Andrew Newton <[email-masked]>
Date: Wed, 23 Jul 2003 13:40:21 -0400

> two different protocols is removed.

After the CRISP meeting in Vienna, it is not presuming much.  However, 
that doesn't stop us from doing a simple requirements document that is 
protocol neutral.  Would that be better first step?  Would people be 
more comfortable with this approach?

-andy

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 23 Jul 2003 23:12:54 +0200

On onsdag, jul 23, 2003, at 16:10 Europe/Stockholm, Jim Reid wrote:

> Do the DNS Delegation Police ever use the whois

I use whois in DNS-problematic cases. When the SOA information is "not 
enough" (doesn't lead to anything).

Last when trying to save a very-broken-TLD and 
undo-this-transfer-of-domain-between-registrars-please situation when 
all admin/tech info was the old, but only the domain name holder (and 
registrar) had changed.

As I stated in a mail some time ago...in Sweden we are interested in a 
CRISP-like function where it is possible to know _to_who_ a delegation 
in the ENUM tree of +46 is supposed to go. It is very good to have both 
the map and the reality, because when they differ, one of them is wrong.

Note, I am _NOT_ talking about having registrant information in this 
system I talk about.

    paf