Subject: [Enum] regexp does not match

From: "Stastny Richard" <[email-masked]>
Date: Fri, 11 Jul 2003 12:23:38 +0200

Hi all, but especially to MM

We talked a lot in the last days in ENUM about _greedy_ regexp that do
always match.
But what about _real_ regexp that does NOT match the AUS.

I tried to find an explicit statement about this either in rfc2916bis or
rfc3403, but did not find
it (maybe it is there, but ...). 

To my understanding, the NAPTR then has to be ignored. Is this correct?

regards
Richard

Richard STASTNY
OeFEG/Telekom Austria
Box 147, A-1103 Vienna, Austria
tel:+43 664 420 4100
fax:+43 1 797 80 13
mailto:[email-masked] 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Mealling <[email-masked]>
Date: 11 Jul 2003 07:38:54 -0400

> To my understanding, the NAPTR then has to be ignored. Is this correct?

Yep. Its there in the algorithm. If the regexp doesn't match you go to
the next record, if it never matches then you'll simply pass over it...

-MM