Subject: [Enum] NAPTR Query Issue

From: Ripple <[email-masked]>
Date: Mon, 17 Mar 2003 14:48:08 +0530

Hi, 
       I have a question about the ENUM Query. When resolver sent a query for NAPTR records to a server. Maybe there isn't the corresponding record in the server zone files. In this conditon, Is it possible that the Answer section is empty, but the Authority Section is a NS record and the Additional Section is the IP address of the NS, then resolver will use the NS information to resend query again? 

Thanks,
Ripple

---

From: Ripple <[email-masked]>
Date: Tue, 18 Mar 2003 15:11:53 +0530

Hi,all
     Who can help me? I think if the ENUM Server is same server, maybe it is possible. But I don't know it is correct or not. English is not my native language, maybe I have not described it clear? if it is, please tell me. Thanks for your help.

Thanks,
Ripple

  ----- Original Message ----- 
  From: Ripple 
  To: [email-masked] 
  Sent: Monday, March 17, 2003 2:48 PM
  Subject: [Enum] NAPTR Query Issue

  Hi, 

  Thanks,
  Ripple

---

From: Ripple <[email-masked]>
Date: Tue, 18 Mar 2003 16:46:37 +0530

Thanks for your help, I have known your opnions.

Best Regards,
Ripple

----- Original Message -----
From: "Juan Rodriguez Hervella" <[email-masked]>
To: "Ripple" <[email-masked]>
Sent: Tuesday, March 18, 2003 3:40 PM
Subject: Re: [Enum] NAPTR Query Issue

> On Tuesday 18 March 2003 10:41, Ripple wrote:
> > Hi,all
> >      Who can help me? I think if the ENUM Server is same server, maybe
it
> > is possible. But I don't know it is correct or not. English is not my
> > native language, maybe I have not described it clear? if it is, please
tell
> > me. Thanks for your help.
> >
> > Thanks,
> > Ripple
> >
> >          I have a question about the ENUM Query. When resolver sent a
query
> > for NAPTR records to a server. Maybe there isn't the corresponding
record
> > in the server zone files. In this conditon, Is it possible that the
Answer
> > section is empty, but the Authority Section is a NS record and the
> > Additional Section is the IP address of the NS, then resolver will use
the
> > NS information to resend query again?
> >
> >   Thanks,
> >   Ripple
>
> Hello:
>
> I don't know a lot about DNS internal format, but I think
> that ENUM queries works exactly the same as any other query against
> the DNS. What happen if you ask for an RR of type A and it doesn't
> exist on the server zone file ? the same behaviour should appear
> whatever RR are you looking for...NAPTR resource records aren't different.
>
> However, the client should implement the algorithm to search for a service
> through a chain of NAPTR records, which is explained in
> http://www.ietf.org/rfc/rfc3401.txt.
>
> Hope this help.
>
> --
> JFRH

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum