Subject: AW: [Enum] partial numbers proposed text changes

From: "Stastny Richard" <[email-masked]>
Date: Wed, 26 Mar 2003 17:35:45 +0100

Hi Philippe,

	So my understanding is that no valid E.164 number can be a subpart of another valid E.164 number, whether the plan's open, closed or anywhere in between, that'd break the "completeness property". I doesn't preclude anyone from using ISDN subaddresses and/or possibly relieve the constraint in dialling plans, but Enum only deals with E.164 numbering plans AFAIK.
	
	Hope this helps,

No is does not help me. As I already explained at the ENUM meeting last week, the
number of my company is:
+43 1 79780
This number is a perfect valid E.164 Number, because it defines the network termination
of the PSTN.
It is at the same time the pilot number of a hunt group with DDI.
 
So my business number is:
+43 1 79780 32
 
Maybe that this is in your definition no E.164 number, but you may reach it in
from every country dialling the above number, because its less than 15 digits.
So what?
 
Now we come to the real question about "partial numbers"
The partial number in this definition is the pilot number, because it
is part of my office number. But the pilot is the "real" E.164 number.
 
Where can I put now the NAPTRs?
In the pilot or in my office number, or both?
 
IMHO in both.
If you dial +43179780 on the PSTN, you get the switchboard (aka secretary)
If you dial +4317978032 you get the phone on my desk.
 
So it is perfectly vailid to put a NAPTR pointing to to the SIP-phone
on the secretaries desk in 0.8.7.9.7.1.3.4.e164.arpa
and another NAPTR in 3.2.0.8.7.9.7.1.3.4.e164.arpa,
pointing to the SIP phone on my desk.
 
I do not want to see anything in rfc2916bis casting any confusion
on this issue, because in this case the "partial" number is the real
E.164 number and the other number is an "extended" number
 
Even more so, because Patriks problem was different, 
he wanted to prevent automatic queries in the DNS by clients digit by digit,
which I agree should not happen.
 
The major reason why we did not implement this up to now where not
DNS issues, but administrative issues (e.g the introduction of a "Tier 3" and
Validation issues)
 
best regards
 
Richard

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Mealling <[email-masked]>
Date: 26 Mar 2003 11:54:33 -0500

On Wed, 2003-03-26 at 11:35, Stastny Richard wrote:
> Hi Philippe,
> 
> 	So my understanding is that no valid E.164 number can be a subpart 
> of another valid E.164 number, whether the plan's open, closed or 
> anywhere in between, that'd break the "completeness property". I 
> doesn't preclude anyone from using ISDN subaddresses and/or possibly 
> relieve the constraint in dialling plans, but Enum only deals with 
> E.164 numbering plans AFAIK.
> 	
> 	Hope this helps,
> 	
> 

Yes. Both. I don't think anyone is suggesting disallowing you from
putting NAPTRs for both of those numbers. If you think I did suggest
that then please accept my apology for not being clear.

> which I agree should not happen.

And my issue is that, since I don't know anything about your numbering
plan, I could very easily make a request for +431797 (minus the last two
digits). What I don't want to happen is for you to be putting NAPTR
records with E2U services in them for that number _IF_ you also consider
that number to be invalid. So help me make that statement that jives
with what you're after so that someone that hasn't personally
administered numbering plans can understand it.

> DNS issues, but administrative issues (e.g the introduction of a "Tier 3" and

This particular issue is a protocol level scoping and error condition
case that needs to be addressed in this document because it affects how
_all_ clients have to be implemented. It is solved by a server side
management solution but the client has to know what it can expect
universally.

-MM