Subject: re: [Enum] NAPTR Query Issue

From: "bill" <[email-masked]>
Date: Wed, 19 Mar 2003 08:12:37 +0800

Hi, Ripple:

I don't know the following may answer your question. I tried this query to different ENUM servers for e164.arpa, 6.8.e164.arpa, and 861036861001 resolution. Here are what i got. There is no additional section in the answer. 

By the way, your question is related to the DNS implementation, you may refer to the DNS protocols. In addition, there is some place which discussed DNS implementation and operational issues, like www.isc.org, IETF DNSEXT WG AND DNSOP WG.

[root@de1650-2 root]# dig @193.0.0.193 1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa naptr

; <<>> DiG 9.1.3 <<>> @193.0.0.193 1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa naptr
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53442
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa. IN  NAPTR

;; AUTHORITY SECTION:
6.8.e164.arpa.          14400   IN      NS      arpa-ns1.enum.net.cn.
6.8.e164.arpa.          14400   IN      NS      arpa-ns0.enum.net.cn.

;; Query time: 306 msec
;; SERVER: 193.0.0.193#53(193.0.0.193)
;; WHEN: Wed Mar 19 07:50:25 2003
;; MSG SIZE  rcvd: 108

[root@de1650-2 root]# dig @159.226.7.156 1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa naptr

; <<>> DiG 9.1.3 <<>> @159.226.7.156 1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa naptr
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40754
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa. IN  NAPTR

;; AUTHORITY SECTION:
1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa. 60 IN NS     naptr-rs0.enum.net.cn.
1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa. 60 IN NS     naptr-rs1.enum.net.cn.

;; Query time: 1 msec
;; SERVER: 159.226.7.156#53(159.226.7.156)
;; WHEN: Wed Mar 19 07:51:03 2003
;; MSG SIZE  rcvd: 110

[root@de1650-2 root]# dig @159.226.7.154 1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa naptr

; <<>> DiG 9.1.3 <<>> @159.226.7.154 1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa naptr
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46230
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa. IN  NAPTR

;; ANSWER SECTION:
1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa. 60 IN NAPTR  20 20 "u" "SIP+E2U" "!^.*$!SIP:[email-masked]!" .

;; AUTHORITY SECTION:
1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa. 60 IN NS     naptr-rs1.enum.net.cn.
1.0.0.1.6.8.6.3.0.1.6.8.e164.arpa. 60 IN NS     naptr-rs0.enum.net.cn.

;; Query time: 2 msec
;; SERVER: 159.226.7.154#53(159.226.7.154)
;; WHEN: Wed Mar 19 07:51:18 2003
;; MSG SIZE  rcvd: 171

-bill
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Ripple <[email-masked]>
Date: Wed, 19 Mar 2003 11:04:32 +0530

Bill：
     Thank you very much! That is exactly my need.

Best Regards,
Ripple