Subject: AW: [Enum] partial numbers proposed text changes

From: "Stastny Richard" <[email-masked]>
Date: Tue, 25 Mar 2003 21:18:13 +0100

He Michael, I think you now are getting a bit ahead of yourself ;-)
 
>Over the
>years we've learned one truism: implementors will be willing to read one
>document, maybe two, thus, you really need to put the most important
client side caveats into the main document or they'll be hopelessly
screwed up. IMHO, this is a very important one to get right.
 
Now I  finally understand why you put the DDDS in five documents;-)
 
Richard
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 26 Mar 2003 13:07:56 +0100

Hi Lawrence,

	** BTW, Richard St, did the esteemed French delegation propose such
	a split out for +33 at some point? I couldn't quite understand their
	proposal, and am unaware of any other proposal to have such a separate
	NS at the "number block" level rather than the full/leaf number level.

The French proposal and one of the possible models in the ETSI TS on Admin
allow for splitting up the Tier 1 (e.g. 1a and 1b). Also in the US one of the possible
models is to delegate CC 1 from T0 to a NANPA tier and the delegate to the
area codes to the T1s (currently in the US the direct delegation from T0 to T1 in US
is preferred). In France it is the other way round: CC 33 is delegated to the French T1a
the T1a delegates to the T1b operated by the TSP holding the numbering
range, which in turn delegated to  the Tier 2. The special thing in France is IMHO that
this T2 is also operated by the TSP and the ENUM subsciber is going thru the ASP,
which is changing the NAPTR on his behalf.
 
regards
Richard
PS: The weather here is not soo hot, only approx 26-28 C ;-)
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: [email-masked]
Date: Wed, 26 Mar 2003 12:38:14 +0100

Dear All, 

Just a little question: 

Assuming that Tier-1 is responsible for the management of the zone
corresponding to the E.164 country code, would splitting further delegations
(e.g. to map the allocated number blocks) not be at the Tier-2 level rather
than at Tier-1 level ?

I mean, in the French case Tier-1 is managing the zone 3.3.e164.arpa and
then Tier-2a is managing the zone corresponding to its number blocks and
Tier-2b the NAPTRs)...   

It's a detail, I know, but as the agreement IAB/ITU-T is dealing with the
relation between Tier-0 and Tier-1 we should have clear definitions...

Am I wrong ?

Regards, 

olivier

> -----Original Message-----
> From:	Stastny Richard [SMTP:[email-masked]]
> Sent:	Wednesday, March 26, 2003 1:08 PM
> To:	Conroy, Lawrence (SMTP); Michael Mealling
> Cc:	[email-masked]
> Subject:	AW: AW: [Enum] partial numbers proposed text changes
> 
> Hi Lawrence,
>

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 26 Mar 2003 14:09:42 +0100

Hi Oliver,
 
you should know better;-)
Please see ETSI TS 102 051 Example 4 Figure A.4 Two stage Tier 1 with
Tier 1 Registry Part A and Tier 1 Registry Part B.
 
The ENUM Tier 2 is defined there as the level corresponding
to the E.164 Number CC N(S)N, which is the national (significant) number.
 
So all levels above must belong to Tier 1.
 
best regards
Richard

	-----Ursprüngliche Nachricht----- 
	Von: [email-masked] [mailto:[email-masked]] 
	Gesendet: Mi 26.03.2003 12:38 
	An: Stastny Richard; [email-masked]; [email-masked] 
	Cc: [email-masked] 
	Betreff: RE: AW: [Enum] partial numbers proposed text changes

	Dear All,
	
	Just a little question:

	
	
	Am I wrong ?
	
	Regards,
	
	olivier

---

From: "FOUQUART Philippe FTRD/DAC/ISS" <[email-masked]>
Date: Wed, 26 Mar 2003 14:09:59 +0100

Hi Richard, all,

Although I'm certainly not entitled to speak on behalf of the, ahem, no-less esteemed French Administration, I should point out that the French model does indeed make it possible but isn't more specific than its US/UK counterparts in that respect. At this point, there is no decision made as to whether the French numbering plan should be split out, be it for trial or long-term implementation. Having said that, I think potential intermediate Tier 1 levels are only a matter of administration/responsibility that should not impact the Enum architecture. I thought (?) the consensus last week was that Enum was E.164, and the debate would now focus on 1) what is E.164 2) whether the word "believe" in the proposed text was appropriate.  

So my take on the "partial number" debate now: the term "partial" is misleading IMO, there are two types of numbers, E.164 and non-E.164. Although the French numbering plan is closed, I don't see how a valid E.164 number of open numbering plans could be a subpart of another valid E.164 number. Maybe, some clarification can be found in Appendix A of the E.164 Rec (which I believe is normative - sorry, I always get the 'Appendix/Annex thing' wrong). In Section "Unique identification of international number for geographic areas", clause A.4.3 reads:
"The subscriber number provides unique identification of one subscriber irrespective of where the call is generated from within a local area identified by NDC, where applicable. _The subscriber number is a complete number and can therefore not be separated_." (same thing applies to global services or numbers for Networks.)
So my understanding is that no valid E.164 number can be a subpart of another valid E.164 number, whether the plan's open, closed or anywhere in between, that'd break the "completeness property". I doesn't preclude anyone from using ISDN subaddresses and/or possibly relieve the constraint in dialling plans, but Enum only deals with E.164 numbering plans AFAIK.

Hope this helps,

Philippe Fouquart
FTR&D/DAC/CAR
+33 (0) 1 45 29 58 13

> From: Stastny Richard [mailto:[email-masked]]

---

From: "Pfautz, Penn L, ALABS" <[email-masked]>
Date: Wed, 26 Mar 2003 08:30:20 -0500

Olivier:
The concept of the Tier 1 has been that it directs you to where the NAPTRs are for an individual number (Tier 2). It's part of the common cooperative infrastructure for ENUM unlike Tier 2 which can in principle (and probably will in the US implementation) be selected or maintained by the number assignee. Accordingly, if you want to map by number blocks I see that as being between Tier 0 and Tier 1 or as a mutli-level Tier 1. My advice is, build multi-level structures if they make sense but try to keep Tier 1/ Tier 2 distinction clean. I suppose in the French model as described in the email where there is no choice with respect to Tier 2 this is a little fuzzier but in the general model as discussed in the working group (and at the ITU) I prefer the usage suggested above.

Penn Pfautz
AT&T

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Wednesday, March 26, 2003 6:38 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: AW: [Enum] partial numbers proposed text changes

Dear All, 

Just a little question: 

Am I wrong ?

Regards, 

olivier

---

From: "FOUQUART Philippe FTRD/DAC/ISS" <[email-masked]>
Date: Wed, 26 Mar 2003 14:43:58 +0100

> Tier 1 Registry Part A and Tier 1 Registry Part B.

Maybe what Olivier's referring to is actually Example 2 (Fig A.2) where Tier 0 _directly_ points at multiple Tier 1s, not one CC. In my understanding, this doesn't seem possible given the current ITU-T/IAB agreement (requests only applies to Country Codes, nothing below that). Maybe something different is meant/implied there, but I personally find it confusing too. Clarification would be welcome, maybe off-line.

Sorry List, this is slightly off-topic.
All the best,

Philippe Fouquart
FTR&D/DAC/CAR
+33 (0) 1 45 29 58 13

> Sent: Wednesday, March 26, 2003 2:10 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]
> 	>       proposal, and am unaware of any other proposal 
> to have such a
> 	> separate
> 	>       NS at the "number block" level rather than the 
> full/leaf number
> 	> level.
> 	>      
> 	>
> 	> allow for splitting up the Tier 1 (e.g. 1a and 1b). 
> Also in the US one of
> 	> the possible
> 	> area codes to the T1s (currently in the US the direct 
> delegation from T0
> 	> to T1 in US
> 	> is preferred). In France it is the other way round: 
> CC 33 is delegated to
> 	> the French T1a
> 	> range, which in turn delegated to  the Tier 2. The 
> special thing in France
> 	> is IMHO that
> 	> this T2 is also operated by the TSP and the ENUM 
> subsciber is going thru
> 	> the ASP,

---

From: [email-masked]
Date: Wed, 26 Mar 2003 15:00:52 +0100

Yes, thanks Philippe, that's exactly what I was referring to. 
In fact, if I have understood correctly Penn's answer, if a splitting is
made between CC and CC+N(S)N, it implies always a multi Tier-1 (Tier-1a to
Tier-1x...) where Tier-1a (higher in the hierarchy) is managing the zone
corresponding to the CC.
Or does it mean that a delegation where Tier-0 points to multiple Tier-1s
(beyond the CC) is possible/allowed ?

Regards, 

olivier     

> From:	FOUQUART Philippe FTRD/DAC/ISS
> [SMTP:[email-masked]]
> Sent:	Wednesday, March 26, 2003 2:44 PM
> To:	Stastny Richard; [email-masked]
> Cc:	[email-masked]
> Maybe what Olivier's referring to is actually Example 2 (Fig A.2) where
> Tier 0 _directly_ points at multiple Tier 1s, not one CC. In my
> understanding, this doesn't seem possible given the current ITU-T/IAB
> agreement (requests only applies to Country Codes, nothing below that).
> Maybe something different is meant/implied there, but I personally find it
> confusing too. Clarification would be welcome, maybe off-line.
>

---

From: "Pfautz, Penn L, ALABS" <[email-masked]>
Date: Wed, 26 Mar 2003 09:19:46 -0500

Olivier:
I think either a multi-level Tier 1 or a delegation below CC level from Tier 0 is possible. The ITU recommendation explicitly recognizes that in the case of an integrated numbering plan (like North America has) delegation from Tier 0 may take place at a lower level. The US ENUM Forum as noted prefers delegation at the 1+NPA level from Tier 0 as that's the highest level at which it's possible to distinguish US from other NANP numbering resources. Of course it would be simpler if all the NANP countries would agree to a unified Tier 1 but I'm not holding my breath...

Penn

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Wednesday, March 26, 2003 9:01 AM
To: [email-masked]; [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: AW: [Enum] partial numbers proposed text changes

Regards, 

olivier

---

From: "FOUQUART Philippe FTRD/DAC/ISS" <[email-masked]>
Date: Wed, 26 Mar 2003 16:49:55 +0100

Hi Penn,

Thanks for clarifying. I'm not aware of any ITU-T Recommendation on this matter but I guess you're referring to the interim procedures agreed between IAB and ITU-T. I'll try to explain why this direct tier 0 => multi-tiered link for one specific country is somewhat confusing:
There are actually two (independent) sets of procedures for insertion in e164.arpa: one applies to country codes identifying a specific country ("geographic country codes", approved in May, amended in December), and another applies to countries in an integrated numbering plan among others ("Interim procedures for the delegation of shared E.164 Country Codes and their associated Identification Codes (ICs) for Networks and Group Identification Codes (GICs) for Groups of Countries", approved in December). 
There's no overlapping, we can't apply one set of procedures to the resources of the other. I understand your point, we could perfectly apply the principles that pertain to the "integrated numbering plan" case to country codes identifying a specific country, but if we stick to instructions to the letter (which is what they're here for) and because ITU-T is not supposed to bother about national matters, I still can't see how some direct tier 0 => multi-tiered is possible. Now, maybe we're missing something.

Thanks,

Philippe Fouquart
FTR&D/DAC/CAR
+33 (0) 1 45 29 58 13

-----Original Message-----
From: Pfautz, Penn L, ALABS [mailto:[email-masked]]
Sent: Wednesday, March 26, 2003 3:20 PM
To: [email-masked]; FOUQUART Philippe FTRD/DAC/ISS;
[email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: AW: [Enum] partial numbers proposed text changes

Olivier:

Penn

-----Original Message-----

Regards, 

olivier

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 26 Mar 2003 17:07:17 +0100

IMHO CC 1 is a GIC.
 
These discussions shows that the whole issue is out of scope of this working group,
this is ITU-T matter. We should not try to explain ITU Recs. 
 
So I fully support Dave.
 
Richard

	-----Ursprüngliche Nachricht----- 
	Von: FOUQUART Philippe FTRD/DAC/ISS [mailto:[email-masked]] 
	Gesendet: Mi 26.03.2003 16:49 
	An: Pfautz, Penn L, ALABS 
	Cc: [email-masked]; Stastny Richard; [email-masked]; [email-masked]; [email-masked] 
	Betreff: Re: [Enum] partial numbers proposed text changes

	Hi Penn,

	Thanks,
	
	Philippe Fouquart
	FTR&D/DAC/CAR
	+33 (0) 1 45 29 58 13

	-----Original Message-----
	From: Pfautz, Penn L, ALABS [mailto:[email-masked]]
	Sent: Wednesday, March 26, 2003 3:20 PM
	To: [email-masked]; FOUQUART Philippe FTRD/DAC/ISS;
	[email-masked]; [email-masked]; [email-masked]
	Cc: [email-masked]
	Subject: RE: AW: [Enum] partial numbers proposed text changes

	Olivier:
	
	Penn
	
	-----Original Message-----
	From: [email-masked]
	[mailto:[email-masked]]
	Sent: Wednesday, March 26, 2003 9:01 AM
	To: [email-masked]; [email-masked];
	[email-masked]; [email-masked]
	Cc: [email-masked]
	Subject: RE: AW: [Enum] partial numbers proposed text changes

	Regards,
	
	olivier

---

From: "Pfautz, Penn L, ALABS" <[email-masked]>
Date: Wed, 26 Mar 2003 11:04:26 -0500

Philippe:
You're right; the ITU document only mentions below CC in Tier 0 for integrated plans.

Penn

-----Original Message-----
From: FOUQUART Philippe FTRD/DAC/ISS
[mailto:[email-masked]]
Sent: Wednesday, March 26, 2003 10:50 AM
To: Pfautz, Penn L, ALABS
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]
Subject: Re: [Enum] partial numbers proposed text changes

Hi Penn,

Thanks,

Philippe Fouquart
FTR&D/DAC/CAR
+33 (0) 1 45 29 58 13

-----Original Message-----
From: Pfautz, Penn L, ALABS [mailto:[email-masked]]
Sent: Wednesday, March 26, 2003 3:20 PM
To: [email-masked]; FOUQUART Philippe FTRD/DAC/ISS;

Olivier:

Penn

-----Original Message-----

Regards, 

olivier

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 26 Mar 2003 18:47:35 +0100

Hi MM
I think we are coming closer to the issue now:
 
You wrote:
>This particular issue is a protocol level scoping and error condition
>case that needs to be addressed in this document because it affects how
>_all_ clients have to be implemented. It is solved by a server side
>management solution but the client has to know what it can expect
>universally.

I think we should consider two types of clients here:

One is a user controlled client where a person is entering a phone number 

and then hits the return button. You have two choices here: send out the 

query as is or do some local checking of the validity of the entered digits.

This is problematic because this may work for some CC and may not work for

others. Furthermore the numbering plan may be changed at any time making your client useless.

So we have to live with the first varient anyway.

The second case is a client in a gateway or proxy. What you really want here is that

the client is not starting querying ENUM before he has received the last digit. This means

in bellhead quack _NO overlap outpulsing_. Only problem with this is that you may

not know what the last digit is and have to put in a 5 second timeout, which is another

hit on call setup time. But we have to live with this in the PSTN anyway.

And this is IMHO what you really want to state.

NAPTRs may be inserted anywhere, they do not hurt

Therefore I propose: 

ENUM clients shall only query DNS

en-block after assuming having received the last digit of the

requested E.164 number. Multiple queries of partial number strings

shall not be done.

regards

Richard

	-----Ursprüngliche Nachricht----- 
	Von: Michael Mealling [mailto:[email-masked]] 
	Gesendet: Mi 26.03.2003 17:54 
	An: Stastny Richard 
	Cc: FOUQUART Philippe FTRD/DAC/ISS; [email-masked] 
	Betreff: Re: AW: [Enum] partial numbers proposed text changes

	On Wed, 2003-03-26 at 11:35, Stastny Richard wrote:
	> Hi Philippe,
	>
	>       So my understanding is that no valid E.164 number can be a subpart
	> of another valid E.164 number, whether the plan's open, closed or
	> anywhere in between, that'd break the "completeness property". I
	> doesn't preclude anyone from using ISDN subaddresses and/or possibly
	> relieve the constraint in dialling plans, but Enum only deals with
	> E.164 numbering plans AFAIK.
	>      
	>       Hope this helps,
	>      
	>
	> No is does not help me. As I already explained at the ENUM meeting last week, the
	> number of my company is:
	> +43 1 79780
	> This number is a perfect valid E.164 Number, because it defines the network termination
	> of the PSTN.
	> It is at the same time the pilot number of a hunt group with DDI.
	> 
	> So my business number is:
	> +43 1 79780 32
	> 
	> Maybe that this is in your definition no E.164 number, but you may reach it in
	> from every country dialling the above number, because its less than 15 digits.
	> So what?
	> 
	> Now we come to the real question about "partial numbers"
	> The partial number in this definition is the pilot number, because it
	> is part of my office number. But the pilot is the "real" E.164 number.
	> 
	> Where can I put now the NAPTRs?
	> In the pilot or in my office number, or both?
	> 
	> IMHO in both.
	> If you dial +43179780 on the PSTN, you get the switchboard (aka secretary)
	> If you dial +4317978032 you get the phone on my desk.
	
	Yes. Both. I don't think anyone is suggesting disallowing you from
	putting NAPTRs for both of those numbers. If you think I did suggest
	that then please accept my apology for not being clear.
	
	> So it is perfectly vailid to put a NAPTR pointing to to the SIP-phone
	> on the secretaries desk in 0.8.7.9.7.1.3.4.e164.arpa
	> and another NAPTR in 3.2.0.8.7.9.7.1.3.4.e164.arpa,
	> pointing to the SIP phone on my desk.
	> 
	> I do not want to see anything in rfc2916bis casting any confusion
	> on this issue, because in this case the "partial" number is the real
	> E.164 number and the other number is an "extended" number
	> 
	> Even more so, because Patriks problem was different,
	> he wanted to prevent automatic queries in the DNS by clients digit by digit,
	> which I agree should not happen.
	
	And my issue is that, since I don't know anything about your numbering
	plan, I could very easily make a request for +431797 (minus the last two
	digits). What I don't want to happen is for you to be putting NAPTR
	records with E2U services in them for that number _IF_ you also consider
	that number to be invalid. So help me make that statement that jives
	with what you're after so that someone that hasn't personally
	administered numbering plans can understand it.
	
	> The major reason why we did not implement this up to now where not
	> DNS issues, but administrative issues (e.g the introduction of a "Tier 3" and
	> Validation issues)
	
	This particular issue is a protocol level scoping and error condition
	case that needs to be addressed in this document because it affects how
	_all_ clients have to be implemented. It is solved by a server side
	management solution but the client has to know what it can expect
	universally.
	
	-MM

---

From: "FOUQUART Philippe FTRD/DAC/ISS" <[email-masked]>
Date: Wed, 26 Mar 2003 18:45:44 +0100

> If you dial +4317978032 you get the phone on my desk.

I think we agree on this, the purpose is certainly not to forbid anyone 
from using one particular valid type of number in open numbering 
plans because they may not be possible in someone else's  (closed) 
national numbering plan. I personally have some difficulty aligning 
this with the E.164 paragraph I quoted but that's off-topic. 
Best,

Philippe Fouquart
FTR&D/DAC/CAR
+33 (0) 1 45 29 58 13

> Sent: Wednesday, March 26, 2003 5:36 PM
> To: FOUQUART Philippe FTRD/DAC/ISS
> Cc: [email-masked]
> Subject: AW: [Enum] partial numbers proposed text changes
> 
> 
> Hi Philippe,
> 
> 	So my understanding is that no valid E.164 number can 
> be a subpart of another valid E.164 number, whether the 
> plan's open, closed or anywhere in between, that'd break the 
> "completeness property". I doesn't preclude anyone from using 
> ISDN subaddresses and/or possibly relieve the constraint in 
> dialling plans, but Enum only deals with E.164 numbering plans AFAIK.
> 	
> 	Hope this helps,
> 	
>