Subject: [Enum] Feedback on ENUM Service Registration for MMS

From: "Robert H. Walter" <[email-masked]>
Date: Wed, 19 Feb 2003 11:53:11 -0500

Rudolf, Lawrence and Richard,

Please consider modifying section 5.4 MMS Service Registration to
include the following subtypes and URI schemes as prescribed by 3GPP TS
23.140 V6.0.0 (2002-12) Multimedia Messaging Service (MMS):

Subtypes: "smtp", "http"
URI Schemes:  "mms"

Valid NAPTR service field examples for MMS would include:

"E2U+mms"      - Indicates MMS service availability with NO advertised
                 protocol support.
"E2U+mms:smtp" - Indicates MMS service availability with advertised SMTP
                 protocol support.
"E2U+mms:http" - Indicates MMS service availability with advertised HTTP
                 protocol support.

Regards,

Bob Walter

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Conroy, Lawrence (SMTP)" <[email-masked]>
Date: Thu, 20 Feb 2003 09:54:14 +0000

>"E2U+mms:http" - Indicates MMS service availability with advertised HTTP

Hi Robert, folks,

Thank you for your feedback. We did consider it.

However, as the document to which you refer is a
Stage 2 document, it states nothing on protocol issues -
you can't inter-operate with a functional spec (other
than using the WAP mapping specified in the appendix).

Secondly, in the MSG draft, the enumservice indicates that
the recipient is capable of receiving multimedia messages,
and that the identifier used to address them is in the URI.

Note that it does NOT matter how the recipient connects to
their service MMSCS, merely the identity they use.

All MMS systems currently available (to me, at least) have a
phone number as recipient identifier and so our 'mms:tel' is
valid. I can use it (and I do, when I can afford the prices :).

If a user has instead an email address as their identifier,
then what we're talking about is just email - I don't care
if they pick up their mail using a webmail system, or by a
email/wap/MMS gateway, or even by their Secretary printing
out the mail and reading it over the phone to them. It's
just email, using the identifier held in the (mailto:) URI.

Thus, there is no difference (to the sender of a message)
how the recipient receives it; only their identifier is
important, and the service provided.

Thus for now I don't believe that the extended architecture
described in the MMS functional specification document is
stable enough (or implemented), so for this registration
we have limited ourselves to the service within the overall
MMS architecture that exists. That uses phone numbers as the
recipient identifier, hence mms:tel.

Maybe in the future...

all the best,   L

-- 
-----------------------------------------------------------------------
Roke Manor Research    : This information is provided "as is" and is not
<mailto:[email-masked]>: intended to create any contractual or legal
<tel:+441794833666>    : relationship.
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum