Subject: [Enum] About draft-ietf-enum-rfc2916bis-03

From: marcelo bagnulo <[email-masked]>
Date: 20 Feb 2003 19:23:57 +0100

Hi,

I have a question about draft-ietf-enum-rfc2916bis-03

According to RFC3402 the step 1 of the DDDS algorithm is:
"1.  The First Well Known Rule is applied to the Application Unique
String which produces a Key."

According to draft-ietf-enum-rfc2916bis-03

The only DDDS data base defined is the DNS and " The Keys for this database are encoded as domain-names."
However, the output of the First well known rule is not a valid domain name, so it is not a valid key. 
Moreover, the First well known rule is the identity. Wouldm't this be in contradiction with the part of RFC 3402 quoted above?

Furthemore, draft-ietf-enum-rfc2916bis-03 specifies in 2.4 an additional algorithm to convert the output of the First Well Known Rule to a Key (DNS name),
but I do not see how this  algorithm is inlcuded in the general algorithm described in RFC 3402.

I guess that the real question is why not define the First Well Known rule as the algorithm to convert an E164 number to a DNS name, 
including the algorithm currently included in point 2.4 of draft-ietf-enum-rfc2916bis-03?

Some editorial comments:

I think that there are some typos in the references.
For instance, in  
2. The ENUM Application Specifications

   This template defines the ENUM DDDS Application according to the
   rules and requirements found in [1].  The DDDS database used by this
                                  ^^^^^ should be [6]?

   Application is found in [2] which is the document that defines the
                          ^^^^^ should be 1?

   NAPTR DNS Resource Record type.   

Later on 

2.4 Valid Databases

   At present only one DDDS Database is specified for this Application.
   "Dynamic Delegation Discovery System (DDDS) Part Three:  The DNS
   Database" (RFC 3403) [2] specifies a DDDS Database that uses the
                       ^^^^ should be 1

Finally, i am not sure which one are normative references but wouldn't reference 6 be normative? 
(since it is a Standard track RFC) 

Thanks,
 
-- 
marcelo bagnulo <[email-masked]>
uc3m

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Mealling <[email-masked]>
Date: 20 Feb 2003 13:36:50 -0500

> Moreover, the First well known rule is the identity. Wouldm't this be in contradiction with the part of RFC 3402 quoted above?

Nope. And this is kind of subtle. The First Well Known Rule (FWKR)
produces a key that is Database independent. It isn't until you get to
the Database Specification section that you actually say how you convert
a Key into something that is valid for that particular Database. If it
weren't this way then it would be a pain to specify a new Database for
ENUM if someone were to do so.

> but I do not see how this  algorithm is inlcuded in the general algorithm described in RFC 3402.

Its in the part of 3402 that is Database dependent. The Keys are the
same, they just have to be converted into a format that is valid for
whatever Database you are using.

> including the algorithm currently included in point 2.4 of draft-ietf-enum-rfc2916bis-03?

Because then you'd always be stuck with the DNS database for ENUM when
it could be very possible that folks may decide to build a new database
for ENUM at some latter date.

>    NAPTR DNS Resource Record type.   

Yep. I've gotten that comment from someone else as well. Thanks.

> (since it is a Standard track RFC) 

Yep. Good catch there too. I'll check the copy that Patrik and I are
working on....

-MM

---

From: marcelo bagnulo <[email-masked]>
Date: 20 Feb 2003 19:52:45 +0100

Hi Michael, 

Thanks for such a fast answer.

I understand now...

However, i am not sure that this is so clear in the specs (at least it
wasn't clear to me :-), perhaps it would be interesting to explain this
idea of database independent key vs. the key that is actually used. 

Thanks again, marcelo