Subject: [Enum] AW: ENUM - opt-in

From: "Stastny Richard" <[email-masked]>
Date: Thu, 30 Jan 2003 09:26:35 +0100

Hi Penn,
 
You wrote:
>Perhaps you can elaborate on why you think opt-in is not the view of the enum wg; it certainly seemed to >be at not too long ago.
>Are we talking about the same thing?
>By opt-in I mean that no number assignee has to put their number into enum unless they choose to and; >likewise, no communication originator is required to make use of enum. Granted many us believe there will >be tremendous benefits for doing so on both sides. That's why we're here.

I think you (as a member of the US ENUM Forum) and I excactly mean the same:

As stated in the "Report of the Department of State ITAC-T Advisory Committee SGA AdHoc on ENUM (July 6th, 2001), which was also the basis of the US ENUM Forum, it is stated clearly:

4.3 Opt-in service for called user.

The assignee of a number must choose to participate in ENUM before any NAPTR records for the number can be populated. This is important since records in ENUM are publicly accessible via DNS query. The opt-in process should be designed to ensure the following:

·         Users can control privacy and security of their information.

·         The default condition is to not include NAPTR record information.

·         Any request for inclusion must be authenticated as being from the assignee of the E.164 number.

·         Inclusion of NAPTR record information must be reversible, allowing the party to remove the data from the DNS in a timely fashion.

4.4 Opt-in service for calling user and service provider.

The crucial part of Opt-in for the calling user and service provider is whether or not to query ENUM and then whether or not to make use of the results. 

The following approach is proposed for telephony services:

1.       No originating party (e.g., a calling user or a service provider) is obligated to perform an ENUM query to complete a telephone call to an E.164 number.

2.       A party making an ENUM query, whether a calling user or service provider, is not obligated to use any of the services in the NAPTR records returned.

3.       All E.164 numbers must have a Public Switched Telephone Network (PSTN) point of interface. (For geographic numbers this would be an end office or tandem.)

For non-telephony services an ENUM query may be necessary if the initiating party that wishes to communicate with the party that has ENUM service has only that party’s E.164 number. For example, if the terminating party’s e-mail address is [email-masked], the initiating party will only be able to derive that address from the terminating party’s E.164 number by accessing the corresponding ENUM NAPTR record.

This statement was also the basis of the work in ITU-T and ETSI, and is therefore also the basis for the European ENUM trials.

When we dicussed in Atlanta these issues, especially the case of the calling user opt-in in the case the calling user is calling from the PSTN, and the IP-Gateway provider is querying ENUM on behalf of the Calling User. When I mentioned that there has to be some agreement with the calling user (e.g. similar to carrier preselection or call-by-call) if ENUM is queried or not, I earned disagreement.. When I then tried to explain that there is also a calling user opt-in, not the mention the called user opt-in, I was asked wherefrom I had this funny idea. When I answered that this was not my idea, but from the US Forum, one guy even said (although not aloud): "Who cares about the US ENUM Forum".

The whole discussion started around the "User ENUM" and "Infrastructure ENUM" (or Carrier ENUM as Netnumber calls it) issue. Since there is an opt-in for called users (ENUM subscribers), and operator cannot set up an ENUM for e.g. NP purposes in the same domain as e164.arpa, because there is a clash with the opt-in right of the ENUM subscriber. You cannot have two different domain name holders for the same domain. Therefore infrastucture ENUM (if global) has to be setup in a different domain.

best regards

Richard Stastny

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Jeff Williams <[email-masked]>
Date: Thu, 30 Jan 2003 12:43:40 -0800

Richard and all,

  Thank you Richard for expanding and more than adequately delineating the
Opt-In issue for ENUM here.  ( More below your specific comments )

> ·         Users can control privacy and security of their information.

  This is very Key here.  Unlike presently with other IETF protocols
user control of their own privacy and security is or should always be
a design requirement.

> When we dicussed in Atlanta these issues, especially the case of the calling user opt-in in the case the calling user is calling from the PSTN, and the IP-Gateway provider is querying ENUM on behalf of the Calling User. When I mentioned that there has to be some agreement with the calling user (e.g. similar to carrier preselection or call-by-call) if ENUM is queried or not, I earned disagreement..

  Here ( Your comments above ) is where the crux of the philosophical
problem begins...

> When I then tried to explain that there is also a calling user opt-in, not the mention the called user opt-in, I was asked wherefrom I had this funny idea. When I answered that this was not my idea, but from the US Forum, one guy even said (although not aloud): "Who cares about the US ENUM Forum".

  Exactly!  And again this seems tome to point up that some are more interested
in disallowing users to determine their own level of privacy/security via
Opt-In.

> The whole discussion started around the "User ENUM" and "Infrastructure ENUM" (or Carrier ENUM as Netnumber calls it) issue. Since there is an opt-in for called users (ENUM subscribers), and operat…

Regards,

--
Jeffrey A. Williams
Spokesman for INEGroup LLA. - (Over 129k members/stakeholders strong!)
================================================================
CEO/DIR. Internet Network Eng. SR. Eng. Network data security
Information Network Eng. Group. INEG. INC.
E-Mail [email-masked]
Contact Number: 214-244-4827 or 214-244-3801