Subject: [Enum] One Number application

From: Sharon Rozov <[email-masked]>
Date: Wed, 29 Jan 2003 10:03:28 +0200

Hello list,
 
I have been trying to look at the implementation of a "One Number" service
using ENUM.
 
My major concerns currently are:
1.	In calls coming from the PSTN, do you expect the PSTN to generate
the ENUM query or otherwise forward the call to another network capable of
DNS queries?
 
2.	What Caller Identification will be sent when an ENUM customer
establishes a call? 
I was thinking about sending out the ENUM number and not the original
number/address. 
Will this require a Reverse ENUM query and a replacement of the Caller ID
with the replied address?
 
Is anybody gone further with the "One Number" service?
Or perhaps you think I'm ahead of time considering this service? 
What ENUM services one may focus on at this time?
 
Why ENUM is focusing on VoIP to PSTN integration, when more VoIP networks
are using e.164 numbers today?

Thank you for taking the time to read my many questions.
 
Sharon Rozov

---

From: "Pfautz, Penn L, ALABS" <[email-masked]>
Date: Wed, 29 Jan 2003 09:47:29 -0500

Sharon:
See below.
-----Original Message-----
From: Sharon Rozov [mailto:[email-masked]]
Sent: Wednesday, January 29, 2003 3:03 AM
To: [email-masked]'
Subject: [Enum] One Number application

Hello list,
 
I have been trying to look at the implementation of a "One Number" service using ENUM.
 
My major concerns currently are:
1.	In calls coming from the PSTN, do you expect the PSTN to generate the ENUM query or otherwise forward the call to another network capable of DNS queries? 
 ENUM is opt-in on both calling and called sides. So it's up to an originating network whether to query ENUM or not. you can't count on such a query being done.
2.	What Caller Identification will be sent when an ENUM customer establishes a call? 
I was thinking about sending out the ENUM number and not the original number/address. 
Will this require a Reverse ENUM query and a replacement of the Caller ID with the replied address? 
[Pfautz, Penn L, NNAD] ENUM really doesn't address Called Party Number. I expect that would be populated by normal PSTN or alternative (e.g. SIP ) procedures 

Why ENUM is focusing on VoIP to PSTN integration, when more VoIP networks are using e.164 numbers today?
 
 I think the biggest thing ENUM will do at least initially is to join islands of VoIP. VoIP customers can have E.164 numbers today but, by-and-large, unless the person you want to call is a customer of the same VoIP carrier as you will be routed to them through a hop-off gateway to the PSTN. ENUM most immediately offers the prospect of being able to find an IP route for a phone number if one is available, regardless of what, if any VOIP service, the called party is subscribed to.
Thank you for taking the time to read my many questions.
 
Sharon Rozov