Subject: [Enum] Question for ENUM supporting VoIP service

From: "sheng-wang" <[email-masked]>
Date: Thu, 12 Dec 2002 01:10:42 +0800

Hello,

 ENUM porvide a directory-like mechanism to support many services. VoIP is expected to be the first potential application currently.

If we use ENUM to support VOIP service, I am concerned about two issues:

1. Is it necessary to make a enum DNS query for each call ? If it is true, there will be call set up delay-time  performance issues, especially when you make a call that will be destined to international domain, there will be many tiers DNS query . How to handle this ?

2. Is it necessary to allocatte special number for users who wants VoIP with ENUM service? 

Any response or pointer will be appreciated.

Simon Yu
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "sheng-wang" <[email-masked]>
Date: Thu, 12 Dec 2002 01:18:41 +0800

-----Original Message-----
From: sheng-wang [mailto:[email-masked]]
Sent: Thursday, December 12, 2002 1:11 AM
To: [email-masked]
Subject: Question for ENUM supporting VoIP service

Hello,

Simon Yu

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 12 Dec 2002 12:36:33 -0800

> 1. Is it necessary to make a enum DNS query for each call ? If it 
> is true, there will be call set up delay-time  performance 
> issues, especially when you make a call that will be destined to 
> international domain, there will be many tiers DNS query . How to 
> handle this ?

Today, on the Internet, all hostname lookups (www.cnn.com) require
a DNS query.  DNS names are usually resolved in less than 50ms.

Today, on the PSTN, with local number portability, there is also
per-call lookup overhead.

> wants VoIP with ENUM service? 

There is no requirement in ENUM itself.  However, there may
be government requirements or user expectations for such 
assignments.  

For example, GSM cellular phones are billed so that the
caller pays for airtime.  Because of this, GSM cellular phone
numbers are assigned numbers to allow knowledgable individuals
to identify the called party is on a cellular phone.

However, GSM itself doesn't require such assignments.  Similarly,
ENUM itself doesn't require such assignments.

-d