Subject: [Enum] Conclusion of the ENUM meeting (re 2916bis)

From: Patrik Fältström <[email-masked]>
Date: Mon, 18 Nov 2002 19:49:19 +0100

New grammar:

service_field	= "E2U" 1*(enumservice)
enumservice	= "+" type 0*(subtype)
type			= 1*32(ALPHA / DIGIT)
subtype		= ":" 1*32(ALPHA / DIGIT)

"type" (and therefore subtype) is registered with IANA, and the 
registration itself specify what to expect.

If we register "A:B" and "C:D", we are not implicitly accepting "A:D".

Comments to this mailing list, or me and michael personally.

     paf

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Mon, 18 Nov 2002 14:28:36 -0500

> ...  "A:B" and "C:D" (!=>) "A:D"

I missed the case against transitive closure. What is it?
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Sun, 24 Nov 2002 12:14:42 +0100

On måndag, nov 18, 2002, at 20:28 Europe/Stockholm, Eric 

> I missed the case against transitive closure. What is it?

It is pure conservatism.

If one register type foo, with subtype bar, that doesn't implicitly say 
subtype bar is ok to have as subtype for type baz.

If baz:bar is ok, it is very easy to add a registration for it, so the 
implicit rule is not needed.

     paf