Subject: RE: [Enum] RE: Draft IETF ENUM usage scenarios

From: "Zmolek, Andrew (Andy)" <[email-masked]>
Date: Wed, 16 Oct 2002 10:40:32 -0600

There are several possible methods of going to a PSTN/E.164 number from a SIP address, but in general ENUM has nothing to do with this:

- Your home SIP redirect server could provide a tel: URI to the SIP originator and effectively force it to find a PSTN gateway to complete the call (not sure if this is "legal" in SIP, though)

- Your home SIP proxy/gateway could complete the SIP session by transparently gatewaying the call over the PSTN (Or PBX system, which is how my SIP address rings my regular desk phone)

- You could create a registry similar to enum that maps a SIP URI to an E.164 address

The latter requires a lot of agreement among many parties (vendors, developers, end-users, etc.) and would not happen very soon. But gatewaying SIP calls back to the PSTN or private PBX or POTS lines is easy enough to do today.

--Andy Zmolek 
    Senior Security Consultant 
      Network Consulting Services 
        Avaya Inc. 

            [email-masked] 
              +1 720 444 4001 
                sip:[email-masked]

> -----Original Message-----
> From: Lind, Steven D, ALASO [mailto:[email-masked]]
> Sent: Wednesday, October 16, 2002 8:21 AM
> To: Keats, Evan
> Cc: [email-masked]
> Subject: [Enum] RE: Draft IETF ENUM usage scenarios
> 
> 
> Evan,
> 
> No, tht's not a scenario I/we have considered. It sounds like 
> an interesting scenario and I'd like to think about it some.
> 
> The ENUM WG is starting out with the premise that one only 
> knows an E.164 telephone number instead of an email address. 
> One could imagine that instead of a number, you could use a 
> unique FQDN, e.g., steven.d.lind.name, that could point to 
> the various NAPTR records. That would require the application 
> software to behave differently than looking up a telephone 
> number. And the problem with uniqueness of the names would 
> not guarantee that you've reached the right steven.d.lind (I 
> know of several Steven Linds, not sure about those with same 
> middle initial).
> 
> Steve
> 
> --------------------------------------------------------------
> ------------------
> Steven D. Lind                                Tel: 973-236-6787
> 180 Park Avenue, Bldg. 2                Fax: 973-236-6453
> Room 2G25                                    [email-masked]
> Florham Park, NJ 07932
> --------------------------------------------------------------
> ------------------
> 
> 
> -----Original Message-----
> From: Keats, Evan [mailto:[email-masked]]
> Sent: Wednesday, October 16, 2002 5:17 AM
> To: Lind, Steven D, ALASO
> Subject: Draft IETF ENUM usage scenarios
> 
> 
> 
> I have just read your draft document with great interest.
> 
> I am interested in the following  IP origination - PSTN 
> termination scenario
> 
> Jenny Jones with her SIP client wants to call Evan Keats.  
> Knowing that my
> email address is [email-masked], she tries
> sip:[email-masked].   
> 
> However, rather than answering the call with a SIP client,  I 
> would like to
> take the call on my landline [one phone on my desk is quite 
> enough :) ]
> 
> I have been trying to fathom out how we could use ENUM to 
> allow me translate
> sip:[email-masked] to 
> 6.4.4.4.6.2.2.0.5.5.e164.arpa, but have not
> made tangible progress.
> 
> Is this a scenario you have considered, or would consider for 
> you document ?
> 
> Or am I missing something ridiculously obvious ?
> 
> Thanks.
> 
> Regards,
> Evan Keats
> 
> Unisys
> Unisys New Zealand
> Ph: 64-4-462 2055
> Fax: 64-4-462 2127
> Net2: 848 2055
> [email-masked]
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Michael Mealling" <[email-masked]>
Date: Wed, 16 Oct 2002 14:03:55 -0400

Andrew Zmolek said this:
> There are several possible methods of going to a PSTN/E.164 number from a
SIP address,
> but in general ENUM has nothing to do with this:

But the DDDS and the URI Resolution application in RFC 3404 (yes the DDDS
documents
now have RFC #s!) does....

> - Your home SIP redirect server could provide a tel: URI to the SIP
originator and effectively
> force it to find a PSTN gateway to complete the call (not sure if this is
"legal" in SIP, though)
>
> - Your home SIP proxy/gateway could complete the SIP session by
transparently gatewaying
> the call over the PSTN (Or PBX system, which is how my SIP address rings
my regular desk
> phone)

Both of these assume that a SIP server will answer for the given SIP
address. What happens
when I have a SIP address and no server responds? It would be nice is there
was a service
that could turn a SIP address into a tel: URL without a SIP server even
being involved.

> - You could create a registry similar to enum that maps a SIP URI to an
E.164 address

This is what RFC 3404 does. It takes _any_ URI and looks up the
deconstruction rules
for how to find an authoritative server for it. I.e. the NAPTR record for
sip.uri.arpa would
look like this:

sip.uri.arpa    IN      NAPTR    0    0    ""    ""
"!^sip:(.*)@(.*)$!/2!"    .

Which says, "go ask the domain-name in that address for a NAPTR record that
can
tell me if a server can answer questions about this URI". One of the obvious
questions would
be: "since a SIP server isn't responding, what should I do to contact that
user?" and the
result would be a tel: URL, or an error message sayign what happened, or a
redirect
to another sip address, etc.

> The latter requires a lot of agreement among many parties (vendors,
developers,
> end-users, etc.) and would not happen very soon. But gatewaying SIP calls
back to the
> PSTN or private PBX or POTS lines is easy enough to do today.

All that needs to be done is register the NAPTR record for the 'sip' URI
scheme in
the uri.arpa zone....

-MM

---

From: Mats Dufberg <[email-masked]>
Date: Wed, 16 Oct 2002 22:21:18 +0200 (CEST)

On Oct 16, 2002, 14:03 (-0400) Michael  Mealling <[email-masked]> wrote:

> But the DDDS and the URI Resolution application in RFC 3404 (yes the
> DDDS documents now have RFC #s!) does....

That RFC does not exist according to the IETF RFC repository. Could you
check the data?

Mats

----------------------------------------------------------------------
Mats Dufberg				             Registry TeliaNet
[email-masked]                                          Skanova/Nwi
+46 8 71 354 38                                Mårbackagatan 11, hus L
+46 70 258 2588                                       SE-123 86 Farsta
----------------------------------------------------------------------

---

From: "Michael Mealling" <[email-masked]>
Date: Wed, 16 Oct 2002 16:52:57 -0400

> That RFC does not exist according to the IETF RFC repository. Could you

I was a little premature. ;-) They should be appearing shortly. In the
meantime
the draft version is here:

http://www.ietf.org/internet-drafts/draft-ietf-urn-uri-res-ddds-07.txt

-MM