Subject: [Enum] RE: Draft IETF ENUM usage scenarios

From: "Lind, Steven D, ALASO" <[email-masked]>
Date: Wed, 16 Oct 2002 10:20:55 -0400

Evan,

No, tht's not a scenario I/we have considered. It sounds like an interesting scenario and I'd like to think about it some.

The ENUM WG is starting out with the premise that one only knows an E.164 telephone number instead of an email address. One could imagine that instead of a number, you could use a unique FQDN, e.g., steven.d.lind.name, that could point to the various NAPTR records. That would require the application software to behave differently than looking up a telephone number. And the problem with uniqueness of the names would not guarantee that you've reached the right steven.d.lind (I know of several Steven Linds, not sure about those with same middle initial).

Steve

--------------------------------------------------------------------------------
Steven D. Lind                                Tel: 973-236-6787
180 Park Avenue, Bldg. 2                Fax: 973-236-6453
Room 2G25                                    [email-masked]
Florham Park, NJ 07932
--------------------------------------------------------------------------------

-----Original Message-----
From: Keats, Evan [mailto:[email-masked]]
Sent: Wednesday, October 16, 2002 5:17 AM
To: Lind, Steven D, ALASO
Subject: Draft IETF ENUM usage scenarios

I have just read your draft document with great interest.

I am interested in the following  IP origination - PSTN termination scenario

Jenny Jones with her SIP client wants to call Evan Keats.  Knowing that my
email address is [email-masked], she tries
sip:[email-masked].   

However, rather than answering the call with a SIP client,  I would like to
take the call on my landline [one phone on my desk is quite enough :) ]

I have been trying to fathom out how we could use ENUM to allow me translate
sip:[email-masked] to 6.4.4.4.6.2.2.0.5.5.e164.arpa, but have not
made tangible progress.

Is this a scenario you have considered, or would consider for you document ?

Or am I missing something ridiculously obvious ?

Thanks.

Regards,
Evan Keats

Unisys
Unisys New Zealand
Ph: 64-4-462 2055
Fax: 64-4-462 2127
Net2: 848 2055
[email-masked]

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Mats Dufberg <[email-masked]>
Date: Wed, 16 Oct 2002 23:30:02 +0200 (CEST)

On Oct 16, 2002, 10:20 (-0400) Lind, Steven D, ALASO <[email-masked]> wrote:

> The ENUM WG is starting out with the premise that one only knows an
> E.164 telephone number instead of an email address. One could imagine
> that instead of a number, you could use a unique FQDN, e.g.,
> steven.d.lind.name, that could point to the various NAPTR records.
> That would require the application software to behave differently than
> looking up a telephone number. And the problem with uniqueness of the
> names would not guarantee that you've reached the right steven.d.lind
> (I know of several Steven Linds, not sure about those with same middle
> initial).

I don't think that we should try to force everything into DNS. There is
already a service responsible for mail addresses -- mail service.

To me it seems simpler to update the SMTP protocol by adding a new
command, say, INFO, to the nameserver in charge of the maildomain
telia.net according to the MX record.

  INFO [email-masked]

which would or could return a list of URL:s for that address, or maybe a
referal to another SMTP server holding the data. Mailservers know about
mail addresses.

In order to force mailaddresses into DNS we would have to invent a
conversion from mailaddress into domain. The allowed characters in the
mailbox part is different from the characters that can normally be used in
DNS. The mailbox part is case sensitive.

Mats

----------------------------------------------------------------------
Mats Dufberg				             Registry TeliaNet
[email-masked]                                          Skanova/Nwi
+46 8 71 354 38                                Mårbackagatan 11, hus L
+46 70 258 2588                                       SE-123 86 Farsta
----------------------------------------------------------------------