Subject: RE: [Enum] Opt-in principle for calling users and communications providers

From: "Vaudreuil, Greg M (Greg)" <[email-masked]>
Date: Tue, 3 Sep 2002 12:42:46 -0500

>On Tue, Sep 03, 2002 at 10:10:15AM -0500, Vaudreuil, Greg M (Greg) wrote:
>> I don't have a view as to whether these services 
>> require a separate root from the end-user services.  However, I thought 
>> we beat the separate root per service (or class of services) down in 
>> favor of the NAPTR multi-service approach.

>I thought we had too. In fact, I'd like someone to explain why simply
>designating "infrastructure" enum-services as opposed to "user-designated"
>enum-services isn't sufficient? When the user signs up with a service
>they explicitly delegate the ability for their infrastructure provider
>to insert "infrastructure" class NAPTR records in there for them but
>that "user-designated" enum-services are still at the users discretion....

>What's wrong with that model?

A few problems come to mind... some we have been discussing for a while.

1) There is an opportunity to have too many NAPTR records for a single entry, requiring TCP and slowing down the retrieval.  

2) The DNS does not provide an easy way to have separate authorities mastering some records and another authority mastering the others.  Infrastructure records are likely to be mastered by a telco-ish entity and end-user records are likely to be a registrar-like entity.  Making one dependant upon the other for updates makes initial deployment technically and politically messy.  (Have we discussed this enough yet?)

3) It is tough to have separate access policies and privacy constraints for records in the same entry, i.e., Opt-in for end-user services, mandatory but privacy protected for infrastructure entries. It is easier to have diverging policies and control under different roots.

Greg V.

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Mealling <[email-masked]>
Date: Tue, 3 Sep 2002 13:53:37 -0400

On Tue, Sep 03, 2002 at 12:42:46PM -0500, Vaudreuil, Greg M (Greg) wrote:
> 1) There is an opportunity to have too many NAPTR records for a single 
> entry, requiring TCP and slowing down the retrieval.  

True, but a consideration for anything with DNS...

> 2) The DNS does not provide an easy way to have separate authorities 
> mastering some records and another authority mastering the others.  
> Infrastructure records are likely to be mastered by a telco-ish entity 
> and end-user records are likely to be a registrar-like entity.  Making 
> one dependant upon the other for updates makes initial deployment 
> technically and politically messy.  (Have we discussed this enough yet?)

The DNS doesn't but that's not DNS's job. We have solutions to this
right now: My ISP puts things in my domain all the time: mx records, etc.
But I can request them to put specific domains in there if I need them.
Its the whole reason we have Technical Contacts seperate from Administrative
Contacts, the Technical Contact has abilities and can be seperate from
the Administrative. Seems easy enough to me..

> 3) It is tough to have separate access policies and privacy 
> constraints for records in the same entry, i.e., Opt-in for end-user 
> services, mandatory but privacy protected for infrastructure entries. 
> It is easier to have diverging policies and control under different 
> roots.

All of those requirements have to do with how the record gets in the zone
which DNS has _zero_ to do with. If you have policies and privacy issues
with how records get into the zone then it sounds like you want some of the
more interesting features of EPP to maintain how/when records get inserted.

Given the fact that my ISP and I share the ability to edit my zone file
I still can't see problem....

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling	|      Vote Libertarian!       | urn:pin:1
[email-masked]      |                              | http://www.neonym.net
--------------------------------------------------------------------------------
!! The Trailblazer spacecraft is going to the Moon! And for just $2500 a gram !!
!! you can send something along with it! Business cards, momentos, cremains,  !!|| anything! See http://www.transorbital.net for details!                     !!