Subject: [Enum] how to provide ENUM for all end users

From: "Tuomo Rostela" <[email-masked]>
Date: Mon, 16 Sep 2002 15:22:45 +0300

Hi folks!

I think, all the previous discussions and scenarios assume that the whole operative national number block is ENUM served but maybe I am wrong. My question is, how should Tier 1 and Tier 2 organised if all TSPs do not use ENUM and common intention is provide ENUM for all end user?

We can consider the following example. 
A customer wants use VoIP and ENUM, but his/her TSP do not support ENUM.
The used national hierarchy of ENUM could be:
At Tier 1 the number blocks which are assigned to certain TSP points to Tier 2 DNS maintained by these operators (or it is outsourced to another entity). Golden tree and opt-in are used.

Which are the possibilities of this customer to use ENUM?
1) the customer can't use ENUM, because number owner TSP do not have any ENUM/DNS (later I call this operator as "no-ENUM TSP")
2) the customer change the number and operator
3) the customer change the operator and keep the old number (number portability)

The last alternative is the best from customer point of view, but how should the number blocks organised at Tier 1?
It is impossible to change the whole number block of "no-ENUM TSP" to point this new operator "x", because another customer of "no-ENUM TSP" could want use operator "y". Ok, of course its possible from technical point of view but from business point of view it is highly unlikely. I guess any opearator will not provide free ENUM/DNS service to the customer of other rival operators.

Lousy solutions:
1) these individual numbers are operated at Tier 1
2) a common Tier 2 ENUM/DNS are established for these number blocks (all operators have a right to add individual numbers)
3) all the operators must participate to ENUM
4) some kind pseudonumbers are used in ENUM (as routing numbers on PSTN)

1 and 2 are poor solutions. If this "no-ENUM TSP" wants later give ENUM services for its numbers, how should these systems (1 and 2) take down?

Do you have any suggestion? 

Best regards Tuomo

---

From: "Pfautz, Penn L, ALVAP" <[email-masked]>
Date: Mon, 16 Sep 2002 10:02:07 -0400

Tuomo:
I'm not sure if the scope of your issue is ENUM use by carriers or more generally. If it's the latter I think there's a problem with what you suggest. The IETF has assumed that the subscriber is the arbiter of ENUM service and that the he/she can have VOIP even if his or her TSP isn't interested. I have a broadband ISP connection to the net and I can choose to have ENUM direct calls to my SIP-enabled PC instead of through the TSP from which I got (or to which I ported) my phone number.
(In the US at least I still have to keep PSTN service on the number to keep it, but that said, I can use ENUM to have calls from ENUM-enable originators routed however I want.)
The conseqence is that number blocks can't be delegated per TSP (in the US and wherever else you have number portability) but the Tier 1 must represent the full number and point to a correct Tier 2 where the NAPTR records reside. This is the path the ENUM Forum is pursuing in the US: a cooperative Tier 1 infrastructure with a competitive Tier 2 to maximize customer choice.
 
Penn Pfautz

-----Original Message-----
From: Tuomo Rostela [mailto:[email-masked]]
Sent: Monday, September 16, 2002 8:23 AM
To: [email-masked]
Subject: [Enum] how to provide ENUM for all end users

Hi folks!

 

Lousy solutions:

 
Best regards Tuomo