Subject: RE: [Enum] Opt-in principle for calling users and communications providers

From: "Yu, James" <[email-masked]>
Date: Wed, 4 Sep 2002 11:04:32 -0400

Kevin,

Using DNS to request for NAPTR RRs, there is no way to indicate that it is
the TSP's or end user's NAPTR RRs that are to be retrieved.  So you cannot
have a pointer to point to the TSP's nameserver(s) for TSP's NAPTR RRs.  The
requestor will get all the NAPTR RRs for that particular phone number.

James

> -----Original Message-----
> From: Kevin McCandless [mailto:[email-masked]]
> Sent: Wednesday, September 04, 2002 10:14 AM
> To: 'Stastny Richard'
> Cc: [email-masked]; Michael Mealling
> Subject: RE: [Enum] Opt-in principle for calling users and
> communications providers
> 
> 
> Well, the problem could be your assumption that the TSP would 
> provide the
> end user with infrastructure records, such as a SIP gateway 
> address.  Maybe
> the TSP would actual be smarter then this and provide only a 
> pointer to the
> registrant.  This pointer would be entered into their Tier II 
> providers
> database.  This pointer directs queries to the TSPs 
> infrastructure database
> the contains records for their gateway addresses.
> 
> Its all vapor ware right now ;-)
> 
> Kevin................
 
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Mealling <[email-masked]>
Date: Wed, 4 Sep 2002 11:34:14 -0400

> requestor will get all the NAPTR RRs for that particular phone number.

yes you can...

Define an enumservice called "tspredirect" with the NAPTR record that
looks like this:

$ORIGIN 4.3.2.1.6.7.9.8.6.4.e164.arpa.
	IN NAPTR 10 10 "" "E2U+tspredirect"	""	foo.tspdomain.com.

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling		       | mailto:[email-masked]
Advanced Naming Research Manager       | go:Michael Mealling
Verisign Applied Research              | urn:pin:1
--------------------------------------------------------------------------------
!! The Trailblazer spacecraft is going to the Moon! And for just $2500 a gram !!
!! you can send something along with it! Business cards, momentos, cremains,  !!
|| anything! See http://www.transorbital.net for details!                     !!
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum