Subject: [Enum] Opt-in principle for calling users and communications providers

From: "Stastny Richard" <[email-masked]>
Date: Mon, 2 Sep 2002 11:20:38 +0200

Patrik, let's clarify this issue first:

Richard Stastny wrote:
> > 1. ENUM in e164.arpa is opt-in for end-users (for the 
> called AND and 
> > also for the calling user)
> 
To which Patrik replied:
> No, not for the calling user. The calling user can not tell 
> all involved parties what kind of databases should be used 
> during call setup. That is already the case today, and will 
> be also with ENUM. There is no way I can tell the telcos 
> whether they should use Informix or just MySQL databases in 
> their IN systems, whether number portability should be used, 
> whether call forwarding should be used or not.
> 
> That is a decision of the called party, and the calling party 
> is only requesting the call to go to the destination 
> addressed by the E.164 number.
> 
> The opt-in which has been discussed around ENUM is only about 
> the called party. Whether a specific E.164 number should 
> exists in DNS or not.
> 

Patrik, this is not up to your opinion, you cannot ignore the ITAC-T and ETSI.

THE DEFAULT SERVICE IS THE EXISTING TELEPHONY SERVICE WITHOUT ENUM INVOLVEMENT.

"Report of the Department of State ITAC-T Advisory Committee
Study Group A Ad Hoc on ENUM - July 6th, 2001"

Which states clearly in Section 4.4:

"4.4 Opt-in service for calling user and service provider.
The crucial part of Opt-in for the calling user and service provider is whether or not to query ENUM and then whether or not to make use of the results. 

The following approach is proposed for telephony services:
1.	No originating party (e.g., a calling user or a service provider) is obligated to perform an ENUM query to complete a telephone call to an E.164 number.
2.	A party making an ENUM query, whether a calling user or service provider, is not obligated to use any of the services in the NAPTR records returned.
3.	All E.164 numbers must have a Public Switched Telephone Network (PSTN) point of interface. (For geographic numbers this would be an end office or tandem.)

For non-telephony services an ENUM query may be necessary if the initiating party that wishes to communicate with the party that has ENUM service has only that party's E.164 number. For example, if the terminating party's e-mail address is [email-masked], the initiating party will only be able to derive that address from the terminating party's E.164 number by accessing the corresponding ENUM NAPTR record."

AND the ETSI TR 102 051 " ENUM Administration in Europe" (July 2002)

Which states in section 7.3:

"7.3 Principle for calling users and communications providers
The default service delivered to the calling user who enters an E.164 number is the existing telephony service according to ITU-T recommendation E.105 [3] without ENUM involvement. This implies that:
* No originating party (e.g., a calling user or a communications provider) is obligated to perform an ENUM query to complete a telephone call to an E.164 number.
* A party making an ENUM query, whether a calling user or communication provider, is not obligated to use any of the services in the NAPTR records returned.
* The specified number should be appropriately terminated for calls that originate on the PSTN/ISDN/PLMN. This termination could also be an announcement."

Of course I cannot tell the telcos if they should use Informix, MySQL or ENUM technology within their IN-systems, but what is told the telcos is, e.g by the regulator, if and based on what principles and databases content e.g. NP is used.

Best regards
Richard

Richard STASTNY
OeFEG/Telekom Austria
Box 147, A-1103 Vienna, Austria
tel:+43 664 420 4100
fax:+43 1 797 80 13
mailto:[email-masked] 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Mon, 2 Sep 2002 10:28:17 +0100

Stastny Richard said:
> > during call setup.
[...]

You two are talking past each other.

> THE DEFAULT SERVICE IS THE EXISTING TELEPHONY SERVICE WITHOUT ENUM INVOLVEMENT.
[...]

> 1.	No originating party (e.g., a calling user or a service provider) is obligated to perform an ENUM query to complete a telephone call to an E.164 number.

This does not prevent a service provider from using ENUM if they want to.
It simply says they are not required to.

Patrik is saying that an SP *can* use ENUM if they wish, and the calling
user can't stop them. Two different matters entirely.

-- 
Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:  +44 20 8371 1138
Internet Expert     | Home:  <[email-masked]>  | Fax:  +44 870 051 9937
Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973 377646
Thus plc            |                            | NOTE: fax number change
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 02 Sep 2002 12:04:04 +0200

--On 2002-09-02 10.28 +0100 "Clive D.W. Feather" <[email-masked]> wrote:

>> 1.	No originating party (e.g., a calling user or a service provider) is
>> obligated to perform an ENUM query to complete a telephone call to an
>> E.164 number.
> 

Yes, we were talking beside each other. I wrote a mail to Richard, my
co-chair to help out so it was not viewed as I as wg co-chair was arguing
with Richard. That is not the case. I am only arguing as Patrik.

Clive has read the document the same way as I have.

A originating party is not forced to use ENUM, but they can if they want to.

My view of your proposal is that:

(a) the enum URI MUST be used for ENUM lookups to happen
(b) enum lookups MUST NOT be used for tel URI's

This implies for me that "default" is that ENUM lookups MUST NOT be used,
if not explicitly requested by the calling party. I.e. what you call
"opt-in for the calling party".

My view is instead:

(a) Anyone MAY use ENUM lookups
(b) Noone MUST do ENUM lookups (what the ETSI document say)
(c) A parameter to the tel: URI scheme SHOULD indicate that
    ENUM lookup is not necessary, but still (a) rules
(d) ENUM URI scheme is not needed, even though marketing wise it
    would be interesting -- the cost for a new URI scheme is
    extremely high, and given (a), a new scheme is not needed

I can see need for (c) when for example a tel: URI is passed from one
system to another when either ENUM lookup has been done, or something
similar.

I am still happy to be convinced about the need for an enum URI scheme, but
have not seem the evidence.

    paf