Subject: [Enum] Protocol in enum service?

From: "Stastny Richard" <[email-masked]>
Date: Thu, 11 Jul 2002 18:54:59 +0200

Hi folks,
sorry, I could not really participate in the discussion, because I was on vacation and had only limited Internet access. 
 
In the new rfc2916bis-01 draft I am somewhat confused with the term protocol. Is this now the URI-scheme or the protocol? In the examples, again mailto is used, in this case as protocol. I have learned from the previous discussions, that this is no protocol, because this may be smtp.
 
IMHO this term should be named URI-scheme and a protocol should never be in the enumservice, because the recepient never knows the protocol the originator will use with the URI-scheme.
 
What kind of protocol should be given e.g. with the tel-URI? DSS1, SS7, h323? In most cases not even the recipient will know.
 
best regards from Cordoba (Spain)
Richard Stastny

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 12 Jul 2002 09:58:20 +0200

--On 2002-07-11 18.54 +0200 Stastny Richard <[email-masked]>
wrote:

> In the new rfc2916bis-01 draft I am somewhat confused with the term
> protocol. Is this now the URI-scheme or the protocol? In the examples,
> again mailto is used, in this case as protocol. I have learned from the
> previous discussions, that this is no protocol, because this may be smtp.
>  
> IMHO this term should be named URI-scheme and a protocol should never be
> in the enumservice, because the recepient never knows the protocol the
> originator will use with the URI-scheme.

I thought I was clear stating that both the term "protocol" and "service"
have absolutely no meaning if one does not read carefully the registration
document (an RFC) for the protocol and service in question.

That is where the string is defined.

   paf