Subject: AW: [Enum] Triggering ENUM Queries

From: Brandner Rudolf <[email-masked]>
Date: Mon, 10 Jun 2002 18:50:44 +0200

Comments inline.

Sorry for being lazy.

> -----Ursprüngliche Nachricht-----
> Von: ripple [mailto:[email-masked]]
> Gesendet: Samstag, 8. Juni 2002 05:29
> An: [email-masked]
> Cc: [email-masked]
> Betreff: Re: [Enum] Triggering ENUM Queries
> 
> 
-----[snipp]-----
> 
> sure, the user get all NAPTR records, and then he can make a 
> dicision. But the callee maybe wouldn't rather his private 
> information known by everyone, especially for the telemarketing. 
> 

A user who has an ENUM domain controls what NAPTRs are listed in that domain. So it is the user's responsability and choice, what the NAPTRs reveal. And the user has the option of not opt-in.

This is similar to an entry in a phone book. You have the choice of not being listed, or if listed, what's in there.

-----[snipp]-----
> 
> First, I can't sure if the 'NAPTR blabla "E2U+enum" blabla 
> enum:+436644204100' is the output of the ENUM query.

I am not quite sure what you mean here.
If it comes down to the question: how can I be sure that this response to my ENUM request is the correct one, then it is not specific to an enum: URI. 

> Second, if the end user is a telephone subscriber, how does 
> he use the URL ?
> 

Not sure what you mean here.
If my end system or terminal can query ENUM and gets an enum: URI, the end systems just queries ENUM with that phone number of the enum: URI.

> Hope this helps,
> ripple

If the answers do not cover your questions, please let me know.

Rudi

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "ripple" <[email-masked]>
Date: Tue, 11 Jun 2002 15:33:21 +0800

Hi,
thanks for your comments, mine are inline...

>----- Original Message ----- 
>From: "Brandner Rudolf" <[email-masked]>
>To: "'ripple'" <[email-masked]>
>Cc: <[email-masked]>; "CONROY LAWRENCE" <[email-masked]>; <[email-masked]>
>Sent: Tuesday, June 11, 2002 12:50 AM
>Subject: AW: [Enum] Triggering ENUM Queries

>If it comes down to the question: how can I be sure that this response to my ENUM request is the correct one, >then it is not specific to an enum: URI. 

I just want to confirm that when I have sent a ENUM query whether 'NAPTR blabla "E2U+enum" blabla 
enum:+436644204100 ' is a response for the query.

>If my end system or terminal can query ENUM and gets an enum: URI, the end systems just queries ENUM with that >phone number of the enum: URI.

I mean that when I use the telephone, How do I click the URL ? So the 3# approach "ENUM query triggered by URL" is not available. 

Thanks again,
rippple

---

From: Richard Shockey <[email-masked]>
Date: Fri, 21 Jun 2002 10:47:21 -0400

I was wondering for a while what might be the possible use for the ENUM URI 
scheme until I started talking to several carriers (who shall remain nameless).

Over the last several weeks I've had talks with senior SS7 (C7) types who 
are clearly thinking about  the impact of VoIP in their markets etc.

What they are trying to wrestle with is the following scenario...which is 
how can they dump a call destined for a IP endpoint immediately at point of 
origination to a Media Gateway which then does the ENUM query and routes 
the call as appropriate.

This was the first time I've heard a carrier really start to think hard and 
long about convergence signalling.

1. A POTS call enters the C5 switch

2. How does the switch know that the call has a alternative routing 
mechanism (IP)?

3. In the US case the idea was to do a LNP dip immediately at origination 
instead of N-1 but there would be a trigger field in the LRN data field 
that would signal the C5 that ...AH HA .. you can transport this call via 
IP.  Now I started thinking ...what if that trigger was a enum URI?

4. Now of course this could be accomplished by having the C5 do a DNS query 
immediately but I doubt we will see switches build in that capability any 
time soon.

Rudolf ..what I'm suggesting is some usage examples here to focus attention 
on how the ENUM URI might be useful in a converged routing architecture.

Thoughts ... could this be a useful C7/SS7 signalling data point?

Richard Shockey, Senior Manager, Strategic Technology Initiatives
NeuStar Inc.
45980 Center Oak Plaza   Bldg 8     Sterling, VA  20166
1120 Vermont Ave NW Suite 400 Washington DC 20005
Voice +1 571.434.5651 Cell : +1 314.503.0640,  Fax: +1 815.333.1237
<mailto: [email-masked]> or
<mailto: [email-masked]>
<http://www.neustar.biz>
<http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<