Subject: AW: AW: [Enum] enumservices in new version of 2916bis

From: "Stastny Richard" <[email-masked]>
Date: Fri, 28 Jun 2002 18:57:49 +0200

Comments inline:

	-----Ursprüngliche Nachricht----- 
	Von: Michael Mealling [mailto:[email-masked]] 
	Gesendet: Fr 28.06.2002 18:21 
	An: Brandner Rudolf 
	Cc: 'Richard Shockey'; Stastny Richard; Peterson, Jon; [email-masked]; CONROY LAWRENCE; [email-masked] 
	Betreff: Re: AW: [Enum] enumservices in new version of 2916bis

	On Fri, Jun 28, 2002 at 06:09:37PM +0200, Brandner Rudolf wrote:
	> > -----Ursprüngliche Nachricht-----
	> > Von: Richard Shockey [mailto:[email-masked]]
	> > Gesendet: Freitag, 28. Juni 2002 04:42
	> > An: Stastny Richard; Peterson, Jon; [email-masked];
	> > [email-masked]
	> > Betreff: Re: AW: [Enum] enumservices in new version of 2916bis
	> >
	> -----[snipp]-----
	> So we would have:
	>      servicefield = "E2U" ("-" <uri-scheme>) [*("+" <enumservice/category>)] ["*" addinfo]
	
	Umm... I'd really like to change that from uri-scheme to protocol. It is
	_very_ common for protocols to be able to handle more than one URI scheme.
	URI scheme does _not_ equate to an actual protocol and vice versa.
	In the above grammar it is impossible to specify that a mailto URI can be
	used for something that isn't using SMTP.
	
	Richard Stastny replies: 

	NO, now I am totally confused. Maybe I missed something or I do not properly understand ENUM, but I have been told (and thats also what I told then everybody who wanted to listen), that ENUM is an E.164 to URI mapping. 

	If I see an mailto:[email-masked] on a webpage, I do not need an additional information to send an e-mail to Hugo, or do I? 

	So I personally considered it redundant to even use the URI-Scheme in the NAPTR, because anybody or any-SW can see it, I they just look a bit to the left, but if this is considered helpfull, ok, shall it be.  Then I may add some service definitions to the URI, e.g. if this tel URI may be used for sms and/or fax. 

	But I definetly see nor reason to add a protocol information.

	best regards

	Richard

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Mealling <[email-masked]>
Date: Fri, 28 Jun 2002 13:09:22 -0400

On Fri, Jun 28, 2002 at 06:57:49PM +0200, Stastny Richard wrote:
> NO, now I am totally confused. Maybe I missed something or I do 
> not properly understand ENUM, but I have been told (and thats also what 
> I told then everybody who wanted to listen), that ENUM is an E.164 to 
> URI mapping. 

Correct. E.164 to URI mapping. But a URI denotes a network endpoint (node) 
within the WorldWideWeb. Some URIs suggest what transport you use to get to 
that endpoint but not all of them.  There are _many_ URI schems that have 
no transport defined for them at all. 

> If I see an mailto:[email-masked] on a webpage, I do not need an 
> additional information to send an e-mail to Hugo, or do I? 

From RFC 2368:

   The mailto URL scheme is used to designate the Internet mailing
   address of an individual or service. In its simplest form, a mailto
   URL contains an Internet mail address.

It does not define the _reason_ why you are doing it and what protocols
you are using to do what is is you are attempting to do. Its simply
saying "hey, the thing after the colon is an Internet email address".
What you _do_ with that address and _how_ you do it isn't defined or
restricted. In many Instant Messaging schemes the 'mailto' URI generates
an Instant Message sent via some IM network.

> So I personally considered it redundant to even use the URI-Scheme in 
> the NAPTR, because anybody or any-SW can see it, I they just look a bit 
> to the left, but if this is considered helpfull, ok, shall it be.  Then 
> I may add some service definitions to the URI, e.g. if this tel URI may 
> be used for sms and/or fax. 
> 

You need it because URI does _not_ equate with how you are expected
to access it that particular endpoint. You can use _any_ URI scheme
within the HTTP protocol. 'urn', 'mailto', 'data', 'news', etc are
all examples of URIs that do not and never will define a protocl by which
you access the resource identified by that URI.

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling	|      Vote Libertarian!       | urn:pin:1
[email-masked]      |                              | http://www.neonym.net