Subject: RE: [Enum] EPP for E.164 - Start Last Call ???

From: "Pfautz, Penn L, ALVAP" <[email-masked]>
Date: Wed, 5 Jun 2002 13:32:44 -0400

Richard:
While I'm generally supportive of the work to make use of EPP in ENUM provisioning, I have a couple of potential concerns about the context in which it is used. These may prove insubstantial (I hope so) but I'd like to offer them up anyway:

1. It's not entirely clear from the document what, if any, assumptions are being made about which information flows in the ENUM provisioning process would make use of EPP. The Registry (Tier 1) - Registrar interface seems the most likely candidate, but at least in the domestic USA ENUM Forum plan, this would not require the NAPTR record objects, so I infer that Registrar - Tier 2 use is also contemplated.  Can Scott or someone elese elaborate?

2. In the US ENUM Forum there has been some debate about what contact information the Tier 1 Registry would actually have. EPP seems to assume a thick Registry  and I'm not sure there is agreement on this for ENUM. I'd at least like to see some statements about contact objects being optional in the document.

Penn Pfautz
AT&T

-----Original Message-----
From: Richard Shockey [mailto:[email-masked]]
Sent: Monday, June 03, 2002 1:32 PM
To: [email-masked]
Subject: Re: [Enum] EPP for E.164 - Start Last Call ???

At 09:14 AM 5/23/2002 -0700, you wrote:
>We want to bring to everyone's attention to the draft for provisioning 
>E.164 numbers using EPP in a registry 
>environment. 
><http://search.ietf.org/internet-drafts/draft-ietf-enum-epp-e164-00.txt>http://search.ietf.org/internet-drafts/draft-ietf-enum-epp-e164-00.txt. 
>This draft was accepted as an ENUM working group item at the 53rd 
>IETF.  We would like to solicit comments for this draft so we can make 
>changes, if necessary, to the draft before the June 24th cut off date for 
>the 54th IETF in Japan.  We would like to move forward, as expediently as 
>possible, because the ENUM forum is very interested in having this draft 
>move to RFC before they adopt it into their provisioning process.

I'd like to re-note this message sent to the list earlier and poll the list 
for any objections to taking this to Last Call as a Informational document 
ASAP.

Richard Shockey, Senior Manager, Strategic Technology Initiatives
NeuStar Inc.
45980 Center Oak Plaza   Bldg 8     Sterling, VA  20166
1120 Vermont Ave NW Suite 400 Washington DC 20005
Voice +1 571.434.5651 Cell : +1 314.503.0640,  Fax: +1 815.333.1237
<mailto: [email-masked]> or
<mailto: [email-masked]>
<http://www.neustar.biz>
<http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 5 Jun 2002 13:55:44 -0400

> From: Pfautz, Penn L, ALVAP [mailto:[email-masked]]
> Sent: Wednesday, June 05, 2002 1:33 PM
> To: Richard Shockey; [email-masked]
> Subject: RE: [Enum] EPP for E.164 - Start Last Call ???
> 
> 
> Richard:
> While I'm generally supportive of the work to make use of EPP 
> in ENUM provisioning, I have a couple of potential concerns 
> about the context in which it is used. These may prove 
> insubstantial (I hope so) but I'd like to offer them up anyway:
> 
> 1. It's not entirely clear from the document what, if any, 
> assumptions are being made about which information flows in 
> the ENUM provisioning process would make use of EPP. The 
> Registry (Tier 1) - Registrar interface seems the most likely 
> candidate, but at least in the domestic USA ENUM Forum plan, 
> this would not require the NAPTR record objects, so I infer 
> that Registrar - Tier 2 use is also contemplated.  Can Scott 
> or someone elese elaborate?

I'd suggest that the scope is for any registry-registrar interface that
requires the provisioning of NAPTR information.  Maybe it's not needed for
the anticipated tier-1 situation in the US, but it's hardly safe to assume
that the same operating model holds world-wide.

> 2. In the US ENUM Forum there has been some debate about what 
> contact information the Tier 1 Registry would actually have. 
> EPP seems to assume a thick Registry  and I'm not sure there 
> is agreement on this for ENUM. I'd at least like to see some 
> statements about contact objects being optional in the document.

EPP assumes nothing about the registry being thick or thin; mappings are
defined to support both models.  If the domain examples used in the document
appear to imply a requirement for a thick registry, I don't have a problem
with adding text to make it clear that there is no such requirement.

-Scott-

---

From: "Pfautz, Penn L, ALVAP" <[email-masked]>
Date: Fri, 7 Jun 2002 09:16:34 -0400

Looking over the draft-ietf-enum-epp-e164-00.txt and the other EPP I-Ds I've come to the following conclusions which I'd like test others' agreement to since I'm not protocol wizard:

1. draft-ietf-enum-epp-e164-00.txt is just about provisioning of NAPTR records.
So from the  perspective of the US ENUM Forum, UKENUM, (and probably the ITU supplement )it has nothing to do with the Registrar-Tier 1 Registry interface, but speaks more to a Registrar - Tier 2, Registrant - Tier 2, or ASP - Tier 2 interface.

2. The functions defined in <draft-ietf-provreg-epp-domain-04.txt> are sufficient to handle Registrar-Tier 1 Registry for ENUM as have been generally discussed e.g. in the some earlier I-Ds and in the US ENUM Forum.

3. The hosts provisioned in Tier 1 will be external hosts (with a TLD different from that used for ENUM domain names) and thus managed on a per-client (per Registrar) basis so there will be no issues with two different Registrars registering differernt ENUM domain names that point to the same Tier 2 name server.

4. EPP allows a domain name to be registered without any name servers specified (although in this case it can't get DNS service)

Penn Pfautz

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 7 Jun 2002 09:35:27 -0400

> Sent: Friday, June 07, 2002 9:17 AM
> To: [email-masked]
> Looking over the draft-ietf-enum-epp-e164-00.txt and the 
> other EPP I-Ds I've come to the following conclusions which 
> I'd like test others' agreement to since I'm not protocol wizard:
> 
> So from the  perspective of the US ENUM Forum, UKENUM, (and 
> probably the ITU supplement )it has nothing to do with the 
> Registrar-Tier 1 Registry interface, but speaks more to a 
> Registrar - Tier 2, Registrant - Tier 2, or ASP - Tier 2 interface.

Currently true.  In the absence of any known (by me) requirements to
provision anything other than NAPTR details, that's all that's in there
right now.

> 2. The functions defined in 
> <draft-ietf-provreg-epp-domain-04.txt> are sufficient to 
> handle Registrar-Tier 1 Registry for ENUM as have been 
> generally discussed e.g. in the some earlier I-Ds and in the 
> US ENUM Forum.

Also true.

> 3. The hosts provisioned in Tier 1 will be external hosts 
> (with a TLD different from that used for ENUM domain names) 
> and thus managed on a per-client (per Registrar) basis so 
> there will be no issues with two different Registrars 
> registering differernt ENUM domain names that point to the 
> same Tier 2 name server.

Also true.

> 4. EPP allows a domain name to be registered without any name 
> servers specified (although in this case it can't get DNS service)

True again.

-Scott-