Subject: RE: [Enum] ..and I quote

From: "Stastny, Richard" <[email-masked]>
Date: Wed, 29 May 2002 08:46:35 +0200

Patrik wrote:

> -----Original Message-----
> From: Patrik Fältström [mailto:[email-masked]] 
> Sent: Tuesday, May 28, 2002 8:03 PM
> To: Lawrence Conroy; [email-masked]
> Subject: Re: [Enum] ..and I quote
>  
> --On 2002-05-27 20.12 +0100 Lawrence Conroy <[email-masked]> wrote:
> 
> > OK, if we need to add URI-scheme to the service field, we 
> add it. If 
> > we do this, then the sipvoice in the above extract might become 
> > "sip-voice".
> 
> Please stop using the same characters in the enumservice as 
> in the URI scheme.
> 
> Call the schemes "foo" and "bar", and try to explain what 
> they are about.

To which I reply:
Good Morning.
Huh?
Now I am totally confused.
Aren't you the (co)-author of rfc2916bis?
There I find:
   $ORIGIN 4.3.2.1.6.7.9.8.6.4.e164.arpa.
     IN NAPTR  10 10 "u" "E2U+sip"     "!^.*$!sip:[email-masked]!"    .
     IN NAPTR 102 10 "u" "E2U+mailto"  "!^.*$!mailto:[email-masked]!" .
     IN NAPTR 102 10 "u" "E2U+tel"     "!^(.*$)$!tel:\1!"     .

Maybe I missed something in the discussion last week, but then the draft has
to be updated substantially.

BTW, is now sipvoice or telvoice allowed or not? (provided I try to explain
it ;-)

Regards
Richard

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 29 May 2002 09:28:09 +0200

>      IN NAPTR 102 10 "u" "E2U+tel"     "!^(.*$)$!tel:\1!"     .

Yes, but obviously people do NOT understand that the string "sip" in the
servicefield has absolutely NOTHING to do with the string sip in the
rewrite rule.

The sip enumservice could have been "foo".

> BTW, is now sipvoice or telvoice allowed or not? (provided I try to
> explain it ;-)

_Any_ string is allowed. But you have to explain what it means. A string is
a string is a string. Whether it is called sip, telvoice, stockholm or foo
does NOT matter.

Too many people on this list read some meaning in the set of characters
which create the enumservce.

  paf