Subject: Re: AW: [Enum] Common Issues with ENUM and enumservices

From: Lawrence Conroy <[email-masked]>
Date: Fri, 1 Mar 2002 11:20:16 +0000

Hi Patrik, Folks,
Apologies for this, but comments inline:

At 4:31 pm -0500 28/2/02, Patrik Fältström wrote:
>--On 2002-02-28 21.07 +0100 Brandner Rudolf
><[email-masked]> wrote:
>
>>>  Is your point the need for different entities for different
>>>  NAPTR records?
>>
>>  Not quite, we know that a CNAME is a complete redirection. This is
>>  transparent to DDDS, so there are some impacts on RegExp matching.
>
>What impacts? Can you give an example?
We gave an example in the 'tel' doc. If you match on the full AUS then
this probably won't match against a query that has "arrived" via a CNAME.

This allows some NAPTRs to match only if the number is queried directly.

That is a restriction (or "Beware!") on the use of RegExps, I think.
I think that there may even be occasions where it's not a good idea
even to match against the '+'.

>  >> The priority/preference must be calculated over all NAPTR
>>>  records with the
>>>  same owner. I.e. it is calculated as part of the DNS
>>>  resolution, and not
>>>  the NAPTR resolution.
>>
>>  I see, you mean in the same zone?
>
>The priority/preference is calculated over all NAPTR with the same owner.
>If two sets of NAPTR are in the same zone, but with different owners, the
>two sets are used separated from each other.
>
>Example: If I have a.example.com and two NAPTR for that owner, the priority
>and preference is calculated over both records, regardless of the service
>or flag fields. If also have b.example.com in the same zone, that is not
>included in the calculation.
>
>I _think_ you with "zone" mean same "owner", i.e. same domain name?

Now I'm mightily confused. Please clarify what is an owner.
Can one have more than one "owner" within the same leaf zone,
and how can the requestor tell? Are you talking about views here?

>  >> Not saying I don't want to write about them. Just as an explanation.
>>
>>  So I look forward to reading this ;^)
>
>Hmmm....there are nice books about how DNS works ;-)
>
>   paf
Where? - DNS&BIND is not exactly up-to-date :(

best regards from a puzzled
    Lawrence
-- 
[email-masked]: +44 1794 833666::<my opinions>:

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 01 Mar 2002 18:54:30 -0500

> even to match against the '+'.

Ok, now I understand.

If you have a NAPTR for owner A, and a CNAME for B which points to A, then
"of course" the regexp must be such that it matches whatever the input will
be. In this case something which matches both the number which lead to A
and the number which lead to B.

Are we on the same page now?

A regexp which works might then be !(.*)!tel:\1!

This is one of the examples why I really like having the ability of having
regexps in NAPTR. Of course, it is a loaded gun you can shoot yourself in
the foot with, but...

> and how can the requestor tell? Are you talking about views here?

A zone contain all records in a domain except domains which are delegated
somewhere. A zone always start with an SOA record.

Owner is the "name" to the left in a traditionally formatted domain name,
and all owners in the same zone end with the name of the zone.

So, in the zone example.com, you can have records:

a.example.com. IN A ...
b.example.com. IN NAPTR ...

In this case, a.example.com and b.example.com are "owners".

> Where? - DNS&BIND is not exactly up-to-date :(

Edition 4 of DNS & BIND by Cricket Liu at O'Reilley is up to date...

   paf