Subject: RE: [Enum] I've seen no comments on the proposed agenda...

From: "Stastny, Richard" <[email-masked]>
Date: Wed, 6 Mar 2002 09:21:14 +0100

Hi folks,
in addition to the list from Patrik, although it may fit into some of the
issues also, I would like to see a discussion on the issue of redirection,
and also a discussion on the purpose and usage of the tel URI:

1. What is the proper way to redirect an ENUM domain to another domain, or
what is the difference in using CNAME and tel?

2. What is the primary purpose of the tel URI? Is it redirection? Or is it
the replacement of IN functionality. (Comment: Maybe this issue should be
discussed with the brander draft. I am still working on this, but the issue
is very complex)

3. In RFC2916bis in Exaple 2, there is:
IN NAPTR 102 10 "u" "E2U+tel"     "!^(.*$)$!tel:\1!"     .
What does this expample show? How a replacemet "\1" may work, or is it a
valid use of a tel URI? In the latter case, I do not understand the example.
I query a database and get the information back, if sip does not work, I may
use the same phone number I queried. But this I knew already. Especially
since most proposals for implementation, e.g. the ITAC-T Report or the ETSI
TS, require, that a working E.164 termination is available on the GSTN.
There is also the "opt-in" principle for the calling user: I do not need to
query ENUM in the first place to reach an E.164 number on the GSTN and if I
query, I am not obligated to use the results (ITAC-T report 4.4.)

4. A question concerns the relationship between differnt NAPTR records,
especially if I have more than one tel URIs or tel and sip URIs together?
How does this work especially with phone-contexts? E.g. see the discussion
on freephone numbers: One wants the user to choose (depending on his
context) between different records, some of them may be tels and some sips?
I think there is some more explanation necessary in RFC2916bis (or DDDS
Part3 - RFC2915bis) on the order and preference fields.

best regards
RichardS

Richard STASTNY
OeFEG
Arsenal Objekt 24
P.O. Box 147
A-1103 Vienna, Austria

Tel: +43 664 420 4100
Fax: +43 1 79780 13
[email-masked]
[email-masked]

> -----Original Message-----
> From: Richard Shockey [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2002 6:43 PM
> To: Dave Crocker; Patrik Fältström
> Cc: Zmolek, Andrew (Andrew); Lawrence Conroy; [email-masked]
> Subject: RE: [Enum] I've seen no comments on the proposed agenda...
> 
> 
> At 10:33 AM 3/4/2002 -0800, Dave Crocker wrote:
> >At 06:32 PM 3/4/2002 +0100, Patrik Fältström wrote:
> >>As co-chair, I don't want _presentations_, but use the time 
> for resolution
> >>of issues which have been discussed on this mailing list before the
> >>meeting...
> >>
> >>I know it is a detail in what word to use, but...
> >>
> >>So, all of you (including myself) which have documents 
> which have been
> >>discussed, please send a list of issues
> >
> >Patrik is making such a good suggestion -- requirement, 
> really -- let me 
> >suggest that folks specify exactly what decisions need to be 
> made and what 
> >alternatives are available for the decisions.
> >
> >That way, we will know what to debate, and the presenters 
> will know what 
> >they need to say that is relevant to making decisions, 
> rather than feeling 
> >that they must provide more general
> 
> 
> I certainly concur with this ... the sense I have is that 
> there are general 
> issues with the what service fields are appropriate for ENUM 
> and why and 
> how in specific cases should records be processed ... aka SIP ...
> 
> What are the requirements for service registration ... what is the 
> justification for such registrations  given issues of privacy 
> ..what level 
> of granularity is necessary ...
> 
> this is the beginniing of a general issues resolution list 
> for the service 
> drafts etc....any additional suggestions.
> 
> In addition I have not seen much comment and suggestion on 
> 2916 bis beyond 
> technicial corrections... Patrik had a list of issues that he wanted 
> covered ... are we in consensus about these?
> 
> ################
> 
> -Mailman-Version: 1.0
> Precedence: bulk
> List-Id: Enum Discussion List <enum.ietf.org>
> X-BeenThere: [email-masked]
> 
> I have here compiled a list of things to be changed to RFC 2916 when
> 2916bis is created.
> 
> (1) It must be made clear that ENUM service is a delegation in the
> e164.arpa domain
> 
> (2) It must be explained how ENUM-like mechanisms can be used for for
> example private dialing plans even though e164.arpa is the 
> tree where ENUM
> is located
> 
> (3) The use of NAPTR should instead of being some handwaving 
> be a proper
> DDDS specification according to the DDDS documents which 
> replaces RFC 2915
> 
> (4) A registration mechanism must be created for the first 
> part of the flag
> field
> 
> (5) Registrations must be made in separate documents for some 
> basic flags,
> especially LDAP and TEL which have been asked especially how to handle
> 
> (6) Privacy issues must be described more clearly in the security
> consideration section which explains that some privacy issues can be
> resolved via storage in a secondary storage, like an LDAP 
> database, which
> uses an access protocol which can handle authentication and 
> other needed
> security mechanisms
> 
> (7) Loops must be specified how to detect (i.e. a paragraph 
> should be added
> which explains the traditional need for convergence)
> 
> (8) Examples must be corrected and made mode clear. For example, there
> should be absolutely no confusion about full regular 
> expressions are used.
> I.e. any delimiter and any matchingh mechanism can be used
> 
> 
> 
> All of this leads to the need for the following document(s) 
> in this wg:
> 
>    - 2916bis
>    - Registration procedure of ENUM flag fields
>    - Flag field registration for whatever needed for TEL URI scheme
>    - Flag field registration for whatever needed for SIP URI scheme
>    - Flag field registration for whatever needed for MAILTO URI scheme
>    - Flag field registration for whatever needed for LDAP URI scheme
> 
> I will take care of 2916bis, but as wg co-chair I would 
> appreciate people
> interested in working on the other documents.
> 
> I suggest we take these 8 issues (and maybe others) as main 
> agenda items on
> the IETF meeting in Minneapolis. Further, we add the flag field
> discussions, if we have takes, to the agenda aswell.
> 
>      paf
> 
> 
> 
> 
> 
> 
> >introductions.
> >
> >d/
> >
> >----------
> >Dave Crocker  <mailto:[email-masked]>
> >Brandenburg InternetWorking  <http://www.brandenburg.com>
> >tel +1.408.246.8253;  (new)fax +1.408.850.1850
> 
> 
>  >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> Richard Shockey, Senior Manager, Strategic Technology Initiatives
> NeuStar Inc.
> 45980 Center Oak Plaza   Bldg 8     Sterling, VA  20166
> 1120 Vermont Ave NW Suite 400 Washington DC 20005
> Voice +1 571.434.5651 Cell : +1 314.503.0640,  Fax: +1 815.333.1237
> <mailto: [email-masked]> or
> <mailto: [email-masked]>
> <http://www.neustar.biz>
> <http://www.enum.org>
> <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 06 Mar 2002 10:30:26 +0100

--On 2002-03-06 09.21 +0100 "Stastny, Richard" <[email-masked]>
wrote:

> valid use of a tel URI? In the latter case, I do not understand the
> example. I query a database and get the information back, if sip does not
> work, I may use the same phone number I queried.

Probably a stupid example...

I tried to show that (1) the world is not only SIP and (2) one can use the
\1 construction.

Do you have a better suggestion?

   paf