Subject: RE: [Enum] Re. 2916bis

From: "Yu, James" <[email-masked]>
Date: Wed, 20 Feb 2002 22:06:49 -0600

Jim,

The process involves retrieving NAPTR RRs via DNS where the URLs (e.g.,
mailto URL or e-mail address and SIP URL, etc.) are part of the NAPTR RRs
(in the regular expression field).

In addition, ENUM, as a DDDS application, also provides the
mechanism/foundation for many ENUM applications (e.g., SIP, VPIM).  So it
should describe something that can be used by all the ENUM applications and
leave specifics to each ENUM application.

James

> -----Original Message-----
> From: Jim Reid [mailto:[email-masked]]
> Sent: Wednesday, February 20, 2002 7:26 PM
> To: Patrik Fältström
> Cc: Yu, James; 'Lawrence Conroy'; [email-masked]
> Subject: Re: [Enum] Re. 2916bis 
> 
> 
> Forgive me, but could someone please explain why we need to say
> anything about NAPTR records in 2916bis? I thought this document
> defined a protocol for mapping E.164 numbers into domain names.
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Lawrence Conroy <[email-masked]>
Date: Thu, 21 Feb 2002 04:39:18 +0000

At 10:06 pm -0600 20/2/02, Yu, James wrote:

><snip>
><snip>
To which I reply:
  I'm not comfortable with the terms here (specifically the nasty overload of
"application").

I had thought that "ENUM" included more than just the client application making
the query. As such I tend to use the term "ENUM Application" to be 
analogous with
the program running on the ENUM client.

As for SIP, VPIM, ...
I don't view of them as ENUM applications - at best they're protocols that
can be used to further resolve URIs returned by the ENUM Application. That,
however, is what happens AFTER the DDDS algorithm has done its stuff.

Does that make sense?

All the best,
    Lawrence
-- 
[email-masked]: +44 1794 833666::<my opinions>:

---

From: Jim Reid <[email-masked]>
Date: Thu, 21 Feb 2002 01:12:55 -0800

>>>>> "James" == Yu, James <[email-masked]> writes:

    James> Jim, The process involves retrieving NAPTR RRs via DNS
    James> where the URLs (e.g., mailto URL or e-mail address and SIP
    James> URL, etc.) are part of the NAPTR = RRs (in the regular
    James> expression field).

Indeed. But what has any of that got to do with the mapping of E.164
numbers to domain names? ENUM tells me how to enter my phone number in
the DNS. It shouldn't (have to) tell me what record types or data are
required for that number's DNS representation.

---

From: Michael Mealling <[email-masked]>
Date: Thu, 21 Feb 2002 08:45:51 -0500

> required for that number's DNS representation.

Umm... I think you might be mistaken in your definition of ENUM.
ENUM isn't about storing telephone number _in_ the DNS, its about
using the DNS to find available services for a given TN. Those
services are encoded in the form of URIs and Service descriptions.
If you just want a standard for putting TNs into DNS zones then
ENUM isn't what you're looking for...

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling	|      Vote Libertarian!       | urn:pin:1
[email-masked]      |                              | http://www.neonym.net