Subject: RE: [Enum] DDDS, DNS clarification needed?

From: "Stastny, Richard" <[email-masked]>
Date: Wed, 20 Feb 2002 15:52:27 +0100

Please, 
I did not intend to start a discussion on private or public regarding the
Internet.
I just wanted to state, that users of _ENUM_ and _ENUM LIKE_ services, since
they will use phone numbers as input to establish comunication, may like to
use the same conventions the are already used to with existing phone
systems, so I used the _analogy_ of public and private DIALLING plans.

And to end the discussion on the political correct ENUM root, maybe IAB and
ITU-T may set up a server, where the currently valid root for RFC2916 ENUM
is stored and all clients have to look it up before adding it to the number
string (e.g. like the bubble coming up for the Windows update: there is an
ENUM Root update for you ;-)

regards

Richard STASTNY
OeFEG
Arsenal Objekt 24
P.O. Box 147
A-1103 Vienna, Austria

Tel: +43 664 420 4100
Fax: +43 1 79780 13
[email-masked]
[email-masked]

> -----Original Message-----
> From: Tony Rutkowski [mailto:[email-masked]]
> Sent: Wednesday, February 20, 2002 2:25 PM
> To: Lawrence Conroy; Stastny, Richard; 'Clive D.W. Feather'
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Enum] DDDS, DNS clarification needed?
> 
> 
> At 06:24 AM 2/20/2002, Lawrence Conroy wrote:
> >If there is a "private" system that operates like ENUM, then
> >it should *mostly* be a case of re-defining the root domain under
> >which this other system operates - it will NOT use "e164.arpa", as
> >that is reserved for the ("public") ENUM system.
> 
> The Internet and its services (including DNS) under current
> international (and most national) law are "private."
> 
> The one and only authoritative "public" E.164 syntax is that
> of the ITU and its Member States, and the mappings are
> provided via SS7 infrastructure.
> 
> That authority is not going to be ceded to an advisory
> committee of the Internet Society (i.e., the legal status
> of the IAB).
> 
> This is the first well-understood rule.
> 
> --tony
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny, Richard" <[email-masked]>
Date: Thu, 21 Feb 2002 09:51:24 +0100

Clarification: As I understood the discussion within ITU-T SG2, the question
from the ITU-T point of view is not 1 or 2 or many roots, its 0 or 1;-)

regards

Richard STASTNY
OeFEG
Arsenal Objekt 24
P.O. Box 147
A-1103 Vienna, Austria

Tel: +43 664 420 4100
Fax: +43 1 79780 13
[email-masked]
[email-masked]

> From: Shaw, Robert [mailto:[email-masked]]
> Sent: Wednesday, February 20, 2002 6:01 PM
> To: 'Randy Bush'
> Cc: [email-masked]
> > the idea of different e164.foos is great.  it should be used 
> > to map the different global numbering plans, you know, the 
> ones where 
> > north america is +42, +666, etc.  for the nonce, we will 
> use e164.arpa 
> > to map the current prosaic global numbering plan, where 
> north america 
> > is +1.
> > 
> > btw, when will the itu be publishing these alternate 
> numbering plans?
> > 
> 
> Huh? Interesting leap of logic...
> 
> Randy, the real world has this habit of defying one's 
> instinctive or even one's strongly held engineering 
> beliefs.
> 
> A coordinated hierarchical symbol set (to use 2826 
> terminology) does not a priori require a single 
> technical root. In the PSTN world, that's a simple
> fact and proof that one can have a coordinated 
> hierarchical addressing system that is not dependent 
> upon a single technical root.
> 
> A disadvantage of this model is that it requires a
> much more complex level of coordination among various 
> systems; made more difficult with telecoms 
> liberalization and the growth in facilities-based 
> carriers.  
> 
> I know that it's a difficult transition for some but 
> the issues are deeper and go beyond technical 
> elegance of pulling a symbol set from one central 
> computer or switch somewhere. There are other factors such 
> as real world geopolitics, national sovereignty over critical 
> infrastructure, CI security issues, intercept, etc. 
> 
> If you make the mental leap that discussing where ENUM is 
> rooted a priori implies a non-coordinated country code symbol 
> space, then I'd have to say that I'd disagree with your 
> assumption.
> 
> Bob
>