Subject: RE: [Enum] ENUM individual draft on root domain.

From: Patrik Fältström <[email-masked]>
Date: Fri, 22 Feb 2002 21:46:17 +0100

--On 2002-02-22 15.02 -0500 Mark Harris <[email-masked]> wrote:

> If 2916 became policy-neutral, by removing the mandated TLD of ".arpa",
> and then "allowed" other implementations, like NetNumber's e164.com (and
> others)
> to be "officially" considered ENUM, how would that be a Trojan horse for
> e164.arpa?
> 
> Wouldn't that change, actually allow ENUM (at-large) to thrive...?

DNS need one and only one root. You can not have two.

I have earlier pointed at draft-iab-itu-enum-notes-00.txt, and I do it
again...

  paf

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Tony Rutkowski <[email-masked]>
Date: Fri, 22 Feb 2002 16:28:55 -0500

>DNS need one and only one root. You can not have two.

Hi Patrik,

You might look at the RBL services arena - which is
very much DNS based, which operates quite successfully
on a large scale, and which functions very much like
the ENUM protocol - as an example to the contrary.
Different providers even return different values.

You can argue that it's not desirable on some personal
preference basis or comparative merits; but as to
"need one" and "can not" - reality clearly argues
otherwise.  We're also dealing here with a DNS namespace
zone, not "DNS."

Providers and customers do work these things out in
the marketplace without the need for governmental
intervention to bless somebody's best-loved namespace.

--tony

---

From: Jim Reid <[email-masked]>
Date: Fri, 22 Feb 2002 19:46:13 -0800

>>>>> "Tony" == Tony Rutkowski <[email-masked]> writes:

    Tony> You might look at the RBL services arena - which is very
    Tony> much DNS based, which operates quite successfully on a large
    Tony> scale, and which functions very much like the ENUM protocol
    Tony> - as an example to the contrary. 

No they don't. And RBL services are not relevant to ENUM which gets
discussed here either. But we're used to your distractions and
off-topic irrelevances. RBL services are discretionary: you will stll
get mail (and lots more spam) if your mail system chooses not use
them. If applications chooose not to perform ENUM lookups, they can't
make use of ENUM based services. Not even in your parallel universes.

    Tony> Providers and customers do work these things out in the
    Tony> marketplace without the need for governmental intervention
    Tony> to bless somebody's best-loved namespace.

Please tell us where customers and providers have created a market in
reverse lookup name spaces for IPv4 or IPv6 addresses. With our
without government intervention.

---

From: Tony Rutkowski <[email-masked]>
Date: Sat, 23 Feb 2002 07:52:44 -0500

Hi Jim,

>make use of ENUM based services. Not even in your parallel universes.

Actually, so is ENUM.  The "authoritative" E164 resource
records are the property of telecom carriers and resident
as IN Network Elements.  That's unlikely to change.

The IAB's proposed e164.arpa is just one provider's
private parallel universe to potential ancillary services.
NetNumber has another one.  ICQ another.  So does Stupi AB.

>without government intervention.

Of course, it would be trivially simple, and indeed, some
private ones exist.  However, the present free service
provided by existing players doesn't incent such a market
emerging.

RBL remains a good model for how a new, large-scale DNS
based and ENUM-like pointer service can emerge that provides
customer choice among multiple providers and differing
business models.

Hope this provides some food for thought even if you don't
like the idea.

cheers,
--tony

---

From: David Conrad <[email-masked]>
Date: Sun, 24 Feb 2002 10:01:32 -0800

Tony,

On 2/23/02 4:52 AM, "Tony Rutkowski" <[email-masked]> wrote:
>> reverse lookup name spaces for IPv4 or IPv6 addresses.
> private ones exist.

Trivially simple?

Given in-addr.arpa and ip6.arpa are a part of every resolver library
included in every DNS lookup supporting programming language library, both
embedded and not since 1985, trying to migrate to an alternative to these
domains would be _FAR_ from trivial.

What might be trivial would be to spoof the global in-addr/ip6.arpa to a
local version (which, of course, won't work with DNSSEC, but we'll ignore
that). 

Pointers to the "private ones" you mention would be interesting.

> customer choice among multiple providers and differing

The reason multiple RBLs exist is that it is trivial for _anyone_ to get the
authoritative data in real-time as to whether a mail server should be on the
RBL (can mail be relayed?  Yes: rbl 'em).

How would one go about getting real-time access to the (globally
distributed) telephone number database, particularly given that I suspect
some owners of parts of that database would be singularly uninterested in
opening up access to arrogant American startup companies?

Rgds,
-drc

---

From: Tony Rutkowski <[email-masked]>
Date: Sun, 24 Feb 2002 19:16:34 -0500

>opening up access to arrogant American startup companies?

Hi David,

Agreed - many implementations are technically trivial,
but the economics and constraints of the embedded base
make it otherwise.

Like it or not, the only "authoritative" E.164 database
is SS7 based, and increasingly represented as Network
Elements within the Intelligent Network.  For many
reasons - technical, commercial, legal, national security
- this is unlikely to change anytime soon.

Bundling the ENUM protocol *and* the administrative schema
together is almost certain to result in failure, since
even the authoritative E.164 world itself is based on
diverse autonomous national schema where the "resource
records" are often never shared even with a closed
club of providers.

Even within the U.S., the information is shared only among
members of the club - i.e., telecom providers - and only
because of regulatory mandates.  The European Commission
is considering similar limited liberalization.

In an environment where 2/3 of the countries of the world
ban IP telephony, it's not likely that they're going to
populate authoritative resource records in a common DNS
zone for others to use.

A certain pragmatism is going to be required here that
reflects the diversity of the real world.  It's going
to include multiple diverse DNS zones where a few are
maintained (probably in DNS VPNs) by national regulatory
fiat, where some are ported in part as UNEs from the IN
databases, where some are specially allocated E164 blocks,
and where some are non-authoritatively but reliably
supplemented by entrepreneurs.

Any authoritative implementation is also going to be
fraught with significant diverse obstacles that include
mandatory requirements like Local Number Portability,
E911, competitive directory assistance, UNEs, Caller ID,
unwanted solicitation control, and LI/CALEA.

There are no simple answers here.  But one thing seems
certain - a monolithic ENUM approach where protocol
and administration are bundled together is dead-on-
arrival.

--tony