Subject: RE: [Enum] DDDS, DNS clarification needed?

From: "Stastny, Richard" <[email-masked]>
Date: Wed, 20 Feb 2002 11:19:59 +0100

I don not fully understand this discussion. Considering the Zillions of
parameters already existing in operation systems and applications, I do not
see the problem in including the ENUM Root Domain in the Application. Or the
other way round, if I had to write an ENUM Add-on to Outlook, Netmeeting or
Messenger, the first thing I would implement is a parameter for the ENUM
Root Domain (also considering that the discussion is still not settled
discussion between IAB and ITU), and second I would implement additional
optional parameters for other root domains: e.g. if an number is entered
with +, I would go to ENUM Root, with 000 also, any number without 0 or + to
a private root, etc.

I would expect to be able to enter digits on my office PC in the same way I
use my PBX.

regards

Richard STASTNY
OeFEG
Arsenal Objekt 24
P.O. Box 147
A-1103 Vienna, Austria

Tel: +43 664 420 4100
Fax: +43 1 79780 13
[email-masked]
[email-masked]

> -----Original Message-----
> From: Clive D.W. Feather [mailto:[email-masked]]
> Sent: Wednesday, February 20, 2002 10:00 AM
> To: Lawrence Conroy
> Cc: Rudolf Brandner; [email-masked]; [email-masked]'
> Subject: Re: [Enum] DDDS, DNS clarification needed?
> 
> 
> Lawrence Conroy said:
> > Question - Should the process of converting a key to DNS-suitable
> > form append a "well known constant" domain (e.g. ENUM_ROOT_DOMAIN),
> > rather than "hard-wiring" the domain?
> > The value of this constant is ".e164.arpa.", of course, and it *is*
> > a generalisation, but this may be useful in the future.
> 
> I think this would be useful. Apart from anything else, it 
> means that you
> can set up testbeds simply by changing the value of 
> ENUM_ROOT_DOMAIN. If
> software expected to do this, the value would be configurable 
> rather than
> hardwired, with obvious benefits.
> 
> -- 
> Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:  +44 
> 20 8371 1138
> Internet Expert     | Home:  <[email-masked]>  | Fax:  +44 
> 870 051 9937
> Demon Internet      | WWW: http://www.davros.org | Mobile: 
> +44 7973 377646
> Thus plc            |                            | NOTE: fax 
> number change
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Lawrence Conroy <[email-masked]>
Date: Wed, 20 Feb 2002 11:24:07 +0000

At 11:19 am +0100 20/2/02, Stastny, Richard wrote:
>And before that Clive wrote:
>
>(In response to my earlier posting):
>  > Lawrence Conroy said:

>  > hardwired, with obvious benefits.

To which I reply:
Hi Folks,
   Sorry for any confusion this causes. IMHO, it's really no big deal.
The aim of using an ENUM_ROOT_DOMAIN is only to avoid having
to put ".e164.arpa" throughout the documents, *and* ...
to indicate the Application Clash Avoidance mechanism required of
DDDS applications - basically, we put all ENUM-specific NAPTRs
under the ENUM_ROOT_DOMAIN, and there are no NAPTRS that are
specific to other DDDS applications within this domain space, so
we avoid a clash. Confused? - so am I, but it's a start.

Now, this is pretty much standards document "syntactic sugar".
If there is a "private" system that operates like ENUM, then
it should *mostly* be a case of re-defining the root domain under
which this other system operates - it will NOT use "e164.arpa", as
that is reserved for the ("public") ENUM system.
When Richard's add-on to Outlook gets a number without a leading +
it can use this new non-ENUM application and operate as expected.
If there's a + (or a 000, converted to +), then it fires up the
ENUM application and all is fine.

BTW: Yes, I am aware of the current discussions in SG2 on whether
or not ".e164.arpa" is or is not appropriate. To be honest, I'm
not driven by religious fervor on this topic, as long as it's
independent I don't see why it needs a sub-working group to discuss it.
(That's why I'm an Engineer and don't get the big bucks, I guess :)

Also, I've looked at the meeting documents Bob mentioned, and
consider that Appendix F is an excellent document - congratulations
to the author(s).

Best Regards,
   Lawrence
-- 
[email-masked]: +44 1794 833666::<my opinions>:

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 20 Feb 2002 13:52:45 +0100

--On 2002-02-20 11.19 +0100 "Stastny, Richard" <[email-masked]>
wrote:

> parameters already existing in operation systems and applications, I do
> not see the problem in including the ENUM Root Domain in the Application.
> Or the other way round, if I had to write an ENUM Add-on to Outlook,
> Netmeeting or Messenger, the first thing I would implement is a parameter
> for the ENUM Root Domain (also considering that the discussion is still
> not settled discussion between IAB and ITU), and second I would implement
> additional optional parameters for other root domains: e.g. if an number
> is entered with +, I would go to ENUM Root, with 000 also, any number
> without 0 or + to a private root, etc.

This is not an implementation issue. You have to differ between:

 1 How you handle the global E.164 space
 2 How you handle private dialing plans
 3 How you implement things in your software

Three very different things.

Let's take them one at a time, for the last time:

1. The ENUM work in the IETF had as a task to find out how to use DNS to
find URL's when one _only_ knew the E.164 number. No other knowledge is
available. Let's say that I can choose between a.com and b.com as the
domain, and I use b.com. If I give you my E.164 number (only), how are you
to know that it is b.com you should use? I.e. the issues are exactly the
same as with a single root in DNS as a whole.

See draft-iab-itu-enum-notes-00.txt

2. If you and everyone which use a private dialing plan you can agree on
using a different domain for storage of DNS data. That is according to the
definitions we use in this wg though _NOT_ ENUM. This builds onto the fact
that you need to have some extra knowledge part from the E.164 number, the
domain you will use when looking up the NAPTR.

I do though know several cases (for example internally in a company) where
this is extremely useful.

3. Given that software probably should be able to handle both (1) and (2)
it of course probably should be implemented in as dynamic way as possible.

Did this make things more clear?

    paf

---

From: Tony Rutkowski <[email-masked]>
Date: Wed, 20 Feb 2002 08:25:03 -0500

>that is reserved for the ("public") ENUM system.

The Internet and its services (including DNS) under current
international (and most national) law are "private."

The one and only authoritative "public" E.164 syntax is that
of the ITU and its Member States, and the mappings are
provided via SS7 infrastructure.

That authority is not going to be ceded to an advisory
committee of the Internet Society (i.e., the legal status
of the IAB).

This is the first well-understood rule.

--tony

---

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Wed, 20 Feb 2002 09:22:59 -0500

Tony,

In Federal Indian Law every question begins with a jurisdictional analysis.
I mention FIL because it is something I know a (very) little bit about, so
there is a (small) possibility I'll understand some of your reply.

> international (and most national) law are "private."

What is your jurisdictional framework? Can you cite an exception to the
"most national" observation? Can you cite an instance of this general
characteristic?

I wish this list had a [email-masked] for non-technical discussions.

Eric

---

From: Tony Rutkowski <[email-masked]>
Date: Wed, 20 Feb 2002 09:57:20 -0500

>I wish this list had a [email-masked] for non-technical discussions.

Hi Eric,

This is not a useful forum - although by virtue
of getting into administrative matters, including
privacy, etc, - substantial non-technical discussions
are implicated.

I'm putting together an extensive ID on this that will
be presented next month at a Federal Communications Bar
gathering, so perhaps the detail can be deferred.

However, in a nutshell, the term "public" as it applies
broadly to telecommunication services has an explicit
connotation going back 150 years in treaty instruments
and domestic law.  The world of networks and services
over that time has been bifurcated fundamentally into
public and private.  This includes multiple treaties in
force of both the International Telecommunication Union
and the World Trade Organization.  It's also organically
embedded in many national statutory and regulatory
provisions.

Until the late 80s, it was unlawful in most jurisdictions
to use private leased lines to construct any networks that
provided services to the public.  The networks were restricted
to intra-organization closed user groups only.  The Internet
in particular was regarded as a threat.

The devised created was to denominate all Internet
networks and services as "private" among closed user
groups not offering services to the public.  That
remains the basic paradigm today - although it is
getting nibbled around the edges as those who inhabit
the cybertelecom list know.

There are also related bifurcations between "basic"
and "enhanced" or "value-added" that reinforce the
public-private dichotomy.

If you want "authoritative public services," it's a
very different legal and policy ballgame that's subject
to a great deal of global, regional, national, state,
and local law and regulatory regimes.

--tony

---

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Wed, 20 Feb 2002 14:36:50 -0500

Tony,

The response you provided wasn't ... responsive.

Two houses, both alike in dignity, in the fair Verona(s) where you lay
your scene.

One with private law, one with public law, and both with dns or any like
infrastructure you think applicable.

You can respond off-list, and as briefly as two iso3166 values.

Actually, I just need the private one, I've got a public one -- .cn.

I still wish this list had a meta-foo outlet for non-technical discussions.

I'm cluttering up other people's mailboxes as someone else may have one or
more examples, and off-list reply is _fine_ by me.

Eric

---

From: Dave Crocker <[email-masked]>
Date: Wed, 20 Feb 2002 12:49:36 -0800

At 09:57 AM 2/20/2002 -0500, Tony Rutkowski wrote:
>and domestic law.

Tony,

Perhaps you have not noticed that this is not a law forum?

The term public, when used in the IETF, is not being used as a legal term 
of art, no matter how much attorneys might try to force otherwise.

So it is a wonderful thing that you know about such matters of legal 
history.  No doubt many people would like to hear such recitations.

However they are quite irrelevant to this technical working group, so such 
pedagogy belongs elsewhere, as you have often been told.

d/

----------
Dave Crocker  <mailto:[email-masked]>
Brandenburg InternetWorking  <http://www.brandenburg.com>
tel +1.408.246.8253;  fax +1.408.273.6464