Subject: RE: [Enum] DDDS, DNS clarification needed?

From: "Yu, James" <[email-masked]>
Date: Wed, 20 Feb 2002 21:59:23 -0600

> > >
> > To which I add more questions on the TripleDS thicket:
> > Question - is the AUS "+494023451234" or is it "494023451234"?
> 
> The AUS is the second one. The '+' is extraneous here so its
> removed to make the Key as simple as possible but still useable.
> 

Mike, is it a typo?  The AUS is the first one, "+494023451234."  I believe
that Patrik intentionally keep the "+" for the regular expression mapping
use.

James

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Mealling <[email-masked]>
Date: Wed, 20 Feb 2002 23:02:49 -0500

> that Patrik intentionally keep the "+" for the regular expression mapping

Yes. Your are correct. It roots the regexp so that you are sure you're 
matching on something that is a 'fully qualified' e164 number....

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling	|      Vote Libertarian!       | urn:pin:1
[email-masked]      |                              | http://www.neonym.net

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 21 Feb 2002 07:19:14 +0100

--On 2002-02-20 21.59 -0600 "Yu, James" <[email-masked]> wrote:

> I believe

That was the intention, yes. If one reuse NAPTR for for example private
dialing plans, then one might want to have some way in the regexp to detect
a E.164 number and ENUM, and that was why I kept the '+'.

  paf

---

From: Michael Mealling <[email-masked]>
Date: Thu, 21 Feb 2002 08:40:23 -0500

> a E.164 number and ENUM, and that was why I kept the '+'.

See! He is smarter than I am! ;-)

-MM