Subject: Re: [Enum] New I-D on ENUM Neutrality Framework

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 05 Sep 2001 10:57:28 +0200

--On 30. august 2001 07:59 -0400 "A.M.Rutkowski" <[email-masked]> wrote:

> The Internet-Draft is fairly self explanatory.
> A visual aid is also attached.

For the last response to a proposal for specifying interworking between a 
working implementation and a pipe dream, see the IESG statement at
http://www.ietf.org/IESG/Announcements/draft-higgs-root-defs.ann

My problem with Rutkowski's draft is that the menu choices he lists don't 
specify a service to the degree that it is independently implementable, 
which means that interworking with it can't even be started, and yet it 
wants to "kind of" mandate that interoperability should exist.

As a scarred veteran of email interoperability (remember X.400?), I cannot 
see the value of this draft.

             Harald

>
> --tony
>
> ====================================================================
> Framework for ENUM Neutrality                            A.M. Rutkowski
> Document: <draft-rutkowski-enum-neutrality-00.txt>        VeriSign, Inc
> Expires: 1 Mar 2002                                        29 Aug 2001
>
>                        Framework for ENUM Neutrality
>
>     The list of current Internet-Drafts can be accessed at
>     http://www.ietf.org/ietf/1id-abstracts.txt
>
>     The list of Internet-Draft Shadow Directories can be accessed at
>     http://www.ietf.org/shadow.html.
>
>
>     Abstract
>
>     The pursuit by major national Administrations of declared
>     policies of ENUM technical and administrative neutrality among
>     implementations in the marketplace suggest the need for a
>     framework for such neutrality and a focus on interworking
>     among them. [1] [2]  This document draws upon the ENUM Working
>     Group archive of discussions as well as public activities in other
>     standards forums and the marketplace to construct an ENUM options
>     framework for facilitating neutrality.  This framework includes not
>     only protocol considerations, but also various critical technical
>     and administrative support functions such as authentication and
>     ancillary directory services.
> ====================================================================

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: "A.M.Rutkowski" <[email-masked]>
Date: Wed, 05 Sep 2001 11:14:04 +0200

Hi Harald,

>wants to "kind of" mandate that interoperability should exist.

It was intended as a framework for interoperability
using multiple IETF and other forum protocols
and options within those protocols - largely for
implementation purposes.  While the X.400 and X.500
experience are appreciated, it was the attempt to
define service side (F.400 and F.500) that failed.
The same liability is associated with RFC2916.

I wasn't aware the mission of the IETF was to
assure *service* interoperability in the marketplace.

best,
tony

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 05 Sep 2001 11:29:23 +0200

> The same liability is associated with RFC2916.

Believe me, the protocol level was fun too.
See RFC 2156-2161 for some of the "fun stuff".

> assure *service* interoperability in the marketplace.

so in your opinion, your draft is irrelevant to the IETF?
I'll stop commenting on it in this forum, then.

you can't have service interoperability without protocol interoperability. 
and you can't have protocol interoperability without a specified protocol.

The mission of the IETF is to make the Internet work.

IMHO, of course.

---

From: "A.M.Rutkowski" <[email-masked]>
Date: Wed, 05 Sep 2001 12:47:53 +0200

Hi Harald,

>The mission of the IETF is to make the Internet work.

How to do this is being discussed right now
at the ITU-T SG2 meeting in Geneva.  There were
a number of national Administrations in the
meeting a few minutes ago who articulated their own
views. :-)   Maybe we'll get F.400 and F.500
back!

cheers,
tony (from Geneva)

---

From: Dave Crocker <[email-masked]>
Date: Wed, 05 Sep 2001 08:55:46 -0700

>using multiple IETF and other forum protocols

That means that it is an attempt to provide a layer of coherence, on top of 
a set of otherwise independent activities.  Hence, it is an attempt to make 
them cease to be independent.

So, Tony, you cannot have it both ways.  If you are going to push for 
multiple, independent efforts, then it makes no sense to push for coherence.

In any event, such efforts usually fail, unless there is a very, very 
strong community desire for that coherence.  A single person publishing a 
"framework" paper is essentially useless to the task.  And all of the 
desire, demonstrated so far, is either for coherence within the ENUM 
working group effort's "framework" --  that is, under e164.arpa -- or for 
non-coherence.

Hence all of the evidence is that your paper fills a much needed gap...  It 
tries to consider a solution that no one is interested in.  Feel free to 
demonstrate community support.

For the moment, that task is beyond the scope of this working group.

>While the X.400 and X.500

No, Tony, the problem was the technical work.  The protocols and formats 
were far too complex, and the addressing model was fundamentally flawed.

The service side failed because too much was demanded of it by the 
technical work, not because the service side work was done badly.

>assure *service* interoperability in the marketplace.

Oh?  Then why is the requirement for demonstrated interoperability present 
for advancing to Draft standard?

(Rather than having to pursue Introduction to IETF Principles 101, in this 
forum, it is suggested that folks needing to learn such things carefully 
read existing IETF documentation.)

d/

----------
Dave Crocker  <mailto:[email-masked]>
Brandenburg InternetWorking  <http://www.brandenburg.com>
tel +1.408.246.8253;  fax +1.408.273.6464