Subject: RE: [Enum] epp-e164 & naptr objects

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 23 Aug 2001 10:06:48 -0400

>-----Original Message-----
>From: Chip Sharp [mailto:[email-masked]]
>Sent: Thursday, August 23, 2001 9:47 AM
>To: [email-masked]
>Subject: [Enum] epp-e164 & naptr objects
>
>
>Warning - the following is allegedly a technical question. :-)
>
>Can the information required to be entered into DNS for RFC2916  be 
>adequately dealt with (in EPP) by defining a <host:naptr> and/or 
><domain:naptr> object?
>
>What other information is needed?  Specific examples and proposals would be

>appreciated.

It's certainly possible to define object extensions for NAPTR record
provisioning; the extension mechanism might actually be easier and more
intuitively obvious than defining a new object type as currently described
in epp-e164-00.  That can be fixed with a rewrite.  It's also possible to
define extensions to provision other RRs if it makes sense to do so.

I don't believe anything other than the fields described in 2916 are needed
unless some non-DNS data is also required somewhere.  If that's the case,
I'm also open to suggestions.

<Scott/>

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 23 Aug 2001 18:45:10 +0200

--On 01-08-23 10.06 -0400 "Hollenbeck, Scott" <[email-masked]>
wrote:

> I don't believe anything other than the fields described in 2916 are
> needed unless some non-DNS data is also required somewhere.  If that's
> the case, I'm also open to suggestions.

Maybe you need (new) error codes if the registry is to verify the regular
expressions, so the "set" of NAPTR resource records which are provisioned
"makes sense"?

  paf

---

From: Richard Shockey <[email-masked]>
Date: Thu, 23 Aug 2001 13:18:03 -0400

>expressions, so the "set" of NAPTR resource records which are provisioned

Are you suggesting that the registry perform a validation test on the NAPTR 
records before provisioning the DNS?

Humm not a bad idea actually especially in light of Mike's clarification of 
how to write order and preference fields.

Richard Shockey, Senior Manager, Strategic Technology Initiatives
NeuStar Inc.
45980 Center Oak Plaza   Bldg 8     Sterling, VA  20166
1120 Vermont Ave NW Suite 400 Washington DC 20005
Voice 571.434.5651 Cell : 314.503.0640,  Fax: 815.333.1237
<mailto: [email-masked]> or
<mailto: [email-masked]>
<http://www.neustar.com>
<http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 23 Aug 2001 20:49:07 +0200

--On 01-08-23 13.18 -0400 Richard Shockey <[email-masked]> wrote:

> Are you suggesting that the registry perform a validation test on the
> NAPTR  records before provisioning the DNS?
> 
> Humm not a bad idea actually especially in light of Mike's clarification
> of  how to write order and preference fields.

If you have a registry which have more policy on what is actually assigned
than today's .com, the question is whether the registry should not do any
verification of the data at all? Maybe not? I don't know.

I just thought some mechanical verification, if possible, is a possibility
on the registry side of the registration process.

I am not saying it should be done. I just want to give some degree of
freedom to the one which decides what the registry and registrar is to do.

   paf