Subject: RE: [Enum] fyi RE: I-D ACTION:draft-dommety-e212-dns-00.txt

From: Young Michael-Y10724 <[email-masked]>
Date: Tue, 26 Jun 2001 14:07:03 -0400

Andy,

Please see my comments in line.

BR,

Michael Young 
--------------------------------------------------------------- 
System Design, GTSS Vancouver, Motorola 
Tel: +1 (604)241-6032   Cel: +1 (604)726-6609 
Email: [email-masked] 
--------------------------------------------------------------- 

> -----Original Message-----
> From: Gallant, Andy [mailto:[email-masked]]
> Sent: Monday, June 25, 2001 3:56 PM
> To: [email-masked]
> Subject: [Enum] fyi RE: I-D ACTION:draft-dommety-e212-dns-00.txt
> 
> 
> This Internet Draft was announced earlier today
> (see below) and stated that comments should be
> directed to this (ENUM WG) list.
> 
> Here are some comments about how this I-D
> talks about E.212 (and RFC 2916).
> 
> FYI, E.212 IMSIs are identifiers.  IMSIs are
> not intended "for dialling purposes" even though
> they happen to be strings of decimal digits.

[MYH] Agreed.  It is also stated in the ID.
> 
> IMSIs have to do with roaming and mobility 
> services, providing unique international
> identification of mobile terminals and/or users.

[MYH] Agreed.
> 
> The term "E.212 number" is incorrect.  E.212 is not
> used the same way that E.164 is.  The I-D also lacks 
> a Scenario and examples that describe associated 
> services, and it is not "very similar" to RFC 2916.

[MYH]  E.212 number is widely used.  Please check MAP spec. 
> 
> A reference to the current version of E.212 is:
> ITU-T  Recommendation  E.212, The international 
> identification plan for mobile terminals and mobile 
> users, 11/98.
> 
> It would be very interesting to understand the context
> for this Internet Draft.  In particular, it would be
> useful to have some indication of the authors' thoughts
> about the E.212-related issues, what some useful work
> efforts might be, and what next steps might be considered.
> 
> Regards,
> 
> -Andy
> 
> 
> Andrew Gallant, NeuStar, Inc.
> 1120 Vermont Avenue NW, 4th Floor
> Washington, DC  20005  USA
> Tel:    +1 202 533 2812
> Fax:    +1 202 533 2987
> Email:  [email-masked]
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, June 25, 2001 7:11 AM
> Subject: I-D ACTION:draft-dommety-e212-dns-00.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
> 	Title		: E.212 number and DNS
> 	Author(s)	: G. Dommety et al.
> 	Filename	: draft-dommety-e212-dns-00.txt
> 	Pages		: 5
> 	Date		: 22-Jun-01
> 	
> An  E212 number or IMSI  (International  Mobile Station Identity) is
> used to uniquely identify a mobile station Internationally. This
> document discusses the use of the Domain Name System (DNS) for
> storage of information regarding E.212 numbers and  how DNS can be
> used for identifying available services connected to one E.212
> number. This draft is adaptation of RFC 2916 to E.212 numbers.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-dommety-e212-dns-00.txt
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-dommety-e212-dns-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-dommety-e212-dns-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/enum
>

---

From: "Gallant, Andy" <[email-masked]>
Date: Wed, 27 Jun 2001 03:24:01 -0500

Hi, John, and thanks for providing this information.  -Andy

Note to others:  FYI, John and James Yu wrote an interesting I-D
last year - J. Loughney & J. Yu, " Roaming Support with DNS," 
draft-loughney-enum-roaming-00.txt, July 14, 2000. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, June 27, 2001 2:00 AM
To: [email-masked]; [email-masked];
[email-masked]
Subject: RE: [Enum] fyi RE: I-D ACTION:draft-dommety-e212-dns-00.txt

Hi Michael & Andy,

[MYH]  E.212 number is widely used.  Please check MAP spec.
[<JAL> ] I believe that some text about this would be very helpful.  I do
not think most IETF folks know MAP very well.  Also, it could be stated in
more clear terms how MAP over IP (SIGTRAN for example) would need this kind
of functionality.  Also, as SIP will be used in 3G networks, service
identification via E.212 could also be useful.

> efforts might be, and what next steps might be considered. 

[<JAL> ] Agreed.

John

---

From: [email-masked]
Date: Wed, 27 Jun 2001 13:52:35 +0300

Hi Andy,

> draft-loughney-enum-roaming-00.txt, July 14, 2000. 

Thanks for the quote - I still have the draft on my computer - 
if there is interest, I could see about updating it.

br,
John

---

From: [email-masked]
Date: Thu, 28 Jun 2001 14:14:41 +0300

Hi Andy,

>      The question, "Could E.212 be ENUMified?" is easy.
>      The question, "Should E.212 be ENUMified?" is non-trivial.
>      For the E.212 I-D, further information about intended
>      use, related applications, administrative and coordination
>      aspects, and other relevant matters would materially
>      help with the second question.

Cutting through the fog ... I think this is a good idea. I can
see uses for ENUMifying E.212 numbers and this may dovetail
nicely into some work that is going on elsewhere - but some
discussion of this is warrented.

best regards,
John

---

From: Segal Niranjan-FNS001 <[email-masked]>
Date: Thu, 28 Jun 2001 10:20:41 -0500

Andy,
I am the co-author of the above draft. 

Here are some more thoughts which might help answer some of your questions
and provide some more support in favour of this draft:
With reference to the scope/motivation/future work behind this IMSI based
DNS, I quote directly from E.212 recommendation:

"In order to enable land mobile stations to roam among public land mobile
networks located in different countries, an international identification
plan is required for unique international identification of such stations.
It is desirable that the allocation of international mobile station
identities should be made independently of the numbering plans used for
accessing mobile stations from the different public networks. This will
enable Administrations to develop their own national numbering plans for
land mobile stations for different services without the need for
coordinating them with other countries. Note - The word "country" in this
Recommendation is also used with the meaning of geographical area".

Currently, IMSI is used in mobile environment not only for registration,
roaming services but also for billing/chrging, subscriber profile updates
etc. As far as the future services specific to IMSI are concerned, MNP and
perhaps inter-working of LNP/MNP comes to mind.

My point here is: although IMSI is treated as an identifier from the E.164
point of view; in fact IMSI,  in mobile environment, is being used in
conjuction with E.164 numbers as a supplemental numbering scheme. Therefore,
the motivation behind IMSI-DNS draft is of importance.

Regards,
Niranjan Segal

-----Original Message-----
From: Gopal Dommety [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 8:44 AM
To: Gallant, Andy; [email-masked]
Subject: Re: [Enum] fyi RE: I-D ACTION:draft-dommety-e212-dns-00.txt

Andy,

Sorry for the delay (I was travelling).
Thanks for the comments. Please see reply inline.

>they happen to be strings of decimal digits.

I agree.

>identification of mobile terminals and/or users.

I agree.

>The term "E.212 number" is incorrect.  E.212 is not

This term is frequently used. Not sure if I understand the concern.

>services, and it is not "very similar" to RFC 2916.

I agree with u that E.164 and E212 are different. And in that context this 
draft is not very simlar to RFC2916.
It is similar to RFC2916 from  DNS perspective.

>identification plan for mobile terminals and mobile

I will add this reference to the draft.

>efforts might be, and what next steps might be considered.

3GPP (UMTS/3G standards body - under the umbrella of ITU) is considering 
using SUA (SCCP User Adaptation Layer)  for transporting mobile related
  SS7 messages in the Core network. Details of this study can be found in 
TR 29.903. The aim is to transport these message over the existing  IP 
network.

IMSI is used to uniquely identify a mobile subscriber globally. When a 
mobile shows up at  foreign  network, the foreign network
gets the IMSI of the mobile. Depending on the IMSI we want to be able to 
route SS7 traffic to the Home Network (as obtained from DNS).
This is the motivation behind the draft. Doing this will significantly 
reduce the configuration information that needs to be maintained in mobile 
networks regarding
foreign IMSIs and facilitate sending of these messages using  SUA. Going 
forward there could be other features that can be developed.

Regards,
Gopal

---

From: "Gallant, Andy" <[email-masked]>
Date: Thu, 28 Jun 2001 13:06:28 -0500

This is good information.  In fact, we're in a race
condition right now for sending out E.212 quotes!
This helps lower my concerns about the many ways
that good discussion of issues could have been
sidetracked, and I look forward to the next messages
on this thread.

-Andy

-----Original Message-----
From: Segal Niranjan-FNS001 [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 11:21 AM
To: 'Gopal Dommety'; Gallant, Andy; [email-masked]
Subject: RE: [Enum] fyi RE: I-D ACTION:draft-dommety-e212-dns-00.txt

Andy,

Regards,
Niranjan Segal

-----Original Message-----
From: Gopal Dommety [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 8:44 AM
To: Gallant, Andy; [email-masked]
Subject: Re: [Enum] fyi RE: I-D ACTION:draft-dommety-e212-dns-00.txt

Andy,

I agree.

I agree.

Regards,
Gopal

---

From: "Gallant, Andy" <[email-masked]>
Date: Thu, 28 Jun 2001 13:06:21 -0500

Hi, Gopal, and sorry for my delay.  The brief explanation
to your comments is: (1) I worked on the latest version
of E.212 and wanted to get some of the info out there, and
(2) I'm working on ENUM and trying to learn from the
experience.

In the Numbering Question (Q1) in ITU-T Study Group 2,
"E.212 number" isn't used, and things about IMSIs
aren't the same as for E.164 numbers.  My intent was
to get accurate info on E.212 out on the list ASAP
to improve the odds of meaningful discussions and
shorter handshakes on terminology.

I also wanted to highlight some things that I think
are central to discussing your I-D.  Some of the
issues came from ENUM (is ENUMifying something
a "good" thing for the DNS or not), and some
come from E.212 (users should almost never
know their IMSIs).

Your information on the mobile context is very
useful and much appreciated.  It helps a great
deal with understanding why this should be
considered.  I'm looking forward to the
forthcoming discussions on substantive issues.

Good luck, thanks, and best regards,

-Andy

-----Original Message-----
From: Gopal Dommety [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 9:44 AM
To: Gallant, Andy; [email-masked]
Subject: Re: [Enum] fyi RE: I-D ACTION:draft-dommety-e212-dns-00.txt

Andy,

I agree.

I agree.

Regards,
Gopal

---

From: "Gallant, Andy" <[email-masked]>
Date: Sat, 30 Jun 2001 02:02:33 -0500

(possible duplicate transmission - my apologies)

Hello, John.

You said, "... some discussion of this is warranted."
I agree absolutely.  Since there are many factors in
the mix that come up during such discussions, it helps
to clear up what the starting points are.

One factor in getting to "should" is describing what
the interesting uses of an ENUM-like capability might
be.  Another factor is looking into the outside value 
and the inherent constraints (in this case, those
that come from E.212).

Below are some excerpts from Rec. E.212 (11/98). It is
possible that constraints/intents like those might
well conflict with a desired ENUMification.  The 
discussion should include an assessment that considers
constraints as well as benefits.  This I hope would
help figure out the most relevant factors that would
be part of the should/shouldn't decision.

brgds,

-Andy

Some excerpts from ITU-T Rec. E.212, "THE INTERNATIONAL IDENTIFICATION 
PLAN FOR MOBILE TERMINALS AND MOBILE USERS", Geneva, November 1998.

Excerpt:  Section 2 - Scope

	This Recommendation describes an international identification plan 
	for mobile terminals or mobile users  of public networks enabling 
	roaming capabilities. It also establishes procedures for the
assignment
	of International Mobile Subscriber Identities (IMSIs) to the mobile 
	terminals and mobile users of such networks. This Recommendation 
	describes the format of the IMSI.

Excerpts: from Section 6 - Considerations

	6.4	The IMSI permits the identification of the home country
(MCC) as 
	well as the home network (MCC + MNC) to which the mobile terminal or

	mobile user is subscribed.

	6.7	The identifiers assigned to a subscriber under this
identification 
	plan should, for security reasons, not be directly related to the
numbers 
	assigned to that same subscriber under numbering plans, e.g. E.164,
in 
	use for different services.

	6.9	The IMSI should, if necessary, enable:
	...
	c)	mobile terminal or mobile user identification when
information 
	about a specific mobile terminal or mobile user is to be exchanged 
	between networks offering mobility services;
	...
	e)	mobile terminal identification for signalling on the radio 
	control path;
	f)	mobile terminal or mobile user identification for charging 
	and billing purposes;
	...
	h)	mobile user identification during the user authentication 
	procedure, e.g. UPT: the IMSI is then called the Personal User 
	Identity (PUI).
	This list is not exhaustive.

	6.10	The IMSI is not used for dialling purposes in the public 
	switched network.
	
Excerpts:  from Section 7 - IMSI Structure, Format and Assignment procedures

	...
	7.2	IMSI Assignment procedures
	...
	7.2.1	TSB assigns MCCs to countries ...
	7.2.2	MNCs are administered by the designated administrator within

	each country ...
	7.2.3	MSINs are administered by the MNC assignee.
	7.2.4	The utilization of IMSIs should be such that not more than 
	the first 6 digits of the IMSI have to be analysed in a visited 
	public network for querying the home network.
	7.2.5	In principle, only one IMSI shall be assigned to each mobile

	terminal or mobile user. 
	...
	
[end of excerpts from E.212 (11/98)]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 7:15 AM
To: [email-masked]; [email-masked]
Subject: RE: [Enum] fyi RE: I-D ACTION:draft-dommety-e212-dns-00.txt

Hi Andy,

best regards,
John