Subject: [Enum] RFC1530 (TPC.INT)

From: Stephane Alnet <[email-masked]>
Date: Thu, 22 Feb 2001 18:44:10 -0500

Hi,

The recent discussion on Designated vs Competitive models reminded me that 
there's already a E.164-like hierarchy around there, tpc.int [RFC1530]: 
"The primary purpose of the tpc.int subdomain is to provide transparent 
mapping between the Internet and telephony environments".

It doesn't provide provisions for ENUM itself but that doesn't seem to be a 
problem. Has there already been any discussions on re-using that hierarchy 
(which already has its own policies)?

S.

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Thu, 22 Feb 2001 19:05:07 -0500

At 06:44 PM 2/22/2001 -0500, Stephane Alnet wrote:
>It doesn't provide provisions for ENUM itself but that doesn't seem to be 
>a problem. Has there already been any discussions on re-using that 
>hierarchy (which already has its own policies)?

TPC.INT is not used by many folks for numerous reasons and as such is 
useless model for ENUM specifically..though nearly all of its technicial 
principals for reverse concatenation of the numbers into a single 
"protected" domain derive from it.

TPC.INT was a useful experiment ..nothing more.

Richard Shockey, Senior Technical Industry Liaison
NeuStar Inc.
1120 Vermont Avenue N.W., Suite 550, Washington DC. 20005
Voice: 202.533.2811,  Cell : 314.503.0640,  Fax: 815.333.1237
<mailto: [email-masked]> or
<mailto: [email-masked]>
<http://www.neustar.com>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: "A.M.Rutkowski" <[email-masked]>
Date: Thu, 22 Feb 2001 21:44:54 -0500

>TPC.INT was a useful experiment ..nothing more.

Stephane,

An alternative view.

TPC.INT was not only an incredibly innovative protocol and use
of the Internet's distributed entrepreneurial properties by
two of the Internet's most celebrated developers, it was a
political statement if not movement heard around the world
when it was first announced at Interop in 1994.

Lycos hotbot currently gets nearly 10,000 hits in every corner
of the globe for TPC.INT and its services are still relied
upon by a great many people, albeit apparently not by Richard.

The Phone Company's fax bypass and remote paging services
were a statement to the ITU and it's highly structured
PTO communities, that a set of autonomous entities could
independently organize themselves to provide telco
services.  Needless to say, it caused considerable
consternation in some quarters that led to a subsequent
largely ITU Secretariat let effort to tuck some kind of
formal ITU designated e164 zone under INT.

TPC.INT's leadership also inspired a broadbased
IP Telephony movement - the results of which we see
today.

--tony

---

From: Richard Shockey <[email-masked]>
Date: Thu, 22 Feb 2001 22:11:18 -0500

>when it was first announced at Interop in 1994.

Really Marshall Rose is going to love this ..  YO Marshall ..were you 
making a political statement or were you just trying to save a buck or two.

>upon by a great many people, albeit apparently not by Richard.

HA >>  I would not equate hits on Lycos to use of service..... your 
expansion of reality to serve your narrow political interest continues to 
astound and amaze me.

>formal ITU designated e164 zone under INT.

Are you really serious ... some smart guys wanted to save some money and 
have some fun in the process.

>IP Telephony movement - the results of which we see

Pardon me  list readers I have to go put my hip waders on to deal with this BS.

---

From: "David R. Conrad" <[email-masked]>
Date: Thu, 22 Feb 2001 20:50:55 -0800

Richard,

At 10:11 PM 2/22/2001 -0500, Richard Shockey wrote:
>>it was a

Actually, Tony's right.  Carl Malamud, the other individual involved, told 
me explicitly when he was setting it up that his interest was to bypass 
PTTs and annoy the ITU.  Given the personalities involved, this should not 
be surprising... :-).

Rgds,
-drc

---

From: "A.M.Rutkowski" <[email-masked]>
Date: Fri, 23 Feb 2001 08:40:14 -0500

Hi David,

>PTTs and annoy the ITU.  Given the personalities involved, this should not 

People might want to start with Carl's initial battle
with the telco world chronicled in the book he did for
Dan that is now graciously available on-line at
http://museum.media.org/eti/

It's now almost ten years, and Bruno's standards
are still not yet liberated!  Carl was always
far ahead of his time.

--tony

---

From: "A.M.Rutkowski" <[email-masked]>
Date: Fri, 23 Feb 2001 09:39:06 -0500

Hi Stephane,

It's not clear whether the historical context
here has been lost or conveniently forgotten
in the penchant for rudeness.

During they heydays of searching for alternative
DNS name structures in 1996, of which ITU secretariat
representatives were a part, there was a recognition
of TPC.INT as "the telephone number domain."  I've
included one of the messages below in what was an
extended IAHC public dialogue about instantiating a
telephone number domain schema.

Around that same time, the same folks promised
the INT domain to the ITU General Secretariat,
although it never really happened, in part because
historically, ITU Secretariats were not supposed to
be in the business of network operations - public
or private.  Some of the remnants can be seen at
http://www.itu.int/net/int/

As part of the deal, the ITU itself - which had
long insisted upon using the CH domain because
it was compatible with their OSI standards -
created an entire INT zone of CNAME aliases to
front end their CH domain name structure that
remains to this day, so they could appear to
be using the INT domain themselves.

E164.INT was then created as a more politically
correct version of TPC.INT  Indeed, you can see
the reference to it in the above notice on the ITU
site.

Last year, E164.ARPA was added to the ARPA zone
while E164.INT was quietly deleted.

The information is pretty much all out there
on sites as a matter of record.

Based on current formal ITU documents recently
released, it's not inconceivable that we could end
up with two or more Designated ENUM Zones in
addition to the Competitive ENUM Zones - all of
which suggests that we might consider some
administrative diversity here.

--tony

>Date: Thu, 21 Nov 96 12:21 EST
>From: [email-masked] (John R Levine)
>To: [email-masked]
>Subject: Re: Long-term viability: telephone numbers as aliases
>Newsgroups: local.iahc
>Organization: I.E.C.C., Trumansburg, N.Y.
>Cc: [email-masked]
>Sender: [email-masked]
>
> >> Current naming conventions probably cannot be sustained...
> >> Most individuals/organizations already have unique identifiers
> >> (telephone numbers) ...
>
>
>There already is a telephone number domain called tpc.int.  Phone
>numbers such as:
>
>         +1 802 555 2368
>
>are represented by reversing the number and making each digit a component:
>
>         8.6.3.2.5.5.5.2.0.8.1.tpc.int.
>
>It's ugly, but it has the important property that sub-domains can be
>created starting at any digit, just like the real phone system does.
>This scheme was used for an e-mail to fax delivery experiment and it
>wasn't all that successful, partly because of the ugly addresses and
>partly because the experiment, having no budget, depended on volunteer
>sites to do the actual faxing.  It worked technically, each delivery
>site could sign up for the part of the number space that was a local
>call to them.
>
>In any event, if anyone wants phone number based domain addresses,
>here they are.  Personally, I don't want them, partly because they're
>so ugly, but mainly because I greatly value the feature that my domain
>addresses didn't change when I moved, even though all of my phone
>numbers did (other than one old number that I have forwarded at extra
>cost.)
>
>--
>John R. Levine, IECC, POB 640 Trumansburg NY 14886 +1 607 387 6869
>[email-masked] "Space aliens are stealing American jobs." - MIT econ prof

---

From: "Marshall T. Rose" <[email-masked]>
Date: Fri, 23 Feb 2001 08:19:25 -0800

pardonez-moi, but unless we're having a discussion about prior art and the
ability for anyone to patent enum like stuff, i don't understand the
relevance of this thread to the enum mailing list.

/mtr

---

From: Randy Bush <[email-masked]>
Date: Fri, 23 Feb 2001 08:43:33 -0800

> relevance of this thread to the enum mailing list.

it's simple.  tony works for nsi.  nsi would like to monopolize as much of
registration in the enum space as possible because they think there is a LOT
of money to be made, just as they have with com, net, and org.  so any fud,
sociopathology, etc. that tony can spread to disrupt the working of this wg
is to his direct business benefit.  make sense?

randy

---

From: "A.M. Rutkowski" <[email-masked]>
Date: Fri, 23 Feb 2001 11:40:24 -0500

>relevance of this thread to the enum mailing list.

Hi Marshall,

Prior art, pioneering history, and why there
as an initial focus on the INT domain that
remains alive at the ITU and the French
Autorité de régulation des télécommunications.

c'est toutes

--tony

---

From: "Marshall T. Rose" <[email-masked]>
Date: Fri, 23 Feb 2001 08:50:20 -0800

> is to his direct business benefit.  make sense?

here's my context: i'm not on the enum list. looks like a fine project, but
it's not on my scope.

so i get this message, mid-thread, about tpc.int. and i'm like "ancient
history, who cares?"

so, irregardless of commercial interests, what possible impact can a
discussion of tpc.int have on the enum working group, other than having
people spend their time reading and writing e-mails. why not just ignore the
thread and move on?

/mtr

---

From: Bill Manning <[email-masked]>
Date: Fri, 23 Feb 2001 10:03:40 -0800 (PST)

% Last year, E164.ARPA was added to the ARPA zone
% while E164.INT was quietly deleted.

	e164.arpa was added roughly during the timeframe of
	the RIPE mtg in Amsterdam.

	e164.int had a ~6month lifetime.

;
;       E164.INT        09july1997 per Jon Postel
;                       pulled jan98 - (duplicate of TPC.INT?) - per postel
;
;e164.int.      in      ns      dot.ep.net.

% --tony

--bill

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 23 Feb 2001 10:09:01 -0800

>people spend their time reading and writing e-mails. why not just ignore the

What Marshall wrote.

As wg chair, I declare discussion of tpc.int clearly being out of 
scope of the discussions of this mailing list, and I will use tools 
available if needed to see that this descision is enforced.

    Patrik Fältström
    co-Chair of the ENUM wg

-- 
Patrik Fältström <[email-masked]>                         Cisco Systems
Consulting Engineer                                  Office of the CSO
Phone: (Stockholm) +46-8-4494212            (San Jose) +1-408-525-8509
        PGP: 2DFC AAF6 16F0 F276 7843  2DC1 BC79 51D9 7D25 B8DC

---

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Fri, 23 Feb 2001 17:47:19 -0500

[obvious subtext, tony, nsi, fear, loathing, and diddling the feds, removed,
 in the assumption that we're all adults]

On the up-side, "Allied Pipe" will be hosting happy hour at the bar Tuesday.

A length of pvc conduit gets the Enum'ed a brewski.

Eric