Subject: RE: [Enum] Subject: I-DACTION:draft-ranalli-peek-walter-enum-t1ro les-00.txt

From: "Ash, Gerald R (Jerry), ALCOO" <[email-masked]>
Date: Tue, 28 Nov 2000 14:33:51 -0500

At 9:44 PM 11/27/2000, Richard Shockey wrote:

> If there is a problem it is one of semantics and understanding the new 
> service logic of Internet Telephony.
>
> Assume the case of 1 800 DOG-BONES that wishes to provision ENUM services 
> to accept calls using SIP.
> 
> That number has been delegated to that "subscriber" under the normal terms

> and conditions of 800 service ..so the "controlling party" is known to the

> 800 SMS and can be verified.  The key to ENUM authority is that this 
> verification can be successfully accomplished and that proper
authorization 
> can be delegated from the T1 to the T2 entity that actually holds the 
> Resource Records that provision real service.
>
> Once this is accomplished we can assume that 1 800 DOG-BONES resolves to a

> SIP URL either under the direct control of the "controlling party", to use

> your terms, or to a T2 ENUM service provider that maintains these records 
> under contract for this service under various SLA's etc.
>
> The SIP proxy that ENUM resolves to will maintain the real service logic
of 
> call routing necessary to complete the call based on the numbers 
> "controlling party" requirements.[ time of day etc]  And the syntax of
that 
> service logic is defined by the IPTEL WG as Call Progress Language.
>
> http://www.ietf.org/internet-drafts/draft-ietf-iptel-cpl-04.txt
>
> The CPL is the real provisioning tool for Call Progress and routing as you

> outline. And the promise of this whole exercise in standards development
is 
> that  service logic now resides within the complete control of the 1 800 
> number holder ..and not the carrier from whom service was delivered.

Is CPL the only choice for service logic?  Suppose the number holder wants
service logic retained in IN/SCP, as is normal today for 800-time-of-day
routing; how does that work (e.g., with a SIP URL)?

Jerry Ash

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: "Judith Oppenheimer" <[email-masked]>
Date: Tue, 28 Nov 2000 14:59:23 -0500

> 800 SMS and can be verified.

NO.  The "controlling party" is the subscriber.  The subscriber is not
known to the 800 SMS.

Judith Oppenheimer, 212 684-7210, 1 800 The Expert
Publisher, http://www.ICBTollFreeNews.com
President, http://www.1800TheExpert.com
FREE 800/Domain Classifieds, http://ICBclassifieds.com
Domain Name & 800 News, Intelligence, Analysis

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Ash,
> Gerald R (Jerry), ALCOO
> Sent: Tuesday, November 28, 2000 2:34 PM
> To: 'Richard Shockey'
> Cc: Ash, Gerald R (Jerry), ALCOO; [email-masked]
> Subject: RE: [Enum] Subject:
> I-DACTION:draft-ranalli-peek-walter-enum-t1roles-00.txt
>
>