Subject: [Enum] FYI - Article on ENUM in Network World

From: Richard Shockey <[email-masked]>
Date: Tue, 03 Oct 2000 08:50:05 -0400

IETF spec could propel Internet telephony

                   By CAROLYN DUFFY MARSAN
                   Network World, 10/02/00

                   Think of it as directory assistance for
                   the 'Net.

                   The Internet engineering community
                   has developed a technology that lets
                   you type a telephone number into your
                   Web browser and find a corresponding
                   URL, e-mail address or IP address.
                   Called Enum, the new technology
                   integrates the world's telephone
                   numbering plan with the Internet's
                   Domain Name System (DNS) to power
                   a new class of online telephony
                   services.

                   The Internet Engineering Task Force
                   (IETF) published its Enum specification
                   as a proposed standard in September.
                   Last week, Telcordia Technologies and
                   VeriSign announced the first
                   large-scale test of Enum services. And
                   network vendors such as Cisco,
                   Lucent and Nortel Networks are
                   expected to ship Enum-compliant
                   products next year.

                   Why all the buzz about Enum? Because
                   it's considered a key enabling
                   technology for the anticipated
                   convergence of the public switched
                   telephone network and the Internet.

                   For corporate network managers,
                   Enum offers the potential for each
                   employee to have a single contact for
                   communications devices, including
                   PCs, fax machines, handheld
                   computers, cell phones and pagers.

                   "Enum may enable the corporate
                   phone group to manage the mapping
                   between phone numbers and per-user
                   lists of URLs, where the URLs tell the
                   caller how to contact the callee via
                   phone, e-mail, fax, etc.," says Scott
                   Bradner, director of the IETF's
                   transport area. "Enum puts this under
                   the control of the corporate phone
                   person, not the phone company."

                   Enum is a simple service that
                   functions like a large database. When
                   an end user types a telephone number
                   into an Enum-enabled application, he
                   pulls up what's called a Naming
                   Authority Pointer record that lists all
                   the resources associated with that
                   number, including the domain name.

                   Enum doesn't change the international
                   telephone numbering plan - which uses
                   globally unique E.164 numbers - or how
                   individual countries with the oversight
                   of the International
                   Telecommunication Union administer
                   these numbers. Instead, Enum lets an
                   end user or application see what
                   Internet resources are available for a
                   particular telephone number. Enum is
                   designed for use in the Internet and in
                   private telephone numbering systems
                   and IP networks.

                   On the Internet, businesses and
                   consumers will have to pay to register
                   their phone numbers for Enum
                   services. The businesses and
                   consumers can then specify their
                   preferences for receiving incoming
                   messages to that number, whether as
                   live calls, voice mails, e-mails or faxes.

                   VeriSign sees a potential opportunity
                   to serve as the central registry for
                   Enum, says Pat Conley, a business
                   development executive.

                   That's why VeriSign and Telcordia are
                   hosting a free test bed for Enum
                   developers that will run for six months
                   starting in December.

                   "There are 250 million telephones in
                   the U.S. If 1% of those numbers were
                   registered as Enum records, that
                   would be 2.5 million registrations,"
                   Conley says. "We think [Enum] could
                   be a big opportunity around the globe."

                   Enum developers say the technology
                   will be useful in an array of corporate
                   applications, including e-mail, instant
                   messaging and voice-over-IP services.

                   "Enum would be supported in Web
                   browsers, e-mail clients and voice mail
                   systems for unified messaging
                   scenarios," says Patrik Faltstrom,
                   author of the Enum specification and a
                   Cisco engineer. "You could have a
                   system that, at the voice prompt,
                   records a message and sends it on as
                   e-mail."

                   In conjunction with another IETF
                   protocol - Voice Profile for Internet
                   Messaging - Enum would let carrier
                   and enterprise voice mail servers
                   locate each other over the 'Net and
                   exchange messages. Enum also would
                   let Internet-aware fax machines send
                   documents to each other and to
                   unified messaging systems.

                   But Enum shows the most promise in
                   making it simple to place telephone
                   calls over the Internet.

                   "What Enum does is allow
                   [voice-over-IP] proxies and
                   gatekeepers to find each other with no
                   other information than the phone
                   number," says Richard Shockey,
                   co-chair of the IETF's Telephone
                   Number Mapping group and a senior
                   technical industry liaison with
                   NeuStar, the North American
                   telephone numbering authority. "That's
                   always been the biggest problem in
                   [voice-over-IP] services."

                   This innovation promises big savings
                   for corporations, which typically spend
                   40% of their long-distance bills on
                   internal communications, Shockey
                   says.

                   "Voice over IP. Universal messaging.
                   Fax. These are major enterprise
                   applications that can be enabled more
                   efficiently over IP networks vs.
                   switched networks," Shockey adds.
                   "Enum leverages the enormous
                   investment that corporations have
                   made in their IP backbones and VPNs."

                   One application that already supports
                   Enum is Bind 9, the latest version of
                   the open source software that powers
                   most DNS servers. Bind 9 supports all
                   the resource record types required by
                   Enum, says David Conrad, chief
                   technology officer at Nominum, which
                   wrote Bind 9.

                   Although the Enum protocol is
                   considered solid, it faces a slew of
                   administrative and regulatory hurdles
                   before it can be deployed in the U.S.
                   One challenge was resolved one week
                   ago, when the Internet Assigned
                   Numbers Authority set aside a new
                   domain - E164.arpa - for the storage of
                   E.164 numbers.

                   The next question is: Which federal
                   agency will oversee Enum
                   registrations? Telephone numbering
                   administration is handled by the
                   Federal Communications Commission,
                   while the Department of Commerce
                   oversees DNS. Some regulatory
                   agency will need to oversee Enum
                   subdelegations.

                   Another sticky issue is the ownership
                   and portability of Enum registrations.
                   Businesses and consumers don't own
                   their telephone numbers, but they do
                   own their domain names and can move
                   them from one ISP to another.

                   "The technology is pretty much there.
                   It's just a matter of setting up the
                   administrative infrastructure and
                   procedures you need to make it work,"
                   says Penn Pfautz, an AT&T manager
                   and a participant of the IETF Enum
                   effort.

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Tue, 3 Oct 2000 10:26:34 -0400

Neat article.

One question about portability of phone numbers:

Is there a long term plan in the US for how these numbers would be
formatted? My understanding is that as of now, portable numbers in the US
plan look just like fixed numbers. This has the drawback of making them less
than totally portable. Is there some plan to change the scheme to a more
geographically agnostic-looking number?

Bert
[email-masked]

> -----Original Message-----
> From: Richard Shockey [mailto:[email-masked]]
> Sent: Tuesday, October 03, 2000 8:50 AM
> To: [email-masked]
> Subject: [Enum] FYI - Article on ENUM in Network World
> 
> 
>

---

From: Richard Shockey <[email-masked]>
Date: Tue, 03 Oct 2000 10:35:18 -0400

>[email-masked]

Neither the Industry Numbering Council [INC] or the FCC has any plans to 
permit "geographic portability" in the US  ..though it is technically feasible.

However service number portability ..from landline to cellular or from 
cellular to cellular provider has been mandated beginning in 2002.

---

From: "Conley, Pat" <[email-masked]>
Date: Tue, 3 Oct 2000 10:47:07 -0400

I do not believe there are any real plans in place, but
telephone numbers in the US are gradually loosing their
geographic meaning... 800 numbers, 500 numbers and over-
lapping area codes are adding to this trend.

IMHO we will see this trend continue... albeit slowly.

pat

-----Original Message-----
From: Manfredi, Albert E [mailto:[email-masked]]
Sent: Tuesday, October 03, 2000 10:27 AM
To: 'Richard Shockey'; [email-masked]
Subject: RE: [Enum] FYI - Article on ENUM in Network World

Neat article.

Bert