Subject: Re[2]: [Enum] Re: draft-ietf-enum-e164-dns-03.txt

From: [email-masked]
Date: Wed, 9 Aug 2000 17:35:18 -0400

Sorry, all.  I haven't looked at "+" in the enum process, but I don't 
     agree that "+" is only for readability.  What's the context (public 
     international or not)?  What's the usage (such as whether you've got a 
     number as opposed to a dialing string)?
     
     Here are two ITU-T data points, plus (oops!) a personal experience 
     that shows what can go wrong.
     
     1. From E.164 (5/97):  
     
     In accordance with Recommendation E.123, the symbol "+" is recommended 
     to indicate that an international prefix is required.  
     
     [Many but not all countries use 00 as an international prefix.]
     
     2. From E.123 (1988 Blue Book - now being revised):
     
     ... A procedural symbol is a symbol which tells the user how to dial. 
     
     ... The international prefix symbol should be + (plus) and should 
     precede the country code in the international number.  It serves to 
     remind the subscriber to dial the international prefix which differs 
     from country to country and also SERVES TO IDENTIFY THE NUMBER 
     FOLLOWING AS THE INTERNATIONAL TELEPHONE NUMBER. 
     
     [emphasis added - didn't really mean to shout]
     
     3.  Ye personal experience.
     
     Several numbering plan changes ago, a colleague from the UK left a 
     message with his home number.  I tried to call him back and failed.  I 
     tried everything, but nothing worked.  Next day I called his office.  
     He apologized.
     
     Here's what happened.  The message I got had a number beginning with 
     44.  I assumed it was the UK country code.  Wrong!  He lived so far 
     outside London that his UK number at the time began with 44.  When I 
     finally tried + 44 44 ... I finally got through.
     
     -Andy

     =========(note:  email address change)=========
     Andrew Gallant ([email-masked]);  LMGT
     Lockheed Martin Global Telecommunications, Inc.
     6560 Rock Spring Drive;  Bethesda, MD 20817 USA
     Tel:   +1 301 214 3264;  Fax:   +1 301 214 7226

Received: from ro.ctd.comsat.com ([134.133.40.45]) by cqgate5.cmc.comsat.com
with SMTP
  (IMA Internet Exchange 3.13) id 000EF80C; Wed, 9 Aug 2000 16:36:16 -0400
[128.96.41.1])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id QAA19532
	for <[email-masked]>; Wed, 9 Aug 2000 16:31:07 -0400 (EDT)
Received: from research.telcordia.com (mmc-11-as5200-d32.cc.telcordia.com
[128.96.11.32])
	by thumper.research.telcordia.com (8.10.1/8.10.1) with ESMTP id e79KOQR25519;
	Wed, 9 Aug 2000 16:24:26 -0400 (EDT)
Message-ID: <[email-masked]>
Date: Wed, 09 Aug 2000 16:24:28 -0400
From: Hong Liu <[email-masked]>
Organization: Telcordia Technologies Applied Research
X-Mailer: Mozilla 4.7 [en] (WinNT; U)
X-Accept-Language: en,zh
MIME-Version: 1.0
To: James Yu <[email-masked]>
CC: "[email-masked]'" <[email-masked]>, "[email-masked]'" <[email-masked]>
Subject: Re: [Enum] Re: draft-ietf-enum-e164-dns-03.txt
References: <[email-masked]>
Content-Type: text/plain; charset=iso-8859-1
Sender: [email-masked]
Errors-To: [email-masked]
X-Mailman-Version: 1.0
Precedence: bulk
List-Id: Enum Discussion List <enum.ietf.org>
X-BeenThere: [email-masked]
Content-Transfer-Encoding: quoted-printable
X-MIME-Autoconverted: from 8bit to quoted-printable by optimus.ietf.org id
QAA28836

---

From: Hong Liu <[email-masked]>
Date: Wed, 09 Aug 2000 18:06:26 -0400

Andy,

Thanks for the clarification. I agree with you that from a user perspective, "+" means
more than just for readability.

The problem we are discussing here is whether "+" is needed for ENUM process given the
fact that the input is a canonical E.164 number already. I would like to hear from you
and others. Thanks!

--Hong

>      finally tried + 44 44 ... I finally got through.

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 10 Aug 2000 07:35:38 +0200

>fact that the input is a canonical E.164 number already. I would 

I say it once again, and only one more time.

If you try to write regular expressions which is to work on both 
E.164 numbers and non-E.164 numbers (see example from email from 
Andrew) it is extremely nice to have the '+' which indicates what 
kind of number we are talking about. ITU specifications explicitly 
talks about the '+'. See more text from Andrews document.

In the case that one is using a closed numbering plan and is in the 
future going to mix E.164 numbers and his closed numbering plan 
together, and apply a modified version of ENUM, it is nice to have 
the '+'.

    Patrik