Subject: RE: [Enum] Re: draft-ietf-enum-e164-dns-03.txt

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 10 Aug 2000 13:42:57 -0400

Folks,

Is this even an enum wg issue?

How one types the number in the PC is important, but I don't think it
belongs here. How the PC sends out the DNS query does matter, and the fact
that a query is sent to e164.arpa indicates that the PC has understood the
request to be for an e.164 number.

The way the request is typed into the PC is up to the application
programmer, I would think. Using + is probably a great idea, but do we in
enum care?

Maybe the request is typed in a little Windows dialog box, where e164 is one
of the selections you might check.

If other requests are formatted in the future, for non-e.164 numbers, then
they would be made to a different domain, not e164.arpa.

Or am I missing something here?

Bert
[email-masked]

> -----Original Message-----
> From: BARNOLE Valerie FTRD/DAC/ISS
> [mailto:[email-masked]]
> Sent: Thursday, August 10, 2000 11:28 AM
> To: 'Patrik Fältström'
> Cc: [email-masked]'; Manfredi, Albert E; 'Hong Liu'
> Subject: RE: [Enum] Re: draft-ietf-enum-e164-dns-03.txt
> 
> 
>  
> So a user dialing on his PC a number with a "+" in front 
> indicates to the
> system that it has to look through e164.arpa rather than in 
> the originating
> country of the call, namely Sweden and e164.se in your example ?
> A maybe trivial question :
> How does the system knows that it has to go through telia.se 
> rather than
> through e164.se in case Telia operator decided to put its 
> customers numbers
> in a DNS zone telia.se for any reason ? 
> 
> end of message
> _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
> 
> Valérie Barnole
> 
> FTR&D/DAC/ACE
> 
> tel. : + 33 1 45 29 58 39
> fax : + 33 1 46 29 31 42
> 
> mail to : [email-masked]
> 
> 
> 
> -----Message d'origine-----
> De: Patrik Fältström [mailto:[email-masked]]
> Date: jeudi 10 août 2000 16:38
> À: Manfredi, Albert E; 'Hong Liu'
> Cc: [email-masked]'
> Objet: RE: [Enum] Re: draft-ietf-enum-e164-dns-03.txt
> 
> 
> At 09.48 -0400 00-08-10, Manfredi, Albert E wrote:
> >If the DNS query is made to domain e164.arpa, perhaps use of the + is
> >redundant and not particularly helful for the future anyway?
> 
> If we start using some more interesting parts of the NAPTR 
> algorithms/possibilities, it is possible to have an input to the 
> algorithm (output of first well-known-rule) that is either a full 
> E.164 number or some other kind of telephone number.
> 
> Let's say that we have for phone numbers in Sweden the TLD e164.se.
> 
> A phone number in Sweden can look like "08-978777", which without the 
> '-' is 08978777.
> 
> Let's store that in DNS:
> 
> 7.7.7.8.7.9.8.0.e164.se.
> 
> What do we now do?
> 
> Well, we can use the string we got 08978777 as input to a NAPTR 
> rewrite mechanism where the flag field is empty, and because of that 
> forces the rewrite to loop.
> 
> We can then store
> 
> 7.7.7.8.7.9.8.0.e164.se. IN NAPTR 10 10 "" "" "![0-9].*!foo.se!" .
> 
> In parallell we have the full E.164 number +46-8-978777 (the same 
> number) which have the DNS record 7.7.7.8.7.9.8.6.4.e164.arpa.
> 
> That NAPTR can look like
> 
> 7.7.7.8.7.9.8.6.4.e164.arpa. IN NAPTR 10 10 "" "" "![0-9].*!foo.se!" .
> 
> Now, at foo.se, we want to distinguish between the "referals" which 
> have been made from non-E.164 numbers and the ones which uses the 
> full number (think of the two as two different dialling plans). How 
> do we do that?
> 
> Well, the input to the algorithms are 08978777 and +468978777, and 
> because of this different. We can because of that have two different 
> NAPTR RRs at foo.se as follows:
> 
> foo.se. IN NAPTR 10 10 "u" "mailto+E2U" "!+.*!mailto:[email-masked]!" .
> foo.se. IN NAPTR 10 10 "u" "mailto+E2U" 
> "![0-9].*!mailto:[email-masked]!" .
> 
> Note that the regular expressions are different, and because of that 
> only one of the two will match, and according to the NAPTR algorithm 
> one should use the regexp which matches given that the repacement 
> field is empty.
> 
> Also, note (of course) that the URIs which should be used are 
> different.
> 
> So, I _really_ want the '+' there so it is simpler to know that we 
> are talking about a real E.164 number and not something else 
> (regardless of what it is) when dealling with regular expressions.
> 
> As usual, Michael will jump in if I have made an error :-)
> 
>      paf
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/enum
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Mealling <[email-masked]>
Date: Thu, 10 Aug 2000 13:50:30 -0400

> Or am I missing something here?

I think the issue is more along the lines of allowing future extenstibility.
I.e. if we don't put the "+" in there now then it makes it much
harder for us to work around it in the future. Much like the issue
surrounding the MIME version header. Its supposed to never change from
version 1.0 but it was thought best to put it in there "just in case"
we realized something latter.

I.e. if you put the "+" in there now it doesn't cause any real pain.
But in the future if you want to tell the difference and it isn't there
then it makes life really suck....

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling	|      Vote Libertarian!       | www.rwhois.net/michael
Sr. Research Engineer   |   www.ga.lp.org/gwinnett     | ICQ#:         14198821
Network Solutions	|          www.lp.org          |  [email-masked]