Subject: RE: [Enum] FW: Last Call or New Draft? - .arpa or .e;164.itu.in t ?

From: [email-masked]
Date: Fri, 14 Jul 2000 10:09:50 +0300

Hi Patrik,

> No, in DNS you always get back all RRs which have the same "owner", 
> and for NAPTRs that is 4.3.2.1.6.7.9.8.6.4.e164.arpa.
> 
> There is no definition at the moment for the NAPTR RRs to request 
> only one of the services separately (for example by using a naming 
> convention like you propose).

To whom should I talk to about this?  I feel that there might
be a scalability issue with ENUMs & NAPTR.  The reason being
is that if you have a 1 800 number (for example), there
might be a lot of services defined for it, which would like
to use DNS.  I think that quite quickly, we may see some
scalability issues.  Best to attempt to solve them now.

cheers,
John

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 14 Jul 2000 07:29:03 -0700

>scalability issues.  Best to attempt to solve them now.

How many?

I.e. I don't understand what you belive is a scalability issue. You 
also have to think about what is handled through different URIs 
(different NAPTRs) and what is handled through the URI resolution.

It could be more interesting to query on the service field than the protocol.

   paf

---

From: "David P. Peek" <[email-masked]>
Date: Fri, 14 Jul 2000 11:39:20 -0400

In reference to the scalability issue...

With the way ENUM requirements are defined today the Fältström draft
supports these requirements by returning all the services based on a query.

I agree that there are scalability issues with this approach that is why the
http://search.ietf.org/internet-drafts/draft-peek-enum-itd-00.txt draft
supports 'application specific queries' which allows specific service
information to be retrieved separately based on a known service ("Service
Protocal") thereby limiting the amount of information returned solving the
scalability issue. (ie. sip.x.x.x.x.x.x.e164.arpa)

NetNumber has built and deployed the implementation as described in the
above draft and is also prepared to support the outcome of ENUM once it is
defined.
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Patrik Fältström
Sent: Friday, July 14, 2000 10:29 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Enum] FW: Last Call or New Draft? - .arpa or .e;164.itu.in
t ?

How many?

It could be more interesting to query on the service field than the
protocol.

   paf

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 14 Jul 2000 09:07:01 -0700

At 11.39 -0400 00-07-14, David P. Peek wrote:
>I agree that there are scalability issues

What scalability issues?

   paf

---

From: Michael Mealling <[email-masked]>
Date: Fri, 14 Jul 2000 14:09:12 -0400

> scalability issue. (ie. sip.x.x.x.x.x.x.e164.arpa)

I've heard this several times but I've never seen a single example
of anything that advertises more than a small handful of services.
How many different ways are there to make a telephone call these days anyway?

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling	|      Vote Libertarian!       | www.rwhois.net/michael
Sr. Research Engineer   |   www.ga.lp.org/gwinnett     | ICQ#:         14198821
Network Solutions	|          www.lp.org          |  [email-masked]