Subject: RE: [Enum] NAPTR is not as an ENUM Requirement

From: Patrik Fältström <[email-masked]>
Date: Wed, 28 Jun 2000 22:37:19 +0200

At 13.13 -0700 00-06-28, Christian Huitema wrote:
>  > How are you going to use the SRV?
>
>Classic VOIP example. I want to contact +1 234 567 8901. I will look for the
>corresponding SIP/SRV record under _sip.udp.1.0.9.8.7.6.5.4.3.2.1.ipv6.int

But, the SRV for sip is to be looked up for the domain part of the 
sip URI, i.e. you seem to use 1.0.9.8.7.6.5.4.3.2.1.ipv6.int as if it 
was the domain part of the URI, to find the SIP server which handles 
that number.

What is the local part?

Or have I misunderstood something with SIP completely?

 From RFC 2543:

>    For example, consider a client that wishes to send a SIP request. The
>    Request-URI for the destination is sip:[email-masked].  The client
>    only supports UDP. It would follow these steps:
>
>         1.   The host portion is not an IP address, so the client goes
>              to step 2 above.
>
>         2.   The client does a DNS query of QNAME="sip.udp.company.com",
>              QCLASS=IN, QTYPE=SRV. Since it doesn't support TCP, it
>              omits the TCP query. There were no addresses in the DNS
>              response, so the client goes to the next step.
>
>         3.   The client does a DNS query for A records for
>              "company.com". An address is found, so that client attempts
>              to contact a server at that address at port 5060.

What I thought what one should do is:

(a) Take the E.164, and turn that into a domain name
(b) Look up the NAPTR for the domain name
     (following CNAME, DNAME, NAPTR non-terminals etc etc)
(c) Take the SIP URI from the according NAPTR
(d) Use the algorithm above to fetch the SRV for the SIP URI

Or:

(a) Take the E.164, and turn that into a domain name
(b) Look up the NAPTR for the domain name
     (following CNAME, DNAME, NAPTR non-terminals etc etc)
(c) Take the LDAP URI from the according NAPTR
(d) Lookup in LDAP what SIP URI to use at this very moment
     (according to some other future specification)
(e) Take the SIP URI from the according NAPTR
(f) Use the algorithm above to fetch the SRV for the SIP URI

I.e. steps (a) and (b) are very generic and can/should be done all the time.

I claim that -- as you understand...

   paf

_______________________________________________
enum mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/enum

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 28 Jun 2000 23:04:26 -0400

> Or have I misunderstood something with SIP completely?

No, you are correct; I would expect a two stage process whereby the
telephone number is first resolved to a SIP URL, and then the domain
part of the SIP URL is looked up to find the SRV record for that domain.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com