Subject: RE: [Enum] Overlap dialing, again

From: "Manfredi, Albert E" <[email-masked]>
Date: Wed, 29 Mar 2000 10:00:41 -0500

FWIW, I completely agree with Greg. Also, in any DNS query situation
involving enum, whatever appliance or server is making this query must know
to append the "e164.int" domain to the number anyway, as this scheme being
defined in this wg. Therefore, the appliance or server _must_ be smart
enough to know when the e.164 number is complete.

Or at least, this appliance/server must make a guess as to when the e.164
number being queried is complete, even if in reality it isn't, and the query
will end up with an error message.

For example, in a cell phone, one typically has to push the "send" button
after having entered the telephone number. I think that it isn't too much to
ask that the appliance which is using enum has this same sort of
functionality?

Bert
[email-masked]

> -----Original Message-----
> From: Vaudreuil, Greg M (Greg) [mailto:[email-masked]]
> Sent: Tuesday, March 28, 2000 8:08 PM
> To: Lind, Steven D, ALARC; 'Manfredi, Albert E'; 'Sören Nyckelgård';
> [email-masked]
> Subject: RE: [Enum] Overlap dialing, again
> 
> 
> 
> In the GSTN, most switches support two types of digit 
> analysis, I will call
> them deterministic and non-deterministic.  For the 
> local/in-country dial
> plan, the switch has a list of valid prefixes, the expected 
> number of digits
> to collect, and any digit translations necessary to "fully 
> qualify" the
> number.  This table maps from the dialed number (such as a 
> private dial
> plan) into a unique national/international number.  This 
> prefix list varies
> switch-to-switch (and often within a switch) based on the 
> local dialing plan
> in effect for the caller.  With this list, a number can be 
> determined to be
> invalid before all the digits are entered.
> 
> For out-of-country telephone numbers, an international escape 
> code is dialed
> which simply informs the switch that the local digit analysis 
> rules do not
> apply.  The switch then collects digits until either a 
> time-out or a pounds
> termination is dialed.  
> 
> In Internet space, it is somewhat unreasonable for end-node clients to
> independently administer a local copy of the often-changing 
> national dialing
> plan.  Further, I  suggest that dialing-time, digit-by-digit 
> validation over
> a network protocol will be excessively taxing on both the 
> server and the
> client.  I definitely recommend against using DNS to provide 
> this function.
> If local dial-plans must be supported, either to eliminate 
> the time-out or
> pre-validate a dialed number, they should be provided by the 
> local client,
> using a standardized and downloadable digit-analysis 
> configuration file
> (such as a web proxy list).   
> 
> Greg V.
> 
> -----Original Message-----
> From: Lind, Steven D, ALARC [mailto:[email-masked]]
> Sent: Tuesday, March 28, 2000 9:27 AM
> To: 'Manfredi, Albert E'; 'Sören Nyckelgård'; [email-masked]
> Subject: RE: [Enum] Overlap dialing, again
> 
> 
> I would assume that "an appliance," smart enough to perform 
> the front end of
> the enum functionality, would have some sort of local 
> directory function
> that would already contain the complete E.164 number. A 
> "dumb" terminal,
> i.e., a plain old telephone, would attach through some 
> network (e.g., the
> PSTN) to a gateway. The existing dialing plan and associated 
> timeouts would
> govern the progress of the call to the gateway, where the 
> enum functionality
> would occur after receiving the complete E.164 number.
> 
> If there is a dumb phone attached to an IP access network (e.g., cable
> telephony), then the interface to the IP access network would have to
> simulate the dialing plan/timeouts existing as general 
> practice or standards
> within the specific geopolitical area.
> 
> Steve Lind
> 
> 
> ---------------------------------------------------------------
> Steven D. Lind                   Tel: (973) 236-6787
> AT&T                             Fax: (973) 236-6452  
> 180 Park Ave., Bldg. 2            e-mail: [email-masked]
> Florham Park, NJ 07932                 
> ---------------------------------------------------------------
> 
> 
> > -----Original Message-----
> > From:	Manfredi, Albert E [SMTP:[email-masked]]
> > Sent:	Tuesday, March 28, 2000 9:52 AM
> > To:	'Sören Nyckelgård'; [email-masked]
> > Subject:	RE: [Enum] Overlap dialing, again
> > 
> > When does the appliance decide to query the DNS? Does the 
> appliance not
> > have
> > to append the "e164.int" to the phone number before the 
> query is sent?
> > Somehow, doesn't this imply that the complete number has 
> been entered,
> > before the query?
> > 
> > Or are you saying that if the user is slow at entering digits, the
> > appliance
> > might send out multiple DNS requests? Interesting twist.
> > 
> > Bert
> > [email-masked]
> > 
> > 
> > > -----Original Message-----
> > > From: Sören Nyckelgård [mailto:[email-masked]]
> > > Sent: Monday, June 21, 1999 10:23 AM
> > > To: [email-masked]
> > > Subject: [Enum] Overlap dialing, again
> > > 
> > > 
> > > At the ENUM meeting in Adelaide, the overlap dialing issue 
> > > was rised again.
> > > The specific issue was that the lenght of the number might 
> > > not be known by
> > > the client, thus forcing the client to query the DNS for 
> > > every new digit
> > > entered by the user. In this case we assume that the call is 
> > > made from a
> > > terminal, like a conventional black phone, that does not 
> require an
> > > 'end-of-number' kind of button to be pushed to complete 
> the number.
> > > 
> > > The chairs were not aware of this particular hazle so the 
> > > suggestion was to
> > > bring up the issue on the list again. So, here it comes...
> > > 
> > > Would it be possible for the DNS to, in some way, drop a hint 
> > > of the length
> > > of the number, e.g. exact length or a minimum length, in 
> > > order to avoid
> > > querying the DNS inbetween every digit?
> > 
> > _______________________________________________
> > enum mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/enum
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/enum

---

From: Sören Nyckelgård <[email-masked]>
Date: Wed, 23 Jun 1999 09:38:01 +0200

Firtst of all, I'd like to clarify that I'm not in favour of adding any
functions to the DNS that are not already there. I just want to address
the issue of the client knowing or not knowing the length of the number.

Some countries/regions have fixed number lengths, some have number
series depending number length and yet others have variable number
length. Okey, if the number length is not fixed, some contries/regions
generally accept inter-digit timeout as the mechanism to determine
'end-of-number', others only accept that mechanism for international
calls. In the latter case, customers are customed to get a ringtone
immediately after they type the last digit when they make local or national
calls. In this case, callers generally don't accept any noticable post-dial
delay. Ann inter-digit time-out mechanism is hence not acceptable here.
This is, in fact the situation in Sweden and several other countries.

There are several ways for a client, local exchange, PBX, etc. to
determine the length of a local or national number. A table with number
series / number length tuples is one way of doing it, as long as there are
means to keep the table dynamically updated, which unfortunately is
rarely the case. Number lengths are being canged rather frequently in
some countries/regions due to lack of telephone numbers. Since
updating of routing tables and number analysis functions in all nodes is a
time-consuming process, a mechanism commonly applied is based on
the knowledge of a 'minimum length' for the number series in concern,
i.e. the routing table or number analysis function can at least determine
the minimum length of the number. What happens when a call is made
is that the node will collect digits until the minimum length has been
reached and then call the next node. If no 'address complete' message
is immediately returned, then the sending node will assume a transparent
mode, passing on all succeding digits received from the user until it
finally
gets an 'address complete' message in return.

I just want to establish the fact that in several cases, the client, local
exchange, PBX, etc. will be unaware of  the exact length of the number
and hence forced to repetedly query the DNS until the desired
response is received.

Maybe later on we should address the number lengt issue again in order
to find ways to distribute number lengh information but I don't consider
this to be an issue for the ENUM WG.

Cheers,
Sören

---------------------------------------
Sören Nyckelgård, Telia Research AB
[email-masked]
---------------------------------------
----- Original Message -----
From: Manfredi, Albert E <[email-masked]>
To: 'Vaudreuil, Greg M (Greg)' <[email-masked]>; <[email-masked]>
Sent: Wednesday, March 29, 2000 5:00 PM
Subject: RE: [Enum] Overlap dialing, again

>
>
> > ----------
> > From: Manfredi, Albert E[SMTP:[email-masked]]
> > Sent: Wednesday, March 29, 2000 5:00:41 PM
> > To: 'Vaudreuil, Greg M (Greg)'; [email-masked]
> > Auto forwarded by a Rule