Subject: RE: [Enum] Overlap dialing, again

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 27 Mar 2000 22:57:10 -0500

I'm confused about why this issue comes up.

In most systems there is a "dialing plan", which determines
how many digits to collect.  The local system applies
this dialing plan as the first step.  When it discovers
the terminal digit (by algorithm or timeout), the entire
result is subjected to routing.  The dialed number it is 
NOT submitted, digit by digit, to the call routing 
mechanism.

Why should we should we be trying to change this?

Brian

> -----Original Message-----
> From: Sören Nyckelgård [mailto:[email-masked]]
> Sent: Monday, June 21, 1999 10:23 AM
> To: [email-masked]
> Subject: [Enum] Overlap dialing, again
> 
> 
> At the ENUM meeting in Adelaide, the overlap dialing issue 
> was rised again.
> The specific issue was that the lenght of the number might 
> not be known by
> the client, thus forcing the client to query the DNS for 
> every new digit
> entered by the user. In this case we assume that the call is 
> made from a
> terminal, like a conventional black phone, that does not require an
> 'end-of-number' kind of button to be pushed to complete the number.
> 
> The chairs were not aware of this particular hazle so the 
> suggestion was to
> bring up the issue on the list again. So, here it comes...
> 
> Would it be possible for the DNS to, in some way, drop a hint 
> of the length
> of the number, e.g. exact length or a minimum length, in 
> order to avoid
> querying the DNS inbetween every digit?
> 
> 
>  / Sören Nyckelgård, Telia Research
> 
> 
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/enum

---

From: "Michael Welser" <[email-masked]>
Date: Tue, 28 Mar 2000 07:42:45 +0200

E.g. Germany and Austria have variable-length numbers (there may be more such
countries). There, "classical" POTS access equipment MUST support overlap
sending (the only other way would have been to force customers to enter # at the
end of the dialling process, which nobody dared enforce - we are talking about
the dark past).

Of course, there is also a timeout, but this is quite high (I could find out the
actual value, it should be around 7 sec) and therefore not really useable...

Michael

------------------------------------------------------------
mailto:[email-masked]         Telekom Austria AG

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Rosen, Brian
> Sent: Tuesday, March 28, 2000 5:57 AM
> To: 'Sören Nyckelgård'; [email-masked]
> Subject: RE: [Enum] Overlap dialing, again
>
>

---

From: [email-masked]
Date: Tue, 28 Mar 2000 15:12:50 +0900

Support of overlap sending does not necessarily depend on variable or fixed.
Japan has variable-length E.164 numbering plan but does not support overlap sending. Local switches have both a capability to send digits en-bloc when
maximum number of digits are dialed, and a timer (about 4 sec).

Interworking with overlap-sending countries is also supported at international
interface.

I still don't know if information about existing PSTN capability helps 
solution of future issues.... 

Toshiyuki Tamura
[email-masked]

>> To: 'S(Iv(Jren Nyckelg$BiS(Jd'; [email-masked]
>> > From: S(Iv(Jren Nyckelg$BiS(Jd [mailto:[email-masked]]
>> >  / S(Iv(Jren Nyckelg$BiS(Jd, Telia Research
>> >
>> >
>> >
>> >

---

From: Bill Manning <[email-masked]>
Date: Mon, 27 Mar 2000 22:24:51 -0800 (PST)

% 
% I'm confused about why this issue comes up.
% 
% In most systems there is a "dialing plan", which determines
% how many digits to collect.  The local system applies
% this dialing plan as the first step.  When it discovers
% the terminal digit (by algorithm or timeout), the entire
% result is subjected to routing.  The dialed number it is 
% NOT submitted, digit by digit, to the call routing 
% mechanism.

	Most, not all.

% Why should we should we be trying to change this?

	We shouldn't, this is how the DNS works.

% Brian
% 
% 
% > -----Original Message-----
% > From: Sören Nyckelgård [mailto:[email-masked]]
% > Sent: Monday, June 21, 1999 10:23 AM
% > To: [email-masked]
% > Subject: [Enum] Overlap dialing, again
% > 
% > 
% > At the ENUM meeting in Adelaide, the overlap dialing issue 
% > was rised again.
% > The specific issue was that the lenght of the number might 
% > not be known by
% > the client, thus forcing the client to query the DNS for 
% > every new digit
% > entered by the user. In this case we assume that the call is 
% > made from a
% > terminal, like a conventional black phone, that does not require an
% > 'end-of-number' kind of button to be pushed to complete the number.
% > 
% > The chairs were not aware of this particular hazle so the 
% > suggestion was to
% > bring up the issue on the list again. So, here it comes...
% > 
% > Would it be possible for the DNS to, in some way, drop a hint 
% > of the length
% > of the number, e.g. exact length or a minimum length, in 
% > order to avoid
% > querying the DNS inbetween every digit?
% > 
% > 
% >  / Sören Nyckelgård, Telia Research
% > 
% > 
% > 
% > 
% > _______________________________________________
% > enum mailing list
% > [email-masked]
% > http://www.ietf.org/mailman/listinfo/enum
% > 
% 
% _______________________________________________
% enum mailing list
% [email-masked]
% http://www.ietf.org/mailman/listinfo/enum
% 

-- 
--bill