Subject: RE: [Enum] Re: Structure of DNS entry for ENUM

From: Randy Bush <[email-masked]>
Date: Fri, 04 Feb 2000 08:32:53 -0800

> However, it's not clear to me why the fields of the E.164 number which are
> clearly delineated, such as country code and city/area code, could not at
> least have been kept together, delimited by dots. The long series of dots
> seems a bit excessive?

because only north americans think country codes and city codes are clearly
delineatable in a universal way?

randy

_______________________________________________
enum mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/enum

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 4 Feb 2000 11:29:32 -0500

Randy Bush [mailto:[email-masked]] wrote:

> > I understand that "e164.int" might become a new global TLD, 
> but what do mean
> > the digits of the E.164 number as they are i.e separated by 
> a dot and
> > therefore, I suppose, having to point out INDIVIDUALLY to certain IP
> > addresses.
> 
> it is the phone number reversed and the dots are added in a 
> way that allows
> dns delegation at any level in that phone number.  e.g.
> 
>   phone number is +1 206 780 0431
> 
>   look up 1.3.4.0.0.8.7.6.0.2.1.e164.int
> 
> this allows the dns 'owner' of
> 
>   6.0.2.1.e164.int
> 
> (+1 206 all of the seattle area) to delegate
> 
>    0.8.7.6.0.2.1.e164.int
> 
> to the server set which just handles +1 206 780,  bainbridge island.
> 
> this is so it distributes well and hence scales well.

True, and the reverse order is used because, as Steven Lind pointed out, the
hierarchy in the names is opposite that of the E.164 numbers (and also
opposite that of the IP addresses, I might add).

One might _also_ argue that as long as e164.int is used in the DNS name
field, the convention for the stuff up front be in accordance with E.164?

I think it would be far clearer, and no tremendous problem, to show

+1 206 780 0431

as 1.206.7800431.e164.int,

and a euro-style number like

39 06 3295887 as

39.06.3295887.e164.int.

I mean, the whole point of DNS names was that they be clear to a human, yes?

I still think, though, that using the DNS field for AESAs, peer to the IP
address field, would be a useful feature in addition to this naming
convention.

Bert
[email-masked]