Subject: RE: [ITU+IETF] RE: [Enum] Re: Structure of DNS entry for ENUM

From: James Yu <[email-masked]>
Date: Mon, 7 Feb 2000 11:55:12 -0600

Dean,

Agree with what you said; however, I don't consider private numbering plans
part of E.164.  We are addressing E.164 numbers defined by ITU-TS.  Other
private numbering plans using different domains is a separate issue.

James

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Monday, February 07, 2000 12:52 PM
> To: IETF Enum
> Subject: [ITU+IETF] RE: [Enum] Re: Structure of DNS entry for ENUM
> 
> 
> 
> I second Jonathan's position. I think that there will by 
> necessity be a
> generalization of ENUM to allow for privately administered 
> dialing plans.
> The obvious way to do this is to define another domain for 
> each private
> numbering plan. How a client knows which one to use is somebody else's
> problem. Before anyone can get traction there, ENUM needs to 
> move further
> along the single-domain E.164 solution path. On the other 
> hand, we do need
> to keep in mind the assumption that there WILL be other 
> domains, and not
> make any design choices which preclude such an approach.
> 
> --
> Dean
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > Jonathan Rosenberg
> > Sent: Monday, February 07, 2000 11:12 AM
> > To: James Yu
> > Cc: 'Randy Bush'; Richard Shockey; [email-masked]; [email-masked]
> > Subject: Re: [ITU+IETF] RE: [Enum] Re: Structure of DNS 
> entry for ENUM
> >
> >
> >
> >
> > James Yu wrote:
> > >
> > > This means that the client would need to know which
> > consortium/domain to use
> > > when sending the DNS query.  It may be fine if the client only
> > handles calls
> > > within a consortium/domain.  But it won't be true for all 
> the clients.
> >
> > I don't think we're trying to solve all aspects of the 
> general problem
> > here. I think our job is to start with a tld, and from 
> there, figure out
> > how to formulate the query to get back some kind of useful response.
> > Deciding who owns these tld's, and how to configure them in 
> clients, is
> > important but not what we are solving here.
> >
> > -Jonathan R.
> >
> > --
> > Jonathan D. Rosenberg                       200 Executive Drive
> > Chief Scientist                             Suite 120
> > dynamicsoft                                 West Orange, NJ 07052
> > [email-masked]                     FAX:   (732) 741-4778
> > http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> > http://www.dynamicsoft.com
> >
> > _______________________________________________
> > enum mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/enum
> >
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/enum

---

From: Dean Willis <[email-masked]>
Date: Wed, 16 Feb 2000 18:25:44 -0600

Yep. Just don't screw the design down in such a way as to PRECLUDE use of
enum techniques for dealing with those separate issues.

--
Dean

> From: James Yu [mailto:[email-masked]]
> Sent: Monday, February 07, 2000 11:55 AM
> To: 'Dean Willis'
> Cc: IETF Enum
> Subject: RE: [ITU+IETF] RE: [Enum] Re: Structure of DNS entry for ENUM
>
>
> Dean,
>

---

From: Richard Shockey <[email-masked]>
Date: Wed, 16 Feb 2000 20:34:56 -0600

>enum techniques for dealing with those separate issues.

Point well raised Dean. I see this as another form of delegation. Internal 
private numbering plans could be resolved within separate zones within the 
appropriate domain.

lets say  x.x.x.x.x.x.x.x.x.x.x.e164.domain.com

Internal gateways or intelligent telephony devices would have some logic 
that understands that certain _dialing_ strings...resolve against a 
different _numbering_ domain than the global E164 proposed by ENUM.

I think this has hung up some people before. Dialing and numbering are two 
distinct things.

The protocol usage would be the same.

One Internal ..One Global.

Maybe this should be documented more clearly.

Richard Shockey
Shockey Consulting LLC
8045 Big Bend Blvd. Suite 110
St. Louis, MO 63119
Voice 314.918.9020
eFAX Fax to EMail 815.333.1237 (Preferred for Fax)
INTERNET Mail & IFAX : [email-masked]
GSTN Fax 314.918.9015
MediaGate iPost VoiceMail and Fax 800.260.4464
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<