Subject: Re: [Emo-dir] [edu-team] Educational RFCs

From: "Salz, Rich" <[email-masked]>
Date: Mon, 11 Apr 2022 20:59:56 +0000

Hi there.  Resurrecting this.  Sorry for the nearly-a-year without any reply (that I saw).  Are you still interested in talking about this?

From: "[email-masked]" <[email-masked]>
Date: Tuesday, June 22, 2021 at 11:34 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [edu-team] Educational RFCs

Greetings to the edu-team,

Apologies if this has already been discussed in the past. I searched the mail archives as much as possible but couldn’t find anything similar.

On a course on Internet Protocols at the University of Piraeus (https://www.ds.unipi.gr/en/courses/internet-protocols-2/<https://urldefense.com/v3/__https:/www.ds.unipi.gr/en/courses/internet-protocols-2/__;!!GjvTz_vk!FNjdXWW-z2O0oRcqs5NHzw7BKpHkU-zibDjgXW4k6RiiXACeQ0fRx9EFLZx6$>), Professor Rouskas and I, have begun a series of laboratory exercises where we want our students to become adept at being able to read and implement internet protocol specification documents, specifically from the IETF.

With that goal in mind, we wrote a small IETF-like draft (using xml2rfc) where we outlined a very simple protocol in detail and asked them to read and implement it.

That got us thinking whether it makes sense for the IETF and specifically for the edu-team to create a series of educational RFCs with the goal of providing material for Universities for preparing students/future-engineers to be ready to participate in the IETF.

We do understand that this is not the current focus of the edu-team and the IETF in particular, but we were thinking whether it makes sense to expand the charter to allow creating short introductory RFCs, where attendees/students could be introduced into reading and understanding specs at a smaller scale.

Regards,
Evangelos Haleplidis.

---

From: <[email-masked]>
Date: Tue, 12 Apr 2022 01:14:34 +0300

Greetings,

Certainly, we are still working on this.

Last year, it went very well, and our students were very interested in this exercise and got a real handle on being able to read a very simple protocol, written with the IETF format and of course using the necessary tools (xml2rfc + ipnits, etc.). We got some pretty good results.

We are going to make the same exercise this year as well, so yes, we are interested in this work.

Regards,

Evangelos Haleplidis.

From: Salz, Rich <[email-masked]> 
Sent: Τρίτη, 12 Απριλίου 2022 00:00
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [edu-team] Educational RFCs

From: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Date: Tuesday, June 22, 2021 at 11:34 AM
To: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Subject: [edu-team] Educational RFCs

On a course on Internet Protocols at the University of Piraeus (https://www.ds.unipi.gr/en/courses/internet-protocols-2/ <https://urldefense.com/v3/__https:/www.ds.unipi.gr/en/courses/internet-protocols-2/__;!!GjvTz_vk!FNjdXWW-z2O0oRcqs5NHzw7BKpHkU-zibDjgXW4k6RiiXACeQ0fRx9EFLZx6$> ), Professor Rouskas and I, have begun a series of laboratory exercises where we want our students to become adept at being able to read and implement internet protocol specification documents, specifically from the IETF. 

Regards,

Evangelos Haleplidis.

---

From: Greg Wood <[email-masked]>
Date: Tue, 12 Apr 2022 10:57:34 -0400

Hello!

With many thanks to Rich for picking this up and to you for the reply, you and your students might find a few new-since-last-year resources interesting:

https://authors.ietf.org

and

https://author-tools.ietf.org

also, this webpage:

https://www.ietf.org/standards/rfcs/

was recently revised, including a link to this blog post, which might be useful:

https://www.ietf.org/blog/how-read-rfc/

In any case, I would be very interested in talking about this further.

Regards,

-Greg

> On 11, Apr2022, at 18:14, <[email-masked]> <[email-masked]> wrote:
> 
> Greetings,
> 
> On a course on Internet Protocols at the University of Piraeus (https://www.ds.unipi.gr/en/courses/internet-protocols-2/), Professor Rouskas and I, have begun a series of laboratory exercises where we want our students to become adept at being able to read and implement internet protocol specification documents, specifically from the IETF.
> 
> _______________________________________________
> Emo-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emo-dir

---

From: <[email-masked]>
Date: Thu, 14 Apr 2022 17:49:21 +0300

Greetings Greg,

Thanks for your email, and I also would like to thank Rich for reviving this thread (I should have done that in the previous email!).

Thank you for your pointers, while we were aware of xml2rfc and other tools for authoring IETF documents, we were not aware of those resources being brought together. We are thinking of how to incorporate these tools in our course.

As per our initial email, our initial goal in this venture is to familiarize our students with the IETF format and make them able to read, understand and implement a small networking protocol. Keep in mind that our target audience, for that specific course, are undergraduate students.

So, we were discussing the possibility of co-creating a couple of very basic introductory IETF documents, published by the edu-team, with the sole purpose of providing outreach educational material to interested academic institutions that would like to train their students in reading, implementing, and understanding the IETF RFC series. While this is the second year we have integrated this work in our curriculum, it would be more beneficial for us and our students to have simple and basic IETF RFCs that they can work on.

We do understand that the role of the edu-team of the IETF is to provide materials for the attendees, however we're asking to see whether it may be of interest to the community to increase the scope of the charter to provide educational material outside of the IETF members. We would be very interested in collaborating in such a context with both writing documents as well as using these into our course.

Regards,
Evangelos.

-----Original Message-----
From: Greg Wood <[email-masked]> 
Sent: Τρίτη, 12 Απριλίου 2022 17:58
To: [email-masked]
Cc: Salz, Rich <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Emo-dir] [edu-team] Educational RFCs

Hello!

https://authors.ietf.org

and

also, this webpage:

Regards,

-Greg