Subject: [Emo-dir] draft IETF journal article

From: Karen O'Donoghue <[email-masked]>
Date: Fri, 9 Jun 2017 22:08:43 +0000

Folks,

Here is an article for the IETF Journal on the directorate that I wrote at the last minute today. I may have a small window for corrections / additions on Monday. Please review and send comments. Sorry for the short timeline. I volunteered the article at the last minute. 

Karen

**********
Education and Mentoring Directorate Established

The IETF is a very large diverse community with a large body of technical work, a unique culture, and an amazing collection of tools and information to support the community. The community is globally distributed with remote participation a growing component of this community. There are many challenges in providing the right information to the right people at the right time to help them as they endeavor to contribute to the community. Especially challenging is encountering the community for the first time as a newcomer. Just prior to IETF 98, a new directorate was formed to help focus on some of these challenges and to provide better coordination across all the various activities ongoing in this space. This article provides an overview of the current activities of the directorate and solicits volunteers to help with the many varied projects.  

Introduction to the Directorate

The Education and Mentoring Directorate has three primary goals: 1) to enhance the productivity of IETF work; 2) to expand diversity and inclusiveness of the IETF; and 3) to enable the IETF to facilitate technical development and innovation in the Internet.

In support of these goals, this directorate will structure and guide the development of educational activities and associated materials to be more accessible, relevant, reusable, and broadly understandable. The directorate will also help the mentoring activities to focus on the establishment of relationships that enable productive participation in the IETF. Next, the directorate will serve as a coordination function for IETF related outreach activities, directed at participants, ensuring that related activities are sufficiently coordinated and have the necessary education and mentoring program support. And finally, the directorate will work on improved metrics and measurements for assessing the effectiveness of directorate activities.

This directorate serves the General (GEN) area in IETF. The participants include project leaders of the various education, mentoring, and outreach coordination projects, the IESG liaison to educational activities, the IETF chair, the IETF executive director, liaisons to the Tools team and ISOC outreach programs, and additional members selected as needed. The plan is that the directorate itself will focus on coordination and light weight project management, and the individual projects will have larger teams of volunteers for the execution of the various projects.

Projects of the Directorate

The projects of the directorate are divided into three general areas with two cross cutting initiatives. The general areas are education, mentoring, and outreach coordination with the cross cutting initiatives being metrics and analysis and improving the newcomer’s experience.

The education projects are focused on providing training materials for newcomers and long time IETF participants. This includes the Sunday tutorials, the online materials, and the working group chairs forum. In addition to executing the ongoing program of tutorials, this includes projects that are looking at ways to improve the education materials for better online access.

There are also a number of projects related to mentoring and newcomer outreach. The IETF runs a full mentor program that matches mentors with mentees based on desired outcomes and interests. In addition, lighter weight activities like speed mentoring and a newcomer’s dinner are provided. These are all targeted at helping to make sure that IETF newcomers are quickly integrated into the community.

Next, there are a set of activities that are looking at building physical communities beyond the IETF meeting. They might be groups of people gathering together to participate remotely in an IETF. They might also be local community groups of IETF participants gathering outside an IETF meeting for further collaboration. There are a number of exciting ideas about extending and strengthening the IETF community.

Cross cutting the three areas of projects above are two efforts looking at monitoring and evaluating the efficiency and effectiveness of these projects. The first is looking at improving the newcomer experience across the IETF including the website, training, registration, interaction with working groups, etc. What do newcomer’s need to become effective contributors, and what can the IETF community do to meet these needs. Closely related to the newcomer effort, is a task looking at identifying metrics and monitoring the effectiveness of all these programs. Resources are valuable, and we need to focus first on the projects that offer the biggest benefit while still be executable with the resources available.

Further details on the various projects can be found on the wiki (https://trac.ietf.org/trac/edu/wiki/EduMProjects).

How you can help?

Speaking of resources, there are many opportunities for members of the IETF community to contribute. Below are just some ideas. For any comments, suggestions, or volunteering, please send email to the directorate mailing list ([email-masked]) or catch any of the directorate members in the hallway at IETF 99!

Are you working on a new and exciting technology in the IETF that you are willing to share with a broader audience in a one hour Sunday tutorial? Recent excellent examples include DNS Privacy ( https://www.youtube.com/watch?v=2JeYIecfwdc) and QUIC (https://www.youtube.com/watch?v=lPSTcBITbvs )!

Do you have expertise in technical training that can be used to help us improve our online materials?

Do you have expertise in metrics and survey design approaches that can be used to help us evaluate how we are doing with our various programs?

Are you a relatively new participant to the IETF (in the last two years) that is willing to provide feedback on how the quality of the programs for IETF address the needs of newcomers?

Are you a remote participant either individually or via a remote hub that is willing to help us improve those experiences.

Are you a seasoned IETF participant who is willing to help provide guidance to newcomers via either the regular mentoring or speed mentoring programs?

Are you frustrated by the difficulty in locating the information you need on the various IETF platforms (website, datatracker, tools) and are willing to help with review and reorganization of these materials?

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Sat, 10 Jun 2017 12:11:46 +0000

Hi Karen,

Great idea to do this for the journal. Looks really good - I forwarded to the IESG if they have any quick comments.

Deborah
IESG Liaison

Sent from my iPhone

> On Jun 9, 2017, at 6:12 PM, Karen O'Donoghue <[email-masked]> wrote:
> 
> Folks,
> 
> <IETF Journal - EduM directorate.docx>
> _______________________________________________
> Emo-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emo-dir

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 12 Jun 2017 11:45:46 +0200

Hi Karen,

Sounds good. Thanks for putting this together.

Mirjam