Subject: [drinks] DRAFT minutes of the DRINKS design team call on May 30 2012.

From: Alexander Mayrhofer <[email-masked]>
Date: Thu, 31 May 2012 13:18:48 +0000

DRAFT minutes DRINKS design team call May 30 2012
=================================================

May 30 2012, 10am - 11am eastern

Participants
------------

- Vikas Bhatia
- Manjul Maharishi
- David Schwartz 
- Alexander Mayrhofer
- Syed Ali
- Ken Cartwright
- Sumanth Channabasappa 

ACTION ITEMS
------------

- continue discussion of open items

Agenda
------

1/ Work on documented open issues

Minutes
-------

Sumanth opens the call - runs through last week notes.

Alex summarizes decisions from last week.

Vikas mentions that the decision whether egress route was to be associated
with rte grp instead of rte rec was pending.

Alex asks whether the design team would be ok with chaing egr rte from 
rte rec to rte grp.

Sumanth brings up the respective email from vikas, group is ok with the change,
including the svcs addition (alex mentions that the svcs field semantics 
need to be clearly defined). The team agrees to the two changes.

-> Decision: change association of egress route from route record to route 
group, add "svcs" field to egress route. Clarify svcs semantics.

Target vs. location (and rte to sed rename): Vikas said they are connected,
david comments he's not sure why. 

David explains the Target/Location issue - sees a gap between SPEERMINT 
terminology and the DRINKS documents.

Alex notes that an "identification" field in the base rte rec type (optional) would allow people to choose whether or not they want to
use the "split".

Sumanth brings up david's proposal (chart):
http://www.ietf.org/mail-archive/web/drinks/current/msg01152.html

Manjul: are we trying to solve an resolution protocol problem here?
David: no, just trying to add to the provisioning side a way to 
differentiate whether the provisioned data is LUF or LRF.

Alex: concerned that people would be forced to categorize..
David: Want to force people to do it, in order to solve interopability nightmares.

Syed: Clarification that it's just *annotation*, there's no effect on the 
resolution protocol side.

Ken: please summarize issue in two sentences?

David: Trying to force the SP into removing ambiguity from the provisioned 
data. Resolution side is not affected. There's just a little bit of 
extra data in the registry.

More discussion around whether that split is useful, and options to convey it
in resolution protocols (such as terminal flag in ENUM).

Discussion whether this is in scope or not - "S" in "drinks" stands for "SIP"? 
Sumanth: Thinks we should be ok if that is annotation only.

Ken: Need to think that through, but would it be possible to make "colliding" 
annotations, such as a "gspid:" URI scheme with a "Location" type?

Syed: All we're looking is adding an additional element for annotation, in 
order to distinguish the types.

Sumanth: Call on Fri? 
Group: Let's do Thur - new call tomorrow.

Discussion about whether sub-typing or attribute would be the easier way. 
Alex feels that subtyping is pretty strict (Ken agrees), David thinks 
being strict can be an advantage. No conclusion here.

Call concludes after an hour, next call on Thu, May 31.

---

From: David Schwartz <[email-masked]>
Date: Thu, 31 May 2012 16:47:37 +0300

Here is a possible snippet for my Action Item…

<simpleType name="SEDCategoryType">
  <restriction base="token">
    <enumeration value="location"/>
    <enumeration value="target"/>
    <enumeration value="unspecified"/>
  </restriction>
</simpleType>

<complexType name="SEDRecType" abstract="true">
  <complexContent>
    <extension base="sppfb:BasicObjType">
      <sequence>
        <element name="sedName" type="sppfb:ObjNameType"/>
        <element name="sedCategory" type="sppfb:SEDCategoryType" />
        <element name="isInSvc" type="boolean"/>
        <element name="ttl"
                 type="positiveInteger" minOccurs="0"/>
      </sequence>
    </extension>
  </complexContent>
</complexType>

:D

On May 31, 2012, at 4:18 PM, Alexander Mayrhofer wrote:

Participants
------------

- Vikas Bhatia
- Manjul Maharishi
- David Schwartz
- Alexander Mayrhofer
- Syed Ali
- Ken Cartwright
- Sumanth Channabasappa

ACTION ITEMS
------------

Agenda
------

Minutes
-------

Sumanth: Call on Fri?

Call concludes after an hour, next call on Thu, May 31.
_______________________________________________
drinks mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/drinks