Subject: [drinks] Draft minutes from the DRINKS design team call (2/15)

From: "Alexander Mayrhofer" <[email-masked]>
Date: Thu, 16 Feb 2012 19:08:13 +0100

Minutes from the Design team call are included below - please review.

thanks,

Alex

IETF DRINKS DESIGN TEAM CALL 
============================
2/15/2012, 10:00a-11:00a (Eastern)/8:00a-9:00a (Mountain)
 
Participants
============
- Alexander Mayrhofer
- Dean Willis
- Vikas Bhatia
- Manjul Maharishi
- David Schwartz

AGENDA
======

1/ Discuss follow-up from interim
2/ Next Steps

REVIEWERS
=========

Alex reports that Peter St. Andre has volunteered to do a review 
of an updated revision, Chairs will inform him when a new version
is available.

DOCUMENT ACTION ITEMS
=====================

The action items identified during the Interim were clarified, and 
unassigned AIs were assigned to owners. The current list is as follows:
(I've also assigned numbers for easier reference)

Framework document
------------------

AI-1/ Address Diagram Inconsistencies (Vikas)

AI-2/ Investigate Route group offer generalization (David)

AI-3/ Propose text about structure of non-numeric PI (Ken, Vikas)
(Originally listed as "Decide on type of CoR identifier)

AI-4/ TNType to RteRecRefType pointer: reconsider (David)

AI-5/ Remove priority from RteRecBaseType (Vikas)

AI-6/ Also add isinservice flag on RteRecBaseType (Ken, David)

("Define 'service' in the base route rec type was considered obsolete)

AI-7/ Move up "ttl" field to base route rec type (Vikas)

AI-8/ Reconsider "extension" options with new info (David)

AI-9/ Consider adding "service" field to Egress Route (David)

AI-10/ Discuss on mailing list how registry handles batches (Jeremy)

AI-11/ Review Security Cons section (All)

AI-12/ Organize early expert review of Security Cons section  (Chairs)

SOAP document
-------------

AI-13/ Clarify/remove definition of transaction id type (to "Token"),
or remove definition from here (Vikas)

AI-14/ Evaluate whether to expand "Dtl" and make Type names 
consistent (Vikas)

AI-15/ Add max length to result code/message definition (Vikas)

AI-16/ Clarify behaviour/expiration of offers, include a lifecycle
Diagram? (Alex, David)

AI-17/ Internationalization/Comparison Ops (Alex)

AI-18/ Ensure internal consistency on terminology and structure (David)

AI-19/ Clarify uniqueness of object-type names (Vikas)

TIMELINE
========

Vikas indicated that there will be no update of the documents by 
3/2, and he will provide the changes by 3/10. It was also noted 
that no further comments on the documents arrived before the 
deadline of 2/10. 

Chairs will inform Peter St. Andre that a new version is not 
expected before 3/10, and will decide/discuss whether he will
review the current versions instead.

NEXT CALL
=========
2/22/2012, 10:00a-11:00a (Eastern)/8:00a-9:00a (Mountain)

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 17 Feb 2012 00:03:20 +0000

The issue described here:

http://www.ietf.org/mail-archive/web/drinks/current/msg01111.html

should be captured and addressed.

Scott

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Alexander Mayrhofer
> Sent: Thursday, February 16, 2012 1:08 PM
> To: [email-masked]
> Subject: [drinks] Draft minutes from the DRINKS design team call (2/15)
> 
> 
> _______________________________________________
> drinks mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/drinks

---

From: "Alexander Mayrhofer" <[email-masked]>
Date: Fri, 17 Feb 2012 09:39:08 +0100

> should be captured and addressed.

Scott,

thanks for the heads up. It will be added to the AI list, and addressed
in the next revision.

Alex