Subject: [dns-dir] Service "subtypes"

From: Ralph Droms <[email-masked]>
Date: Mon, 16 Jan 2012 19:06:27 -0500

draft-ietf-nfsv4-federated-fs-dns-srv-namespace proposes the use of subtypes of the service type "_nfs"; e.g.:

_domainroot._nfs._tcp.example.com

The use of subtypes is defined in draft-cheshire-dnsext-dns-sd (currently in the RFC Ed queue), but not mentioned in RFC 2782 or RFC 6335.  I only see one reference to a "subtype" in the new service registry, http://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xml  Is there any reason to be uncomfortable with the definition of the _domainroot subtype in draft-ietf-nfsv4-federated-fs-dns-srv-namespace, as specified in the IANA Considerations section of draft-ietf-nfsv4-federated-fs-dns-srv-namespace?

- Ralph

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 17 Jan 2012 01:07:19 -0500

Yes, but I can't think of any principled way to do anything about it. 

We lost control of this means of extending the DNS ages ago.  There have been attempts to set up a registry but the fact is that a multilayer hierarchy doesn't lend itself to anything except a flat registry, or else multiple delegations. We are reproducing the registration quirks in the DNS in an IANA registry.

-- 
Andrew Sullivan 
Please excuse my clumsy thumbs. 

On 2012-01-16, at 19:06, Ralph Droms <[email-masked]> wrote:

> _______________________________________________
> dns-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-dir