Subject: [dispatch] dispatching draft-campbell-sip-messaging-smime

From: Cullen Jennings <[email-masked]>
Date: Thu, 7 Dec 2017 20:40:06 -0700

From all the discussions so far, it seems the most logical path for this draft is AD sponsor. If anyone has any strong objections to this draft being AD sponsored, please let us know by Dec 14. 

Thanks, Cullen <with my co-chair hat on>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 8 Dec 2017 07:18:06 +0000

Hi,

I have no problem with AD sponsored, but we should make sure that at least
SIPCORE reviews the draft before publication.

Regards,

Christer

On 08/12/17 05:40, "dispatch on behalf of Cullen Jennings"
<[email-masked] on behalf of [email-masked]> wrote:

>
>From all the discussions so far, it seems the most logical path for this
>draft is AD sponsor. If anyone has any strong objections to this draft
>being AD sponsored, please let us know by Dec 14.
>
>_______________________________________________
>dispatch mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dispatch

---

From: Brian Rosen <[email-masked]>
Date: Fri, 8 Dec 2017 09:56:10 -0500

We’ll do that.  We could probably also take it on if it’s decided that’s best. 

Brian

> On Dec 8, 2017, at 2:18 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>

---

From: Mary Barnes <[email-masked]>
Date: Mon, 11 Dec 2017 14:47:59 -0600

As an individual, I have a slight preference for a mini WG as I think that
would make it easier for this to get on the radar of security folks before
it goes through IETF LC.  The whole notion of a mini WG was to provide a
lightweight process for work that might be of a bit broader interest than
other drafts we have AD sponsored in the past that are of more interest to
a narrower group (e.g., 3GPP specific docs).

And, yeah, I know that we likely have the most expert people in IETF
working on this, but in the spirit of transparency I don't necessarily
think that's the highest priority factor when we determine how to dispatch
work items.

Regards,
Mary.

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 12 Dec 2017 08:48:07 +0000

Hi,

> As an individual, I have a slight preference for a mini WG as I think that would make it easier for this to get on the radar of security folks before it goes through IETF LC.  The
> whole notion of a mini WG was to provide a lightweight process for work that might be of a bit broader interest than other drafts we have AD sponsored in the past that are of more interest to a narrower group (e.g., 3GPP specific docs).
>
> And, yeah, I know that we likely have the most expert people in IETF working on this, but in the spirit of transparency I don't necessarily think that's the highest priority factor when we determine how to dispatch work items.

While the protocol experts may be in IETF, some major users of the protocols are outside IETF. For example, I got feedback of the –00 version by one of my GSMA colleagues, forwarded it to the author, and it has now been addressed in section 9.1 of the –01 version.

But again, as long as we make sure the appropriate people are made aware of the draft, and will have an opportunity to review it before publication, I have no strong feelings whether it’s done as AD sponsored, within a mini-WG or within an existing WG. Same people :)

Regards,

Christer

_______________________________________________
dispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Mary Barnes <[email-masked]>
Date: Tue, 12 Dec 2017 12:07:33 -0600

Well, you missed my point that it might not be the "same people" if we have
a mini-WG that has S/MIME in the WG name.  I would think that we might get
a few more security folks from the outset as opposed to getting
*additional* input from security folks during IETF LC when they do the
SecDIR review.  Again, I realize that with Russ as a author, there likely
will not be issues. But, I still think broader input from the security
community isn't a bad thing.

Mary.

On Tue, Dec 12, 2017 at 2:48 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> > As an individual, I have a slight preference for a mini WG as I think
> that would make it easier for this to get on the radar of security folks
> before it goes through IETF LC.  The
> > whole notion of a mini WG was to provide a lightweight process for work
> that might be of a bit broader interest than other drafts we have AD
> sponsored in the past that are of more interest to a narrower group (e.g.,
> 3GPP specific docs).
> >
> While the protocol experts may be in IETF, some major users of the
> protocols are outside IETF. For example, I got feedback of the –00 version
> by one of my GSMA colleagues, forwarded it to the author, and it has now
> been addressed in section 9.1 of the –01 version.
>
> But again, as long as we make sure the appropriate people are made aware
> of the draft, and will have an opportunity to review it before publication,
> I have no strong feelings whether it’s done as AD sponsored, within a
> mini-WG or within an existing WG. Same people :)
>
> Regards,
>
> Christer
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 12 Dec 2017 20:26:23 +0000

Hi,

>Well, you missed my point that it might not be the "same people" if we have a mini-WG that has S/MIME in the WG name.
>I would think that we might get a few more security folks from the outset as opposed to getting *additional* input from security
>folks during IETF LC when they do the SecDIR review.  Again, I realize that with Russ as a author, there likely will not be issues.
>But, I still think broader input from the security community isn't a bad thing.

All I care about is making sure that the appropriate people get to review the document. I’ll let others decide what the best way to achieve that is :)

Regards,

Christer

On Tue, Dec 12, 2017 at 2:48 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Mon, 18 Dec 2017 14:06:03 -0600

(Strictly as an individual contributor.)

I will be surprised if there are enough participants to make even a mini-WG worthwhile. While the discussion in Singapore shows a number of people interested in secure messaging in general (BTW, Yay!), far fewer were interested in participating for this particular document. I recall 4 people (other than the authors) saying they were interested in helping. 2 of those have already offered feedback, and IIRC one of them was an AD (but I could be mistaken on that part.) Once you assign (a) WG chair(s), that's not many participants left to do the work.

I see the point that a WG with S/MIME in the name may bring in some more security experts. But I’m guessing we are talking about 1 or 2, not dozens. Similar levels of review could be achieved for an AD sponsored draft by the AD asking for some targeted reviews.

But in any case, I am happy to accept whatever approach DISPATCH and the remaining ART ADs prefer. (I will of course recuse myself from that decision.)

Thanks!

Ben.

> On Dec 12, 2017, at 12:07 PM, Mary Barnes <[email-masked]> wrote:
> 
> Well, you missed my point that it might not be the "same people" if we have a mini-WG that has S/MIME in the WG name.  I would think that we might get a few more security folks from the outset as opposed to getting *additional* input from security folks during IETF LC when they do the SecDIR review.  Again, I realize that with Russ as a author, there likely will not be issues. But, I still think broader input from the security community isn't a bad thing.
> 
> Mary.
> 
> On Tue, Dec 12, 2017 at 2:48 AM, Christer Holmberg <[email-masked]> wrote:
> Hi,
>

---

From: Adam Roach <[email-masked]>
Date: Mon, 18 Dec 2017 14:09:55 -0600

Before I weigh in on the topic: did I miss some new information that we 
uncovered after DISPATCH agreed to adopt this document that would be the 
basis for reversing that consensus?

/a

---

From: Adam Roach <[email-masked]>
Date: Mon, 18 Dec 2017 14:11:31 -0600

Sorry; I was reading too quickly, and mixed this document up with 
draft-ietf-dispatch-javascript-mjs. Please ignore my previous message.

/a

On 12/18/17 2:09 PM, Adam Roach wrote:
> Before I weigh in on the topic: did I miss some new information that 
> we uncovered after DISPATCH agreed to adopt this document that would 
> be the basis for reversing that consensus?
>
> /a
>
>>> On Dec 12, 2017, at 12:07 PM, Mary Barnes<[email-masked]>  wrote:
>>>
>>> On Tue, Dec 12, 2017 at 2:48 AM, Christer Holmberg<[email-masked]>  wrote:
>>> Hi,
>>>
>>> On Thu, Dec 7, 2017 at 9:40 PM, Cullen Jennings<[email-masked]>  wrote:
>>>