Subject: Re: [dispatch] draft-petithuguenin-ice-pmtud-00

From: Cullen Jennings <[email-masked]>
Date: Wed, 1 Mar 2017 11:00:54 -0700

So it seems like this would be in scope for TRAM. Would it make sense to just send it there or do you think we should consider other places for it?

> On Feb 18, 2017, at 4:46 PM, Marc Petit-Huguenin <[email-masked]> wrote:
> 
> Dear Dispatch,
> 
> I would like 5 minutes to present draft-petithuguenin-ice-pmtud-00 (not yet published) during the dispatch session.  This draft started with the ICE specific stuff that was removed from draft-ietf-tram-stun-pmtud-02, with the goal of defining a usage of stun-pmtud to discover the Path MTU for an RTP/RTCP session.
> 
> Thanks.
> 
> -- 
> Marc Petit-Huguenin
> Email: [email-masked]
> Blog: https://marc.petit-huguenin.org
> Profile: https://www.linkedin.com/in/petithug
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 2 Mar 2017 05:20:49 -0800

> So it seems like this would be in scope for TRAM. Would it make sense to just send it there or do you think we should consider other places for it?

The subject of this draft is "How to do PMTUD with RTP" aka "how much video can I safely stuff in an RTP packet".  Using STUN as the mechanism to discover the MTU in the path of the RTP packets is not central to this discussion, but as a transport to collect the packets identifiers (i.e. to implement RFC 4821).  So it could be AVTCore (or whatever it will be called after it reabsorbs payload and avtext).  We will also need a way to signal that an endpoint supports that feature and that's a new SDP attribute.  So it could be MMUSIC.  But maybe getting a larger Path MTU could be used to prioritize ICE.  So it could be in the ICE WG.  But at the end the only people who will probably care about this stuff are RTCWeb peple, not SIP people.  So maybe WebRTC.  Hence going to Dispatch to figure that out.

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 13 Mar 2017 06:22:17 -0700

I just submitted the draft: https://datatracker.ietf.org/doc/draft-petithuguenin-dispatch-rtp-pmtud/

Comments are welcome.

Cullen, you may want to update the DISPATCH agenda with the new name of the draft.

Thanks.