Subject: [dispatch] Questions regarding draft-petithuguenin-dispatch-rtp-pmtud-00

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Mar 2017 14:20:55 +1100

This draft would appear to be firmly in the MMUSIC working group
remit.  I note that the ICE working group defines mechanisms for ICE,
and MMUSIC defines SDP.  Since this really only uses a mechanism that
is defined in TRAM, the only new protocol pieces here are some SDP,
which MMUSIC is good at.

I see that this is a new -00 draft, so maybe it's just too new to have
been discussed.  Was it rejected from those groups?

On the details, ice-options is a better place to signal this.  Drop
the abominable x- prefix at the same time.

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 21 Mar 2017 03:29:18 -0700

> is defined in TRAM, the only new protocol pieces here are some SDP,

Yes.

> been discussed.  Was it rejected from those groups?

No, this draft comes from some bits that we removed from draft-ietf-tram-stun-pmtud when we found out that the usage for RTP (or ICE or whatever) was too under-defined to be useful.  I also see that document as a blueprint on how to specify a PMTUD extension to an existing protocol.  This is the first appearance of the idea of doing PMTUD for RTP sessions in this form.

> the abominable x- prefix at the same time.

I am not sure about the ice-options (I agree with the x- prefix), as an ice-options would restricts the signaling to ICE.  It's probably safe to say that WebRTC will be the main user of that draft, but may be SIP would like to use that too without ICE.  Hence Dispatch.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 21 Mar 2017 06:39:15 -0700

>> is defined in TRAM, the only new protocol pieces here are some SDP,

I withdraw that "yes".  It is also about finding the right bytes in all the packets exchanged (RTP, RTCP, STUN, even DTLS?) to be able to match the list of packets sent with the list of identifiers that will be sent back in the Report response.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Mar 2017 13:09:52 +1100

> I withdraw that "yes".  It is also about finding the right bytes in all the packets exchanged (RTP, RTCP, STUN, even DTLS?) to be able to match the list of packets sent with the list of identifiers…

Sounds like a good reason not to ask MMUSIC to do this (assuming the
other necessary conditions are met).  The SDP part becomes minor
compared to that.