Subject: [dispatch] rfc5988bis

From: Mark Nottingham <[email-masked]>
Date: Mon, 13 Feb 2017 13:03:08 +1100

Hi DISPATCH,

Could I please have ~15 minutes in Chicago to present proposed changes to RFC5988, with an eye towards finding an appropriate home for the work?

I've briefly mentioned this before, would appreciate a bit more time to go into detail and have the discussion.

Draft:
  https://tools.ietf.org/html/draft-nottingham-rfc5988bis-04

Thanks,

--
Mark Nottingham   https://www.mnot.net/

---

From: Martin J. Dürst <[email-masked]>
Date: Mon, 13 Feb 2017 11:42:37 +0900

> Could I please have ~15 minutes in Chicago to present proposed changes to RFC5988, with an eye towards finding an appropriate home for the work?

For those who don't want to look this up, nor are able to remember all 
the RFC numbers and their topics, RFC 5988 is "Web Linking".

Regards,   Martin.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 15 Feb 2017 06:03:15 -0700

Yes, we can have some agenda time for this. What should the agenda say about Web Linking ? Is there a draft ? charter proposal ? 

> On Feb 12, 2017, at 7:42 PM, Martin J. Dürst <[email-masked]> wrote:
> 
> For those who don't want to look this up, nor are able to remember all the RFC numbers and their topics, RFC 5988 is "Web Linking".
> 
> Regards,   Martin.
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 16 Feb 2017 09:48:32 +1100

> On 16 Feb 2017, at 12:03 am, Cullen Jennings <[email-masked]> wrote:
> 
> 

See my original message below for a link to the draft.

Straw-man charter:

---8<---
WG Name: 5988bis
Acronym: 5988bis
Area: ART
Area Director: TBD
Chair: TBD

RFC5988 "Web Linking" has seen extensive deployment since publication. Since that time, various clarifications, corrections and operational issues have been noticed. 

This Working Group will publish a "bis" document for RFC5988, focusing on clarifying the document and registry operation. 

Its focus will be on preserving interoperability with existing deployments of web linking, especially the `Link` HTTP header fields, HTML5 and Atom. Changes that are backwards-incompatible with RFC5988 are acceptable, provided that the Working Group judges there is sufficient motivation, and that such changes do not break compatibility with Web linking as widely deployed.

The only deliverable of this Working Group is a RFC5988bis document.

Topics that are out of scope for this Working Group include:

* Defining new features, capabilities or registries
* Defining new link relation types
* Defining new target attributes
* Defining new link serialisations

The Working Group will use draft-nottingham-rfc5988bis-04 as a starting point for its work. Doing so does not imply consensus on the contents of that document.

## Milestones

Chartering+3 months -- Submit RFC5988bis to IESG for consideration as a Standards-Track document

--->8---