Subject: [dispatch] NGMTP Class 9 Questions & Answers

From: Anton Tveretin <[email-masked]>
Date: Sat, 07 Jan 2017 21:51:56 +0500

Hello All,
I have published a small memo for the format of payment documents. This is not the actual specification.
Direct URL: http://www.fit-rulez.narod.ru/ngmtp/ngmtp_c9_qa.html
In the past, both work groups showed interest in these.
Regards,
Anton

---

From: KETELS Kris <[email-masked]>
Date: Mon, 9 Jan 2017 13:06:49 +0000

Anton,

SWIFT MT is totally different from ISO 15022. SWIFT uses a proprietary syntax for all its messages, except category 5 (securities) which uses ISO 15022.
SWIFT MX is not the same as ISO 20022.
ISO 20022 is far more than a syntax, let alone XML. It is a modeling methodology and a repository of conceptual semantic concepts, BusinessProcesses, BusinessTransactions and messages. Its layered design makes its logical models syntax independent, allowing for the generation of XML, ASN1 and now also JSON from that same logical model, fostering thus interoperability between different syntaxes. We are as we speak extending ISO 20022 to model following RESTful architectural design principles.

BTW I have no clue why you attach the note 'XML must die' to SWIFT MX ISO 20022.

Please be informed about a standard before judging it. I would happily inform you or give you a crash course on what ISO 20022 is really about.

regards
Kris Ketels

-----Original Message-----
From: Anton Tveretin [mailto:[email-masked]] 
Sent: 07 January 2017 22:34
To: DISPATCH list; [email-masked]
Subject: NGMTP Class 9 Questions & Answers

Hello All,

---

From: KETELS Kris <[email-masked]>
Date: Mon, 9 Jan 2017 13:58:11 +0000

May be good to complete that SWIFT uses a proprietary syntax for all its MT messages. MX covers SWIFT specific and ISO 20022 messages.

-----Original Message-----
From: KETELS Kris 
Sent: 09 January 2017 14:07
To: Anton Tveretin; DISPATCH list; [email-masked]
Cc: KETELS Kris
Subject: RE: NGMTP Class 9 Questions & Answers

Anton,

regards
Kris Ketels

-----Original Message-----
From: Anton Tveretin [mailto:[email-masked]] 
Sent: 07 January 2017 22:34
To: DISPATCH list; [email-masked]
Subject: NGMTP Class 9 Questions & Answers

Hello All,

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Tue, 10 Jan 2017 15:26:58 +0000

So the sit you are using plays really weird video adds and content that my corporate firewall marks as bad. Any chance you could just send an email to the list or publish a draft. 

Thanks

> On Jan 7, 2017, at 9:51 AM, Anton Tveretin <[email-masked]> wrote:
> 
> Hello All,
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 12 Jan 2017 21:54:59 +0000

So the site you sent plays weird video advertisements and content that my corporate firewall marks as bad. Any chance you could just send an email to the list or publish a draft. 

Thanks