Subject: [dispatch] OID Tags for CBOR, and CBOR update New Version Notification for draft-bormann-cbor-tags-oid-03.txt

From: Sean Leonard <[email-masked]>
Date: Fri, 1 Jul 2016 17:12:30 -0700

Greetings DISPATCH:

Wanted to let folks know that Carsten and I have posted draft-bormann-cbor-tags-oid-03, which updates CBOR to support Object Identifiers and Relative Object Identifiers, along with diagnostic notation. It also has some semantic changes and corrections to tagged items in CBOR, that escaped review in RFC 7049. (There are no changes to the “core” features of CBOR on the wire.) Appendix A lists the changes.

Since this is DISPATCH, I guess the question is: where does it go from here? Thanks.

(Note: Carsten and I discussed the changes in this draft compared to -02; however, I am the author of most of the content. Therefore any controversies in the details of the draft are probably my responsibility rather than his. A future draft update may mellow subsequent issues out.)

Regards,

Sean

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-bormann-cbor-tags-oid-03.txt
> Date: July 1, 2016 at 4:54:26 PM PDT
> 

A new version of I-D, draft-bormann-cbor-tags-oid-03.txt
has been successfully submitted by Sean Leonard and posted to the
IETF repository.

Name:		draft-bormann-cbor-tags-oid
Revision:	03
Title:		Concise Binary Object Representation (CBOR) Tags for ASN.1 Object Identifiers, and Omnibus Corrections and Techniques
Document date:	2016-06-30
Group:		Individual Submission
Pages:		29
URL:            https://www.ietf.org/internet-drafts/draft-bormann-cbor-tags-oid-03.txt
Status:         https://datatracker.ietf.org/doc/draft-bormann-cbor-tags-oid/
Htmlized:       https://tools.ietf.org/html/draft-bormann-cbor-tags-oid-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-bormann-cbor-tags-oid-03

Abstract:
  The Concise Binary Object Representation (CBOR, RFC 7049) is a data
  format whose design goals include the possibility of extremely small
  code size, fairly small message size, and extensibility without the
  need for version negotiation.

  The present document makes use of this extensibility to define CBOR
  tags <<O>> and <<R>> [values TBD] for ASN.1 object identifiers.  It
  is intended as the reference document for the IANA registration of
  the CBOR tags so defined.  This document also provides other
  corrections and improvements to CBOR.

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 2 Jul 2016 08:24:27 +0200

Whoa.

This is what you get for letting a co-author charge ahead on a draft without having time for review.

This document also provides other 
corrections and improvements to CBOR. 
For the record, I don’t believe CBOR needs “corrections and improvements”.  At all.

(I still have to read the rest of the new text in the document.)

Grüße, Carsten