Subject: [dispatch] comments on draft-bhjl-x509-srv-00

From: Cullen Jennings <[email-masked]>
Date: Sat, 23 Jul 2016 03:39:49 -0600

I like the general idea of this and it seems very good timing as we get close to LetsEncrypt providing free certs for email. My preference would be for this to be general enough that it worked for other things such and xmpp and sip that use email style addresses. They face the same problem of how to discover the recipients certificate. 

In the end, the security seems like it has to be based on how the sender trying to reach [email-masked] <mailto:[email-masked]> decides the certificate retrieved is valid for that user or not. I’d certainly want to be able to use it in a mode where I did not need to trust the server that cached the cert (or the HTTPS or DNS leading to that), but as long as I got a cert signed by a trusted CA for the correct user, then it could be used to encrypt. 

I’m also a fan of the approach where if the HTTPS server has a cert for the domain example.com <http://example.com/>, then it can use that cert to sign the actual email certs for [email-masked] <mailto:[email-masked]>. 

Cullen

---

From: "John Levine" <[email-masked]>
Date: 23 Jul 2016 15:53:22 -0000

>I like the general idea of this and it seems very good timing as we get close to LetsEncrypt
>providing free certs for email. My preference would be for this to be general enough that it worked
>for other things such and xmpp and sip that use email style addresses. They face the same problem of
>how to discover the recipients certificate. 

The cert lookup in the draft has little to do with e-mail beyond the
fact that the lookup keys are (or look like) e-mail addresses.  RFC 4387
only provides for S/MIME and PGP cert lookups.  If you can use an S/MIME
cert for xmpp or sip, perhaps that's all you need.

>I’m also a fan of the approach where if the HTTPS server has a cert for the domain example.com
><http://example.com/>, then it can use that cert to sign the actual email certs for
>[email-masked] <mailto:[email-masked]>. 

This is the semantic pit of despair I mentioned a few messages ago.
Some domains are authoritative sources of information for their e-mail
users, some aren't, and I don't see any mechanical way to tell the
difference.

For e-mail, the main use of a cert lookup would be to send encrypted
mail to someone who's never written to you.  In that scenario, between
sending plain text and encrypting to a cert that might be the user's
or might be a MITM from his e-mail provider, even the latter doesn't
make things worse.

R's,
John