Subject: [dispatch] AD sponsoring draft-jimenez-p2psip-coap-reload

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 2 Jul 2014 15:27:52 +0300

Folks,

the draft below, which relates to both P2PSIP and IoT, has been
discussed in both the RELOAD and CoAP communities. In particular, it
was presented at the Paris IETF in the P2PSIP WG and received positive
feedback.

http://datatracker.ietf.org/doc/draft-jimenez-p2psip-coap-reload/

As you know, RELOAD took a little more time than originally planned to
get published as an RFC. Now that RELOAD has been published, we can
progress this draft.

We have discussed with the RAI ADs and P2PSIP chairs and at this point
the plan is not to add more WG items to the P2PSIP WG. Instead, one of
the RAI ADs (Richard) will AD sponsor this draft with one of the P2PSIP
chairs (Carlos Jesus) acting as its shepherd. Given that the draft spans
two communities, as part of the shepherding process we are getting
dedicated reviewers from both the RELOAD and the CoAP communities.

If somebody here in DISPATCH has additional comments, please share them.

Thanks,

Gonzalo

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 2 Jul 2014 15:29:31 +0000

Is the intention with AD sponsoring that this moves to become an informational document, or does it remain standards track.

Keith 

> -----Original Message-----
> From: dispatch [mailto:[email-masked]] On Behalf 
> Of Gonzalo Camarillo
> Sent: 02 July 2014 13:28
> To: [email-masked]
> Cc: [email-masked]; Carlos 
> Jesus Bernardos Cano
> Subject: [dispatch] AD sponsoring draft-jimenez-p2psip-coap-reload
> 
> Folks,
> 
> the draft below, which relates to both P2PSIP and IoT, has 
> been discussed in both the RELOAD and CoAP communities. In 
> particular, it was presented at the Paris IETF in the P2PSIP 
> WG and received positive feedback.
> 
> As you know, RELOAD took a little more time than originally 
> planned to get published as an RFC. Now that RELOAD has been 
> published, we can progress this draft.
> 
> We have discussed with the RAI ADs and P2PSIP chairs and at 
> this point the plan is not to add more WG items to the P2PSIP 
> WG. Instead, one of the RAI ADs (Richard) will AD sponsor 
> this draft with one of the P2PSIP chairs (Carlos Jesus) 
> acting as its shepherd. Given that the draft spans two 
> communities, as part of the shepherding process we are 
> getting dedicated reviewers from both the RELOAD and the CoAP 
> communities.
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 2 Jul 2014 11:31:49 -0400

My initial inclination is to keep it Standards Track, since it defines
protocol.  But if you have concerns, I'm open.

On Wed, Jul 2, 2014 at 11:29 AM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> Is the intention with AD sponsoring that this moves to become an
> informational document, or does it remain standards track.
>
> Keith
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 3 Jul 2014 09:01:03 +0300

Hi Keith,

yes, as Richard indicated below, it will be a PS. This is so because of
the IANA policy defined by RELOAD for Kind-IDs.

    http://tools.ietf.org/html/rfc6940#section-14.6

kind-IDs are registered using Standards Action. That is,
"Values are assigned only for Standards Track RFCs approved by the
IESG)".

Since the draft registers two new Kind-IDs (Sections 11.2 and 11.3), it
needs to be progressed as a PS.

Cheers,

Gonzalo

On 02/07/2014 6:31 PM, Richard Barnes wrote:
> On Wed, Jul 2, 2014 at 11:29 AM, DRAGE, Keith (Keith)
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> 
>     > From: dispatch [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf
>     > Of Gonzalo Camarillo
>     > Sent: 02 July 2014 13:28
>     > To: [email-masked] <mailto:[email-masked]>
>     > Cc: [email-masked]
>     <mailto:[email-masked]>; Carlos
>     > Jesus Bernardos Cano
>     > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 3 Jul 2014 10:00:01 +0000

The reason for my question in the first place is that the mail did not say what track would be used. While there is no requirement for it to be so, documents for AD sponsporing are frequently informational, and in some cases have been downgraded to informational at this point.

What I would have expected is some discussion in Richard's mail as to why it was appropriate that it could be AD sponsored rather than handled by a WG. I would have expected to hear statements like it does not introduce any new significant technical steps that will require discussion at WG level to ensure the correct technical solution exists.

I find the statement that it has to be AD sponsored because we want to get rid of the working group does not really fulfil that need. Rather I would have said, if it needs WG discussion, then you have to solve it.

So does it need to be a WG document, or is AD sponsored sufficient?

Keith 

> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: 03 July 2014 07:01
> To: Richard Barnes; DRAGE, Keith (Keith)
> Cc: [email-masked]; 
> [email-masked]; Carlos Jesus 
> Bernardos Cano
> Subject: Re: [dispatch] AD sponsoring draft-jimenez-p2psip-coap-reload
> 
> Hi Keith,
> 
> yes, as Richard indicated below, it will be a PS. This is so 
> because of the IANA policy defined by RELOAD for Kind-IDs.
> 
> "Values are assigned only for Standards Track RFCs approved 
> by the IESG)".
> 
> Since the draft registers two new Kind-IDs (Sections 11.2 and 
> 11.3), it needs to be progressed as a PS.
> 
> Cheers,
> 
> Gonzalo
> 
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 3 Jul 2014 14:17:44 +0300

Hi Keith,

often times protocols survive the WG that specified them. In such cases,
some time before closing the WG down a process for specifying further
extensions to the protocol is defined.

In this case, RELOAD will likely survive the P2PSIP WG. So, we need a
process to handle RELOAD extensions after P2PSIP finishes its current WG
items. Depending on factors such as the expected number of extensions,
whether reviewers will be easy to find, etc., AD sponsoring some
extensions can be a perfectly appropriate approach. There are other
potential options as well, such as keeping the WG alive, creating
mini-WGs for each new extension, etc. I do not want to speak for the
current RAI ADs, but my understanding is that they have indeed
considered all those options.

When it comes to this particular draft, it has already been presented
and discussed in the P2PSIP WG. Additionally, it has also been discussed
within the CoAP community. That is, the technical work in the draft
includes input from both relevant communities. Additionally, as I
mentioned in my first email, we are going to get a dedicated reviewer
from each community so that they check the draft one more time.

Lastly, responding to your last question, the formal requirement for
this extension is that it needs to be a PS. So, an AD sponsored spec is
enough... and given that we have already gotten technical input from the
P2PSIP community, processing it within the WG as opposed to outside of
it does not provide any clear benefit at this point AFAICT.

Having said that, I do not really care much about the actual process we
follow here. I am flexible in that respect.

Cheers,

Gonzalo

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 3 Jul 2014 11:22:48 +0000

Thanks, that is fine.

I just think Richard should have said some of this in his original mail.

Keith 

> Sent: 03 July 2014 12:18
> To: DRAGE, Keith (Keith); Richard Barnes
> Cc: [email-masked]; 
> often times protocols survive the WG that specified them. In 
> such cases, some time before closing the WG down a process 
> for specifying further extensions to the protocol is defined.
> 
> In this case, RELOAD will likely survive the P2PSIP WG. So, 
> we need a process to handle RELOAD extensions after P2PSIP 
> finishes its current WG items. Depending on factors such as 
> the expected number of extensions, whether reviewers will be 
> easy to find, etc., AD sponsoring some extensions can be a 
> perfectly appropriate approach. There are other potential 
> options as well, such as keeping the WG alive, creating 
> mini-WGs for each new extension, etc. I do not want to speak 
> for the current RAI ADs, but my understanding is that they 
> have indeed considered all those options.
> 
> When it comes to this particular draft, it has already been 
> presented and discussed in the P2PSIP WG. Additionally, it 
> has also been discussed within the CoAP community. That is, 
> the technical work in the draft includes input from both 
> relevant communities. Additionally, as I mentioned in my 
> first email, we are going to get a dedicated reviewer from 
> each community so that they check the draft one more time.
> 
> Lastly, responding to your last question, the formal 
> requirement for this extension is that it needs to be a PS. 
> So, an AD sponsored spec is enough... and given that we have 
> already gotten technical input from the P2PSIP community, 
> processing it within the WG as opposed to outside of it does 
> not provide any clear benefit at this point AFAICT.
> 
> Having said that, I do not really care much about the actual 
> process we follow here. I am flexible in that respect.
> 
> Cheers,
> 
> Gonzalo
> 
> 
> > The reason for my question in the first place is that the 
> mail did not say what track would be used. While there is no 
> requirement for it to be so, documents for AD sponsporing are 
> frequently informational, and in some cases have been 
> downgraded to informational at this point.
> > 
> > What I would have expected is some discussion in Richard's 
> mail as to why it was appropriate that it could be AD 
> sponsored rather than handled by a WG. I would have expected 
> to hear statements like it does not introduce any new 
> significant technical steps that will require discussion at 
> WG level to ensure the correct technical solution exists.
> > 
> > I find the statement that it has to be AD sponsored because 
> we want to get rid of the working group does not really 
> fulfil that need. Rather I would have said, if it needs WG 
> discussion, then you have to solve it.
> > 
> >> yes, as Richard indicated below, it will be a PS. This is 
> so because 
> >> of the IANA policy defined by RELOAD for Kind-IDs.
> >>
> "Values are 
> >> assigned only for Standards Track RFCs approved by the IESG)".
> >>
> >> Since the draft registers two new Kind-IDs (Sections 11.2 
> and 11.3), 
> >> it needs to be progressed as a PS.
> >>
> >> Cheers,
> >>
> >> Gonzalo
> >>
> >>

---

From: Richard Barnes <[email-masked]>
Date: Thu, 3 Jul 2014 08:53:32 -0400

Sorry for the brevity in my earlier email.  Gonzalo's mail captures my
thoughts well.
--Richard