Subject: [dispatch] Announcing a MUC with RFC4575

From: Emil Ivov <[email-masked]>
Date: Sun, 21 Apr 2013 22:43:07 +0200

Hey all,

I have been looking at RFC4575 and wondering what the best way would be
for a mixer to announce that a conference has an associated chatroom
(e.g. an XMPP MUC) available at a certain address. This would allow UAs
that support MUCs can join there too.

>From what I see the most reasonable way to do this would be a
<conf-uri>, like this for example:

<conf-uris>
  <entry>
   <uri>sip:[email-masked]</uri>
   <display-text>TTI Bridge</display-text>
   <purpose>participation</purpose>
  </entry>
  <entry>
   <uri>xmpp:[email-masked]</uri>
   <display-text>Multi-User Chat 545</display-text>
   <purpose>impp-participation</purpose>
  </entry>
</conf-uris>

Another option would be to use the same <entry> but place it ina a
<service-uris> element instead:

<service-uris>
  <entry>
   <uri>http://sharepoint/salesgroup/</uri>
   <purpose>web-page</purpose>
  </entry>
  <entry>
   <uri>xmpp:[email-masked]</uri>
   <display-text>Multi-User Chat 545</display-text>
   <purpose>impp-participation</purpose>
  </entry>
</service-uris>

Does any of the above make sense? In case no other mechanism allows for
the same thing in a simpler way, then could we maybe put one of the two
on paper?

Emil
-- 
https://jitsi.org

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Mon, 22 Apr 2013 09:53:14 +0200

Hi Emil!

>   <purpose>impp-participation</purpose>

I think the above does make sense, now, would the same URI be usable with Jingle or is intended for MUC only?

> the same thing in a simpler way, then could we maybe put one of the two

This second approach would require a new entry in the IANA registry for that 'purpose' element right? In any case, this one could also make sense, I guess it depends on the scenario.

Assuming your scenario is Jitsi's use case, that is, the audio / video conference is held by some entity and the MUC by some other, IMHO this second approach makes more sense.

Regards,

--
Saúl Ibarra Corretgé
AG Projects

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Mon, 22 Apr 2013 13:29:23 +0000

Emil,

You may want to look at the following CCMP draft:
https://datatracker.ietf.org/doc/draft-yusef-dispatch-ccmp-indication/?include_text=1

We considered the two options you mentioned below and decided that the services-uris option is more appropriate.
As Saúl Ibarra Corretgé mentioned this requires IANA registration for the new purpose value, but it can be done in the same document (see section 4 of the document above).

Regards,
 Rifaat

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Saúl Ibarra Corretgé
> Sent: Monday, April 22, 2013 3:53 AM
> To: Emil Ivov
> Cc: [email-masked]
> Subject: Re: [dispatch] Announcing a MUC with RFC4575
> 
> Hi Emil!
> 
> This second approach would require a new entry in the IANA registry for
> that 'purpose' element right? In any case, this one could also make
> sense, I guess it depends on the scenario.
> 
> Assuming your scenario is Jitsi's use case, that is, the audio / video
> conference is held by some entity and the MUC by some other, IMHO this
> second approach makes more sense.
> 
> 
> Regards,
> 
> --
> Saúl Ibarra Corretgé
> AG Projects
> 
> 
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Emil Ivov <[email-masked]>
Date: Mon, 22 Apr 2013 21:22:50 +0200

Hey Rifaat, Saúl

> As Saúl Ibarra Corretgé mentioned this requires IANA registration for the new purpose value, but it can be done in the same document (see section 4 of the document above).

Just to make sure I understand: are you suggesting that you could add an
impp purpose for service-uris in the above document?

If so, then this certainly works for me!

Thanks!
Emil

-- 
https://jitsi.org

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Mon, 22 Apr 2013 19:36:36 +0000

> If so, then this certainly works for me!

No, that is not what I am suggesting.
What I am saying is that when you create your document to define your impp, you can register the new purpose value in the same document in the IANA section, similar to what we did in section 4 of our CCMP document.

Regards,
 Rifaat

> From: Emil Ivov [mailto:[email-masked]]
> Sent: Monday, April 22, 2013 3:23 PM
> To: Shekh-Yusef, Rifaat (Rifaat)
> Cc: Saúl Ibarra Corretgé; [email-masked]
> > We considered the two options you mentioned below and decided that the
> services-uris option is more appropriate.
> > As Saúl Ibarra Corretgé mentioned this requires IANA registration for
> the new purpose value, but it can be done in the same document (see
> section 4 of the document above).
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 22 Apr 2013 13:48:27 -0600

> What I am saying is that when you create your document to define your impp, you can register the new purpose value in the same document in the IANA section, similar to what we did in section 4 of o…

https://datatracker.ietf.org/doc/draft-saintandre-impp-call-info/
registers the "impp" value for Call-Info, but not for other message
header fields.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 22 Apr 2013 14:44:35 -0600

> the same thing in a simpler way, then could we maybe put one of the two

Somehow "impp-participation" doesn't sound right to me. What you're
talking about is a multiparty text conference that is associated with or
auxiliary to the main conference. It seems to me that the text
conference could be an XMPP MUC room, an IRC channel, an MSRP multiparty
chat session, etc. So I would suggest something like "groupchat" (since
the primary purpose here is multiparty text chat, not one-to-one IM and
presence as they are traditionally understood).

Peter

Peter

---

From: Emil Ivov <[email-masked]>
Date: Mon, 22 Apr 2013 22:59:29 +0200

On 22.04.13, 22:44, Peter Saint-Andre wrote:
> Somehow "impp-participation" doesn't sound right to me.

That was just a stab really. I don't really have a preference for the
name ... unless it would mean less overhead: if for example we could
have just reused the "impp" purpose from draft-saintandre-impp-call-info
then that would have been great. However, as you point out, it currently
only applies to Call-Info and we would need another draft that looks
pretty much the same way (like Rifaat suggested).

> What you're
> chat session, etc.

Correct.

> So I would suggest something like "groupchat" (since

Well, it seems to me that a URI with an "impp" purpose that has a 1-to-1
relation with a conference can only be a group chat and it would also
give us some uniformity in the naming conventions. But again, I don't
really mind what the exact name would be as long as a name is defined.

Cheers,
Emil

-- 
https://jitsi.org

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 22 Apr 2013 15:06:49 -0600

> really mind what the exact name would be as long as a name is defined.

The "impp" acronym goes back to the IMPP WG and its main output, RFC
2778 and RFC 2779, which talked about one-to-one IM and one-to-one
presence. IMHO groupchat / multiparty text conferencing / whatever you
want to call it is quite a different beast.

Peter

---

From: Emil Ivov <[email-masked]>
Date: Mon, 22 Apr 2013 23:14:07 +0200

> want to call it is quite a different beast.

OK then, so can we agree that a "groupchat" purpose would be a
reasonable resolution to this and that a short draft specifying it would
make sense?

Some guidance from the chairs would be very much appreciated ;)

Cheers,
Emil

-- 
https://jitsi.org

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 22 Apr 2013 17:21:10 -0400

> presence as they are traditionally understood).

Yes, any of these could be possible, though probably if it was MSRP it 
wouldn't be a separate URI from the main conference URL.

So the mechanism should be work for any of those. 
<purpose>groupchat</purpose> together with the URI scheme to distinguish 
among them should work. (As long as we believe everyone knows that 
"chat" means "type" rather than "talk informally".)

	Thanks,
	Paul

---

From: Jonathan Lennox <[email-masked]>
Date: Tue, 23 Apr 2013 10:41:54 -0400

> "chat" means "type" rather than "talk informally".)

Maybe something with "text" in the name would be clearer -- "grouptextchat"?

(Also, I think the bike shed should be orange.)

--
Jonathan Lennox
[email-masked]

---

From: Mary Barnes <[email-masked]>
Date: Tue, 23 Apr 2013 09:50:40 -0500

This would also be something useful for the XCON chat, which is
defined in draft-boulton-xcon-session-chat (we will shortly be
updating this and posting for discussion on this mailing list).  I
think "grouptextchat" would work, although I don't find it
particularly readable, but I don't think abbreviating is useful, so I
don't have another suggestion.

Mary.

---

From: Emil Ivov <[email-masked]>
Date: Tue, 23 Apr 2013 17:33:13 +0200

Hey Mary,

> don't have another suggestion.

I suppose I am once again missing something so I'd better ask :)

Are you saying that you would find a draft that defines the value
helpful for draft-boulton-xcon-session-chat or are you planning on
adding the definition in the draft itself?

The former could be quicker I suppose and I'd be happy to write the
document, but the latter also works for me.

Cheers,
Emil

-- 
https://jitsi.org

---

From: Mary Barnes <[email-masked]>
Date: Tue, 23 Apr 2013 10:36:08 -0500

> document, but the latter also works for me.
[MB] I agree with you.  I think we can write a simple doc to define
this and it can be referenced by these other docs as necessary (since
it isn't unique to any of these chat applications).
[/MB]

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 23 Apr 2013 11:57:52 -0600

On 4/23/13 9:36 AM, Mary Barnes wrote:
>>> This would also be something useful for the XCON chat, which
>>> is defined in draft-boulton-xcon-session-chat (we will shortly
>>> be updating this and posting for discussion on this mailing
>>> list).  I think "grouptextchat" would work, although I don't
>>> find it particularly readable, but I don't think abbreviating
>>> is useful, so I don't have another suggestion.
>> 
>> Are you saying that you would find a draft that defines the
>> value helpful for draft-boulton-xcon-session-chat or are you
>> planning on adding the definition in the draft itself?
>> 
>> The former could be quicker I suppose and I'd be happy to write
>> the document, but the latter also works for me.
> [MB] I agree with you.  I think we can write a simple doc to
> define this and it can be referenced by these other docs as
> necessary (since it isn't unique to any of these chat
> applications). [/MB]

+1

Peter

---

From: Emil Ivov <[email-masked]>
Date: Wed, 24 Apr 2013 04:10:35 +0200

There it is then:

http://tools.ietf.org/html/draft-ivov-grouptextchat-purpose

Cheers,
Emil

-------- Original Message --------
Subject: New Version Notification for
draft-ivov-grouptextchat-purpose-00.txt
Date: Tue, 23 Apr 2013 19:09:01 -0700
From: [email-masked]
To: Emil Ivov <[email-masked]>

A new version of I-D, draft-ivov-grouptextchat-purpose-00.txt
has been successfully submitted by Emil Ivov and posted to the
IETF repository.

Filename:	 draft-ivov-grouptextchat-purpose
Revision:	 00
Title:		 A Group Text Chat Purpose for Conference and Service URIs in
the Session Initiation Protocol (SIP) Event Package for Conference State
Creation date:	 2013-04-24
Group:		 Individual Submission
Number of pages: 5
URL:
http://www.ietf.org/internet-drafts/draft-ivov-grouptextchat-purpose-00.txt
Status:
http://datatracker.ietf.org/doc/draft-ivov-grouptextchat-purpose
Htmlized:
http://tools.ietf.org/html/draft-ivov-grouptextchat-purpose-00

Abstract:
   This document defines and registers a value of "grouptextchat"
   ("Group Text Chat") value for the URI <purpose> element of SIP's
   Conference Event Package [RFC4575].

The IETF Secretariat

-- 
https://jitsi.org

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Wed, 24 Apr 2013 08:48:27 +0200

+1

--
Saúl Ibarra Corretgé
AG Projects

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 24 Apr 2013 15:04:02 +0300

>> http://tools.ietf.org/html/draft-ivov-grouptextchat-purpose

great!

/Sal

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 24 Apr 2013 14:29:50 +0000

> http://tools.ietf.org/html/draft-ivov-grouptextchat-purpose

I like it. 

Now how would people like to dispatch this? My preference would probably be if one of the authors could talk to ADs about AD sponsoring this and if they seem like they might be OK with that, just do a quick call on the dispatch list for any objects then send it that way. 

Cullen

---

From: Mary Barnes <[email-masked]>
Date: Wed, 24 Apr 2013 09:32:10 -0500

> Now how would people like to dispatch this? My preference would probably be if one of the authors could talk to ADs about AD sponsoring this and if they seem like they might be OK with that, just d…
[MB] My thoughts exactly.  I've cc'ed the RAI ADs to see if they have
any issues with this approach. [/MB]

Mary

---

From: Richard Barnes <[email-masked]>
Date: Wed, 24 Apr 2013 17:32:08 -0400

That sounds fine to me.
--Richard

On Wed, Apr 24, 2013 at 10:32 AM, Mary Barnes <[email-masked]>wrote:

> > Now how would people like to dispatch this? My preference would probably
> be if one of the authors could talk to ADs about AD sponsoring this and if
> they seem like they might be OK with that, just do a quick call on the
> dispatch list for any objects then send it that way.
> >
> > Cullen