Subject: Re: [dispatch] New Version Notification for draft-pascual-dispatch-bfcp-websocket-00.txt

From: <[email-masked]>
Date: Fri, 12 Apr 2013 21:07:31 +0000

Hi all

I come back on the PS note below. It is possible to handle binary data in JS code using TypedArrays (http://www.khronos.org/registry/typedarray/specs/latest/). The Uint8Array typed array is appropriate for BFCP.
It is already widely supported in browsers (http://caniuse.com/typedarrays). 

Stéphane

-----Message d'origine-----
De : Iñaki Baz Castillo [mailto:[email-masked]] 
Envoyé : lundi 11 mars 2013 15:28
À : Adam Roach
Cc : Cullen Jennings; [email-masked]; CAZEAUX Stephane OLNC/OLPS
Objet : Re: [dispatch] New Version Notification for draft-pascual-dispatch-bfcp-websocket-00.txt

2013/3/11 Adam Roach <[email-masked]>:
> All I think you'll see is that the browser -- just like any other 
> endpoint that doesn't support BFCP -- would decline the BFCP media section.

Hopefully yes :)

Then the problem is how the JS code *parses* and *mangles* the SDP to interact with the BFPC media section, which is hard to accomplish given the SDP format... but that's another subject :)

PS: Anyhow I would like to insist that, if BFPC means a "binary protocol", then it will be really hard to implement it at JavaScript level.

--
Iñaki Baz Castillo
<[email-masked]>

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Fri, 12 Apr 2013 23:49:21 +0200

Sure but, is it really friendly? Would somebody design such a binary
protocol from scratch to be handled by JS?

--
Iñaki Baz Castillo
<[email-masked]>
El 12/04/2013 23:07, <[email-masked]> escribió:

> Hi all
>
> I come back on the PS note below. It is possible to handle binary data in
> JS code using TypedArrays (
> http://www.khronos.org/registry/typedarray/specs/latest/). The Uint8Array
> typed array is appropriate for BFCP.
> Objet : Re: [dispatch] New Version Notification for
> draft-pascual-dispatch-bfcp-websocket-00.txt
>
> Then the problem is how the JS code *parses* and *mangles* the SDP to
> interact with the BFPC media section, which is hard to accomplish given the
> SDP format... but that's another subject :)
>
> PS: Anyhow I would like to insist that, if BFPC means a "binary protocol",
> then it will be really hard to implement it at JavaScript level.
>
>
> --
> Iñaki Baz Castillo
> <[email-masked]>
>

---

From: Paul Kyzivat <[email-masked]>
Date: Sat, 13 Apr 2013 11:31:52 -0400

> protocol from scratch to be handled by JS?

No, probably not.
But since the protocol is already defined and implemented, it isn't 
unreasonable to expect JS to deal with it, rather than having everybody 
else adapt to JS limitations.

	Thanks,
	Paul

> --
> Iñaki Baz Castillo
> <[email-masked] <mailto:[email-masked]>>
>
> El 12/04/2013 23:07, <[email-masked]
> <mailto:[email-masked]>> escribió:
>
>     Hi all
>
>     I come back on the PS note below. It is possible to handle binary
>     data in JS code using TypedArrays
>     (http://www.khronos.org/registry/typedarray/specs/latest/). The
>     Uint8Array typed array is appropriate for BFCP.
>     De : Iñaki Baz Castillo [mailto:[email-masked] <mailto:[email-masked]>]
>     Cc : Cullen Jennings; [email-masked] <mailto:[email-masked]>;
>     CAZEAUX Stephane OLNC/OLPS
>     2013/3/11 Adam Roach <[email-masked] <mailto:[email-masked]>>:
>     Then the problem is how the JS code *parses* and *mangles* the SDP
>     to interact with the BFPC media section, which is hard to accomplish
>     given the SDP format... but that's another subject :)
>
>     PS: Anyhow I would like to insist that, if BFPC means a "binary
>     protocol", then it will be really hard to implement it at JavaScript
>     level.
>
>
>     --
>     Iñaki Baz Castillo
>     <[email-masked] <mailto:[email-masked]>>
>
>
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 15 Apr 2013 13:01:18 +0200

Section 6 has some typos:

- Missing dot at the end of paragraphs 1, 3 and 4.

- s/WS/WSS/g in the 4th paragraph.

2013/2/21 Victor Pascual Avila <[email-masked]>:
> Hi all,
>
> We have submitted a new Internet draft to describe the WebSocket
> Protocol as a Transport for the Binary Floor Control Protocol (BFCP).
> We are looking forward to your review comments.
>
> http://tools.ietf.org/html/draft-pascual-dispatch-bfcp-websocket-00
>
> Best regards,
> -Victor
>
>
> On 2/15/13 6:17 PM, "[email-masked]" <[email-masked]>
> wrote:
>
>>
>>A new version of I-D, draft-pascual-dispatch-bfcp-websocket-00.txt
>>has been successfully submitted by Victor Pascual and posted to the
>>IETF repository.
>>
>>Filename:       draft-pascual-dispatch-bfcp-websocket
>>Revision:       00
>>Title:          The WebSocket Protocol as a Transport for the Binary Floor
>>Control Protocol (BFCP)
>>Creation date:  2013-02-15
>>Group:          Individual Submission
>>Number of pages: 9
>>URL:
>>http://www.ietf.org/internet-drafts/draft-pascual-dispatch-bfcp-websocket-
>>00.txt
>>Status:
>>http://datatracker.ietf.org/doc/draft-pascual-dispatch-bfcp-websocket
>>Htmlized:
>>http://tools.ietf.org/html/draft-pascual-dispatch-bfcp-websocket-00
>>
>>
>>Abstract:
>>   The WebSocket protocol enables two-way realtime communication between
>>   clients and servers.  This document specifies a new WebSocket sub-
>>   protocol as a reliable transport mechanism between Binary Floor
>>   Control Protocol (BFCP) entities to enable usage of BFCP in new
>>   scenarios.  This document normatively updates
>>   [I-D.draft-ietf-bfcpbis-rfc4582bis] and
>>   [I-D.draft-ietf-bfcpbis-rfc4583bis]
>>
>>
>>
>>
>>
>>The IETF Secretariat
>>

-- 
Iñaki Baz Castillo
<[email-masked]>