Subject: [dispatch] draft-saintandre-sip-xmpp-media-02

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Mon, 8 Apr 2013 13:41:16 +0000

Hi Peter,

I did a quick review for the sip-xmpp-media-02 document and have the following comments/questions:

Section 2.1, bullet 3:
This bullet states "The SIP signaling channel is transported over UDP, ...". While SIP can be transported over UDP, it is also widely transported over TCP and TLS. You may want to reword this sentence and clarify that statement.

Section 2.2.1, Jingle Action to SIP Method mapping table:
content-accept, session-accept: I think that the SIP part should be "INVITE response (18x)" instead of "... (1xx)"
content-add, content-modify, content-remove: how about UPDATE?

Section 2.3.1, first jingle,
you have two "from" attributes; I think that the second one should be the "to" attribute instead.

Section 2.3.1, the SDP in the first INVITE sent from the GW to the target, the m line should include the codecs offered by this SDP.

Section 2.3.1., 180 Ringing,
The "To" header seems to include a tag with the same value as of the resource of the "to" attribute in the Jingle session-initiation.
It is likely that these values will be different, and it would be up to the GW to map these values.

General comments:
* This document seems to assume that the user part of the SIP id and XMPP id is the same.
I understand that this document is trying to address the media mapping, but is there any document that deals with the mapping of ids, and does it address the use case of a user having different user parts for his SIP and XMPP ids?
* A SIP INVITE could be forked and multiple responses sent to the originator. Are you going to cover this use case? does this change the mapping table?

Regards,
Rifaat

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 08 Apr 2013 11:27:47 -0600

> I did a quick review for the sip-xmpp-media-02 document and have the following comments/questions:

Thanks, Rifaat! This document still needs quite a bit of work. Saúl
Ibarra and I are working to update draft-saintandre-sip-xmpp-groupchat
first, but we'll move on to draft-saintandre-sip-xmpp-media after that.
I'll reply to your message in more detail later this week.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/