Subject: [dispatch] Fwd: I-D Action: draft-saintandre-sip-xmpp-presence-05.txt

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 02 Apr 2013 22:03:33 -0600

FYI.

-------- Original Message --------
Subject: I-D Action: draft-saintandre-sip-xmpp-presence-05.txt
Date: Tue, 02 Apr 2013 21:02:57 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : Interworking between the Session Initiation Protocol
(SIP) and the Extensible Messaging and Presence Protocol (XMPP): Presence
	Author(s)       : Peter Saint-Andre
                          Avshalom Houri
                          Joe Hildebrand
	Filename        : draft-saintandre-sip-xmpp-presence-05.txt
	Pages           : 20
	Date            : 2013-04-02

Abstract:
   This document defines a bi-directional protocol mapping for the
   exchange of presence information between the Session Initiation
   Protocol (SIP) and the Extensible Messaging and Presence Protocol
   (XMPP).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-saintandre-sip-xmpp-presence

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-saintandre-sip-xmpp-presence-05

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-saintandre-sip-xmpp-presence-05

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Sun, 7 Apr 2013 19:44:27 +0200

Hi Peter,

Here are some comments on revision 5:

- Section 3.3.1: The initial SUBSCRIBE should have an empty to tag.

- Section 4.3: Tuple id should be ID-orchard

- Section 4.3, table 7: The reference to <body> looks like a c&p error ;-)

I think we should make sue of the 'contact' child element of the PIDF tuple to provide the full (translated as per the core draft) URI of the presence entity. From/To headers cannot have GRUUs in them IIRC, so the contact element seems like the right place to hold this piece of information. This way the endpoint which processes this presence information will learn how to contact *this* particular instance.

In addition, the draft currently only considers the case where a single NOTIFY is generated for a presence stanza, but if RLS is used a presence agent will aggregate multiple PIDF documents in a single RLMI document and send it in a single NOTIFY, so not relying in the From header would help.

Regards,

On Apr 3, 2013, at 6:03 AM, Peter Saint-Andre wrote:

> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

--
Saúl Ibarra Corretgé
AG Projects