Subject: Re: [dispatch] draft-hanes-dispatch-fax-capability-01

From: Paul Kyzivat <[email-masked]>
Date: Sat, 01 Sep 2012 11:56:26 -0400

David,

This version is better!

A couple of issues:

The shown usage of Accept-Contact:

    Accept-Contact: +sip.fax="t38"

is syntactically incorrect. Minimally it needs to be:

    Accept-Contact: *;+sip.fax="t38"

(That expresses a *preference* for t38, while not excluding callees that 
don't support fax or that support only some other fax encoding.)

The section on values appropriate for use with this feature tag is wishy 
washy. If "t38" and "passthrough" are simply *typical*, then are other 
values also permitted? If so, which ones?

In the case of passthrough, what does "transmission of fax using an 
audio codec" *mean*? There must be some encoding.

IMO you should spell out the choices as an enumeraton, and each value of 
the enumeration should normatively reference some standard.

	Thanks,
	Paul

On 8/31/12 10:15 PM, David Hanes wrote:
> Thanks for the constructive feedback on this draft. I posted a new version of the draft for your review.
>
>   The principal changes in this new version are:
>
> - Per Dan Wing, insertion of a paragraph expanding upon why SDP alone is not suitable for indicating fax capability.
>
> - Per Christer Holmberg, the +sip.fax tag has been changed from a boolean type to token with an equality relationship so that we can now explicitly define the fax transport being used
>
> - addressing various nits and formatting issues
>
> Additional feedback and suggestions on taking this draft forward are welcomed and appreciated.
>
> Regards,
> David

---

From: David Hanes <[email-masked]>
Date: Wed, 5 Sep 2012 00:38:45 -0400

Hi Paul,

I appreciate the comments and they made a lot of sense. I am in complete agreement so I went ahead and just spun up another draft (version 2) taking your comments into account. T.38 and passthrough are the only options really seen today outside of some proprietary offerings. Additionally, G.711 is the audio codec that is used for passthrough so I went ahead and explicitly cited it.

If folks could take a look at this latest draft and provide me with any additional feedback or suggestions it would be appreciated.

Regards,
David

On Sep 1, 2012, at 11:56 AM, Paul Kyzivat wrote:

> (That expresses a *preference* for t38, while not excluding callees that don't support fax or that support only some other fax encoding.)
> 
> The section on values appropriate for use with this feature tag is wishy washy. If "t38" and "passthrough" are simply *typical*, then are other values also permitted? If so, which ones?
> 
> In the case of passthrough, what does "transmission of fax using an audio codec" *mean*? There must be some encoding.
> 
> IMO you should spell out the choices as an enumeraton, and each value of the enumeration should normatively reference some standard.
> 
> 	Thanks,
> 	Paul
> 
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 05 Sep 2012 10:22:23 -0400

> If folks could take a look at this latest draft and provide me with any additional feedback or suggestions it would be appreciated.

Much better thanks.

Is there a spec for how fax is encoded over G.711?
At the very least, I suppose there is a spec for how fax is encoded over 
analog audio, with that then being sampled for transmission over G.711. 
ISTM the draft should reference something that specifies how fax is 
encoded in the passthru case.

(Consider some new implementer that has done no fax before. He wants to 
implement fax support, receiving a fax and saving it as an image file. 
He finds that some devices he needs to interwork with only support 
passthru. How does he parse the incoming G.711 frames to extract the fax 
image? While I don't expect this draft to tell him, I do think it should 
normatively reference something that does tell him.)

	Thanks,
	Paul

---

From: Kevin Fleming <[email-masked]>
Date: Wed, 5 Sep 2012 10:16:12 -0500

On Wed, Sep 5, 2012 at 9:22 AM, Paul Kyzivat <[email-masked]> wrote:

>> I appreciate the comments and they made a lot of sense. I am in complete
>> agreement so I went ahead and just spun up another draft (version 2) taking
>> your comments into account. T.38 and passthrough are the only options
>> really seen today outside of some proprietary offerings. Additionally,
>> G.711 is the audio codec that is used for passthrough so I went ahead and
>> explicitly cited it.
>>
>> If folks could take a look at this latest draft and provide me with any
>> additional feedback or suggestions it would be appreciated.
>>
>
> Much better thanks.
>
> ISTM the draft should reference something that specifies how fax is encoded
> in the passthru case.
>
> implement fax support, receiving a fax and saving it as an image file. He
> finds that some devices he needs to interwork with only support passthru.
> How does he parse the incoming G.711 frames to extract the fax image? While
> I don't expect this draft to tell him, I do think it should normatively
> reference something that does tell him.)
>
>
That would be the ITU-T T.30 recommendation.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 05 Sep 2012 11:49:56 -0400

On 9/5/12 11:16 AM, Kevin Fleming wrote:
> On Wed, Sep 5, 2012 at 9:22 AM, Paul Kyzivat <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>         I appreciate the comments and they made a lot of sense. I am in
>         complete agreement so I went ahead and just spun up another
>         draft (version 2) taking your comments into account. T.38 and
>         passthrough are the only options really seen today outside of
>         some proprietary offerings. Additionally, G.711 is the audio
>         codec that is used for passthrough so I went ahead and
>         explicitly cited it.
>
>         If folks could take a look at this latest draft and provide me
>         with any additional feedback or suggestions it would be appreciated.
>
>
>     Much better thanks.
>
>     At the very least, I suppose there is a spec for how fax is encoded
>     over analog audio, with that then being sampled for transmission
>     over G.711. ISTM the draft should reference something that specifies
>     how fax is encoded in the passthru case.
>
>     (Consider some new implementer that has done no fax before. He wants
>     to implement fax support, receiving a fax and saving it as an image
>     file. He finds that some devices he needs to interwork with only
>     support passthru. How does he parse the incoming G.711 frames to
>     extract the fax image? While I don't expect this draft to tell him,
>     I do think it should normatively reference something that does tell
>     him.)
>
>

Then can you reference that?

	Thanks,
	Paul