Subject: Re: [dispatch] SIP media load balancer requirement

From: dave Cruse <[email-masked]>
Date: Tue, 1 May 2012 07:59:35 +0000

Hello,

I have few basic queries on this draft.

How does SIP Load balancer shift traffic from one path to another to avoid congestion on any particular 

link?

How does Load balancer minimize the cost of transit across external networks OR improve network 

reliability?

How is your SIP Load balancer used to implement failover of one or more of its components? Does your 

components are monitored continually?

How does SIP load balancer is used to monitor network activities and can it be used to split huge data 

flows into several sub-flows and use several network analyzers?

How can you achieve SIP based load balancing for media servers like PSTN-SIP GW, SBC,vOICE Gateway etc.

Regards
- Dave

> From: [email-masked]
> To: [email-masked]; [email-masked]
> Date: Thu, 5 Jan 2012 06:28:22 +0000
> Subject: Re: [dispatch] SIP media load balancer requirement
> 
> Hi Ram,
> 
> Nice to see your interest. Please read inline for more comments.
> 
> Thanks
> Partha
> 
> >-----Original Message-----
> >From: Ram Mohan R (rmohanr) [mailto:[email-masked]]
> >Sent: Thursday, January 05, 2012 11:45 AM
> >To: Ravindran, Parthasarathi; [email-masked]
> >Subject: RE: [dispatch] SIP media load balancer requirement
> >
> >Hi Partha,
> >
> >I would be interested in this work. See more inline
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]] On
> >> Behalf Of Ravindran, Parthasarathi
> >> Sent: Thursday, December 22, 2011 8:02 AM
> >> To: [email-masked]
> >> Subject: [dispatch] SIP media load balancer requirement
> >>
> >> Hi all,
> >>
> >> As a continuation of IETF-81 Dispatch minutes
> >> (http://www.ietf.org/mail-archive/web/dispatch/current/msg03742.html)
> >> about SIP load balancing, I thought of discussing about SIP media
> >> servers load balancing as mentioned in the SIP load balancing proposed
> >> charter (http://www.ietf.org/mail-
> >> archive/web/dispatch/current/msg03615.html).
> >>
> >> "As SIP request resource consumption in SIP signaling only server
> >> varies drastically from SIP media servers [3], should the solution be
> >> split such that load balancing of a pure signaling server is different
> >> than that of a SIP server that handles signaling as well as media?"
> >>
> >> SIP media server load balancing solution will be different from
> >> signaling only because the downstream resource consumption is mainly
> >> because of media  (RTP) than signaling (SIP) and the units to indicate
> >> the load balancing information will be different in both solution.
> >> There is a need to indicate those media resource consumption to the
> >> load balancer in the standard manner. Please let me know your comment
> >> on this.
> >
> >I think what we need is some text/document saying how media overload is
> >different from signaling overload and what are the different resources
> >that need to considered for media overload. In that way we will have
> >good starting point to discuss on this topic.
> 
> <partha> The focus of this charter is about SIP media load balancing and not media overload handling. I agree with you that SIP media load balancing algorithm works in conjunction with media overload mechanism and selection of the load balancing algorithm majorly depends upon media overload mechanism. 
> 
> SIP media load balancer requirement is to consider media resource consumption of the peer apart from the signaling resource consumption.  </partha>
> 
> >
> >Regards,
> >Ram
> >>
> >> Thanks
> >> Partha
> >> _______________________________________________
> >> dispatch mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/dispatch
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Wed, 2 May 2012 12:18:48 +0000

Dave,

Sec 3.5 of draft-partha-dispatch-siploadbalancing-survey-00 provides the existing mechanism for  SIP media load balancing. One of the solution is draft-partha-soc-overload-resource-availability-00<http://tools.ietf.org/html/draft-partha-soc-overload-resource-availability-00> but the downside is that of defining the units like CPU, Memory, DSP channels.

Please read inline for more comments.

Thanks
Partha

From: dave Cruse [mailto:[email-masked]]
Sent: Tuesday, May 01, 2012 1:30 PM
To: Ravindran, Parthasarathi; [email-masked]; [email-masked]
Subject: RE: [dispatch] SIP media load balancer requirement

Hello,

link?

<partha> Shifting the traffic will be based on the feedback from the media server and the local
Policy </partha>

reliability?

<partha> I could not understand in detail. Could you please explain in detail here </partha>

<partha> Basically, there is a need of feedback mechanism. The failover could be 503 or threshold
Limit reaching in the feedback. </partha>

<partha> In case of audio call, flow is mainly Based on SIP signaling and RTP data with the
negotiated codec. Please explain the actual huge data flow and its subflow.  </partha>

How can you achieve SIP based load balancing for media servers like PSTN-SIP GW, SBC,vOICE Gateway etc.
<partha> One of the mechanism is mentioned in http://tools.ietf.org/html/draft-partha-soc-overload-resource-availability-00 </partha>

Regards
- Dave
> From: [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> >To: Ravindran, Parthasarathi; [email-masked]<mailto:[email-masked]>
> >> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On
> >> To: [email-masked]<mailto:[email-masked]>
> >> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>