Subject: [dispatch] Charter process for the INSIPID WG

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 1 Mar 2012 13:23:05 +0200

Folks,

Robert and I have been working on a charter proposal for the INSIPID WG.
This is the proposal that we have sent for review to the IESG and IAB:

http://www.ietf.org/iesg/evaluation/sessionid-charter.txt

We believe this proposal represents the consensus of the group. Note
that we have left out some comments that failed to get rough consensus
on this list.

>From now on, I will be taking care of the chartering process for this
WG. Today, I will discuss the charter proposal with the IESG and, if
everything goes OK, we will be sending it for external review shortly.
If you have further comments on the charter proposal, please send them
as part of its external review, which will be announced on the IETF
announcement list as usual.

Also, I am going to be requesting the creation of the insipid mailing list.

Cheers,

Gonzalo

---

From: "Paul E. Jones" <[email-masked]>
Date: Tue, 6 Mar 2012 14:31:38 -0500

Gonzalo,

I would suggest adding the following text to the end of the second paragraph
of the charter:
"Consideration must be given to the fact that the entities involved in a
communication session might change as a result of service interaction in the
network, such as call transfers, joins, etc."

This is text we introduced in a later version of the charter.

Paul

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Gonzalo Camarillo
> Sent: Thursday, March 01, 2012 6:23 AM
> To: DISPATCH
> Subject: [dispatch] Charter process for the INSIPID WG
> 
> Folks,
> 
> We believe this proposal represents the consensus of the group. Note that
> we have left out some comments that failed to get rough consensus on this
> list.
> 
> From now on, I will be taking care of the chartering process for this WG.
> Today, I will discuss the charter proposal with the IESG and, if
> If you have further comments on the charter proposal, please send them as
> part of its external review, which will be announced on the IETF
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 06 Mar 2012 15:52:40 -0500

> This is text we introduced in a later version of the charter.

These words don't mention any constraints that should be imposed wile 
considering this. So the outcome might or might not specify that such 
changes do or don't preserve the session id.

Is that what you are looking for?

	Thanks,
	Paul

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 06 Mar 2012 17:22:01 -0600

At 02:52 PM 3/6/2012, Paul Kyzivat wrote:
>These words don't mention any constraints that should be imposed 
>wile considering this. So the outcome might or might not specify 
>that such changes do or don't preserve the session id.
>

May I suggest that folks interested in this subject take their 
discussions over to the NEW INSIPID list at [email-masked] after 
they register into that list.

This will clear up DISPATCH from hearing about this, while focusing 
Session-ID talk to the IPSIPID list, which is more appropriate IMO.

James

---

From: Mary Barnes <[email-masked]>
Date: Tue, 6 Mar 2012 18:31:28 -0600

Personally, I think we should keep charter discussions on DISPATCH for now.
 I agree that discussing solution details should happen on the INSIPID list.

Thanks,
Mary

On Tue, Mar 6, 2012 at 5:22 PM, James M. Polk <[email-masked]> wrote:

> May I suggest that folks interested in this subject take their discussions
> over to the NEW INSIPID list at [email-masked] after they register into
> that list.
>
>>>> From: [email-masked] [mailto:dispatch-bounces@ietf.**org<[email-masked]>]
>>>> On
>>>> http://www.ietf.org/iesg/**evaluation/sessionid-charter.**txt<http://www.ietf.org/iesg/evaluation/sessionid-charter.txt>
>>>>
>>>> that
>>>> WG.
>>>> as
>>>> ______________________________**_________________
>>>> dispatch mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/**listinfo/dispatch<https://www.ietf.org/mailman/listinfo/dispatch>
>>>>
>>>
>>> ______________________________**_________________
>>> dispatch mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/**listinfo/dispatch<https://www.ietf.org/mailman/listinfo/dispatch>
>>>
>>
>> ______________________________**_________________
>> dispatch mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/dispatch<https://www.ietf.org/mailman/listinfo/dispatch>
>>
>
> ______________________________**_________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/dispatch<https://www.ietf.org/mailman/listinfo/dispatch>
>

---

From: Mary Barnes <[email-masked]>
Date: Tue, 6 Mar 2012 18:34:36 -0600

Also, did anyone ever send an email to DISPATCH announcing the new mailing
list?  I can't find anything in the archives nor was anything posted on the
RAI area mailing list.

Mary.

---

From: "Paul E. Jones" <[email-masked]>
Date: Tue, 6 Mar 2012 23:22:06 -0500

Paul,

> > I would suggest adding the following text to the end of the second
> > paragraph of the charter:
> > "Consideration must be given to the fact that the entities involved in
> > a communication session might change as a result of service
> > interaction in the network, such as call transfers, joins, etc."
> >

This is text just to serve as a reminder that we cannot ignore service
interactions.  Now, what we decide to do as a result of service interactions
is still to be determined.  However, every single time I've seen a "call ID"
proposed before, it seemed the proposal did not fully take such mid-call
service interactions into account or failed to do so properly.  So, I just
don't want that to be ignored.

Paul

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 7 Mar 2012 09:05:28 -0700

I believe the charter in the proposed link represents the rough consensus from the hum we took in the meeting and the associated mailing list discussion. 

I do not believe there was consensus in DISPATCH to expand the scope to service interaction issues  beyond the semantics to/from/call-id semantics. In the meeting, specific questions were asked around this topic such as interaction with conferences bridges and what people hummed on was not the expanded scope.

Cullen <DISPATCH Co-Chair>

---

From: "Dawes, Peter, VF-Group" <[email-masked]>
Date: Mon, 12 Mar 2012 11:31:39 +0000

Hello Gonzalo, All,
I think the following paragraph of the INSIPID charter at http://www.ietf.org/iesg/evaluation/sessionid-charter.txt should be revised:

"This group will focus on a document that will specify an SIP
identifier that have the same aim as the From-tag, To-tag and
Call-ID conjunction, but is less likely to be mangled by
intermediaries."

This paragraph limits the charter to a single document, even though more than one draft already exists related to identifying sessions, and by mentioning the "From-tag" points to a solution that includes information from both ends of a session before INSIPID has started discussion. Therefore, I would like to propose the following re-wording:

"This group will focus on specifying a SIP
identifier that has similar uniqueness and end-to-end properties as a dialog identifier (made up of the From-tag, To-tag and
Call-ID conjunction), but is less likely to be mangled by
intermediaries. Related identifiers and parameters to satisfy requirements for use cases like troubleshooting,
billing, session tracking, session recording, media and signalling
correlation, and so forth will also be specified."

Regards,
Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
Sent: 01 March 2012 11:23
To: DISPATCH
Subject: [dispatch] Charter process for the INSIPID WG

Folks,

We believe this proposal represents the consensus of the group. Note that we have left out some comments that failed to get rough consensus on this list.

>From now on, I will be taking care of the chartering process for this WG. Today, I will discuss the charter proposal with the IESG and, if everything goes OK, we will be sending it for external review shortly.
If you have further comments on the charter proposal, please send them as part of its external review, which will be announced on the IETF announcement list as usual.

Cheers,

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 13 Mar 2012 23:18:22 +0200

Hi Peter,

note that the paragraph you quoted simply says that the new identifier
will have the same *aim*. It does not say or imply anything about what
the solution needs to include.

Cheers,

Gonzalo