Subject: Re: [dispatch] I-D Action: draft-bakker-sipping-3gpp-ims-xml-body-handling-07.txt

From: John-Luc Bakker <[email-masked]>
Date: Tue, 20 Mar 2012 18:53:03 +0000

Hi,

Thanks, Paul for reviewing the draft.
Appologies for having delayed this response. 

Let me address first the question about this being a SIPPING draft: I intend to ask Gonzallo to sponsor this draft. To collect any further comments and ensure visibility (sine the sipping list is obsolete), I have copied the DISPATCH list.

See also inline with <JL>.

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Saturday, December 03, 2011 12:11 PM
To: John-Luc Bakker
Cc: sipping
Subject: Re: I-D Action: draft-bakker-sipping-3gpp-ims-xml-body-handling-07.txt

I'm commenting on this on the (now obsolete) sipping list because this 
has sipping in its name. This may not be the best place. I suppose an 
alternative is rai.

ISTM that there are three degrees of freedom here for identifying how to 
process these bodies:
- content-disposition
- content-type
- the actual content of the body

Of these, the content-disposition is the most heavy weight in terms of 
mechanism, while the actual content of the body is the least heavy-weight.

So, I wonder why you have chosen to use one content-type, that seems to 
already contain distinct representations for the differing behaviors of 
interest, and yet use distinct content-dispositions. I think you could 
use a single content-disposition and get the same effect.

I guess multiple content-dispositions might make sense if they are 
processed by different entities, so that only the intended entities need 
decode the body. 

<JL> The reason for having two content dispositions is because there are different behaviors for the same content-type when received by different entities.
<JL> There are two different entities that apply a different behavior when receiving the body, say behavior A and behavior B. However, XML elements present in the body trigger behavior A (in the abstract of the draft, behavior (2)) by entity A and if not present, no further behavior by entity A is specified in this draft. Other XML elements present in the body trigger one of a set of behaviors B (in the abstract of the draft, behaviors (1) and (3)) by entity B and if not present, no further behavior by entity B is specified in this draft.

It would also make sense if the same identical body 
representation was processed differently based on the 
content-disposition. 

<JL> The bodies triggering the different behaviors are indeed not identical. 
<JL> However, the content-dispositions are processed by different entities, which is a reason for proposing these content-disposition values.

But I don't think either of those is the case here. So I would find it helpful if this draft explained why it chooses to use multiple content-dispositions.

<JL> The draft illustrates that, in IMS, different entities receive bodies with the content-type, and apply different behaviors. The draft further suggests that the applicability of these values may be limited to IMS. Do you see a need for a general discussion of this approach since the applicability is limited to IMS?

I also think it would be useful to say something about how you expect 
the handling parameter to be used with these dispositions. If 
handling=required (the default) is used, then any UA that gets this must 
fail the request unless it is able to handle the body. If 
handling=optional is specified, then that need not be so.

<JL> The handling parameter is mentioned in RFC 3261 and this draft refers to that RFC. RFC 3261 refers to RFC 3204. This draft does not change the behavior and interpretation of the parameter and its values. It should not be necessary to repeat what has already been documented in RFC 3261. Do you see different behavior that goes beyond what has been documented?

	Thanks,
	Paul

On 12/3/11 5:08 AM, [email-masked] wrote:
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
> 	Title           : Specification of 3GPP IM CN Subsystem XML body handling
> 	Author(s)       : John-Luc Bakker
> 	Filename        : draft-bakker-sipping-3gpp-ims-xml-body-handling-07.txt
> 	Pages           : 7
> 	Date            : 2011-12-02
>
>     This document registers new disposition-types for the Content-
>     Disposition header field that apply to the application/3gpp-ims+xml
>     body used by 3GPP.  The applicability of these content-disposition
>     values are limited to 3GPP IMS.  The application/3gpp-ims+xml body
>     has the following three distinct uses: (1) for redirecting the
>     emergency session to use a different domain (e.g. using a Circuit
>     Switched call), (2) for delivering user profile specific information
>     from the SIP registrar to an Application Server, and (3) for causing
>     a UAC to attempt to re-register with the IMS.
>
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-bakker-sipping-3gpp-ims-xml-body-handling-07.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-bakker-sipping-3gpp-ims-xml-body-handling-07.txt
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: John-Luc Bakker <[email-masked]>
Date: Tue, 27 Mar 2012 17:37:01 +0000

Dear all,

I have just made revision 8 of draft-bakker-sipping-3gpp-ims-xml-body-handling available following offline discussion. Biggest addition is the new section 2.1 which aims to further motivate the need for the ID. 

You can find the HTML formatted version here:
http://tools.ietf.org/html/draft-bakker-sipping-3gpp-ims-xml-body-handling-08

I am looking forward to hearing about any concerns you may have.

Kind regards,

John-Luc

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John-Luc Bakker
Sent: Tuesday, March 20, 2012 1:53 PM
To: Paul Kyzivat; [email-masked]
Cc: [email-masked]; sipping
Subject: Re: [dispatch] I-D Action: draft-bakker-sipping-3gpp-ims-xml-body-handling-07.txt

Hi,

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Saturday, December 03, 2011 12:11 PM
To: John-Luc Bakker
Cc: sipping
Subject: Re: I-D Action: draft-bakker-sipping-3gpp-ims-xml-body-handling-07.txt

	Thanks,
	Paul

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.
_______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch